Chapter 1: Creating Reports

- Preliminary Review Exercise
- Using the Presentation Designer
- Reordering and Resizing Columns
- Changing Titles
- Changing How Data is Displayed
- Saving and Opening Reports
- Adding Subtotals and Labels
- Manipulating Bands
- Adding Calculations and Highlighting Exceptions
- Building Charts
- Review Exercise
Preliminary Review Exercise

Build and submit a query that retrieves the total order amount for the stores in all regions. Sort the results on Region in ascending sequence and descending Sum Order Amount. Create the following report from the results.

<table>
<thead>
<tr>
<th>Region</th>
<th>Store Name</th>
<th>Total Order Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td>Golf Boutique Sydney</td>
<td>$1,814,700.00</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Hong Kong</td>
<td>$1,219,509.00</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Melbourne</td>
<td>$1,219,379.00</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Tokyo</td>
<td>$1,209,353.00</td>
</tr>
<tr>
<td></td>
<td><strong>Subtotal for: Asia</strong></td>
<td><strong>$5,452,840.00</strong></td>
</tr>
<tr>
<td>EU Central</td>
<td>Golf Boutique Berlin</td>
<td>$1,848,344.00</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Amsterdam</td>
<td>$1,829,237.00</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Frankfurt</td>
<td>$1,757,447.00</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Rotterdam</td>
<td>$1,199,199.00</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Dusseldorf</td>
<td>$1,170,861.00</td>
</tr>
<tr>
<td></td>
<td><strong>Subtotal for: EU Central</strong></td>
<td><strong>$7,802,888.00</strong></td>
</tr>
<tr>
<td>EU Northern</td>
<td>Golf Boutique London N</td>
<td>$2,000,762.00</td>
</tr>
</tbody>
</table>

Self Evaluation - Were you able to do the following?

- Use the Presentation Designer to select a table? Y N
- Resize the columns? Y N
- Apply the subtotal? Y N
- Change the Sum Order Amount column heading? Y N
- Change the title? Y N
- Add the subtotal labels? Y N
- Change the format of the Total Order Amount column? Y N
- Apply a fill color to the subtotal band? Y N
Using the Presentation Designer -
Creating Tables

To create a report, you send the results of a query to BI/Query Reports

To build the table:
* with a results set displayed in BI/Query, choose
  * Results > Show as Report > BI/Query Reports
  * or click the BI/Query Reports tool
* on the Presentation page of the Presentation Designer, make sure Table is selected, then click Next
* on the Style page, choose a table style, then click Next
* on the Arrange Data page, drag a column up or down in the Columns list to specify the order you want the columns to appear
* click Finish
Using the Presentation Designer - Styles

- The Styles page displays the different types of predefined styles you can choose from:
  - Columnar
  - Free-form
  - Stacked
  - Stacked-Indented
  - Default (user-defined)

- You can also give your report a meaningful title by entering a title in the Title text box.

Each of the predefined table styles present data in tabular format - that is, in rows and columns. Tables supply detailed information that readers can interpret or use to form a conclusion. BI/Query Reports allows you to display your data in tabular format using the following styles: Columnar, Free-form, Stacked, Stacked-Indented (all with or without predefined totals), or a personal style defined previously (Default).

The columnar style is the most commonly used. It allows data to be quickly and easily displayed in rows and columns.
Using the Presentation Designer - Arrange Data

The Arrange Data page lets you reorder columns if you didn’t select the attributes in the correct order when formulating the query.

To reorder columns:
- on the Arrange Data page of the Presentation Designer, drag the columns up or down under Columns.

To remove columns:
- on the Arrange Data page of the Presentation Designer, drag the column from Columns to Available Data.
Reordering Columns

You can reorder columns using the Column Control bar.

Column order can be changed in two different places within BI/Query Reports.

The order of columns can be changed on the Arrange Data page in the Presentation Designer, before the report is created.

Once you have created a report, you can reorder the columns within a table using the Column Control bar.

To reorder columns:
- in a report, click a column in the Column Control bar, then drag it to the position you want
Resizing Columns

- You can resize columns by dragging the column boundary in the Column Control bar

You can resize columns, shrinking or widening all the items within them.

To resize columns:
- in the Column Control bar, position the cursor over the right boundary of a column
- drag left to narrow the column or right to widen it
Changing Titles

- If you forgot to change the report title on the Style page, or if you want to change it to a different title, you can make the change in the table.
- You can also change the column headings from the attribute name to a more meaningful name.

To change a title or column heading:
- double-click the title or column heading
- in the Text Editor dialog box, type the new title or column heading name
- change the font, size, style or alignment
- click OK
Changing How Data is Displayed

- You can change the way a column of data is displayed
- For example, you want all monetary columns to be displayed with a currency sign

To change how the values in a column are displayed:
  - click the column in the Column Control bar
  - choose Format > Properties or click the Properties tool on the toolbar
  - on the Format page, change the display of numeric or date data
  - click OK

![Properties tool]
Saving Reports

- Saving is as simple as File > Save
- Before saving a report, you specify how the report opens and what data the report reader sees:
  - the data saved with the report
  - always refreshed data
  - or the ability to choose

Once you have created a report, you will want to save it.

Before saving, specify how the report opens. If you always want reports to contain the most recent data, you can set them to refresh when you open them. However, you may want to show the data as it appeared the last time it was refreshed; this reduces the load on the database and ensures that everyone is reading the same version of the report. You can also have BI/Query Reports ask you if you want it refreshed.

To specify how a report opens:
- choose Tools > Preferences
- on the General page, choose whether you want this report refreshed automatically, not refreshed, or if you want to be prompted each time you open a report
- Note: this preference is assigned only to the report you are saving

To save a report:
- choose File > Save
- in the Save As dialog box, specify the name and location of the report
- click Save (Your report is automatically assigned the .rep file extension.)

Reports can be saved in any location. However, in order for them to be distributed with a data model, they must be saved in the Reports subfolder of the folder where the data model is stored.
Opening Reports

- Depending on the preference assigned when the report is saved:
  - you may be prompted to choose between refreshing the data or showing the existing data (see below)
  - the report will refresh automatically
  - the report will open with the existing data

Reports are opened using the File > Open menu. When selecting this option, you may be prompted to refresh the data or show existing data.

Refreshing the data will submit the associated query so your report contains the most recent data from your database.

Using existing data will use the data that was used during the last time the report was saved.

You may decide that you want the readers to only see the data the last time this report was opened, so you can select Show existing data along with Don’t ask me this again, and save the report before distributing it.
Adding Calculations Using the Presentation Designer

- The Presentation Designer will add subtotals and grand totals to a table.
- In your query, sort any columns that will act as the subtotal break.
  - for instance, if you want subtotals for each Region or each Country, you must sort Region and Country.
- You do not need to sort columns if you only want a grand total.

If you want subtotals and grand totals in your columnar table, you can choose Columnar with Totals in the Presentation Designer.

If you want subtotals and grand totals, you must have at least one sorted column in your query. The Presentation Designer uses the sorted columns to determine how to calculate the subtotals and where to insert them. Sorted columns are displayed in the 'Break into groups by' area.

If there are no sorted columns in your query, only grand totals will be calculated for the numeric columns.
### Query Results 1

<table>
<thead>
<tr>
<th>Country</th>
<th>Store Name</th>
<th>Receivable</th>
<th>Payable</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td>Golf Boutique</td>
<td>35,500</td>
<td>15,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Sydney</td>
<td>37,000</td>
<td>20,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>72,500</strong></td>
<td><strong>35,000</strong></td>
</tr>
<tr>
<td>Canada</td>
<td>Golf Boutique Toronto</td>
<td>76,000</td>
<td>25,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>76,000</strong></td>
<td><strong>25,000</strong></td>
</tr>
<tr>
<td>China</td>
<td>Golf Boutique Hong</td>
<td>46,000</td>
<td>40,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>46,000</strong></td>
<td><strong>40,000</strong></td>
</tr>
<tr>
<td></td>
<td>Golf Boutique New York</td>
<td>53,000</td>
<td>70,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique New York</td>
<td>27,000</td>
<td>77,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Boston N</td>
<td>78,000</td>
<td>54,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Boston W</td>
<td>63,000</td>
<td>12,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Orlando</td>
<td>13,000</td>
<td>63,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Orlando</td>
<td>67,000</td>
<td>65,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Myrtle</td>
<td>89,000</td>
<td>50,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique San</td>
<td>80,000</td>
<td>40,000</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Chicago</td>
<td>32,000</td>
<td>76,000</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>1,026,000</strong></td>
<td><strong>947,000</strong></td>
</tr>
</tbody>
</table>

**End of Report**

**Grand totals**

**2,066,500**

**2,053,000**
Components of Tables - Bands

- A table is divided into areas, called bands

### Total Sales by Region and Country

<table>
<thead>
<tr>
<th>Region</th>
<th>Country</th>
<th>Store Name</th>
<th>SUM Order Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td>Australia</td>
<td>Golf Boutique Melbourne</td>
<td>1,219,378</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Golf Boutique Sydney</td>
<td>1,814,700</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>3,034,078</strong></td>
</tr>
<tr>
<td>China</td>
<td></td>
<td>Golf Boutique Hong Kong</td>
<td>1,219,509</td>
</tr>
<tr>
<td>Japan</td>
<td></td>
<td>Golf Boutique Tokyo</td>
<td>1,209,353</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td><strong>2,418,862</strong></td>
</tr>
<tr>
<td>EU Central</td>
<td>Germany</td>
<td>Golf Boutique Berlin</td>
<td>1,846,344</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Golf Boutique Düsseldorf</td>
<td>1,170,661</td>
</tr>
</tbody>
</table>
Band Descriptions

- Bands behave in different ways
- You need to understand how bands behave to present your results the way you want them

<table>
<thead>
<tr>
<th>This Element</th>
<th>Represents This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report header band</td>
<td>Information that appears at the top of the table (such as a title). The title typed in the Presentation Designer’s Style page is the name that appears here by default. This band appears once at the beginning of the table.</td>
</tr>
<tr>
<td>Page header band</td>
<td>Information that appears at the top of each page (such as column headings).</td>
</tr>
<tr>
<td>Detail bands</td>
<td>The data in each row (the query results).</td>
</tr>
<tr>
<td>Group footer band</td>
<td>Information that appears below each group of data. This band contains the subtotals value for the group.</td>
</tr>
<tr>
<td>Page footer band</td>
<td>Information that appears at the bottom of each page (such as page numbering and report date).</td>
</tr>
<tr>
<td>Report footer band</td>
<td>Information that appears at the bottom of the table (such as the grand totals). The default is the End of Report label. This band appears once at the end of the table.</td>
</tr>
</tbody>
</table>
Selecting Bands

- Selecting versus activating a band
  - Single-click a band to select it
  - Double-click a band to activate it

To change the properties of a band or to resize it, you must select it. When adding an object to a band in a table, you must activate the band to add the object to the band.

<table>
<thead>
<tr>
<th>Country</th>
<th>Store Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td>Golf Boutique Melbourne</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Sydney</td>
</tr>
</tbody>
</table>

The screen on the right shows detail bands that have been selected by single-clicking inside the detail band. Note the black box pointing up in the middle of each detail band.

<table>
<thead>
<tr>
<th>Country</th>
<th>Store Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td>Golf Boutique Melbourne</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Sydney</td>
</tr>
</tbody>
</table>

The screen below shows detail bands that have been activated by double-clicking inside the detail band. Note the black box pointing down in the middle of each detail band.

One of the difficulties you can encounter when double-clicking inside the detail band, is that you select a column instead of the band. Try double-clicking at the outer edge of the table instead of between the columns.
Sizing Bands

- All bands can be resized
- Resizing bands allows for readability
- Items inside a band cannot be larger than the band that they are in

To resize a band:

- Click once inside the band that you want to resize
- Place your mouse pointer over the bottom border of the selected band
- Wait until your mouse pointer changes to a double arrow
- Drag the bottom border to adjust the height of the band.

Notes:
You cannot make the band smaller than the largest item inside the band.
If you want to increase the size of an item inside a band, adjust the height of the band first and then resize the item inside the band.

<table>
<thead>
<tr>
<th>Country</th>
<th>Store Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td>Gok Boutique Melbourne</td>
</tr>
<tr>
<td></td>
<td>Gok Boutique Sydney</td>
</tr>
</tbody>
</table>
Adding Fill to Bands

- You can add different fills to bands to highlight them
- Adding fill is done through the Properties dialog box

To add fill to a band:

- click once inside the band that you want to add fill to
- select Format > Properties
- on the Fill page of the Properties dialog box, select the fill or pattern you want
- click OK

<table>
<thead>
<tr>
<th>Region</th>
<th>Country</th>
<th>Store Name</th>
<th>SUM Order Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td>Australia</td>
<td>Golf Boutique Melbourne</td>
<td>1,219,378</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Golf Boutique Sydney</td>
<td>1,814,700</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5,034,078</td>
</tr>
<tr>
<td></td>
<td>China</td>
<td>Golf Boutique Hong Kong</td>
<td>1,219,508</td>
</tr>
<tr>
<td></td>
<td>Japan</td>
<td>Golf Boutique Tokyo</td>
<td>1,209,353</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>5,462,940</td>
</tr>
</tbody>
</table>
Inserting Text Labels in Bands

- You can insert a text label in a band
- You must double-click the band to insert a text label into it
- You can also drag text labels from one band to another

To add a text label to a band of a table:
- double-click the band
- click the Text Label tool on the Presentations toolbar
- hold down the mouse and drag inside the band
- release the mouse and the Text Editor dialog box appears
- type the text in the Text Editor dialog box and apply formatting
- click OK

Once you have created a label, you can resize it, move it or delete it.

To delete a text label:
- select the text label
- press the Delete key or choose Edit > Delete

Total Sales by Region and Country

<table>
<thead>
<tr>
<th>Region</th>
<th>Country</th>
<th>Store Name</th>
<th>SUM Order Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td>Australia</td>
<td>Golf Boutique Melbourne</td>
<td>1,219,378</td>
</tr>
</tbody>
</table>
Creating Subtotal Labels

- You can add text boxes to the subtotal band to explain the subtotal value
- You can also drag the column value to the subtotal band

To copy the subtotal group break column value to the subtotal band:
- select the group break column value
- hold down the CTRL key
- drag the value to the subtotal band

<table>
<thead>
<tr>
<th>Region</th>
<th>Country</th>
<th>Store Name</th>
<th>SUM Order Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td>Australia</td>
<td>Golf Boutique Melbourne</td>
<td>1,219,378</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Golf Boutique Sydney</td>
<td>1,814,700</td>
</tr>
<tr>
<td></td>
<td>China</td>
<td>Golf Boutique Hong Kong</td>
<td>1,219,509</td>
</tr>
<tr>
<td></td>
<td>Japan</td>
<td>Golf Boutique Tokyo</td>
<td>1,209,353</td>
</tr>
<tr>
<td></td>
<td>EU Central</td>
<td>Germany</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Golf Boutique Berlin</td>
<td>5,462,940</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>1,846,344</td>
</tr>
</tbody>
</table>
Adding Predefined Calculations
Using Calc-O-Matic

- You can add other calculations to your table, in addition to the totals specified in the Presentation Designer.
- Predefined calculations include Average, Sum, Count, Minimum, Maximum, Percent of Total, Standard Deviation, Running Sum, Running Count.

The tables with totals styles available in the Presentation Designer only produce calculations such as subtotal and grand totals on numeric columns. You may want to count the number of items in a non-numeric column such as company name. Use Calc-O-Matic for this action.

To add a predefined calculation in a table:
- click the column you wish to perform the calculation on
- choose Tools > Calc-O-Matic
- in the Calc-O-Matic dialog box, select a calculation
- click OK

The Calc-O-Matic dialog box may have one or two columns, as shown on the next page. If the Calc-O-Matic dialog box contains one column, you can only add grand totals.
Adding Predefined Subtotal Calculations

- If the data is grouped, you can add subtotals
- The Calc-O-Matic dialog box contains two panes

If the Calc-O-Matic dialog box contains two panes, you can also add subtotals.

For instance, you want a count of the number of stores in each Region. Click the Store Name column, click Tools > Calc-O-Matic, click Count in the Select a function column, then click Region in the Select a group break column.

Columns only appear in the “Select a Group Break” column if a control break is applied to it. A control break is automatically applied in BI/Query Reports to all columns that are sorted in the query or on which duplicates have been suppressed.
Adding a Control Break

- If sorting was not applied to a column, but it is in sorted sequence (grouping applied to it), you can specify it as a control break
- Suppressing duplicates in a column hides duplicate values and designates the column as a control break

To suppress duplicate data:
- click any item in a column that displays duplicates
- choose Format > Table > Suppress Duplicates

### Total Sales by Region and Country

<table>
<thead>
<tr>
<th>Region</th>
<th>Country</th>
<th>Store Name</th>
<th>SUM Order Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td>Australia</td>
<td>Golf Boutique Melbourne</td>
<td>1,219,378</td>
</tr>
<tr>
<td>Asia</td>
<td>Australia</td>
<td>Golf Boutique Sydney</td>
<td>1,814,700</td>
</tr>
<tr>
<td>Asia</td>
<td>China</td>
<td>Golf Boutique Hong Kong</td>
<td>1,219,509</td>
</tr>
<tr>
<td>Asia</td>
<td>Japan</td>
<td>Golf Boutique Tokyo</td>
<td>1,208,353</td>
</tr>
<tr>
<td>EU Central</td>
<td>Germany</td>
<td>Golf Boutique Berlin</td>
<td>1,848,344</td>
</tr>
<tr>
<td>EU Central</td>
<td>Germany</td>
<td>Golf Boutique Düsseldorf</td>
<td>1,170,661</td>
</tr>
<tr>
<td>EU Central</td>
<td>Germany</td>
<td>Golf Boutique Frankfurt</td>
<td>1,757,447</td>
</tr>
<tr>
<td>EU Central</td>
<td>Netherlands</td>
<td>Golf Boutique Amsterdam</td>
<td>1,829,237</td>
</tr>
<tr>
<td>EU Central</td>
<td>Netherlands</td>
<td>Golf Boutique Rotterdam</td>
<td>1,199,199</td>
</tr>
<tr>
<td>EU Northern</td>
<td>UK</td>
<td>Golf Boutique Aberdeen</td>
<td>1,261,993</td>
</tr>
</tbody>
</table>

### Total Sales by Region and Country

<table>
<thead>
<tr>
<th>Region</th>
<th>Country</th>
<th>Store Name</th>
<th>SUM Order Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td>Australia</td>
<td>Golf Boutique Melbourne</td>
<td>1,219,378</td>
</tr>
<tr>
<td>Asia</td>
<td>Australia</td>
<td>Golf Boutique Sydney</td>
<td>1,814,700</td>
</tr>
<tr>
<td>Asia</td>
<td>China</td>
<td>Golf Boutique Hong Kong</td>
<td>1,219,509</td>
</tr>
<tr>
<td>Asia</td>
<td>Japan</td>
<td>Golf Boutique Tokyo</td>
<td>1,208,353</td>
</tr>
<tr>
<td>EU Central</td>
<td>Germany</td>
<td>Golf Boutique Berlin</td>
<td>1,846,344</td>
</tr>
<tr>
<td>EU Central</td>
<td>Germany</td>
<td>Golf Boutique Düsseldorf</td>
<td>1,170,661</td>
</tr>
<tr>
<td>EU Central</td>
<td>Germany</td>
<td>Golf Boutique Frankfurt</td>
<td>1,757,447</td>
</tr>
<tr>
<td>EU Central</td>
<td>Netherlands</td>
<td>Golf Boutique Amsterdam</td>
<td>1,829,237</td>
</tr>
<tr>
<td>EU Central</td>
<td>Netherlands</td>
<td>Golf Boutique Rotterdam</td>
<td>1,199,199</td>
</tr>
<tr>
<td>EU Northern</td>
<td>UK</td>
<td>Golf Boutique Aberdeen</td>
<td>1,261,993</td>
</tr>
</tbody>
</table>
Show/Hide Bands

- You can choose which bands will be displayed in a table by hiding or showing them
  - For example, you may not want to include the Report Header band in your reports or you may want to display the group header band
- Hiding a band also hides the data in the band

The Show/Hide Bands command on the Format > Table submenu opens a dialog box from which you can identify the bands you want in your table. You can also identify the ones you want to hide.

To show or hide a band:
- choose Format > Table > Show/Hide Bands
- select the band you want to show/hide
- click the Show or Hide button
- click OK

The report header band and the group header bands in this table are hidden while all other bands are shown.

When you hide a band, everything within it is hidden as well. In addition, if there's a page break associated with a band, and you hide that band, the page break no longer applies.
Highlighting Exceptions

- Exceptions can be used to highlight areas of interest
- Making an exception is a two stage process
  - Design it in the exception builder
  - Apply the exception using an object’s properties

Exceptions highlight important information, for example order amounts that are below a certain threshold or employees whose performance exceeds certain goals.

Creating an exception is similar to building a calculation, but instead of having an equation in the Editor, you need to define a logical rule. You can name the exception so that it can be easily identified when you are applying it or editing it at a later date.

The True and False style boxes on the Exceptions Editor page can be used to specify how the exception will be shown within the report. For example, you can change the text style and/or fill color of an item, depending on whether the condition returns as true or false. Exceptions can be applied to anything in the table - columns, graphic, even the band.

<table>
<thead>
<tr>
<th>Region</th>
<th>Store Name</th>
<th>Total Order Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td>Golf Boutique Hong Kong</td>
<td>1,219,509</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Melbourne</td>
<td>1,219,378</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Sydney</td>
<td>1,814,700</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Tokyo</td>
<td>1,209,353</td>
</tr>
<tr>
<td>EU</td>
<td>Golf Boutique Amsterdam</td>
<td>1,829,237</td>
</tr>
<tr>
<td></td>
<td>Golf Boutique Berlin</td>
<td>1,846,344</td>
</tr>
</tbody>
</table>

Total order amounts greater than 1,500,000 are highlighted with bold.
Building Exceptions

■ Exceptions must be built before they can be applied to items in a table

To create an exception:

- click anywhere in the table
- choose Tools > Exceptions
- in the Exceptions dialog box, click New, then click the Description tab
- on the Description page, type a name and an optional description
- click the Editor tab
- on the Editor page, specify the exception
- to check the syntax of the exception, click Check
- to highlight an exception when it matches the expression, click True, then specify the formatting options you want
  or
- to highlight an exception when it doesn’t match the expression, click False, then specify the formatting you want
- click OK

If you want Exception formatting to override formatting applied through Properties, click the check box, otherwise the exception properties will not be applied.
Applying Exceptions

- Can be applied to individual columns or entire rows
- Can be turned on and off as required

Once you’ve created an exception, you can apply it to data, bands in a table, or graphics. When you apply an exception, you can control whether what you’ve applied it to is visible when the exception is true, false, or both. You can reuse exceptions, applying them to more than one object in a table. You can’t apply more than one exception to the same object.

To apply an exception:
- select the column
- choose Format > Properties
- in the Properties dialog box, click the General tab
- choose the exception from the Exception Name list
- click an item under Display Status
- click OK
Charts allow you to visually present summaries of your data. Charts are a visual way of presenting summaries of your data. They make abstract numbers more understandable by providing visual cues to the values and relationships the numbers express. Charts are particularly useful for presenting conclusions or for highlighting trends, patterns, and other relationships that aren’t apparent in tabular data.

Just as with the columnar reports, you use BI/Query to retrieve the data you want, then use BI/Query Reports to present the data in a chart.

There are ten basic chart types, with multiple variations available for each:

- Vertical Bar
- Horizontal Bar
- Pie
- 3D
- Area
- Line
- Stock
- Radar
- Scatter
- Special
Building a Chart using the Presentation Designer

- Follow the steps in the Presentation Designer to create a chart
- Use the pages in the Presentation Designer to select a chart style, titles, and select which columns to chart

To build the chart follow the steps below:

- With a results set displayed in BI/Query, choose Results > Show as Report > BI/Query Report
- On the Presentation page of the Presentation Designer, click Chart, then click Next
- On the Style page, click a chart type followed by a chart sub-type. Enter a title for your chart in the Title box at the top of this style page. Click Next
- On the Arrange Data page, if necessary, make any changes you want in the default arrangement by dragging the data from one location and dropping it in another
- Click Finish
Changing Chart Titles

- You can change the titles of a chart through its Properties.

To change chart titles:
- select Format > Properties or click the Properties tool
- in the Properties dialog box click the Titles tab
- type the new titles in the appropriate text boxes
- click OK
Changing The Chart Style

- You can change a chart's style after you have created it
- If you are changing to or from a pie chart, you may need to pivot the data

To change the chart style:
- select Format > Properties or click the Properties tool
- in the Properties dialog box click the Style tab
- choose a new style
- click OK

To pivot data:
- select Format > Properties or click the Properties tool
- in the Properties dialog box click the Options tab
- select Pivot Data
- click OK
Review Exercise

Build and submit a query to display the total order amount for each category and product name, by country. Select Category and Product Name from Product.

In BI/Query Reports, create a columnar report with totals.

Build an exception to test for Total Order > $400,000 and apply the exception to the Total Order values.

Format the report to look similar to the following:

### Product Sales Summary

<table>
<thead>
<tr>
<th>Country</th>
<th>Category</th>
<th>Product Name</th>
<th>Total Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td>Accessories</td>
<td>62 Inch</td>
<td>$262,394.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>68 Inch</td>
<td>$280,274.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>68 Inch Deluxe</td>
<td>$314,264.00</td>
</tr>
<tr>
<td></td>
<td>Subtotal for: Accessories</td>
<td></td>
<td>$856,932.00</td>
</tr>
<tr>
<td></td>
<td>Carts</td>
<td>Aluminum Pull Cart</td>
<td>$318,666.00</td>
</tr>
<tr>
<td></td>
<td>Subtotal for: Carts</td>
<td></td>
<td>$318,666.00</td>
</tr>
<tr>
<td></td>
<td>Clubs</td>
<td>Arsenal Woods</td>
<td>$400,535.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Battle Set</td>
<td>$725,091.00</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Bengal Set</td>
<td>$353,609.00</td>
</tr>
<tr>
<td></td>
<td>Subtotal for: Clubs</td>
<td></td>
<td>$1,479,235.00</td>
</tr>
<tr>
<td></td>
<td>Accessories</td>
<td>Bulk 1000 Pieces</td>
<td>$227,882.00</td>
</tr>
<tr>
<td></td>
<td>Subtotal for: Accessories</td>
<td></td>
<td>$227,882.00</td>
</tr>
</tbody>
</table>
Chapter 1: Summary

In this chapter you have learned how to:

- use the Presentation Designer to quickly and easily turn query results into meaningful reports
- create reports with subtotals and grand totals
- save and open reports
- generate information in a report by adding predefined calculations
- enhance the appearance of a table by manipulating bands and adding text
- resize and reorder columns
- highlight exceptional values
- move text labels within the table
- presents your results in a chart