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"Can't find the Admin layer…" 
 
If you see the following message: 
 

 
 
Click "Browse...". 
 



Data Warehouse Troubleshooting Tips 

 Page 2 of 17 Revised 4/20/2007 

 
 
Click on the "Up one level" button (a folder with a green arrow pointing up), so that you can see the Admin 
folder. 
 

 
 
Make sure that the folder you are looking in corresponds to the model you are trying to open. In the 
example above, we are trying to open the Finance model, and we are looking in the FINANCE folder. 
Click the down arrow next to the Look in box to make sure that is the FINANCE folder under 
c:\DWModels\OSU. Double-click on the ADMIN folder to open it. 
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Click on "finance.gqa", or the appropriate *.gqa file for the model you are trying to open, and click "Open". 
 
Once you get the model open, be sure to do a File > Save so that the model stores the new location you 
just found the next time it is opened. 
 
If there are questions or problems, contact the Warehouse Integration and Training Team for support. 
 

"Can't locate connection document…" 
 

 
 
This message means BI Query can't find the file that it uses to let the user connect and log in to the 
Oracle database. The document named in the message is the default connection file. It has probably 
been moved, renamed, or deleted. 
 
Click OK. 
 
Using My Computer or Windows Explorer, search for file named in the message. 
 
If you can't find that file anywhere, you can copy it from another data warehouse user's computer. 
 
If it is on the desktop or in some location other than the DWModels folder or its subfolders, move it to 
\DWModels\Connections. 
 
If the file is already in the \DWModels\Connections folder, then the model must be looking in a different 
folder. 
 
Go to Host > Connections. 
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Make sure the radio button next to biq.ini is selected. Then click the ellipses to the right of that line. 
 

 
 
Highlight the c:\DWModels\CONNECTIONS folder and click OK. 
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If the missing default connection file isn't there, you may need to search the user's hard drive and maybe 
even their network folders for any *.con files. In the past, all connection files should have been stored in 
the \GQLOSUDW folder or DWModels folder, or one of their subfolders. 
 
If the file may have been renamed, choose another connection file as the default, such as DWPROD.con. 
Click Close. 
 
Then go to File > Save. If that is grayed out, go back into Host > Connections, Highlight the Default 
connection and click the Default button twice so that the default bullet is removed and then replaced. 
Then go back to File > Save. 
 
Test that the connection file comes up properly now by going to Host > Connect. 
 
If there are questions or problems, contact the Warehouse Integration and Training Team for support. 
 

Column Headings are Missing after Copy/Paste 
 
One possible cause is that the user hasn't set their preferences to save column headings 
 
To change this setting for all future results sets, go into Tools > Preferences, and click Results Options. 
To affect only the active results set, go into Results > Options. 
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Click next to "Save column headings" so that box is checked. Then click OK. 
 
Click OK in the Preferences dialog box, if applicable. Then go to the File menu and choose Save to 
update your user customizations. 
 
This is also a known bug in BI Query version 9.0.2. There is a work around that in most cases provides 
the desired result, and is even easier. With the results window active, go to Results > Export. 
 

Connection Error: ORA-01017: invalid username/passw ord; logon denied 
 
When the user tries to connect, if they see the following dialog box before they are even offered a chance 
to log in, it usually means that BI Query 9.0.1 is installed and missing an essential patch. 
 

 
 
The recommended solution is to upgrade the computer to BI Query 9.0.2. Refer to the instructions for 
either the automated or manual installation of BI Query to learn how to uninstall 9.0.1 and install 9.0.2. 
 
An alternative solution is to manually apply the patch. Users who have Administrator rights on their 
machine and are comfortable with following the instructions given below can apply the patch themselves. 
Other users should contact their Departmental Computer Administrator. 
 
Open c:\program files\hummingbird\bi\query\bi.ini in Notepad. Here is what the first few lines will look like. 
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Look for "ODBC.TestConnectWhenMissingInfo=True" and change "True" to "False". Then choose File > 
Save, and then File > Exit. 
 
If the user is given a chance to log in and then sees this error, they should make sure that what they 
typed for their username and password is correct. The username and password are not case-sensitive, 
but if Caps Lock is on, that could affect the characters they are typing. They should also check that the 
Num Lock is on if they are using the numeric keypad. 
 
If the user is sure that they are using the correct username and password, they should check that they 
are using the correct connection file for the database they are connecting to. Go to Host > Connections, 
highlight the connection file they connected with (usually the default, indicated with a bullet next to it), and 
click Edit. The value shown as the Database String should be correct for the database the user is trying to 
connect to. Most OSU employees should be connecting to DWPROD (not case sensitive). 
 
If none of the above tips resolves the problem, the user should contact the Warehouse Integration and 
Training Team for support. 
 

Connection Error: ORA-12154: TNS: could not resolve  service name 
 
When the user tries to connect, if they see the following dialog box, this usually indicates a problem with 
the connection to Oracle. 
 

 
 
Make sure the network is accessible. If it is, then contact the DCA for assistance. 
 
Try removing the sqlnet.ora file from the C:\Oracle\10.2\Client_1\NETWORK\ADMIN folder and logging in 
again. 
 
If that doesn't work, search the user's hard drive for other copies of the TNSNames.ora file, and test each 
one by placing it in the C:\Oracle\10.2\Client_1\NETWORK\ADMIN folder and logging in again. 
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If that doesn't work, download the default TNSNames.ora file from the software distribution server, 
\\softdist2\Oracle\10\TNSNames\OSU\tnsnames.ora (or download 
\\softdist2\Oracle\10\TNSNames\OUS\tnsnames.ora if the user needs to access OUS data warehouses) 
and put it in the C:\Oracle\10.2\Client_1\NETWORK\ADMIN folder and repeat the test. 
 
If none of the above tips resolves the problem, contact the Warehouse Integration and Training Team for 
support. 
 

Crashing application 
 
Multi-processor and dual core computers can experience a variety of spontaneous, errors, often resulting 
in the connection to the data warehouse being lost, or the application crashing entirely. Initial versions of 
BI Query 9.0.1 and 9.0.2 did not contain a patch to fix this problem. Patches are now being made 
available to resolve this problem. 
 
One way to check if a machine is multi-processor, is to right-click on My Computer and choose Manage. 
Click on Device Manager, then click on the plus sign next to Processors. If two or more are listed, then 
you have a multi-processor machine. 
 
To see if the patch has been applied, in Task Manager, right-click on BIQuery.exe. If "Set Affinity" 
appears, the system has been patched. 
 

File exchange from ‘c:\dwmodels\ous\fis\user\wfaaaa aa’ to 
‘c:\dwmodels\ous\fis\user\ous.gqu’ failed. 
 
This usually occurs when downloading a new version of a model if the user does not have Administrator 
rights to the DWModels folder. 
 
Log on to the computer as a member of the Administrators group. 
 
In Windows Explorer, right-click on the DWModels folder and choose "Sharing and Security". 
 
Choose the Security tab and highlight the "Users" group. Check the "Allow" beside "Modify". 
 
"Click OK". 
 

Manuals aren't Installed 
 
BI Query manuals in PDF format are available to be downloaded from our website. You'll find them at 
http://oregonstate.edu/dept/computing/warehouse/handouts.html#UserGuides 
 

No results were found for your query 
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This is the most common error message. When you get that, it may mean that your query was designed 
correctly but there isn't any data in the system matching your qualifications. For example, you qualify in 
the Transaction ledger on an I-Doc number that hasn't completed all of its approvals, so it hasn't posted 
and been loaded in the DW yet. 
 
If you are sure that your query should result in some data, then it means you need to go back to your 
query and look at what you entered into any prompts, and to look at your qualification diagram to make 
sure that you don't have any mistakes. For example, maybe you didn't capitalize all of the characters in 
your Major code when you typed it into a prompt. Or you qualified on Org = 11, instead of Org Begins with 
11. 
 

Printer won't change 
 
When printing a standard report, if you try to change from your Windows default printer to another printer 
but the report prints on the Windows default printer, the user has encountered a known bug in BI Query 
Version 9.0.1. 
 
The recommended solution is to upgrade to BI Query Version 9.0.2. 
 
The work around is to first go into File > Print Setup, choose the desired printer, and click OK. Then print 
the report as you normally would. 
 

Reports or Labels not displaying correctly 
 
BI Query usually works best with post script printer drivers. If a user has problems displaying and printing 
reports or labels, you may want to install post script printer drivers and set them up as the default printer, 
or at least install them as an option your users can select when they encounter problems. 
 
Examples of problems that users might encounter when they don't use a post script printer driver as their 
default are: 
 
Reports that should be landscape display as portrait, or vice versa. 
Reports that should fit onto one page spill over onto a second page. 
Labels that should be 3 columns wide are 2 columns wide. 
 

Results Window is Too Big 
 
When a results set has several columns of data, the results window is sometimes too big for the 
application window, making buttons and scroll bars at the right side of the window not easily accessible. 
This is a known bug. Use one or more of the techniques listed below as work arounds. 
 

• Manually resize or move the window. 
• Use arrow keys, Page Up and Page Down on the keyboard to move around in the results set. 
• Use the scroll button on your mouse to scroll vertically through the data. 
• Double-click on the title bar to maximize the window. 
• Use Ctrl+F4 to close the window. 
• Double-click on the graphic in the left corner of the title bar close the window. 
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Subtotals and Totals have no height 
 
In a BI Query Standard Report, if you create a subtotal or grand total, and none of the columns in your 
results set are formatted as numbers, then the subtotal or grand total will have a height of .01, and you 
may be able to select the text label, but you can't change the calculation from None to Count or make any 
other changes to the subtotal row. It may look like the example shown below. 
 

 
 
The work around is to edit your query to add any column that is formatted as a number or date. Rerun the 
query. Then in the report, hide the unwanted column. 
 

"Unable to execute application 'GQL/User'." 
 

 
 
This occurs when a user goes to Results > Export, and they haven't first set up their Export Options to 
send results to Excel or another application. 
 
To set up this functionality, go into Tools > Preferences. 
 
Click OK. Then, when still in the Preferences dialog box, click "Export Options". 
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Select Excel, or your desired application, from the drop down menu. Click on the "…" button and browse 
to the location of the Excel application on your computer.  
 
The following examples of DDE command sequences send results to Microsoft Excel. For other 
commands, see your Excel user documentation.  
 
Command Sequence Description 
[Paste()] Pastes the results into a worksheet already open in Excel (or, if Excel is 

not already running, runs Excel, opens a new worksheet, and pastes 
the Clipboard contents into it). 

[New()][Paste()] Pastes the results into a new worksheet in Excel. 
[Open("c:\results.xls")]| 
[Paste()] 

Opens the specified worksheet (if it is not already open) and pastes the 
results into it. 
If you often use the same format for a worksheet, you can set up a 
worksheet template, and then use this command sequence to paste 
results into it. Once the results have been pasted, you can save the 
worksheet under a different name. 

 
Click OK. Then in the Preferences window, click OK. Then go to the File menu and choose Save to 
update your user customizations. 
 

Unhandled Exception Error: Failed to load DLL: hbil m 
 

 
 
This error occurs if BI Query version 9.0.1 is installed when you attempt to install BI Query version 9.0.2. 
Follow the instructions in either the Automated or Manual Installation instructions for BI Query to remove 
version 9.0.1 prior to installing version 9.0.2. 
 

What version of BI Query is installed? 
 
Start BI Query. Then look in the menus: Help > About BI Query User 
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You want to see version 9.0.1.0345 or 9.0.1.0219. 
 

What version of the model I am looking at? 
 
Open a model in BI Query User. 
 
You should be on the Home window. If not, navigate there. 
 
You should see text on the window specifying a version number and release date. 
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This is the last time changes were made to the model, not the software. After a model is released, users 
are automatically prompted to download the new model each time they log in until they comply. 
 

Window Doesn't Open When Selected 
 
If you go to the Window menu, choose "More Windows…", and select a window to open, sometimes the 
window listed above it opens instead. If the window you want isn't the last window, you can sometimes 
select it by selecting the window right below it in the list. If you are trying to access the last window, 
running another query and not closing the results will usually make that new results window the last one. 
Select it and hopefully the window you want right above it will open. 
 
Another alternative is to start minimizing windows until the one you want (if it wasn't already minimized) is 
visible. 
 

Windows Security Alert 
 
Version #1 
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This means you are logged on as an Administrator of the machine, and Windows Firewall hasn't been 
configured to allow BI Query to function properly. Click Unblock. 
 
Version #2 
 

 
 
This means you are not logged on as an Administrator of the machine, and Windows Firewall hasn't been 
configured to allow BI Query to function properly. 
 
Contact your DCA (Departmental Computing Administrator) and ask for their assistance in allowing BI 
Query Reports through the Firewall. 
 
The DCA should log on to the computer as a member of the Administrators group. 
 
Go to the Windows Start menu > Control Panel > Security Center > Windows Firewall. 
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Click on the Exceptions tab.  
 

 
 
If BI Query Reports is visible but not checked, click in the checkbox next to it. 
 



Data Warehouse Troubleshooting Tips 

 Page 16 of 17 Revised 4/20/2007 

 
 
If BI Query Reports isn't visible, click Add Program…. 
 

 
 
Highlight BI Query Reports and click OK. 
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Click Ok. Close Windows Security Center. Close Control Panel. 
 

You have made changes to this data model. Would you  like to save your 
changes? 
 

 
 
This pops up frequently. Going into design mode and creating anything, like a button, will cause it to 
happen. Going into Results Options to change your export settings will do it. Editing your 
Tools/Preferences will do it. Creating a calculated attribute, or opening a query that contains a calculated 
attribute will do it. There are probably other things as well. 
 
Usually you should click "No" unless you know you just made a deliberate change and want to save it. 
 


