OREGON STATE UNIVERSITY

You are here

What version of Flash do I need to play MediaSpace videos?

Flash is not required to playback media in MediaSpace. If you find that videos and audio are not loading in your web browser, please make sure that you have the latest version of that browser. If you are not sure, or your browser needs updating, please contact the OSU Computer Helpdesk.