Chapter 4: Charts

- Charts Overview
- Determining What Data to Include
- Choosing the Best Chart Type for Your Data
- Understanding How Charts Work
- Changing How Charts Summarize Data
- Rearranging Data
- Properties of a Chart
- Chart Editor
Charts are a visual way of presenting summaries of your data. They make abstract numbers more understandable by providing visual cues to the values and relationships the numbers express. Information presented in chart form is clearer and more memorable than text.

Charts are particularly useful for presenting conclusions or for highlighting trends, patterns, and other relationships that aren’t apparent in tabular data. For example, if you need to create a report that shows the long-term sales of your company’s products, a chart is the best method for presenting an overview of your company’s performance over time.

BI/Query Reports allows you to create graphical reports with impact by representing your data in a variety of charts and graphs. In addition to creating two-dimensional bar, line, area, and pie charts, you can create 3D charts, scatter charts, histograms, spectral maps, and more.

You can add a legend, format text labels, and use the powerful Charts Editor to specify colors, draw arrows and shapes, and modify three-dimensional chart perspectives to achieve exactly the look you want.
Determining What Data to Include in Charts

- Use charts for summary data
- Limit the number of values you are charting

Not all data make a useful chart. You need to determine whether a chart is a good solution to your business problem and whether you have the right data to create the chart. Charts work best for summary-level information, not for detailed data. When gathering the data for a chart, follow the guidelines in the design checklist.

Design Checklist

- Ensure that the data are intrinsically multidimensional (contains information on at least three dimensions of your business, such as Product, Region, and Metrics).
- Ensure that some of the data is numeric (for example, the data contains metrics such as Units Sold, Revenue, Cost, and Margin).
- Identify the key metrics that measure your success (numeric columns such as Revenue, Units Sold, Margin, Rejected Units, Downtime, and so on).
- Keep the number of attributes in your query small (two to five).
- Ensure that columns don’t contain too many values. Charts communicate most effectively with seven or fewer values along one axis.
- Ensure that the data are evenly distributed. (For example, each metric is captured for all products sold in all sales offices.)
- Focus on one business problem per chart. (Don’t try to answer every question in a single chart.)
- Identify the critical time period. (If you need to compare results over quarters, don’t include monthly or weekly data.)
Choosing the Best Chart Type for Your Data

BI/Query Reports provides a wide range of chart types from which to choose. Before you create a chart, you need to consider the type of data you’re charting and choose the chart type that’s best suited to it. You also need to choose the best chart type for the conclusion you want to present.

Effective charts are simple. They don’t use a lot of fancy graphic options, which can clutter the data and confuse your reader. They also don’t show a lot of data. If you need to present a lot of data in a report, consider using a table or crosstab.

Use the following table to choose the best chart to display your data:

<table>
<thead>
<tr>
<th>To Show This</th>
<th>Use This</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data that changes over time</td>
<td>Line</td>
<td>Annual sales for the last 10 years;</td>
</tr>
<tr>
<td></td>
<td>Bar</td>
<td>30-day stock trend;</td>
</tr>
<tr>
<td></td>
<td>Stacked bar</td>
<td>Exports and imports between 1988 and 1998</td>
</tr>
<tr>
<td></td>
<td>3D bar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Area</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Stock</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Stacked area</td>
<td></td>
</tr>
<tr>
<td>Data at a single point in time</td>
<td>Horizontal bar</td>
<td>1998 sales for a family of products;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1998 sales and costs by month;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Number of employees per sales office</td>
</tr>
<tr>
<td>Parts of the whole</td>
<td>Pie</td>
<td>Percent of sales by region;</td>
</tr>
<tr>
<td></td>
<td>Percent bar</td>
<td>Market share</td>
</tr>
<tr>
<td></td>
<td>Percent Area</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Doughnut</td>
<td></td>
</tr>
<tr>
<td>Frequency distributions</td>
<td>Histogram</td>
<td>Number of employees in various age categories</td>
</tr>
<tr>
<td></td>
<td>categories</td>
<td></td>
</tr>
<tr>
<td>Relationships between variables</td>
<td>Scatter</td>
<td>Relationship between advertising cost and revenue</td>
</tr>
<tr>
<td></td>
<td>Bubble</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Dual Axis</td>
<td></td>
</tr>
<tr>
<td>Ranges of data</td>
<td>Stock</td>
<td>Daily temperature ranges; Range of time between initial contact and close by salesperson</td>
</tr>
<tr>
<td>Scientific data</td>
<td>Spectral</td>
<td>Optimal mix of temperature and time for creating plastic;</td>
</tr>
<tr>
<td></td>
<td>Radar</td>
<td>Comparison of nutritional content of different foods</td>
</tr>
</tbody>
</table>

©Copyright Hummingbird Ltd 2000
Understanding How Charts Work

- Items in charts can be manipulated to focus the reader's attention
  - Hide, reorder, or filter your data
- Bars in a bar chart may be ordered so the highest bar is in the middle of the chart

A chart is a graphical representation of data. Each element (one bar in a bar chart, one wedge in a pie chart, or a point in a line chart) represents the total value for a numeric item (a metric) as it relates to non-numeric items (dimensions and members).

You can change how the data are arranged in a chart by pivoting dimensions and changing how dimensions are nested and by reordering and hiding members. As well, you can focus on specific information by filtering on a member in a dimension.
Changing How Charts Summarize Data

- Alphanumeric columns are identified as dimensions
- Numeric columns are identified as Metrics

How data are being summarized is displayed on the Arrange Data page of the Presentation Designer. Columns containing text and dates are listed under Available data; they become dimensions in the chart. Columns containing numeric data are listed under Metrics; they become members of the Metrics dimension, and their values are plotted along the y-axis.

Occasionally, you may not want all the data in the chart to be summarized. For example, you may want to create a scatter chart containing detailed data that plots metrics along both axes of the chart. You can change how data is summarized by moving columns out of the Metrics area.
Changing How Charts Summarize Data

- You can change a numeric column from a Metric to a dimension

To change how a chart summarizes data:
- on the Arrange Data page of the Presentation Designer, click a metric in the Available Data list
- drag it into the white space at the bottom of the list. (Because Order Year is a numeric, it was originally defined as a Metric. Dragging it from the Metrics area to the bottom of the list redefines it as a dimension.)
Rearranging Data

- You can select where items appear in your chart (e.g. x-axis, y-axis, or z-axis)

You can make charts easier to understand by arranging the dimensions in them. You can change the way dimensions appear by pivoting a chart or by moving a dimension from one axis to another. You can also change the appearance of a dimension by nesting it within another dimension.

Pivoting Dimensions

You can change your view of the data in a chart by swapping, or pivoting, the arrangement of the dimensions on the x-axis with those in the legend. Pivoting allows you to see different relationships in the data.

To pivot a dimension:
- click a chart, then choose Format > Chart > Rearrange Data
- in the Rearrange Data dialog box, to swap dimensions between X Axis and Legend, click Pivot

OR
- under X Axis or Legend, click a dimension, then drag it to Legend or X Axis (To move a dimension from X Axis, there must be more than one dimension in it.)
- click Close

See the next page for an example.
Rearranging Data - An Example

Yearly Sales by Territory

Yearly Sales by Territory
Nesting Dimensions

- Displaying data with “nested” relationships (e.g. Years and Months) allows you to change the emphasis on the chart:
  - How have sales been in the same months over numerous years?
  - How have sales been throughout a year?

When more than one dimension lies along the same axis of a chart, the members within the dimension have a nested relationship. If the members are along the x-axis, the chart displays the members for the second dimension “inside,” or nested within, the members of the first dimension. Nested members normally represent subdivisions within another higher-level dimension. Nesting allows you to change the emphasis or relative importance of nested dimensions within the chart.

For example, if you’re analyzing product sales over the past two years, you might want to create a chart with Months nested within Years. If you notice an anomaly in a particular Month or want to change your analysis to compare Monthly results over the past two years, you can change the nesting to Year within Month.

To change how dimensions are nested:

- click a chart, then choose Format > Chart > Rearrange Data
- in the Rearrange Data dialog box, click a dimension. (There must be more than one dimension on that axis of the chart.)
- drag the dimension up or down
- click Close

See the next page for an example.
Nesting Dimensions - An Example

Territory Sales by Year

Yearly Sales by Territory
Reordering Members

- You can change the order of a dimension's members to emphasize significance

Occasionally, you may want to rearrange the order of members within a dimension to display related items together. For example, you may want to place new account executives in the first part of a chart so you can easily keep an eye on their progress. Or you may want to arrange them by their performance.

To reorder members:

- click a chart, then choose Format > Chart > Rearrange Data
- in the Rearrange Data dialog box, click the Member tool for a dimension
- in the Included Members dialog box, drag the members up or down in the Included Members list
- click Close
- in the Rearrange Data dialog box, click Close
Hiding Members

- You can remove members of a dimension from your chart to:
  - hide data from your readers
  - change the focus of your chart
  - "clean-up" the appearance of your chart, making it more readable

Charts lose impact and become difficult to read when they contain too much data. To improve the readability of charts, you can remove one or more members. (This doesn’t affect the data source you’re using because the change is made in the view.) This is particularly useful if you’re interested only in a subset of the data.

To hide members:
- click a chart, then choose Format > Chart > Rearrange Data
- in the Rearrange Data dialog box, click the Member List tool for a dimension
- in the Included Members dialog box, drag a member from the Included Members list to the Available list
- click Close
- in the Rearrange Data dialog box, click Close
Refresh Preferences

- Hidden members will stay hidden if the Refresh preference is set to Show Existing Items Only

Show all items
Displays all the items in a chart or a crosstab after the report has been refreshed. For example, if a chart containing two items (Canada and France) is associated with a hotspot, and you re-qualify the hotspot so that it'll return three items (Canada, France, and USA), all three items will appear in the chart after the report is refreshed.

Show only existing items
Displays only the existing items in a chart or a crosstab after the report has been refreshed. For example, if a chart containing two items (UK and France) is associated with a hotspot, and you re-qualify the hotspot so that it'll return three items (UK, France, and Spain), only the original items (UK and France) will appear in the chart after the report is refreshed.
Filtering Data

- Use the filter to focus on a particular area of interest

When you want to focus on information of particular interest, you can filter the data. Filtering controls the focus in a chart by displaying only the data related to a specific member, thereby simplifying the view. For example, when a chart contains sales information for products across sales regions, you may want to filter the data to see details only for a particular region.

To filter data:
- click a chart, then choose Format > Chart > Rearrange Data
- in the Rearrange Data dialog box, drag a dimension under Filter On
- click Close

Note the filter in the Presentation Designer as well. To focus a chart on a particular item, click Filter On, then drag the item into the Filter On box.
Changing the Data in the Filter

Changing the data in the filter changes the focus of the chart without refreshing.

To change the data in the filter:

- click a chart, then choose Format > Chart > Rearrange Data
- in the Rearrange Data dialog box, under Filter On, click the Member tool for the dimension
- in the Filter Member dialog box, drag a member under Filter Member
- click Close
- in the Rearrange Data dialog box, click Close

Note: You can filter on only one member of a dimension at a time.
Changing Titles and Labels

- You can change the title, subtitle, footnote, and series and group labels

You can change the titles and text labels on a chart to more accurately reflect the information in it. You can change the title, subtitle, footer, and series and group labels.

To change a title and labels:
- click a chart, then choose Format > Properties
- in the Properties dialog box, click the Titles tab
- on the Titles page, make the changes you want
- click OK

If you are using a Horizontal Bar chart, the X- and Y-axes are reversed.
Changing Titles and Labels - An Example

Total Sales by Country
Shown in Thousands of Dollars

Country Name
Argentina
Australia
Canada
France
Hong Kong
Italy
Japan
Korea
Mexico
New Zealand
Peru
UK
USA

X-axis (groups)

Title
Subtitle

Y axis (metrics)

September 13, 1999

Footer
Changing Options

- Use the Options page in the Properties dialog box to change data labels, grids, axes labels, and the legend

Use this page to modify the appearance of a chart. For example, you can indicate that you want labels, a legend, or grid lines to appear. You can also change the depth of two-dimensional charts and provide values and lines for pie charts.

To change options:
- click a chart, then choose Format > Properties
- in the Properties dialog box, click the Options tab
- on the Options page, make the changes you want
- click OK
Changing Options

Data Value Labels  Displays data values for the wedges in a pie chart
Pie Group Labels Displays labels for the wedges in a pie chart. The labels reflect the included members in the dimension that appears in the legend for the pie chart. To view the dimension that appears in the legend, click the chart, then click Format > Chart > Rearrange Data
Feeler Lines Displays lines from the wedges of a pie chart to the corresponding data values
Depth (2 1/2 D) Displays the bars in a bar chart so that they appear three dimensional
Display column data labels using Specifies how to display the labels for the included members in the dimension that appear in the legend (series)
Display row data labels using In pie charts, specifies how to display the labels for the included members in the Metrics dimension. In bar, line, area, and 3D charts, specifies how to display the labels for the included members in the dimension that appears in the X axis (groups).
Show grids Displays the grid lines for the X-, Y-, second Y- or Z-axis
Show axes labels Displays labels for the X axis or the Z axis
Legend Displays a legend for two dimensional charts
Pivot Data Specifies that the data in a chart is organized as groups. If this option isn’t selected, the data is organized as series.
Show data in band If the chart is inside a band in a table, it shows the data associated with the band. To have the chart show all the data in the table instead of just the data in the band, click this option to deselect it.
Lab 4.1 (page 1 of 2)

Creating and Manipulating a Chart

- Build and submit a query to retrieve Region, Year, and Order Amount.
- Create a Side-by-side bar chart similar to the one shown on the next page.
- Use the Rearrange Data dialog box to reorder the years, from newest to oldest.
- Use Properties to change the chart titles.
- Once you have finished the chart, change it to a pie chart and filter on the European region.
- Your charts should look similar to the ones on the next page.
Chart Editor

- You can make more formatting changes using the Chart Editor
- For more information refer to the electronic Chart Editor user's guide
- You can locate this under the Start menu in Programs
  > Hummingbird BI Suite > Online Documents > BI-Query Chart Editor User's Guide

You can increase the formatting options available to you using the Chart Editor. For example, you can format text labels and change their placement along the axes and in the legend. You can change colors and add patterns and fills. And you can remove perspective from two-dimensional charts, alter its direction, and change the thickness of the markers.

The Chart Editor is an OLE-enabled application, so you can edit charts within BI/Query Reports; you don’t have to run the editor separately.

To format a chart using the Chart Editor:
  - click a chart, then choose Format > Chart > Advanced Editor
  - make the formatting changes you want
  - choose File > Exit
The Chart Editor Window

When you edit a chart using the Chart Editor, your chart is in a separate window.

Chart editor palette to add text, boxes, lines and irregular shapes to the chart.

Chart editor font selection palette

Chart editor color selection palette
In the chart editor you are presented with a series of new menus and palettes.

**Menus**

- **Gallery**  Allows you to select a chart type from a list of approximately eighty different charts.
- **Chart**  Allows you to control the appearance of the chart. In a bar chart you can change the depth and direction of the bars as well as the appearance of a legend.
- **Element**  Allows you to specify the line width and style plus alignment.
- **Window**  You can specify the chart scale and view the chart on the full screen.
Chart Editor - Emphasizing a Pie Wedge

- If you are working with a pie, you can emphasize one or more wedges.

It is often useful to emphasize one or more slices by sliding them out from the centre. Any number of slices can be detached.

To detach a slice:
- select one or more slices
- from the Chart menu choose Detach Slice (or choose Detach Slice from the context-sensitive menu)
- select the desired detach amount

Detaching Slices

Detaching Slices
Chart Editor - Emphasizing a Bar

- You can emphasize one or more bars in a bar chart

To add emphasis to a bar in a bar chart you can give it a unique color or effect, different than that assigned to the other bars in the series. You can assign special emphasis to as many bars on the chart as you wish. Be careful of changing too many, however, since the impact of the emphasis of any one bar will be diluted.

To emphasize a bar:
  - select the bar
  - from the Chart menu choose Emphasize Bar (or right-click and select Emphasize Bar from the context-sensitive menu)
  - use the color picker or the effects palette to give it special decoration
Chart Editor - Text Rotation

- You can rotate text labels to make the report more readable

In the chart editor, you can also control the text rotation for values on the axis.

To rotate text:
- right-click one of the x-axis labels
- from the context-sensitive menu, choose Text Rotation
- select the type of text rotation from the submenu
Chart Editor -
Creating Mixed Charts

- A mixed chart presents the various items in different chart formats
- You can mix bar and line charts

When you mix data in a chart for comparison purposes, a mixed chart allows you to clearly identify the different types of data. For example, you can format a chart containing both a total and the members that make up that total as a mixed chart. You can display the total as a line and the members that make up that total in bars.

You can change a line to a bar, or a bar to a line.

To create a mixed chart:
- in the Chart Editor, right-click the bar (or line) you want to change
- from the context-sensitive menu, select Display as Line (or Display as Bar)
Chart Editor -
Changing the Y-axis Scale

- By default, the Y-axis is automatically scaled for you
- You can manually scale the Y-axis

The Charts Editor automatically selects the correct scale for the numeric axis. Automatic selection scans the data to find the high and low values. It uses these to make the scale range. For linear scales you can override this automatic selection. You then have a choice of what to do with data outside the scale range.

Manually setting the scale range allows you to compare two charts that have different data.
To change to manual scaling:

- right-click on any of the scale numbers along the numeric axis
- choose Scale Range from the context-sensitive menu
- click Automatic to deselect it
- in the From text box, enter the low end of the scale range you want
- in the To text box, enter the high end of the scale range you want
- select how values outside the From/To range are to be treated
  - GRAPH out of range values at scale limits: Out-of-range data will be charted at the scale limits. Be careful of this choice since it makes out of range values appear incorrect
  - DON’T GRAPH out of range values: Out-of-range data will not appear on the chart. Care is required here also since it incorrectly make it look like data are missing
- click OK
Lab 4.2

- Rotating Text and Emphasizing Bars
  - Build and submit a query to retrieve Country and a sum of the Order Amount.
  - Create a vertical bar chart.
  - Use the Advanced Editor to rotate the Country name text.
  - Use the Advanced Editor to emphasize the France bar.
  - Your chart should look similar to the one below.

Using the Advanced Editor

![Graph showing bar chart with countries and order amounts.](image-url)
Chapter 4: Summary

- In this chapter you have learned how to:
  - present data in a chart
  - manipulate the chart