Chapter 3: Multiple Presentations

- Data Sources Are the Source of Your Information
- Views Link Presentations
- The Data Source Dialog Box
- Adding a Presentation to an Existing Report
- Changing the Report Size
- Linking a Chart to a Table
- Adding a Chart to a Table
- Linking a Chart to a Crosstab
- Linking a Map to a Table
Data Sources Are the Source of Your Information

- BI/Query results are stored as raw data in data source files
- Data source files are temporarily stored in the C:\Temp folder and have a .hcr extension

When you retrieve the results of a query in BI/Query, then create a report in BI/Query Reports, a data source is created that stores the raw data. When you create a tabular report, the format of the data is two-dimensional. When you create a crosstab or chart, the two-dimensional data are organized into a multidimensional format to display data in more than one category at a time.

You can create different presentations in the same report using the same data source. Data sources don't change, even when you manipulate the data in your reports - for example, by adding calculations or removing a dimension from a crosstab. The manipulated data are stored in a middle layer called a view.

You can include data from multiple data sources in one report. This allows you to create a report that contains data from multiple queries and even multiple databases.

By default data sources are stored in the C:\Temp folder and are deleted when BI/Query Reports is closed.
Views Link Presentations

When you create a presentation, BI/Query Reports creates a subset of the data called a view. A view is the "middle layer" between a presentation and the corresponding data file that stores calculations, exceptions, and the arrangement of the data.

When you create different presentations using the same view, you can manipulate the data in one presentation and add calculations to it, and those changes will be automatically reflected in another presentation. For example, you can create a crosstab, hide members you don't need, and add a sum. When you create a chart using the view of the crosstab, the chart shows the same arrangement of data as the crosstab, including the sum.
The Data Source Dialog Box

Lists the available data sources during this BI/Query session. If you want to use a data source that isn't listed, click the Browse button to search for it. By default, data sources are in your temp directory.

Data sources are listed in chronological order, with the most recent at the bottom of the list.

The green icon identifies data sources. The yellow icon with the plus sign identifies a view.

Removes the selected data source. You can't remove data sources that you're using in the report.

Allows you to view the items in the selected data source. This is only a preview area. You can't manage your data from here.

Opens the Open dialog box, where you can search for data sources.

Provides the path for the selected data source as well as information about when it was created and when it was last modified.
The Data Source Dialog Box - For Charts and Crosstabs

The turquoise cube represents a summarized data source, called a HyperCube.
Adding a Presentation to an Existing Report

- You can add other tables, charts, crosstabs and maps to an existing report
- The additional presentations can be based on the same data source or a different data source

Once you’ve create a report, you can add other presentations to it. You can add a table, chart, crosstab, or map to a report using data that you’ve already retrieved using BI/Query, or you can retrieve new data.

**Using Existing Data**
- in your report, click a presentation tool on the Presentation toolbar
- on the Data Source page of the Presentation Designer, click a data source
- follow the steps in the Presentation Designer

**Using New Data**
- formulate and submit a query and send the results to BI/Query Reports
- in the Presentation Designer, click Finish
- close the report without saving
- open and refresh the report to which you want to add the presentation
- insert a presentation following the steps above
Changing the Report Size

- Additional presentations are placed on a new page in the report
- If you resize and rearrange the presentations, the report may contain blank pages
- You can add and remove blank pages from the report
- Blank pages do not print

To change the number of pages:
- choose Format > Report > Size
- in the Report Size dialog box, type in a width and height for the report
- click OK

If you’re not sure how small to make a report size, change the width and height to 1. BI/Query Reports will adjust the settings to the minimum size.
Lab 3.1

Adding a Chart to a Table Report Using Existing Data

You want a report that contains a chart and table presentation of the same data.

- Select Country and Sum Order Amount. Sort on Sum Order Amount in descending order
- Submit the query and send the results to BI/Query Reports
- Choose Columnar Style and create a table presentation
- Insert a horizontal chart using the same data source
- Resize the table and chart presentations and place them on the same page of the report
- Remove the extra page from the report
- Your report should look similar to the following:
Lab 3.2

Adding a Chart to a Chart Report Using New Data

You want a report that contains two charts. One shows total sales by country in the European territory, and the second shows total sales by country in the North American territory.

- Select Country from the Store data object and Sum Order Amount. Qualify on Territory = Europe
- Submit the query and send the results to BI/Query Reports
- Choose Pie Chart Style
- Without closing BI/Query Reports, return to BI/Query User and change the qualification to Territory = North America
- Submit the query and send the result to BI/Query Reports
- You can either:
  - Click Finish in the Presentation Designer and close the second report without saving
  - Add a chart to the first report, selecting the most recent data source
  - Resize the two chart presentations and place them on the same page of the report

- OR
  - Create a Pie Chart from the results of the second query
  - Select the Pie Chart, copy and paste it in the first report
  - Close the second report without saving

---

**European Territory Sales**

- France
- Germany
- Netherlands
- Spain
- UK

**North American Territory Sales**

- Canada
- USA

© Copyright Hummingbird Ltd 2000
Linking a Chart to a Table

- You can link a chart to a table through the data source view to include calculations.
- As you change the table, the chart will reflect those changes.

You may want to add a chart that uses the data in an existing table report but present it in a different way. For example, if you have a report that presents detailed data in a table, you can also present the same data in a chart.

To link a chart to a table:

- choose Insert > Chart or click the Chart tool on the Presentation toolbar.
- on the Data Source page of the Presentation Designer, double-click the data source used to create the table.
- from the list that appears, select the view associated with the table. (The icon for a view displays a plus + sign.)
- click Next.
- on the Style page, select a style, then click Finish.
Adding a Chart to a Table

- You can add a chart to the detail band of a table report
- The chart shows the values in the detail band

To add a chart to a table:
- add a chart to a report using the view associated with the table, rather than the data source
- drag the chart into a band. (The first column of data is used as the labels along the x-axis.)
- to use the data in another column as the labels along the x-axis, click the chart, then choose Format > Chart > Rearrange Data. In the Rearrange Data dialog box, click the tool for Columns, then in the Included Members: Columns dialog box, drag the column you want to use to the top of the Included Members list. Click Close, then Close again.
- to have the chart reflect all of the data in the table, click the chart, then choose Format > Properties. In the Properties dialog box, click the Options tab, then click Show Data in Band to deselect it.

### Yearly Sales by Country - All Products

<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Australia</td>
<td>917,086</td>
<td>1,004,760</td>
<td>1,112,232</td>
</tr>
<tr>
<td>Canada</td>
<td>367,451</td>
<td>400,047</td>
<td>437,419</td>
</tr>
</tbody>
</table>

© Copyright Hummingbird Ltd 2000
Linking a Chart to a Crosstab

By linking a chart to a crosstab, any changes made to the crosstab are reflected in the chart.

Charts are useful for showing a high-level summary of results and trends; they focus the reader's attention on areas of interest. When you're presenting a report, however, you'll often have to back up a chart with the numbers used to create it. You can create a chart that always reflects the most up-to-date results by linking it with a crosstab; when you refresh the data or rearrange the crosstab, the chart updates automatically.

To link a chart to a crosstab:
- in a crosstab report, choose Insert > Chart or click the Chart tool on the Presentation toolbar
- on the Data Source page of the Presentation Designer, double-click the icon beside the data source you used to create the crosstab
- select the view associated with the crosstab from the list of views
- click Finish
Linking a Map to a Table

Maps are useful for showing results and trends geographically; they focus the reader’s attention on areas of interest. When you’re presenting a report, however, you’ll often have to back up a map with the numbers used to create it. You can create a map that always reflects the most up-to-date results by linking it to a table; when you refresh the data or add a calculation to the table the map updates.

To link a map to a table:

- create a table, then choose Insert > Map or click the Map tool on the Presentation toolbar
- on the Data Source page of the Presentation Designer, double-click the icon beside the data source used to create the table
- select the view associated with the table from the list of views
- click Finish

<table>
<thead>
<tr>
<th>Country</th>
<th>SUM Order</th>
<th>AVG Order</th>
</tr>
</thead>
<tbody>
<tr>
<td>Argentina</td>
<td>3,375</td>
<td>3,375</td>
</tr>
<tr>
<td>Australia</td>
<td>61,420</td>
<td>5,594</td>
</tr>
<tr>
<td>Canada</td>
<td>19,215</td>
<td>8,405</td>
</tr>
<tr>
<td>France</td>
<td>17,145</td>
<td>5,715</td>
</tr>
<tr>
<td>Hong Kong</td>
<td>34,170</td>
<td>5,895</td>
</tr>
<tr>
<td>Italy</td>
<td>32,255</td>
<td>5,376</td>
</tr>
<tr>
<td>Japan</td>
<td>50,040</td>
<td>7,230</td>
</tr>
<tr>
<td>Korea</td>
<td>31,145</td>
<td>10,382</td>
</tr>
<tr>
<td>Mexico</td>
<td>5,245</td>
<td>5,245</td>
</tr>
<tr>
<td>New Zealand</td>
<td>22,405</td>
<td>7,408</td>
</tr>
<tr>
<td>Peru</td>
<td>3,375</td>
<td>3,375</td>
</tr>
<tr>
<td>UK</td>
<td>141,516</td>
<td>4,717</td>
</tr>
<tr>
<td>USA</td>
<td>114,710</td>
<td>11,471</td>
</tr>
</tbody>
</table>
Lab 3.3

- Linking a Chart to a Crosstab

You want a report that contains a crosstab and a chart presenting the same data. You also want the chart to change as you manipulate the crosstab

- Select Territory, Country, Year and Sum Order Amount
- Submit the query and send the result to BI/Query Reports
- Create a crosstab, including all dimensions
- Insert a chart and choose the crosstab's view
- Resize the two presentations and place them on the same page of the report
- Pivot the crosstab and observe the changes to the chart

<table>
<thead>
<tr>
<th></th>
<th>1997</th>
<th>1998</th>
<th>1999</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asia</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Australia</td>
<td>917,086</td>
<td>1,004,760</td>
<td>1,112,232</td>
</tr>
<tr>
<td>China</td>
<td>373,765</td>
<td>387,153</td>
<td>456,571</td>
</tr>
<tr>
<td>Japan</td>
<td>306,512</td>
<td>396,873</td>
<td>411,977</td>
</tr>
<tr>
<td>Europe</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>France</td>
<td>1,286,079</td>
<td>1,287,037</td>
<td>1,527,516</td>
</tr>
<tr>
<td>Germany</td>
<td>1,411,604</td>
<td>1,587,342</td>
<td>1,776,196</td>
</tr>
<tr>
<td>Netherlands</td>
<td>890,375</td>
<td>1,020,882</td>
<td>1,114,166</td>
</tr>
<tr>
<td>Spain</td>
<td>1,884,667</td>
<td>1,864,077</td>
<td>2,025,962</td>
</tr>
<tr>
<td>UK</td>
<td>3,111,053</td>
<td>3,548,774</td>
<td>3,021,534</td>
</tr>
<tr>
<td>North America</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Canada</td>
<td>807,451</td>
<td>465,947</td>
<td>437,419</td>
</tr>
<tr>
<td>USA</td>
<td>8,626,425</td>
<td>9,042,375</td>
<td>10,403,314</td>
</tr>
</tbody>
</table>

North American Territory Sales
C:\TEMP\Query Results 24.hc

1997 SUM Order Amount
1999 SUM Order Amount
1998 SUM Order Amount
Chapter 3: Summary

- In this chapter you have learned how to:
  - include multiple presentations using the same data source and different data sources
  - link presentations through views