Contents

Chapter 1  Basic Concepts  19

Overview of BI Query Reports ........................................... 19
  About Reports .......................................................... 20
  Detailed and Summary Data ............................................ 20

Presentations Show Off Your Data ................................. 21
  Tables Present Results ................................................ 21
  Charts Visualize Data .................................................. 22
  Crosstabs Analyze Data ............................................... 22
  Data Sources and Views .............................................. 22

Turning Query Results into Reports ............................... 23
  Letting the Designer Do Most of the Work .................... 24

Chapter 2  Getting Started  25

Starting BI Query Reports .................................................. 25
  Starting BI Query Reports from BI Query ....................... 26
  Starting BI Query Reports on Its Own ......................... 26
  Using an Automation Controller .................................. 28

Opening and Refreshing Reports ................................. 28
Chapter 3  Planning Reports  33

Overview of Planning Reports  ......................... 33
Identifying Types of Users  ................................ 34

Presenting Data  ........................................... 34
Tables ......................................................... 34
  Invoices, Purchase Orders, and Other Forms  ............. 35
  Lists and Catalogs  ........................................ 36
Charts ........................................................ 36
Crosstabs ...................................................... 44
  Sales Analysis Scenario  .................................. 45
  Profit and Loss Reporting Scenario  ...................... 46
  Manufacturing Quality Scenario  ......................... 47

Gathering Data  ............................................ 49
Gathering Data for Tables  ................................ 49
  Grouping and Sorting Results in BI Query  ............... 50
Charts and Crosstabs  .................................... 51

Building Tables  .......................................... 51
Using BI Query Reports Predefined Styles  ................. 52
Using Your Own Styles  .................................. 52
## Chapter 4  Creating Reports

### Creating Reports Overview ................................................. 55

### Building Presentations with Presentation Designer ................. 56
   Working with Tables .................................................. 56
      Adding Tables to a New Report .................................. 56
      Adding Tables to Existing Reports ............................... 57
   Working with Charts .................................................. 58
      Adding Charts to a New Report .................................. 58
      Adding Charts to Existing Reports ............................... 59
      Organizing Data in Charts ........................................ 60
      Arranging Data in Charts .......................................... 60
      Changing How Charts Summarize Data ........................... 61
   Adding Crosstabs to Reports ....................................... 61
      Adding Crosstabs to a New Report ............................... 62
      Adding Crosstabs to Existing Reports ........................... 63
      Arranging Data in Crosstabs ...................................... 64
      Redefining a Metrics Member in a Crosstab ..................... 65
   Changing the Style of a Crosstab ................................ 65
      Changing the Page Orientation of a Crosstab .................. 65
      Changing the Data Formatting of a Crosstab .................... 66
      Setting the Crosstab Analysis Mode ............................. 67
   Adding Presentations by Using Views ................................ 68
      Checking the View Name .......................................... 68
      Using Views to Link Presentations .............................. 69
      Copying and Pasting Presentations ............................. 69
      Changing the Presentation Type ................................ 70

### Editing Queries and Replacing Data ................................. 70
   Changing the Data Source .......................................... 71
### Chapter 5  Creating Interactive Reports  

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Interactive Reports</td>
<td>85</td>
</tr>
<tr>
<td>Creating Interactive Reports</td>
<td>86</td>
</tr>
<tr>
<td>About Hotspots</td>
<td>86</td>
</tr>
<tr>
<td>Gathering the Data</td>
<td>87</td>
</tr>
<tr>
<td>Working with Hotspots</td>
<td>87</td>
</tr>
<tr>
<td>Adding Hotspots</td>
<td>87</td>
</tr>
<tr>
<td>Selecting Hotspots</td>
<td>89</td>
</tr>
<tr>
<td>Changing the Hotspot Label</td>
<td>89</td>
</tr>
<tr>
<td>Hotspot Special Fields</td>
<td>90</td>
</tr>
<tr>
<td>Editing, Moving, and Resizing Hotspots</td>
<td>90</td>
</tr>
<tr>
<td>Hotspots in Interactive Reports</td>
<td>91</td>
</tr>
<tr>
<td>Using Interactive Reports in BI Query Reports</td>
<td>91</td>
</tr>
</tbody>
</table>

### Chapter 6  Working with Tables  

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About Tables</td>
<td>93</td>
</tr>
<tr>
<td>Understanding Tables</td>
<td>94</td>
</tr>
<tr>
<td>About Bands</td>
<td>95</td>
</tr>
<tr>
<td>About Columns</td>
<td>95</td>
</tr>
<tr>
<td>Working with Bands</td>
<td>96</td>
</tr>
<tr>
<td>Formatting Bands</td>
<td>96</td>
</tr>
<tr>
<td>Controlling the Display of Bands</td>
<td>97</td>
</tr>
<tr>
<td>Creating Summary Reports (Suppressing Details)</td>
<td>97</td>
</tr>
<tr>
<td>Showing or Hiding Bands</td>
<td>98</td>
</tr>
<tr>
<td>Adding Items to a Band</td>
<td>98</td>
</tr>
<tr>
<td>Adding Charts to Bands</td>
<td>99</td>
</tr>
<tr>
<td>Applying Variable Data Fields and Bands to Tables</td>
<td>100</td>
</tr>
</tbody>
</table>
Problems with Text Wrap in Calculations ........................................ 101

**Working with Columns** ...................................................... 101

  - About the Column Control Bar ........................................... 101
  - Using the Column Control Bar .......................................... 101
  - Adding New Columns ..................................................... 102
  - Formatting Columns ..................................................... 102
  - Managing Columns over Multiple Pages ............................... 103
  - Deleting Columns ....................................................... 104
  - Changing the Spacing Between Columns ............................... 104
  - Merging Columns ....................................................... 104
  - Combining Data Items Using Labels .................................. 105
  - Fitting Columns on One Page ........................................... 105
  - Anchoring Items to a Column .......................................... 106
  - Resizing Columns ....................................................... 106
  - Resizing an Item in a Column .......................................... 107
  - Autosizing Items in a Column ........................................ 107
  - Reordering Columns .................................................... 108

**Working with Data** .......................................................... 109

  - Moving and Copying Items ............................................. 109
  - Copying a Column Item ................................................ 109
  - About Stacked Columns ................................................ 110
  - Stacking Data ............................................................ 110
  - Suppressing Duplicate Data ........................................... 111
  - Adding Data ............................................................... 112
  - Adding New Query Data to a Table .................................. 112
  - Grouping Data ............................................................ 113
  - Ungrouping Data .......................................................... 114
    - Changing the Order of Grouped Columns .......................... 114
Formatting Tables ........................................... 115
  Table Properties ........................................ 115
  Setting Default Formatting for Predefined Table Styles .......... 116
  Adding and Removing Page Breaks ................................ 116
  Adding or Removing Table Frames ................................ 117
  Changing Column Headings and Titles .............................. 118
  Using Styles ............................................ 118
  User-Defined Table Styles .................................. 119
  Creating Table Styles .................................... 119
  Applying Table Styles ..................................... 119
  Modifying Table Styles .................................... 120

Chapter 7  Working with Charts  121

About Charts ........................................... 122
  Understanding Charts .................................... 122
  Rearranging Data in Charts ................................ 124

Working with Dimensions .................................. 124
  Pivoting Dimensions in a Chart ............................. 125
  Grouping Dimensions in a Chart ............................ 125
  Changing How Dimensions are Nested in a Chart ............ 126

Working with Members ................................... 126
  Filtering Data ........................................... 127
    Filtering Using a Different Member .......................... 127
    Filtering with the Filter Bar ................................ 128
  Adding Members ......................................... 128
  Reordering Members ...................................... 129
  Removing or Hiding Members in Charts ......................... 130

Formatting Charts ........................................ 131
Contents

Chart Properties .......................................................... 131
Understanding Chart Types in Detail ................................. 131
  About Column Charts .................................................. 132
  About Bar Charts ....................................................... 133
  About Pie Charts ....................................................... 134
  About 3D Charts ....................................................... 135
  About Area Charts ..................................................... 136
  About Line Charts ..................................................... 137
  About Stock Charts ................................................... 138
  About Radar Charts ................................................... 139
  About Scatter Charts .................................................. 140
  About Special Charts .................................................. 140
Changing the Chart Type ................................................. 142
Adding Legends .......................................................... 143
Formatting Chart Legends .............................................. 143
Automatically Arranging Chart Elements ............................ 144
Removing or Hiding a Column in a Chart ............................ 145
Formatting Chart Elements ............................................ 146
Customizing Chart Gradients .......................................... 147
Customizing Chart Element Textures ................................. 148
Customizing Chart Element Pictures ................................. 148
Adding Your Own Pictures to the Picture Gallery .................. 148
Formatting Lines .......................................................... 149
Formatting Text ........................................................... 149
Formatting Bar Charts ................................................... 150
Formatting Pie Charts ................................................... 151
Formatting Line Charts .................................................. 152
Detaching or Deleting a Pie Chart Slice ............................... 153
## Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Changing the Shape of Individual Risers</td>
<td>154</td>
</tr>
<tr>
<td>Changing the Shape of Markers in a Series</td>
<td>154</td>
</tr>
<tr>
<td>Showing Data Labels on Markers</td>
<td>155</td>
</tr>
<tr>
<td>Adding a Trend Line</td>
<td>155</td>
</tr>
<tr>
<td>Changing the Color Mode</td>
<td>157</td>
</tr>
<tr>
<td><strong>Working with Titles and Labels</strong></td>
<td>158</td>
</tr>
<tr>
<td>Adding a Title</td>
<td>158</td>
</tr>
<tr>
<td>Adding a Subtitle</td>
<td>158</td>
</tr>
<tr>
<td>Adding a Footnote</td>
<td>158</td>
</tr>
<tr>
<td>Adding a Category Title</td>
<td>159</td>
</tr>
<tr>
<td>Adding a Value Title</td>
<td>159</td>
</tr>
<tr>
<td>Adding an X-Axis Title</td>
<td>159</td>
</tr>
<tr>
<td>Adding a Series Axis Title</td>
<td>160</td>
</tr>
<tr>
<td>Adding Pie Chart Labels</td>
<td>160</td>
</tr>
<tr>
<td>Formatting X-Axis Labels</td>
<td>161</td>
</tr>
<tr>
<td><strong>Working with Grids and Scales</strong></td>
<td>161</td>
</tr>
<tr>
<td>Changing Where the Scale Labels Appear</td>
<td>161</td>
</tr>
<tr>
<td>Creating a Descending Axis</td>
<td>162</td>
</tr>
<tr>
<td>Hiding the Axis Line</td>
<td>162</td>
</tr>
<tr>
<td>Displaying a Logarithmic Scale</td>
<td>163</td>
</tr>
<tr>
<td>Removing Zero from a Scale</td>
<td>163</td>
</tr>
<tr>
<td>Setting the Minimum/Maximum Value of the Scale</td>
<td>164</td>
</tr>
<tr>
<td><strong>Working with Gridlines</strong></td>
<td>164</td>
</tr>
<tr>
<td>Hiding Major or Minor Gridlines</td>
<td>164</td>
</tr>
<tr>
<td>About Gridline Formats</td>
<td>165</td>
</tr>
<tr>
<td>Changing the Gridline Format</td>
<td>166</td>
</tr>
<tr>
<td>Formatting Gridline Intervals</td>
<td>166</td>
</tr>
<tr>
<td>Drawing a Custom Gridline</td>
<td>167</td>
</tr>
</tbody>
</table>
Working with Chart Series ................................................. 168
   Changing How a Series Appears ..................................... 168
Working with 3D Charts ......................................................... 168
   Choosing a 3D Viewing Angle ........................................ 168
   Customizing a 3D Viewing Angle .................................... 169
Working with Data Labels .................................................... 170
   Working with Pie Chart Data Labels ............................... 171
   Formatting Data Label Numbers .................................... 172
Working with Dual Axis Charts ............................................. 172
   Moving Elements to the Primary or Secondary Axis .......... 172
   Adjusting the Split Position ....................................... 173
Hiding Labels ................................................................. 173
   Hiding Axis Labels .................................................. 173
   Hiding the Minimum/Maximum Value Label .................... 174
Working with Additional Chart Features ............................... 175
   Staggering the Category or X-Axis Labels ...................... 175
   Displaying a Manual Number of Categories .................... 175
   Formatting Axis Label Numbers ................................ 176

Chapter 8 Working with Crosstabs ................................. 177

About Crosstabs ............................................................. 177
   Understanding Crosstabs .......................................... 178
   Rearranging Data in Crosstabs ................................... 180
Working with Dimensions .................................................. 180
   Pivoting Dimensions in a Crosstab .............................. 181
   Changing How Dimensions are Nested .......................... 181
Working with Members ...................................................... 182
   Filtering Data .......................................................... 182
Filtering Using a Different Member ........................................ 183
Filtering with the Filter Bar ............................................... 184
Adding Members ............................................................ 184
Reordering Members ....................................................... 185
Removing or Hiding Members in a Crosstab ......................... 186
Drilling on Members in a Crosstab ..................................... 187
Displaying Aggregate Values ........................................... 188

**Formatting Crosstabs** ....................................................... 189

Working with Crosstabs .................................................... 189
Setting Default Formatting for Crosstabs ......................... 190
Controlling Page Breaks for a Crosstab .......................... 191
Resizing Crosstabs and Cells ......................................... 192
Autosizing Cells in a Crosstab ........................................ 192
Formatting Crosstabs, Members, and Data ....................... 192

**Chapter 9**  

**Formatting Reports** ....................................................... 195

Enhancing Report Format .............................................. 195
Managing Pages .......................................................... 196
  Adding and Removing Pages ...................................... 196
  Adding Page Numbers ............................................... 197
Working with Text .......................................................... 197
  Adding Text Labels .................................................. 197
  Adding Rich Text ..................................................... 198
  Pasting Text from Another Application ....................... 199
About Hyperlinks ......................................................... 199
  Supported URL Protocols ........................................... 200
File Transfer Protocol Syntax ..................................... 201
Applying a Hyperlink .................................................... 202
Editing and Removing Hyperlinks ........................................ 203
Adding Context-Sensitive Items ......................................... 204
Special Fields Reference .................................................. 205
About Prompts and Prompt Values ................................... 206
Using Fields in Hyperlinks ............................................... 207
Formatting Text .............................................................. 209
Adding Color to Text ....................................................... 210

Graphics and Objects ....................................................... 211
Adding Graphics ............................................................ 212
Adding Drawing Objects .................................................. 212
Formatting and Editing Drawing Objects .............................. 213
Adding Color to Drawing Objects ..................................... 213
Adding Linked Objects .................................................... 214
Editing Linked Objects .................................................... 214
Viewing and Managing Linked Objects ............................... 215
Adding Embedded Objects .............................................. 216
Editing Embedded Objects .............................................. 216

Formatting Objects in a Report ......................................... 217
Selecting Objects .......................................................... 217
Copying and Pasting Objects ............................................ 217
Aligning Text and Graphics .............................................. 217
Making Objects the Same Size ......................................... 218
Spacing Objects Evenly ................................................... 218
Using Snap to Grid ........................................................ 219
Showing Grid Lines ........................................................ 219
Changing Grid Settings .................................................... 219

Creating Headers and Footers ........................................... 220
Using Tables ................................................................. 220
### Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using Repeating Objects</td>
<td>221</td>
</tr>
<tr>
<td><strong>Specifying Data Formats</strong></td>
<td>221</td>
</tr>
<tr>
<td>Specifying a Format for Null Values</td>
<td>221</td>
</tr>
<tr>
<td><strong>Specifying a Number Format</strong></td>
<td>222</td>
</tr>
<tr>
<td>Specifying a Date and Time Format</td>
<td>222</td>
</tr>
<tr>
<td>About Converting Two and Four-Digit Years</td>
<td>223</td>
</tr>
<tr>
<td>Converting Two-Digit Years</td>
<td>224</td>
</tr>
<tr>
<td>Specifying a Format for Strings</td>
<td>224</td>
</tr>
<tr>
<td><strong>Creating Report Backgrounds</strong></td>
<td>226</td>
</tr>
<tr>
<td>About Report Backgrounds</td>
<td>226</td>
</tr>
<tr>
<td>Creating Report Backgrounds</td>
<td>226</td>
</tr>
<tr>
<td>Applying Backgrounds</td>
<td>227</td>
</tr>
<tr>
<td><strong>Chapter 10 Performing Calculations</strong></td>
<td>229</td>
</tr>
<tr>
<td><strong>Calculations and Exceptions</strong></td>
<td>229</td>
</tr>
<tr>
<td>Types of Calculations</td>
<td>230</td>
</tr>
<tr>
<td>About Functions</td>
<td>231</td>
</tr>
<tr>
<td>About Expressions</td>
<td>233</td>
</tr>
<tr>
<td>Operators Table</td>
<td>233</td>
</tr>
<tr>
<td>Syntax Table</td>
<td>235</td>
</tr>
<tr>
<td>Precedence Table</td>
<td>236</td>
</tr>
<tr>
<td><strong>Working with Calculations</strong></td>
<td>237</td>
</tr>
<tr>
<td>Predefined and User-Defined Calculations</td>
<td>237</td>
</tr>
<tr>
<td>Adding Predefined Calculations to Tables</td>
<td>238</td>
</tr>
<tr>
<td>Adding a Grand Total</td>
<td>238</td>
</tr>
<tr>
<td>Adding Calculations to Groups</td>
<td>239</td>
</tr>
<tr>
<td>Adding Predefined Calculations to Crosstabs</td>
<td>239</td>
</tr>
<tr>
<td>Adding Totals</td>
<td>240</td>
</tr>
</tbody>
</table>
BI Query Reports is a reporting tool used to create reports for use in presentations to display your data. You use BI Query Reports to display the query results from BI Query.

- “Overview of BI Query Reports” on page 19
- “Presentations Show Off Your Data” on page 21
- “Turning Query Results into Reports” on page 23

**Overview of BI Query Reports**

BI Query Reports is the reporting tool used with BI Query. It works seamlessly with BI Query to present data in a variety of presentation styles—tables, charts, and crosstabs. The reports created assist your organization in making business decisions.
Chapter 1: Basic Concepts

About Reports

Reports are summaries or collections of information about an aspect of an organization’s business. They contain views of the current data in your organization’s database, organized and formatted the way you prefer. They can contain data from one or more queries, data sources, or databases. How much information you present in a report and how you present it depends on who your readers are, what information they need, and for what purpose they are using that information.

You can create reports that combine tables, crosstabs, and charts to answer every type of business question. You can create reports from multiple queries, add sophisticated calculations, and highlight exceptions in the data. In addition, you can integrate information from different corporate sources, then distribute it internally and externally using anything from electronic mail to the World Wide Web.

Create a report by adding presentations to it. Presentations are the tables, charts, and crosstabs you build from the data you gathered. You can include as many presentations in a report as you want. Once you create a report, you can add hotspots to it to make it interactive and you can distribute it.

Detailed and Summary Data

You can use detailed or summary data sources when creating reports.

**Detailed data sources** (.hcr files)—Present the day-to-day activities of the enterprise and are stored as columns and rows. With detailed data, you can answer questions about how your business is doing, such as:

- How many units did we sell last month?
- What did our New York retailer buy last month?
- How much did each sales representative sell last month?

**Summary data sources** (.hc files)—Present the results of consolidations done on detailed data. It contains the totals, averages, and other algebraic results rather than the detail-level data. With summarized data, you can answer a series of related questions, such as:

- How many units did our Midwest office sell this year, and this quarter?
- Which sales representatives sold the most?
- When were their peak months?
Presentations Show Off Your Data

When was their worst week?

In short, summarized data lets you see relationships between business variables, enabling you to uncover trends, anomalies, problems, and opportunities.

Presentations are the tables, crosstabs, and charts that you use to present data to your readers. Select one of three presentation types based on the types of data that you want to display:

• Use tables to display detailed data.
• Use crosstabs to display summary data.
• Use charts to display trends and exceptions over time.

By determining which presentation type, or combination of types, best suits the data you want to use, you can create a focused report. It can highlight the information that interests audiences such as upper management, potential clients, or the public.

Tables Present Results

Tables provide a quick and easy way of presenting data. They display detailed data in columns, with a heading across the top and in bands. Using the report styles provided with BI Query Reports, or using your own styles, you can create fully formatted tables including subtotals and grand totals, that are ready for presentation. You can also rearrange columns, break data into groups, add calculations and exceptions, or create completely free-form tables.

💡 For more information, see “Tables” on page 34.

Tables give you the freedom to create a different layout every time. You can drag and drop text anywhere in the table, elsewhere in the report, or even into another open report. Tables provide you with an almost unlimited framework for presenting data, from form letters to invoices, purchase orders, catalogs, and so on. Using tables, you can answer questions such as:

• How many units did we sell last month?
• What did our New York retailer buy last month?
• How much did each sales representative sell last month?
Charts Visualize Data

Charts display data in a graphical format. They let you summarize and rearrange your data to help you recognize patterns, trends, and other relationships that may not be apparent in tables or crosstabs. They also let you present conclusions that have a strong visual impact. For example, they can show at a glance a company’s revenues over several years, inventories at different plants, or the account executive who was the biggest revenue generator last quarter. Because they present information graphically, charts make it easy for the reader to extract information from a report.

For more information, see “Charts” on page 36.

You can add a chart to any band in a table. When you add a chart to a detail band, a group footer band, or a group header band, the chart changes to reflect the data for that band. This lets you to add a visual representation to back up the hard data displayed in the bands. For example, if you have a table that shows cost, revenue, and profit by quarter, you can add a chart to the group footer band that will display the revenue, cost, and profit for each quarter.

Crosstabs Analyze Data

Crosstabs let you summarize and view your data dynamically. They display data in a matrix of rows and columns, with headings that appear across the top and sides of the crosstab. You can easily rearrange the data to view it from different perspectives. For example, you can compare sales figures for multiple products, analyze the performance of regional sales staff, and identify quarterly and annual trends. You can also add sophisticated calculations and highlight data using exceptions.

For more information, see “Crosstabs” on page 44.

Crosstabs are powerful organizational and analytical tools that let you analyze your data and discover the relationships among the different dimensions.

Data Sources and Views

When you are creating a report with multiple presentations, you can create the presentations using data sources or views.
A Data Source
A data source stores raw data. For example, when you submit a query in BI Query and send the results to BI Query Reports, a data source is created to store the query results. Data sources do not change, even when you change the data displayed in presentations. For example, you can change the data by adding calculations or removing dimensions from crosstabs.

A View
A view stores a portion of data from a data source. Views are created when you create presentations. They store calculations, exceptions, and the arrangement of the data. For example, when you create a table and add subtotals, a view stores the subtotal calculations and how the data is arranged in the table. When you create different presentations using the same view, you can manipulate the data in one presentation and add calculations to it, and those changes will be automatically reflected in another presentation. In this way, views link presentations.

You can use data sources and views for the following purposes:

• Use the same data source to create different presentations. For example, you can create a table and a chart using the same query results.

• Use a view to create different presentations. When you use the same view, the changes you make to one presentation are automatically reflected in the other. For example, if you create a crosstab and add a sum calculation, then create a chart using the same view as the crosstab, the chart shows the sum calculation.

• Use multiple data sources and views in the same report. For example, you can create a table using a query about sales offices and representatives, and then use another data source to create a chart showing product sales.

Turning Query Results into Reports

Business users and administrators with access to BI Query Reports can turn query results into reports that present detailed results in tables, summarize information in crosstabs, and display data visually in charts.

To turn query results into reports:

1. In BI Query, select attributes that will become the report elements.
2. Run the query.
3. On the Results menu, click Show as Report, and then click BI Query Reports.
4. Using **Presentation Designer**, create the report.

You can use query results to do the following:

- Create different presentations in a report using the same query results.
- Include data from multiple query results (and multiple databases) in one report.
- Replace the data in a presentation with data from another query.
- When reports contain data that changes regularly, you can ensure they display the most current data by refreshing them each time you open them, and rerunning the query or queries they use.

**Letting the Designer Do Most of the Work**

BI Query Reports Presentation Designer lets you quickly turn queries into reports. The designer is a simple, powerful tool that transforms source data into fully formatted tables, charts, and crosstabs with a few clicks of the mouse. The designer contains styles that make it possible to create fully formatted, presentation-quality reports and provides a head start in creating custom reports.
You can start BI Query Reports from BI Query or you can start it on its own. You can view reports saved locally saved reports or reports saved on a network.

- “Starting BI Query Reports” on page 25
- “Opening and Refreshing Reports” on page 28

**Starting BI Query Reports**

BI Query Reports is the reporting tool for BI Query. The two applications are dependent on each other for data and reporting needs. How you start BI Query Reports depends on where you are in the reporting process:

- If you are creating a report from a new BI Query results set, start BI Query Reports from BI Query.
- If you are maintaining a report, start BI Query Reports on its own. When you start BI Query Reports, the **BI Server Login** dialog box may appear. This indicates that your corporate environment includes a central storehouse for reports called the BI Server Repository.

You can log on and use the repository, or you can work offline. If you log on, you can publish reports to the repository, set permissions on them, retrieve them, and schedule them.
You can also run BI Query Reports using an automation controller. For more information, see “Using an Automation Controller” on page 28.

BI Query Reports is installed with BI Query. For installation instructions, see the BI Query Installation Guide.

Starting BI Query Reports from BI Query

To create new reports, start BI Query Reports from BI Query.

To start BI Query Reports from BI Query:
1. In BI Query, open or retrieve a results set. For information on using BI Query, see the BI Query Help.
2. On the Results menu, click Show as Report, and then click BI Query Reports.
   For more information, see “Building Presentations with Presentation Designer” on page 56.
3. Using Presentation Designer, create the report.

Starting BI Query Reports on Its Own

You start BI Query Reports on its own when you are using or maintaining existing reports. The When Opening This Report preference determines how a report opens.

For more information about preferences, see “Preferences for Opening a Report” on page 73.

To start BI Query Reports on its own:
1. On the Start menu, click Programs, Hummingbird BI, Hummingbird BI Query, and then BI Query Reports.
2. If the BI Server Login dialog box opens, do one of the following:
   • To work without repository access, click Work Offline.
   • To access the repository, type your user name, password and domain (if applicable). If you are unsure what information to provide in this dialog box, check with your administrator.
   If you need to publish, retrieve, schedule, or set permissions on reports, you can log on to the repository at any time.
3. In the Welcome to BI Query Reports window, click an icon for the appropriate report option.
Report Options

For instructions on creating a report from BI Query results, see “Starting BI Query Reports from BI Query” on page 26.

To create a report using Presentation Designer:
1. In the Welcome dialog box, click Presentation Designer.
   
   You can use this option only if a data source is available.
2. Using Presentation Designer, create the report.

To open a report you recently used:
1. In the Welcome dialog box, click Recent Report.
2. In the Recent dialog box, click the report, and then click Open.
3. If the Retrieve Data dialog box opens, click a data option, and then click OK.

To open a report stored on your computer or local network:
1. In the Welcome dialog box, click Local Report.
2. In the Open dialog box, locate and click the report, and then click Open.
3. If the Retrieve Data dialog box opens, click a data option, and then click OK.

To open a report stored in the repository:
The Repository Report option is available only if you have logged in to the BI Server Repository.
1. In the Welcome dialog box, click Repository Report.
2. In the Retrieve Report dialog box, locate and click the report, and then click OK.
3. If the Retrieve Data dialog box appears, click a data option, and then click OK.

For more information, see “Setting Preferences” on page 73.

To create a new report:
- In the Welcome dialog box, click New Report.
Using an Automation Controller

You can run BI Query Reports using an automation controller—a development tool or application that lets users and third-party developers write scripts and create applications that drive automation objects. Using an automation controller (such as Microsoft Visual Basic), you can open, refresh, print, save, and publish reports to the World Wide Web.

💡 For a complete list of OLE Automation functions, on the Help menu, click OLE Help.

Opening and Refreshing Reports

Opening Local Reports from BI Query Reports

Once BI Query Reports is started, you can open reports saved to your computer. If you are working in the BI Server environment, you can retrieve reports saved to your computer or local network.

The way reports open is determined by the When Opening This Report preference. If you saved a report with its data sources, refresh it to work with the data in the report.

To open a report stored on your computer or local network:

1. On the File menu, click Open.
2. In the Open dialog box, locate a file, and then click Open.
3. If the Retrieve Data dialog box appears, click an option, and then click OK.

Refreshing Data in Reports

If you are creating the same report on a regular basis (for example, weekly sales reports or quarterly income statements) you need to ensure that it contains the latest data. In BI Query Reports, you can refresh the data in reports to keep them up-to-date.

There are several options for refreshing reports:

• manually refresh a report when you open it
• set a report to refresh automatically each time it is opened
Opening and Refreshing Reports

- be prompted each time you open the report whether to refresh the report or to show existing data instead.

When you create a report, you set your preference for opening the report. Choose whether you want the report refreshed automatically, not refreshed, or if you want to be prompted each time you open the report. If necessary, you can edit the **When Opening This Report** preference later to change how the report opens.

💡 For more information about scheduling, see the *BI Server Scheduling User’s Guide*.

If your reporting environment includes BI Server, you can schedule reports for distribution. When scheduled reports run, they are automatically refreshed to ensure that the data they contain is current.

Whether you refresh from BI Query Reports or while scheduling, you can insert different values into the query in response to prompts. This lets you run the same report based on different information (such as a different sales region) each time.

💡
- Depending on the complexity of the queries, and the amount of data they return, refreshing data may take some time.
- If any query uses a connection file that does not store your password, you are prompted for it. If BI Query cannot find the data model associated with a query, you are prompted to find it.

If you refresh a report that uses a prompt, and you want to replace the current values with new values, make sure that you delete the current values first.

**To delete the current values from a prompt:**

1. In BI Query, in the **Enter Value** dialog box, click the List icon  .
2. Click **Delete All Entries**.
3. Click the Data Values icon  , then click the values on which you want the report to be based.

**Manually Refreshing Reports**

If a report is not set to automatically refresh, you can manually refresh the report either when you open it or after it is opened.

**To refresh a report:**

- Do one of the following:
  - If the report is already open, on the **Data** menu, click **Refresh**.
• Open the report. If the Retrieve Data dialog box opens, click Refresh the Data, and then click OK.

**Automatically Refreshing Reports**
You can set a report to refresh each time it is opened. The options for opening and refreshing are report-level preferences, so set them for each report you create.

**To set a report to refresh each time it is opened:**
1. With the report open, on the Tools menu, click Preferences.
2. On the General page of the Preferences dialog box, click Refresh the Data.
3. Click OK.

**Starting other Hummingbird Programs from BI Query Reports**
You can start other programs in the Hummingbird suite of programs provided they are installed on your computer.

You can start other Hummingbird programs in either of the following ways:
• Starting Hummingbird programs from the Standard toolbar
• Starting Hummingbird programs from the Tools menu

**Starting Hummingbird Programs from the Standard Toolbar**
You can start other Hummingbird programs from the Standard toolbar.

💡 If you do not see the Standard toolbar, on the View menu, point to Toolbars, and then click Standard.

**To start a Hummingbird program from the Standard toolbar:**
- On the standard toolbar, click the icon for the program you want to start. The following table details the Hummingbird program toolbar icons.

<table>
<thead>
<tr>
<th>Toolbar Icon</th>
<th>Program</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Cube Icon" /></td>
<td>BI Cube Creator. For more information on using BI Cube Creator, see the BI Cube Creator User’s Guide.</td>
</tr>
</tbody>
</table>
User and Group Manager. For more information on using User and Group Manager, see the User and Group Manager Help.

Starting Hummingbird Programs from the Tools Menu

You can start other installed Hummingbird programs from the Tools menu.

To start a Hummingbird program from the Tools menu:

- On the Tools menu, point to Hummingbird BI, and then click the program you want to start.
When you create reports, you must first decide who the audience for the report is and then decide the best method for presenting the information.

- “Overview of Planning Reports” on page 33
- “Presenting Data” on page 34
- “Gathering Data” on page 49
- “Building Tables” on page 51

Overview of Planning Reports

Organizations have many departments, such as Finance, Human Resources, Sales, Marketing, Purchasing, Production, Distribution, and Customer Service. Each department works with different types of data and therefore they each have unique reporting needs. If you are designing reports for other users, you need to identify their business requirements and questions. You also need to classify the different types of users and choose report designs that answer their questions and reflect their particular skill levels. Once you know what types of reports various users require, you can decide on which presentation type you want to use in the reports, then gather the data using BI Query.
Identifying Types of Users

Report authors create reports for distribution to other users. They create the best reports by knowing which type of user they are targeting:

💡 For more information, see the *BI Query Queries User’s Guide*.

- Users who read reports—They benefit most from an interface that lets them open reports with the click of a button, either from a link on a Web page or from a button in a data model.

💡 For more information, see “About Interactive Reports” on page 85.

- Users who analyze data—They analyze the data in existing reports. If the reports are interactive, users can re-qualify the data using hotspots.

Presenting Data

According to who your users are, decide what type of data they need and how best to present it to them.

Tables

The most common way of presenting data in a report is to use tables, but not all data makes a useful table. You need to determine whether a table is a good solution to your business question and whether you have the right data to create the table.

Tables work best for presenting detailed data, preparing forms, and creating large lists of information. For example, you can use tables to answer questions such as:

- How many units did we sell last month?
- What did our New York retailer buy last month?
- How much did each sales representative sell last quarter?

To present summary-level information in a matrix, a crosstab is a better solution. To communicate results visually, use a chart instead.
Invoices, Purchase Orders, and Other Forms

You can use BI Query to extract data from the database, then create a form in BI Query Reports using the results. You can use forms to generate monthly invoices, purchase orders, and form letters. For example, you can prepare a form for targeted mailings to customers who match certain criteria, such as customers in the United States who placed orders over $500 in the last year or customers in New York with invoices 30 days past due.

Company XYZ

PURCHASE ORDER

Vendor
A. Chocolate
1 More Royal
Montreal, PQ
Canada

Ship To

<table>
<thead>
<tr>
<th>Quantity</th>
<th>Description</th>
<th>Unit Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.000</td>
<td>Almond Bark</td>
<td>$0.39</td>
<td>$1.56</td>
</tr>
<tr>
<td>4.000</td>
<td>Vanilla Butterfrost</td>
<td>$0.14</td>
<td>$3.74</td>
</tr>
</tbody>
</table>

Subtotal: $2,543.01
Sales Tax: $170.81
Shipping: $20.00
Total: $2,736.82

Approval

Payment

☐ Check
☐ Cash
☐ Account
☐ Credit Card
Name: ____________________________ Issue Date: ________
Lists and Catalogs

You can use BI Query Reports to produce a wide range of lists and catalogs for all facets of your organization: price lists, parts catalogs, employee lists, inventory lists, and so on. You can prepare catalogs and price lists for internal use or to distribute using e-mail or the World Wide Web.

<table>
<thead>
<tr>
<th>97 Catalogue</th>
<th>Chocolate Factory New Product List</th>
<th>Price</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decadent Chocolate Cake</td>
<td>97 Catalogue Chocolate Factory New Product List</td>
<td>$24.95</td>
</tr>
<tr>
<td>This elegant cake is dense, moist and particularly rich. Classy if you want to give the most discerning connoisseur.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ingredients: sugar, butter, flour, heavy cream, semisweet chocolate and ground almonds.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Order Now</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Chocolate Truffles</td>
<td>97 Catalogue Chocolate Factory New Product List</td>
<td>$10.95</td>
</tr>
<tr>
<td>Our Chocolate Truffles are the most aromatic chocolate and cocoa confections. They are sure to please even the most demanding connoisseur.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ingredients: semi-sweet chocolate, cocoa fudge, confectioner sugar, cocoa, natural dye.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Order Now</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Biscotti al Romano</td>
<td>97 Catalogue Chocolate Factory New Product List</td>
<td>$10.95</td>
</tr>
<tr>
<td>Originally developed as a perfect accompaniment for dipping Fine white wine, these buttery balls have a nutty, toasted resonance.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Ingredients: fine wheat and corn flour, sugar, eggs, vanilla, golden raisins, pine nuts.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Order Now</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Charts

💡 Effective charts are simple. They do not use a lot of fancy graphic options that can clutter the data and confuse your reader.
Not all data makes a useful chart. Before you create a chart, you need to consider the type of data you are charting and choose the chart type to which it is best suited. The following list details the main chart types available based on what you want to present:

- Bar charts (see “Bar Charts” on page 38)
- Dual axis charts (see “Dual Axis Charts” on page 40)
- Line charts (see “Line Charts” on page 40)
- Area charts (see “Area Charts” on page 42)
- Pie charts (see “Pie Charts” on page 43)
- Three-dimensional charts (see “Three-Dimensional Charts” on page 44)

Use the following table to choose the best chart to display your data:

<table>
<thead>
<tr>
<th>To Show This</th>
<th>Use This</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data that changes over time</td>
<td>• Line</td>
<td>Annual sales for the last 10 years; 30-day stock trend;</td>
</tr>
<tr>
<td></td>
<td>• Bar</td>
<td>Exports and imports between 1988 and 1998</td>
</tr>
<tr>
<td></td>
<td>• Stacked bar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 3D bar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Area</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Stock</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Stacked area</td>
<td></td>
</tr>
<tr>
<td>Data at a single point in time</td>
<td>Bar</td>
<td>1998 sales for a family of products; 1998 sales and costs by month;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Number of employees per sales office</td>
</tr>
<tr>
<td>Parts of the whole</td>
<td>• Pie</td>
<td>Percent of sales by region;</td>
</tr>
<tr>
<td></td>
<td>• Percent bar</td>
<td>Market share</td>
</tr>
<tr>
<td></td>
<td>• Percent Area</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Doughnut</td>
<td></td>
</tr>
<tr>
<td>Frequency distributions</td>
<td>Histogram</td>
<td>Number of employees in various age categories</td>
</tr>
</tbody>
</table>
Bar Charts

Bar charts show the change in size or volume of a single item or illustrate comparisons among several items over time. Categories are organized horizontally, and values vertically, to emphasize variation over time. For example, you can plot cost and revenue by product.
Grouped bar charts let you chart the values for an extra dimension. For example, if you want to plot sales by quarter for each region in a single chart, you can use a grouped bar chart. For the best readability, make grouped bar charts as simple as possible—with no more than three to four members per group. Grouped bar charts need a legend to identify the members being charted.
Dual Axis Charts

Dual axis charts allow you to make relative comparisons based on different criteria. They plot two sets of bars for the same item and can use different scales and grids for each set. You can use a dual axis bar chart to plot the number of years that account executives have been with your company, along with their annual sales. This lets you to determine if there is a correlation between experience and performance.

Line Charts

Line charts show trends in data at equal intervals, displaying increases and decreases and illustrating relationships between members in a dimension. You can use the slope of the line to analyze the rate of change of the values when you are plotting a single dimension (for example, monthly sales for 1998) or to compare rates of change when you are plotting multiple dimensions (for example, monthly sales for 1996, 1997, and 1998).
Line charts are particularly effective when you are plotting a lot of members. Line charts give a smoother, more detailed comparison of time-oriented data than is possible in a bar chart. For example, plotting monthly sales figures in a bar chart results in a cluttered chart; a line chart gives a cleaner, more accurate picture of growth.
Area Charts

Area charts emphasize the magnitude of change over time by showing the area under the curve created by each member. The large, shaded surface indicates volume, similar to a bar chart. An area chart that plots a single column or row of data is more decorative than a line chart but provides the same information. By displaying the sum of the plotted values, an area chart shows the relationship of parts to a whole.

Avoid using more than four or five areas in the chart.
Pie Charts
Pie charts show the relationship or proportion of parts to the whole. A pie chart plots one column or row of data, with each member in the column or row represented by one slice of the pie. The size of a slice corresponds to the percentage it represents of the total value for the members. In business reports, a pie chart is often used to show the share or percentage of individual categories in relation to a whole, such as market share, the mix of assets in a mutual fund, or the distribution of budget expenditures.

Suggestions:
- To maintain clarity, use no more than seven pie segments.
- Avoid using a legend with pie charts since a legend makes it difficult to visually connect the legend colors to the pie segments. Instead, use labels.
- Avoid using multiple pies since they can be confusing. Alternatively, use a percent bar or area chart.
- Use a proportional pie chart when you need to compare the relative sizes of two pies to convey important information.
- Never compare more than two proportional pies; this makes a chart unreadable.
Three-Dimensional Charts

Three-dimensional charts compare values along three axes. Three-dimensional charts can show data that would otherwise require a series of two-dimensional charts—for example, sales by region, country, or salesperson over a number of years. They make trends easy to recognize and are the best option for presenting large data sets and showing the relationships between them. For example, you can compare four quarters of sales performance in one division with the performance of other divisions. Using three-dimensional charts, you can choose between different data markers—such as cone, cylinder, and pyramid—to lend dramatic effects.

Crosstabs

Not all data makes a useful crosstab. Before creating a crosstab, you need to consider whether a crosstab is a good solution to your business problem and whether you have the right data to create a crosstab. Crosstabs work best for summary-level, multidimensional information. To present detailed data in a report, use a table. To communicate results visually, use a chart.

For typical scenarios, see the following sections:
- “Sales Analysis Scenario” on page 45
- “Profit and Loss Reporting Scenario” on page 46
- “Manufacturing Quality Scenario” on page 47
Sales Analysis Scenario

One of the most common uses for crosstabs is sales analysis. Putting sales data into crosstabs lets you analyze results by product, sales representative, and region over time, discovering growth patterns and trends that were previously hidden. You can ask questions such as:

- Which products drove revenue?
- Has this changed over time?
- Why did results drop in the last quarter?
- Is a particular sales representative or region responsible?
- Does discount influence sales?

The following table lists the dimensions you might want to analyze in a Sales Analysis crosstab and some of the attributes to include in the query:

<table>
<thead>
<tr>
<th>To Analyze This</th>
<th>Include These Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>• Country (if applicable)</td>
</tr>
<tr>
<td></td>
<td>• State/Province</td>
</tr>
<tr>
<td></td>
<td>• Sales Office</td>
</tr>
<tr>
<td></td>
<td>• Sales Representative</td>
</tr>
<tr>
<td>Date</td>
<td>• Year</td>
</tr>
<tr>
<td></td>
<td>• Quarter</td>
</tr>
<tr>
<td></td>
<td>• Month</td>
</tr>
<tr>
<td>Product</td>
<td>• Product Category</td>
</tr>
<tr>
<td>Metrics</td>
<td>• Revenue</td>
</tr>
<tr>
<td></td>
<td>• Cost</td>
</tr>
<tr>
<td></td>
<td>• Quantity</td>
</tr>
<tr>
<td></td>
<td>• Gross Margin</td>
</tr>
<tr>
<td></td>
<td>• Gross Margin%</td>
</tr>
</tbody>
</table>
You can also include attributes in a query that return data about specific customers. Before you do this, think about how many customers you have and how often you sell to them. If you have a lot of customers but do not sell to any of them on a regular basis, or if each sales representative has sole responsibility for certain customers, you will generate a sparse crosstab containing a lot of nulls. Dense crosstabs, on the other hand, are more readable and easier to navigate. They also make trends easier to spot.

**Null Value**
A null indicates that there is no value for a combination of members (for example, that Assorted Truffles are not sold in Canada).

**Sparse**
A crosstab is sparse if a relatively high percentage of the possible combinations of members across dimensions contains null values.

**Dense**
A crosstab is dense if a relatively high percentage of the possible combinations of members across dimensions contains values.

**Profit and Loss Reporting Scenario**
Most organizations have to produce profit and loss reports (income statements). Transforming this data into a multidimensional Profit and Loss crosstab lets you track a much wider range of variance. You can use this crosstab to ask questions such as:

- Why is Travel & Entertainment (T&E) over budget?
- How much did we spend on T&E in relation to total expenses?
- How does T&E for this quarter compare with last quarter? What about last year?
- Is more staff travelling, or is a particular department or individual causing the variance?
- Which suppliers are we purchasing the most from?
- Can we leverage our purchasing power to gain a discount?
The following table lists dimensions you might want to analyze in a Profit and Loss crosstab and some of the attributes to include in the query:

<table>
<thead>
<tr>
<th>To Analyze This</th>
<th>Include These Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Income statement line items</td>
<td>• Revenue (Sales, Discounts)</td>
</tr>
<tr>
<td></td>
<td>• Cost of Goods (Materials, Shipping, Conversion)</td>
</tr>
<tr>
<td></td>
<td>• General &amp; Administration Expenses (Accommodation, Professional, Interest, General, Administration, Depreciation)</td>
</tr>
<tr>
<td></td>
<td>• Other Income/Expenses</td>
</tr>
<tr>
<td></td>
<td>• Tax</td>
</tr>
<tr>
<td>Date</td>
<td>• Year</td>
</tr>
<tr>
<td></td>
<td>• Quarter</td>
</tr>
<tr>
<td></td>
<td>• Month</td>
</tr>
<tr>
<td>Cost center</td>
<td>• Region</td>
</tr>
<tr>
<td></td>
<td>• Department (Sales, Marketing, Manufacturing, Shipping, R&amp;D)</td>
</tr>
<tr>
<td>Metrics</td>
<td>• Budget</td>
</tr>
<tr>
<td></td>
<td>• Forecast</td>
</tr>
<tr>
<td></td>
<td>• Actual</td>
</tr>
<tr>
<td></td>
<td>• Variance</td>
</tr>
</tbody>
</table>

**Manufacturing Quality Scenario**

Quality is of key importance in manufacturing. If you are a manufacturer, creating a Manufacturing Quality crosstab lets you closely monitor quality as well as the impact of poor quality on the number of units produced and their cost.

You can track variance between the number of units actually produced and the number of units planned. If production is off track, you can quickly discover whether it is a result of an unusual number of faulty units, downtime, or slow production runs. You can ask questions such as:

• Are there any runs that are off target? Why?
• Was it because of excessive downtime, or was there an unusual number of faulty units?
• Is this run consistently off plan, or was it a one-time occurrence?
• Is a particular product or component causing the problem, or was there a delay at one stage of the run?

The following table lists the dimensions you might want to analyze in a Manufacturing Quality crosstab, as well as some of the attributes to include in the query:

<table>
<thead>
<tr>
<th>To Analyze This</th>
<th>Include These Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Products</td>
<td>• Product Category</td>
</tr>
<tr>
<td></td>
<td>• Product</td>
</tr>
<tr>
<td></td>
<td>• Component</td>
</tr>
<tr>
<td>Production runs</td>
<td>• Plant</td>
</tr>
<tr>
<td></td>
<td>• Run</td>
</tr>
<tr>
<td>Work stages</td>
<td>• Setup</td>
</tr>
<tr>
<td></td>
<td>• Production</td>
</tr>
<tr>
<td></td>
<td>• Quality Control</td>
</tr>
<tr>
<td></td>
<td>• Packing</td>
</tr>
<tr>
<td>Date</td>
<td>• Year</td>
</tr>
<tr>
<td></td>
<td>• Quarter</td>
</tr>
<tr>
<td></td>
<td>• Month</td>
</tr>
<tr>
<td></td>
<td>• Week</td>
</tr>
<tr>
<td></td>
<td>• Day</td>
</tr>
<tr>
<td></td>
<td>• Hour</td>
</tr>
<tr>
<td></td>
<td>• Minute</td>
</tr>
</tbody>
</table>
Gathering Data

Once you have determined the requirements for a report, you can gather the data you need.

💡 For a description of the different types of data, see “Detailed and Summary Data” on page 20.

Gathering Data for Tables

The data you present in a table starts with a query to the corporate database using BI Query. The attributes you choose in the query correspond to the columns in your table. Although you can also manipulate the data in BI Query Reports (such as by changing the grouping and sorting), you can save yourself extra work by following these guidelines when you formulate your query:

- If you want to group certain information in a report and apply calculations to it, sort the corresponding data in BI Query.
- Eliminate duplicate data in the query using one of the following:
  - Distinct modifier—On the Query menu, click Modifiers, and then click Distinct.
  - Aggregate function (such as SUM)—Click the Function box in the attribute window.

💡 For more information on working with BI Query, see the BI Query Queries User’s Guide.
Grouping and Sorting Results in BI Query

You can group results in a table to present related information together and make your report easier to read. Once you have grouped results, you can then apply calculations such as subtotals to each group. For example, if you create a list of products in various product categories and include the revenues they generate, it makes sense to group products in the same product category together rather than having them dispersed throughout your report. You can then add a subtotal to determine the total revenue for each product category.

💡 For more information, see “Adding User-Defined Calculations to Tables” on page 240.

When you group data, header and footer bands are added to each group. These bands separate the groups and provide an area to stack columns, add subtotals, and place additional information. You can also create a page break for each group (useful for invoices where you want each customer's invoice starting on a new page).

In BI Query, you can specify how to sort results before running a query, or after retrieving the results. You can also edit the query and then replace the data source containing the unsorted data with the data source containing sorted data.

💡 For more information, see “Editing Queries and Replacing Data” on page 70.

In BI Query Reports, Presentation Designer automatically groups any columns that were sorted in BI Query by default. You can change the grouping and sorting options when you create the table with Presentation Designer, or later using the Group and Sort dialog box. Using the Group and Sort dialog box to make necessary adjustments to the grouping and sorting saves you from having to rerun a query, thereby reducing the load on your server.

**To group results by sorting in BI Query:**

- Do one of the following:
  - When you build the query in BI Query, in the attribute window, click Sort for the attribute on which you want to group the data in the report.
  - If you have already run the query, sort the results set. On the Results menu, click Filter and then click Sort.
Charts and Crosstabs

The data you present in a chart starts with a query to the corporate database using BI Query. When you create a chart, the detailed data that you retrieve from BI Query is converted into summary data. To save yourself extra work in your report, follow these guidelines when you formulate the query.

- Ensure that the data is multidimensional. It should contain information on at least three dimensions of your business, such as Product, Region, and Metrics.
- Ensure that some of the data is numeric so that you can measure your success. For example, it should contain metrics such as Units Sold, Revenue, Cost, and Margin.
- Keep the number of attributes/dimensions in your query small (two to five).
- Ensure that descriptive columns do not contain too many values. Charts communicate most effectively with seven or fewer values along one axis.
- Ensure that the data is evenly distributed.
- Focus on one business problem per chart. do not try to answer every question in a single chart or crosstab.
- Identify the critical time period. If you need to compare results over quarters, do not include monthly or weekly data.

Building Tables

If you decide that you want to present data in a table, you can either use one of the predefined styles that appear on the Style page of the Presentation Designer dialog box, or you can create and use a user-defined table style.
Using BI Query Reports Predefined Styles

By selecting one of the BI Query Report predefined styles using Presentation Designer, you are specifying just the arrangement of the data (such as whether all data is presented in simple columns, or stacked by sort order); the initial formatting of the data and the appearance of the bands are controlled by defaults that are independent of the style you select. You can choose a table style using Presentation Designer. With each style you can choose to add totals to numeric columns. The following table styles ship with BI Query Reports:

<table>
<thead>
<tr>
<th>Use This</th>
<th>To Do This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columnar</td>
<td>Arrange data in columns.</td>
</tr>
<tr>
<td>Free-form</td>
<td>Leave columns unanchored.</td>
</tr>
<tr>
<td>Stacked</td>
<td>Stack and left-align sorted data, placing remaining data in columns.</td>
</tr>
<tr>
<td>Stacked Indented</td>
<td>Stack and indent sorted data, placing remaining data in columns.</td>
</tr>
</tbody>
</table>

Each predefined table style uses the default settings specified on the Table page of the Preferences dialog box. These settings determine the initial formats for:

- the data that appears in each band
- the text in each band
- the colors of borders and bands

💡 For more information, see “Setting Default Formatting for Predefined Table Styles” on page 116.

When you are creating a new table presentation using Presentation Designer, you also have the option of using the data formatting from the query which generated the results for your presentation.

Using Your Own Styles

Like predefined styles, user-defined styles are useful for creating reports that all have the same look and feel. Unlike predefined styles, user-defined styles apply to more than just the formatting of a table.
You create user-defined styles by saving a table as a template. The template stores the formats, the column grouping, and the calculations that appeared in the original table.

💡 For more information, see “User-Defined Table Styles” on page 119.

When you create a table using Presentation Designer, you can browse for the user-defined styles, then use them as the basis for the new table. They are most useful when you use them to build tables that contain similar data. For example, if a table style groups data (for example, by retailer) and contains calculations (such as sales by customer), the style works best if you use it to build other tables that contain data for retailers and their sales.

As with predefined table styles, you can preserve the data formatting from the query if you want rather than applying the data formatting associated with the saved template.
Once you have gathered your data, you can use **Presentation Designer** to design your reports. If you would like to create reports containing different information, you can edit your query and replace the data. When you are happy with your report, you can then print it or share it with others.

- “Creating Reports Overview” on page 55
- “Building Presentations with Presentation Designer” on page 56
- “Editing Queries and Replacing Data” on page 70
- “Setting Preferences” on page 73
- “Saving Reports” on page 76
- “Printing Reports” on page 77
- “Exporting Reports” on page 79
- “Distributing Reports” on page 83

**Creating Reports Overview**

The report creation process involves the following general steps:
1. Gathering the data—You can create reports using new data, existing data, or views from other presentations.

2. Adding it to reports using presentations—The tables, charts, and crosstabs that deliver your message.

   You can add any number of presentations to a report. You can also easily requalify the data in a presentation by adding hotspots to the report.

3. Working with the report and making it available:
   - set preferences, save, and print it
   - work with it offline using spreadsheet applications such as Microsoft Excel
   - export it in a number of formats and view it in Adobe Reader or on the World Wide Web
   - distribute it using the repository and e-mail

**Building Presentations with Presentation Designer**

By determining which presentation type or combination of types best suits the data you want to use, you can focus a report on the information that interests your audience—whether that is upper management, potential clients, or the general public.

When you build presentations, Presentation Designer steps you through the process, prompting you to select a presentation type, a style, and an organization for the data. Use the Presentations Designer to:

- add tables to a report
- add charts to a report
- add crosstabs to a report

You can also build presentations to add to existing reports.

**Working with Tables**

You can add tables to both new and existing reports.

**Adding Tables to a New Report**

Tables are best suited for detailed data and large lists of information.
To add a table to a new report:

1. With results displayed in BI Query, on the Results menu, click Show as Report, and then click BI Query Reports.
2. On the Presentation page of the Presentation Designer dialog box, click Table, and then click Next.
3. On the Style page, click a table style from the available list or, to choose a style that you or someone in your organization has created, click Browse.
4. Under Orientation, click Portrait or Landscape.
5. Select the Fit on one page check box if you want the report automatically scaled to fit on one page.
6. Under Data Formatting, do one of the following:
   - Click Use data model formats to use the same data formatting as was used in the query that generated the results upon which the presentation is based.
   - Click Use presentation formats to override the data formatting from the query. If you selected one of the predefined styles, the data would be reformatted according to your default data formatting preferences. If you selected a user-defined style, the data would be reformatted according to the data formatting saved with the selected style.
7. Click Next.
8. On the Arrange Data page, drag a column up or down in the Columns list to specify the order in which you want the columns to appear.
9. Click Finish.

Adding Tables to Existing Reports

When you add a table to an existing report, you can use the same data source used by another table, chart, or crosstab in the report, or you can use a new data source.

To add a table to an existing report:

1. With results displayed in BI Query, on the Results menu, click Show as Report, and then click BI Query Reports.
   If you want to retrieve new data:
   a. In BI Query, retrieve new query results, then send the results to BI Query Reports.
   b. Create a table.
c. In the report in which you want to add the table, on the Insert menu, click Table.

2. On the Data Source page of the Presentation Designer dialog box, click a data source.

   The Data Source page shows the data sources used in the reports you have created or opened and refreshed during the current session. As you create or open new reports, their data sources are added to the bottom of the list.

3. Click Next.

4. On the Style page, choose a table style and specify how you want to format your data. To choose a style that you or someone in your organization has created, click Browse, then locate and open the template.

5. Click Next.

6. On the Arrange Data page, drag a column up or down in the Columns list to specify the order that you want the columns to appear.

7. Click Finish.

Working with Charts

Adding Charts to a New Report

Charts are a visual way of presenting summaries of your data. Charts are particularly useful for presenting conclusions or for highlighting trends, patterns, and other relationships that are not apparent in tabular data.

To add a chart to a new report:

1. With results displayed in BI Query, on the Results menu, click Show as Report, and then click Bi Query Reports.

2. On the Presentation page of the Presentation Designer dialog box, click Chart, and then click Next.

3. On the Style page, click a chart type and subtype.

   For more detailed information on chart types and subtypes, see “Understanding Chart Types in Detail” on page 131.

4. Click Next.

5. On the Arrange Data page, do any of the following:
• Make any changes you want in the default arrangement by dragging the data from one location and dropping it in another. For more information, see “Rearranging Data in Charts” on page 124.

• To focus a chart on a particular item, drag the item into the Filter On box. Filtering controls the focus in a chart by displaying only the data related to a specific member, thereby simplifying the view. For more information, see “Filtering Data” on page 127.

6. Click Finish.

Adding Charts to Existing Reports

When you add a chart to an existing report, you can use the same data source used by another table, chart, or crosstab in the report, or you can use a new data source.

To add a chart to an existing report:

1. Do one of the following:
   • If you have already retrieved the data you want to include in your report, on the Insert menu, click Chart.
   • If you want to retrieve new data:
     a. In BI Query, retrieve new query results, then send the results to BI Query Reports.
     b. Create a chart.
     c. In the report in which you want to add the chart, on the Insert menu, click Chart.

2. On the Data Source page of the Presentation Designer dialog box, click a data source.
   The available data sources correspond to the reports you have created during the current session. They appear in the order in which you retrieved the corresponding data using BI Query.

3. Click Next.

4. On the Style page, click a chart type, click a chart subtype, and then click Next.
   For more detailed information on chart types and subtypes, see “Understanding Chart Types in Detail” on page 131.

5. On the Arrange Data page, make any changes you want in the default arrangement by dragging the data from one location and dropping it into another.
6. Click **Finish**.

**Organizing Data in Charts**

With charts, you can filter and organize the data you want to see. For example, you may only be interested in the fourth quarter’s financial results rather than viewing all of the quarters together.

The **Arrange Data** page of **Presentation Designer** displays data organization.

The following table describes data organization for a typical chart:

<table>
<thead>
<tr>
<th><strong>This Element</strong></th>
<th><strong>Represents This</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>A category of data. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.</td>
</tr>
<tr>
<td>Member</td>
<td>A subcategory of a dimension. For example, Q1, Q2, Q3, and Q4 are members of the Quarter dimension. Member names appear along the axes or in the legend.</td>
</tr>
<tr>
<td>Metrics</td>
<td>A category of numeric information. It contains the numbers that quantify the success of your organization (numbers such as units, costs, revenue, and so on). Every data source must have one Metrics dimension.</td>
</tr>
<tr>
<td>Filter</td>
<td>The focus of the chart. Filtering controls the focus of the chart by displaying the data related only to a specific member.</td>
</tr>
<tr>
<td>Legend</td>
<td>The values being plotted in two-dimensional charts.</td>
</tr>
</tbody>
</table>

**Arranging Data in Charts**

The **Arrange Data** page of **Presentation Designer** illustrates how the presentation displays and summarizes data.

- Columns containing text and dates become dimensions.
- Columns containing numeric data become members of the Metrics dimension (also known as the variable or measures dimension).
- If you want to prevent an item from appearing in the presentation, you can move it from the display area to the **Available Data** list. For more information, see “Changing How Charts Summarize Data” on page 61.
• You can move a member out of **Metrics**, making it a dimension that you can then move anywhere in the display area for the presentation.

**To prevent an item from appearing in the chart:**

- On the **Arrange Data** tab of the **Presentation Designer** dialog box, drag a dimension in the display area to the **Available Data** list.

**Changing How Charts Summarize Data**

The **Arrange Data** page of the **Presentation Designer** displays how data is displayed and summarized:

- Alphanumeric columns containing text and dates are listed in the **Available Data** area. These columns become dimensions in the chart.
- Columns containing numeric data are listed as metrics. These columns become members of the metrics dimension, and their values are plotted along the y-axis.

Occasionally, you may not want all the data in the chart to be summarized. For example, you may want to create a scatter chart containing detailed data that plots metrics along both axes of the chart. You can change how data is summarized by moving columns out of the metrics category.

**To change a numeric column from a metric to a dimension (or non-metric):**

- On the **Arrange Data** tab of the **Presentation Designer** dialog box, drag a metric from the **Available Data** list to the white space at the bottom of the **Available Data** list. For example, Order Year is a numeric that was originally defined as a metric. To redefine it as a dimension, drag it from the metrics category to the bottom of the list.

**Adding Crosstabs to Reports**

You can add crosstabs to both new and existing reports.
Adding Crosstabs to a New Report

Crosstabs display data in multidimensional format. You can use them to uncover trends, anomalies, problems, and opportunities.

To add a crosstab to a new report:

1. With results displayed in BI Query, on the Results menu, click Show as Report, and then click BI Query Reports.
2. On the Presentation page of the Presentation Designer dialog box, click Crosstab, and then click Next.
3. On the Style page of the Presentation Designer dialog box, make any changes you want to the style of the crosstab.
4. Under Orientation, click Portrait or Landscape.
5. Under Data Formatting, do one of the following:
   - Click Use data model formats to use the same data formatting as was used in the query that generated the results upon which the presentation is based.
   - Click Use presentation formats to override the data formatting from the query. The data is reformatted according to your default data formatting preferences.
6. Under Crosstab Analysis Mode, do one of the following:
   - Click Normal Interaction to store a snapshot of the data along with the report. You can reopen the report with the snapshot data displayed, or you can refresh the report to rebuild the data source.
   - Click Immediate Interaction to store the data as a separate hypercube. The presentation is linked to the hypercube and is automatically refreshed when you open the report so that the data is available for analysis. If you choose this option, specify a file name (and location, if other than the Reports folder) for the hypercube.

If you choose Immediate Interaction, there is no automatic method to edit the underlying query. If you subsequently want to change the data, you will need to manually reopen (or recreate) the query.

7. On the Arrange Columns tab, make any changes you want to the arrangement of columns in the crosstab, and then click Next.
8. The **Building hypercube** tab appears while BI Query Reports is creating the hypercube. This is simply a progress indicator; no user interaction is required.

9. On the **Arrange Data** tab, do any of the following:
   - Make any changes you want in the default arrangement by dragging the data from one location and dropping it into another.
   - To filter a crosstab on an item, drag the item into the **Filter On** box. This controls the focus of a crosstab by displaying only the data related to this item. For more information, see “Filtering Data” on page 127.
   - To change your view of the data in a crosstab by swapping the dimensions in the columns with those in the rows, click **Pivot**.

10. Click **Finish**.

### Adding Crosstabs to Existing Reports

When you add a crosstab to an existing report, you can use the same data source used by another table, chart, or crosstab in the report, or you can use a new data source.

**To add a crosstab to an existing report:**

1. Do one of the following:
   - If you have already retrieved the data you want to include in your report, on the **Insert** menu, click **Crosstab**.
   - If you want to retrieve new data, do the following:
     a. In BI Query, retrieve new query results, then send the results to BI Query Reports.
     b. Create a crosstab.
     c. In the report in which you want to add the crosstab, on the **Insert** menu, click **Crosstab**.

2. On the **Data Source** page of the **Presentation Designer** dialog box, click a data source.

   The **Data Source** page shows the data sources used in the reports you have created or opened and refreshed during the current session. As you create or open new reports, their data sources are added to the bottom of the list.

   If the data source you want does not appear in the list, click **Browse** to find it.

3. Click **Next**.
4. On the **Arrange Data** page, make any changes you want in the default arrangement by dragging the data from one location and dropping it in another.

5. Click **Finish**.

You can add more than one presentation to a report so that you can focus on different aspects of your business. For example, one presentation can show product sales per region, while another can show the top performing sales representatives in each region.

You may want to add a presentation that uses the data in an existing report, but presents it in a different way. For example, if you have a report that presents summarized data in a chart, you can also add a table that provides the details of that data.

You can include as many presentations as you like in a report, using the existing data source or a new data source.

### Arranging Data in Crosstabs

The **Arrange Data** page of the **Presentation Designer** shows how data will be displayed and summarized in the presentation.

- All attributes selected from the original query appear in the **Available Data** box.
- Attributes with numeric data types (for example, Order Amount) appear as a second level list under the group heading **Metrics** (preceded by the purple spreadsheet icon).
- Attributes defined as character or date data types (e.g. Territory, Year as a character data type, Product Name) appear below the metrics with a blue cube icon. These attributes are the descriptive Dimensions (non-metrics).
- Columns containing text and dates become dimensions.
- Columns containing numeric data become members of the Metrics dimension (also known as the variable or measures dimension).
- You can move a member out of **Metrics**, making it a dimension that you can then move anywhere in the display area for the presentation.
- The metrics values become the data in the data area.

💡 For more information, see “Redefining a Metrics Member in a Crosstab” on page 65.
To prevent an item from appearing in the crosstab:
1. On the **Arrange Data** page of the **Presentation Designer** dialog box, click a dimension in the display area for the crosstab.
2. Drag the selected item into the **Available Data** box.

**Redefining a Metrics Member in a Crosstab**

By default, the metrics dimension contains attributes with numeric data types. You can convert a metrics member to a non-metrics dimension.

**To convert a metrics dimension member to a non-metric dimension:**
1. On the **Arrange Data** page of the **Presentation Designer**, click a metrics dimension member in the **Available Data** box.
2. Drag the member into the white space at the bottom of the **Available Data** box.
   - A blue cube icon indicates that the metrics dimension is now a non-metrics dimension.

   When dragging a metrics dimension member to the bottom of the list, ensure you drag it to the white space. If you see a blue line at the bottom of the list, keep dragging it until the line disappears.

**Changing the Style of a Crosstab**

The **Style** tab of **Presentation Designer** allows you to change the following:
- Page orientation
- Data formatting
- Crosstab analysis mode

**Changing the Page Orientation of a Crosstab**

You can display the crosstab in either Portrait or Landscape mode. Page Orientation specifies whether the report should print with its top along the short edge of the paper (portrait) or along the long edge of the paper (landscape).

**To change the page orientation:**
- On the **Style** tab of **Presentation Designer**, under **Orientation**, click either **Portrait** or **Landscape**.
You can also change the orientation of the page after you create it. For more information, see “Selecting the Page Orientation” on page 78.

Changing the Data Formatting of a Crosstab

When you create a crosstab (or a table), you can view your data in either of the following two formats:

- Data model format
- Presentation format

Data model format

When you use the data model format for your data, your data retains the formatting it uses in the data model when you create a crosstab (or table). For example, suppose your database contains product codes with dashes between groups of numbers such as ###-###-###. Choosing to retain the data model format will cause BI Query Reports to keep this formatting.

Presentation format

If you choose to use the presentation format, on the other hand, you can override the formatting of the data in your data model. For more information, see “Setting Default Formatting for Predefined Table Styles” on page 116 or “Setting Default Formatting for Crosstabs” on page 190.

To change the data formatting:

- On the Style tab of Presentation Designer, under Data Formatting, click either Use data model formats or Use presentation formats.
Setting the Crosstab Analysis Mode

The following table details the two crosstab analysis modes:

<table>
<thead>
<tr>
<th>Analysis Mode</th>
<th>Description</th>
<th>When to use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal interaction</td>
<td>In this mode, BI Query stores only the visible data in the report. If you</td>
<td>Use this mode if your data updates frequently to ensure that you are looking at the most recent data. For example, this mode would be the best mode for looking at volatile data such as stock prices.</td>
</tr>
<tr>
<td></td>
<td>want to analyze the report, you must first refresh the data.</td>
<td></td>
</tr>
<tr>
<td>Immediate interaction</td>
<td>In this mode, BI Query stores all the data locally in a separate hypercube</td>
<td>Use this mode if your data updates infrequently or if you need to have your data immediately available to you. For example, if you use a laptop, this mode allows you to perform data analysis without having to connect to the database.</td>
</tr>
<tr>
<td></td>
<td>file. BI Query links your report to the hypercube file allowing you the</td>
<td></td>
</tr>
<tr>
<td></td>
<td>ability to immediately analyze the data without needing to refresh the</td>
<td></td>
</tr>
<tr>
<td></td>
<td>data. Note that you can only modify the hypercube file through BI Cube</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Creator.</td>
<td></td>
</tr>
</tbody>
</table>

To set the crosstab analysis mode:

1. On the Style tab of Presentation Designer, under Crosstab Analysis Mode, click either Normal interaction or Immediate interaction.

2. If you selected Immediate interaction, in the Hypercube File Name box, type the name you want to use for the separate hypercube file.
Adding Presentations by Using Views

When you create a presentation, BI Query Reports creates a subset of data called a view. A view is the ‘middle layer’ between a presentation and the corresponding data file. A view stores calculations, exceptions, and the arrangement of the data.

The data sources and views that are available to you are listed in the Data Sources dialog box. Views are listed under the data sources from which they were created. For example, if you used a sales query to create a table, the view for the table is listed under the Sales data source in the Data Sources dialog box.

To add a presentation using a view:

1. In a report, on the Insert menu, click a presentation type. For example, on the Insert menu, click Chart to add a chart to your report.
2. On the Data Source page of the Presentation Designer dialog box, double-click the icon beside the data source used to create the original presentation. For example, to use a crosstab view, double-click the icon beside the data source used to create the crosstab.
3. From the list of views, click the view associated with the original presentation. The icon for a view has a plus sign (+) in the upper left-hand corner.
4. Click Finish.

Checking the View Name

If you need, you can verify the view name for a presentation.

To check the view name for a presentation:

1. Click the presentation.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the General tab. The view name appears in the Source View box.
Using Views to Link Presentations

You can use views to link presentations. When you create different presentations using the same view, you can manipulate the data in one presentation and add calculations to it. Those changes will be automatically reflected in another presentation. For example, you can create a crosstab, hide members you do not need, and add a sum. When you create a chart using the view of the crosstab, the chart shows the same arrangement of data as the crosstab, including the sum.

To link a chart to a crosstab:
1. On the **Insert** menu, click **Chart**.
2. On the **Data Source** page of the **Presentation Designer** dialog box, double-click the data source used to create the table. The **Data Source** page shows the data sources used in the reports you have opened. As you open new reports, their data sources are added to the bottom of the list.
3. From the list that appears, click the view associated with the crosstab. The icon for a view displays a plus (+) sign.
4. Click **Finish**.

To link a chart to a table:
1. On the **Insert** menu, click **Chart**.
2. On the **Data Source** page of the **Presentation Designer** dialog box, double-click the data source used to create the table. The **Data Source** page shows the data sources used in the reports you have opened. As you open new reports, their data sources are added to the bottom of the list.
3. From the list that appears, click the view associated with the table. The icon for a view displays a plus (+) sign.
4. Click **Next**.
5. On the **Style** page, click a style, and then click **Finish**.

Copying and Pasting Presentations

The Copy command lets you create a duplicate of the selected object. You can copy all objects including graphics, text, and presentations. You can copy tables, charts, and crosstabs and paste them anywhere in a report.
To copy and paste a presentation within BI Query Reports:

1. Click a presentation. To select a table, click outside of it, then drag over a portion of its border.
2. On the Edit menu, click Copy.
3. Click in the report where you want the presentation to appear.
4. On the Edit menu, click Paste.

Changing the Presentation Type

After creating your presentation, you may want to try a different presentation style for your data.

To change the presentation:

1. On the Insert menu, click a presentation.
2. On the Data Source page of the Presentation Designer dialog box, double-click the data source used to create the original presentation. The Data Source page shows the data sources used in the reports you have opened. As you open new reports, their data sources are added to the bottom of the list.
3. From the list that appears, click the view associated with the original presentation. The icon for a view displays a plus (+) sign.
4. If you no longer need the original presentation, delete it.

Editing Queries and Replacing Data

There may be times when you create a presentation, format it, and then realize that you want to fine-tune the data. Instead of going to back to BI Query, rebuilding the query, then redoing all your work in the presentation, you can replace the data in the original presentation with new data.

If you change the data for a table by adding new attributes to the query, you must add the corresponding data items to the table because they do not appear automatically.
Changing the Data Source

When you change the data in a report, BI Query Reports matches the new data to the original. When it cannot match any items in the data, you need to match them yourself.

To replace the data source:

1. Open a report and click the presentation. On the Data menu, click Data Sources.
   - If the Data Sources command is not available, click the Refresh button on the toolbar to refresh the report, or, on the Data menu, click Refresh.
2. In the Data Sources dialog box, click the data source, and then click Replace. This associates the original presentation with the new data source.
   If there is unmatched data, the Map Data dialog box opens. Map the unmatched data. Click OK. For more information, see “Mapping Unmatched Data” on page 72.
   If there is unmatched data and the presentation is a chart or crosstab, the Arrange Data page of Presentation Designer opens. Arrange the new data source and click OK. The data source is replaced and the report view is revised.

Editing Queries

You can edit the query associated with an open report (for one data source at a time) and replace the data without having to initially refresh the report. For example, you need to add an attribute, change a qualification, or create a new qualification. Perhaps you want to create another query, or add another presentation to a report. To make these changes, it is necessary to load a query in BI Query for editing, then update the results in Reports.

To edit a query and replace the data:

1. Do one of the following:
   - Open a report and select the presentation. On the Data menu, click Edit Query.
   - Open a report and select the presentation. On the Data menu, click Data Sources. In the Data Sources dialog box, click a data source, and then click Edit Query.
Chapter 4: Creating Reports

2. BI Query opens the query in the appropriate window (the **Query** window, the **Super Query** window, or the **Freehand Query** window). Edit the query and run it to obtain new results.

3. On the **Results** menu, click **Show as Report**, and then click **BI Query Reports**. The **Replace Data Source** dialog box opens.

4. Do one of the following:
   - **Replace an Existing Data Source**—Type a name in the **Data Source Name** box and click **OK**. If the columns match and the presentation is a table, the data source is replaced and the report view is revised.

     If there is unmatched data, the **Map Data** dialog box opens. Map the unmatched data. Click **OK**. For more information, see “Mapping Unmatched Data” on page 72. If there is unmatched data and the presentation is a chart or crosstab, the **Arrange Data** page of **Presentation Designer** opens. Arrange the new data source and click **OK**. The data source is replaced and the report view is revised.

   - **Create a New Presentation**—Click **OK**. The **Presentation Designer** dialog box opens. Create the presentation and click **Finish**.

     If you are adding a new attribute from the query to the report, the formatting applied to the attribute in the query will automatically be applied to the new data in the updated presentation. Once the report has been updated, you can reformat the new data if you want.

5. Save the report.

**Mapping Unmatched Data**

When you apply new data to a presentation, you must match the columns and dimensions in a presentation with those from the new data source. If the data you are trying to match is very different, it may not make sense to try matching it. Instead, it may be easier to create a new presentation and delete the old one. If you are replacing the data in a chart or crosstab, and the new data source contains more items than the old, items that are not matched are filtered.

**To map new (unmapped) data:**

1. In the **Map Data** dialog box, click an item in the **Unmapped new data** list box.

2. Do one of the following:
   - Drag the item to the area beside an item icon in the **Map ‘DataSource’** list.
• Right-click the item and click Cut on the popup menu. Right-click the area beside an item icon in the Map ‘DataSource’ list and click Paste on the popup menu.

3. Continue until you have matched the items. To unmapped an item, drag it to the Unmapped new data box. Alternatively, click it and press DELETE.

4. Click OK.

Removing Data Sources

You can remove data sources you are not using in a report.

To remove a data source:
1. On the Data menu, click Data Sources.
2. In the Data Sources dialog box, click a data source.
3. Click Delete.
4. Click OK.

Setting Preferences

On the General page of the Preferences dialog box, you can set preferences for:
• opening and refreshing reports
• refreshing charts and crosstabs
• refreshing reports that contain the same prompts
• displaying the Welcome window
• resizing bands when you place items into them

The options for opening and refreshing are report-level preferences, so set them for each report you create.

Preferences for Opening a Report

You have a number of options for specifying how to open reports.
• If you always want a report to contain the most recent data, set the report to refresh when it opens. This is useful for reports whose data changes frequently because opening them reruns the associated query or queries and displays the latest data.
Chapter 4: Creating Reports

- If you are distributing a report using the scheduler or e-mail, you may want to show the data that appeared the last time it was refreshed. This reduces the load on the database and ensures that everyone is reading the same version of the report.

- You can have BI Query Reports ask you if you want a report refreshed or to show existing data each time you open it. The default preference is set to ‘Ask me each time’.

The options for opening are report-level preferences, so set them for each report you create.

**To set preferences for opening a report:**

1. On the **Tools** menu, click **Preferences**.
2. On the **General** page of the **Preferences** dialog box, choose whether you want reports refreshed automatically, not refreshed, or if you want to be prompted each time you open a report.
3. Click **OK**.

**Refresh Preferences**

The options for refreshing are report-level preferences, so set them for each report you create.

**To set preferences for refreshing a report:**

1. On the **Tools** menu, click **Preferences**.
2. On the **General** page of the **Preferences** dialog box, select the preferences you want for refreshing the report. You can specify:
   - How to refresh crosstabs or chart presentations in a report.
   - How to refresh a report that uses data from more than one query, and the queries contain the same prompt value.
3. Click **OK**.

**Refreshing Charts and Crosstabs**

If a report contains a chart or crosstab, you can specify how they should be refreshed. When refreshing crosstabs or chart presentations in a report, choose one of the following:

- display all the items in the data
Setting Preferences

- display only the items currently shown

**Example 1:**
If you refresh a report and a new product is introduced, you can decide whether to include the new product in the presentation.

**Example 2:**
A report contains a pie chart showing the percentage of total sales for last quarter in Canada and the United States. The report contains a hotspot, which you re-qualify to include data for Mexico. You can specify that when you refresh the report, the pie chart shows all the items in the data (Canada, United States, and Mexico) or only the current two items (Canada and United States).

**Refreshing Reports with the Same Prompts**
If a report uses data from more than one query, and the queries contain the same prompt, you can specify how to be prompted. When you refresh reports using data from more than one query, and the queries contain the same prompt, by default, you are required to insert the same value each time you are prompted. Instead, you can set a preference:
- to insert a value into the prompt only once
- to insert the same value each time you are prompted (default)
For example, a report contains a table that shows sales for the current quarter, and the associated query contains a prompt for region. The report also contains a pie chart showing the contribution of each sales office to that quarter’s sales, and that query also contains a prompt for region. Unless you have set the preference to be prompted once, when you refresh the report, you are prompted for the region twice.

**Setting Other Report Preferences**
You can set whether the Welcome window displays when you start BI Query Reports. You can also set whether bands automatically resize when you place items into them.

**To set preferences:**
1. On the **Tools** menu, click **Preferences**.
2. On the **General** page of the **Preferences** dialog box, do any of the following:
• Select the **When Starting BI Query Reports, display the Welcome window** check box.
• Select the **When placing items in a band, resize band automatically** check box.

3. Click **OK**.

### Saving Reports

Once you have specified how a report opens, you can save it. You can save reports in any location. However, to distribute reports with a data model (using either the repository or the database), you must save them in the **Reports** subfolder of the folder where the data model is stored.

If you are working in a BI Server environment, you must save reports before you can publish them to the repository.

**To save a report:**

1. On the **File** menu, click **Save**.

   ![Tip]
   For more information about this dialog box, consult the Windows documentation.

2. If the **Save As** dialog box appears, specify the name, file type, and location for the report.

3. Click **Save**.

### Saving Reports with Data Sources

You may need to maintain reports on a computer that is not connected to a database. For example, you may start a report at the office, then decide to finish it at home. In this case, you can download the report and its data sources to a common location on your laptop computer, work on the report at home, and the next day reconnect to the database to retrieve the most up-to-date data.

![Tip]
For more information about publishing and scheduling, see “**Working with BI Server**” on page 257.

You must refresh reports that have been saved with their data sources if you want to work with the data in them. Refreshing reports retrieves the data from local data sources. If you do not want to work with that data, you can show the existing data instead. You may have to set open preferences to show the data in the format you want.
When you save a report with its data sources, it is good practice to create a new folder for them. This keeps the report and its data sources separate from other reports, which helps eliminate confusion about which data sources belong with which reports.

**To save reports and results:**
1. On the File menu, click Work Locally, and click Save Locally As.
2. In the Save Locally As dialog box, specify a name and location for the report.
3. Click Save.

⚠️ When you work in a report that has been saved locally, you cannot publish or schedule that report until you reconnect to the database.

**Reconnecting to the Database**

If you have saved a report locally with results and want to refresh it using the most up-to-date data, you have to reconnect to the database.

⚠️ A report saved locally must be refreshed from its local data source before refreshing it from the database.

**To reconnect to the database:**
1. Open a report.
2. On the File menu, click Work Locally, and then click Reconnect to Database. The Retrieve Data dialog box opens.
3. Select the option to refresh the data. If a message prompts you to refresh the report, click Yes.

**Printing Reports**

The Windows Print dialog box lets you specify how to print a report and whether to print it to a printer or a file. The options in this dialog box depend on the printer to which your computer is connected.

💡 For more information about the Print dialog box, consult the Windows documentation.
By default, pages print horizontally from left to right. Before you print a report, you may want to change this order. For example, your report might contain four pages, with a table spanning two pages vertically, a chart beside the first page of the table, and a crosstab beside the second page of the table. Unless you change the print order, the first page of the table prints first, then the chart, then the second page of the table, then the crosstab.

Before you print a report, you can:

• specify the print order
• choose the page orientation
• preview a report

💡 Blank pages can be created when a report contains a large table and a large crosstab, or when refreshing the data retrieves less information. Blank pages do not print when at the end of a report, but they do print when they are within a report. To avoid printing blank pages, change the printing order or rearrange the report information.

To print a report:

1. On the File menu, click Print.
2. In the Print dialog box, specify the options you want.
3. Click OK.

**Specifying the Print Order**

Print order is established by a section break (a white line) between the pages of the report. To specify the print order, click in the blank space between the pages. For example, to print the pages of a report vertically instead of horizontally, click in the blank space between the vertical pages.

**Selecting the Page Orientation**

Page orientation specifies whether the report should print with its top along the short edge of the paper (portrait) or along the long edge of the paper (landscape).

To select the page orientation:

2. Click Portrait or Landscape.
3. Click OK.
Previewing a Report

You can view a report as it will appear on the printed page before submitting it to the printer.

To preview a report:
1. On the File menu, click Print Preview. The print preview window appears.
2. Use the buttons at the top of the window to zoom in and out, show two pages at a time, and/or scroll through the report.
3. If the report appears as you would like it to appear in print, you can submit it to the printer by clicking Print. Otherwise, click Close to close the print preview window and return to the report.

💡 Instead of using print preview, when a report consists of a small number of pages, you can quickly see them using the zoom in/zoom out feature. On the View menu, click Zoom and choose a low magnification. This feature also lets you see empty pages in the report.

Printing to a File

You can print your report to a file instead of directly to a printer.

To print to a file:
1. On the File menu, click Print.
2. In the Print dialog box, select the Print to File check box, and then click OK.
3. In the Print to File dialog box, specify a file name and location, and then click Save.

Exporting Reports

Exporting lets you extend the usefulness of your reports by letting you export your report to different formats so that the data in your report can be used in other applications. You can export reports in the following formats:

Acrobat (.pdf)—Lets you view and print reports using Adobe Reader.
HTML, Complete—Lets you view reports using a Web browser.
HTML, Single File—Lets you view a simplified version of the report. This format is well suited for viewing on a handheld device, or as an e-mail attachment.
**Text (.csv)**—Reports exported in Comma-Separated Values (CSV) format can be imported easily into other applications.

**Excel (.xls)**—Lets you view and print reports using Microsoft Excel.

<table>
<thead>
<tr>
<th>This type of export</th>
<th>Creates these files</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acrobat</td>
<td>.pdf</td>
</tr>
<tr>
<td>HTML, Complete</td>
<td>.htm, .css, .jpg, .gif, .cfg, .jar</td>
</tr>
<tr>
<td>HTML, Single File</td>
<td>.htm</td>
</tr>
<tr>
<td>Text</td>
<td>.csv</td>
</tr>
<tr>
<td>Excel</td>
<td>.xls</td>
</tr>
</tbody>
</table>

**To export a report:**

1. On the **File** menu, click **Export**, and then click an option from the submenu:
   - Acrobat (.pdf)
   - HTML, Complete
   - HTML, Single file
   - Text (.csv)
   - Excel (.xls)

   ![Tip] If you use exported reports in a network or Internet environment, do not use spaces or special characters (such as &, <, >, “,” etc.) in file names. This avoids problems that can occur with different naming conventions.

2. In the **Save As** dialog box, specify the name and location for the report. If you are saving the report in HTML format, you must save it in a folder separate from other HTML reports.

3. Click **Save**.

   ![Note] If you move an exported report to a new location, make sure you copy all of the files.
Acrobat (PDF) Format

Before exporting a report to .pdf format, make sure the columns in your report provide ample space for their contents. If the content of a column is too close to the edge of the column, the content may not appear in the .pdf.

Adobe supports certain fonts for Acrobat. Using these fonts in reports can ensure more consistent formatting when you export them. For further information, see the user documentation for Acrobat.

In Acrobat, you may achieve a more accurate page layout when you print reports if you turn off the default Fit to Page setting in the Print dialog box. You can also set up BI Query Reports to automatically publish a .pdf every time you publish a report with a data model from within BI Query.

To automatically publish a .pdf every time a report is published:

1. On the Start menu, click Run.
2. In the Run dialog box, type regedit, and then click OK.
3. In the Registry Editor, go to:
   HKEY_LOCAL_MACHINE\SOFTWARE\Hummingbird\BI/Query Reports
4. Double-click PublishPDFonOLE and set the value to T (for True). By default, the value is set to F (for False), in which case only those reports that were last published to .pdf will be published to .pdf in future.

HTML Complete Format

When you open an HTML Complete report in a browser, you open its report_name.htm file first. This opens the first page of the report along with a toolbar that you can use to navigate through the report.

HTML Single File Format

The HTML Single File format is designed for viewing on a handheld device, or as an e-mail attachment. For this reason, this format uses an earlier version of HTML (3.2) than the HTML Complete export format. In addition, when you export a report in HTML Single File format, BI Query Reports:

- removes any graphics from the exported file
- replaces page breaks in the exported file with empty rows
**Text (CSV) Format**

Also called comma-separated values format, you can use text format to import reports into spreadsheet applications, such as Microsoft Excel, and analyze them offline. If Excel is installed on your computer, opening the report automatically places it into an Excel worksheet. You can then perform advanced calculations and other manipulations on the data.

**Microsoft Excel**

You can also export your reports to Microsoft Excel format. When you export to Excel format, the default file name is `report_name.xls`.

For table and crosstab presentations, most formatting (data formats, font, size, and so forth) is preserved. For chart presentations, only the data is exported. Each presentation in a report becomes a separate spreadsheet within the exported file.

**Viewing an Exported HTML Report**

To view an HTML report, open the report’s `report_name.htm` file.

To view an exported report:

- Double-click the `report_name.htm` file. The file appears in your system’s default Web browser.

Printing exported reports via your Web browser can cause reports to be printed incorrectly. We recommend that you export your reports to Acrobat (`.pdf`) if you want to print them.

**Copying Presentations to Other Applications**

You can export reports by copying and pasting tables and crosstabs from BI Query Reports into other applications and then you can perform additional tasks on them. For example, you can paste a table into Microsoft Excel, then apply advanced statistical calculations to the data. You can also copy and paste charts, but they are copied/pasted as graphics or pictures, not OLE-objects, and therefore cannot be manipulated.
To copy a presentation to another application:

1. In BI Query Reports, select the presentation. To select a table, click outside of it, then drag over a portion of its border. To select a crosstab, click inside it.
2. On the Edit menu, click Copy.
3. Open another application.
4. On the Edit menu, click Paste.

Distributing Reports

You can distribute reports using e-mail, the corporate database, or the BI Server repository. You can distribute new and revised reports to other users running BI Query Reports as follows:

- If you are working in a BI Server environment and you have the appropriate permissions, you can publish reports to the repository. This lets users retrieve reports using BI Query Reports or their Web browser.
- You can distribute them using the scheduler.
- You can distribute them using e-mail.

Before distributing a report across your organization, make sure that the users who receive it use the same printer driver (preferably a PostScript printer driver) that you used to create the report. A printer driver determines the amount of printable area on a sheet of paper, the available fonts, and the amount of space each font uses.

You can make sure that reports print the same for everyone by designing them using a PostScript printer driver that corresponds to the printer to which reports are printed. Make sure that everyone who will be printing the reports uses the same driver. If anyone uses a different printer driver or printer, test the reports on their printers to ensure that they still print correctly. If a report does not print correctly, adjust the layout to accommodate the different printers or printer drivers.
Sending Reports Via E-mail

If you have an e-mail application on your computer, you can easily distribute reports as attachments with your mail messages. You can use any mail application that supports Microsoft Messaging API (MAPI), such as Microsoft Exchange or Microsoft Internet Mail, to send e-mail directly from BI Query Reports.

To distribute a report using e-mail from BI Query Reports:

1. On the File menu, click Send. If a report is open, BI Query Reports automatically attaches the file to your message.
2. If you have not saved the report, do so at the prompt.
3. When the mail client opens, specify the subject and recipient(s).
4. Send the message.

Using the Database

Sites that use the database as the means of distributing revisions to BI Query data models can also use it to distribute reports. Administrators need to save reports in a Reports subfolder in the folder where the data model is stored. When users load the data model from the database, the reports are loaded too. For more information, see the BI Query Data Models User’s Guide.
Creating Interactive Reports

Interactive reports let you change the data they contain without having to recreate the queries and generate new reports.

- “About Interactive Reports” on page 85
- “Working with Hotspots” on page 87
- “Hotspots in Interactive Reports” on page 91

About Interactive Reports

Interactive reports let you change the data they contain without having to recreate the queries and generate new reports each time you want to examine the data from a different perspective. These reports are interactive because you click a hotspot to specify new criteria for the data, then refresh the report to obtain that data.

For example, an interactive report that shows sales data for different sales regions can include a hotspot that lets users specify the sales regions they want represented in a report. Using the hotspot, sales managers can either focus on a specific region to examine whether it is meeting its projections, or compare sales in one region with those in the other regions to determine which regions are the most productive.
If your corporate reporting environment includes BI Server, you can also use interactive reports on the Web. If you are using BI Web, see the Help for more information.

Benefits of Interactive Reports
Interactive reports provide the flexibility administrators and users need by letting them:
- change data directly in a report
- focus a report on the information that interests them
- compare data from different perspectives
- serve a wide audience using one report

Creating Interactive Reports
You can make existing reports interactive, or you can create interactive reports from scratch by adding hotspots and using them as titles, labels, or column headings. A hotspot is a button that is linked to a qualification in the associated query; clicking it lets users change the values on which the report is based.

When you create an interactive report, you provide data in the presentation type (table, chart, or crosstab) that you want. You also add one or more hotspots that let you requalify the report and obtain new data. You can create hotspots anywhere in a report.

A report whose associated query contains a prompt also lets you qualify the report. However, it does not provide a visual cue, like a hotspot, to indicate that you can requalify the report. Also, while you can choose to requalify a report using a hotspot, a report with a prompt always prompts you to qualify the data in your report when you refresh it.

About Hotspots
To make a report interactive, you add hotspots to it. Before adding hotspots to a report:
- In the query, qualify the attribute that you want the user to change using the hotspot.
- Ensure that you select the correct data source (.hc or .hcr) in the Data Source page of the Hotspot Wizard.
Working with Hotspots

To use a hotspot, click it. The options you are presented with depend on the qualification associated with the hotspot. Either a list of values appears, or the **Choose Range** dialog box appears.

A hotspot can change the data for one attribute. To requalify on more than one attribute, add more than one hotspot to the report.

Gathering the Data

💡 For information on using BI Query, see the *BI Query Queries User’s Guide*.

The data in an interactive report starts with a query to the corporate database using BI Query. The query must include the qualification on which the hotspot will be based. For example, to create a hotspot that lets you change the sales regions, you need to qualify the Sales Region attribute in the query. It does not matter what values are used to qualify in the query since you can specify values using the Hotspot Wizard in BI Query Reports.

While you can normally qualify attributes in a query with data values, prompts, or variables, the attribute for a hotspot must be qualified using data values. If you link a hotspot to a prompt or variable, it is removed from the query when you use the hotspot to requalify the report.

Working with Hotspots

Adding Hotspots

A hotspot is a button that is linked to a qualification in the query used to generate a report. Clicking it lets users change the value(s) on which the report is based. A hotspot can change the data for one attribute. To requalify on more attributes, add additional hotspots to the report.

To add a hotspot:

1. Do one of the following:
   - Submit a query that includes a qualification, then generate a report by adding a presentation.
   - Refresh a report by clicking the **Refresh** button on the toolbar or clicking **Refresh** on the **Data** menu.
2. In the report, on the **Insert** menu, click **Hotspot**. The mouse pointer changes to a plus sign (+).

3. Position the plus sign where you want the hotspot to appear and then draw the hotspot using a drag-and-drop operation. Make the hotspot large enough to display the text you want, but not so large that it dominates the page.

4. On the **Data Source** page of the Hotspot Wizard, select a data source, and then click **Next**.

   Only the data sources that contain at least one qualification are displayed. If the data source has an `.hcr` extension, its hotspot can requalify tables. If the data source has an `.hc` extension, its hotspot can requalify charts and crosstabs.

5. On the **Qualification** page, select an attribute, and then click **Next**.

6. On the **Values** page, the values specified in the query qualification are displayed under **Selected Values**.

   If a data values results file exists, **Get Data Values** retrieves values from it. **Load Database Values** retrieves values from the database even when a data values results file exists.

   To add additional values to the hotspot:
   
   a. Click **Get Data Values** or **Load Database Values**.
   
   b. Select the values that you want under **Available Values**, and then click **Add**. **Load Database Values** is available only after you click **Get Data Values**.

7. To prevent users from specifying values by typing them, clear **Allow Users To Type Values**. You may want to prevent users from typing values for security reasons.

8. Click **Finish**.

   If your reporting environment includes BI Server, and you have the appropriate permissions, publish the report to the repository and ensure that you grant refresh permissions to users who will view the report.

   For information about publishing reports, see the **BI Server Scheduling User’s Guide**.

Once you create a hotspot, you can move it, resize it, and change its label.
Selecting Hotspots

When you click a hotspot, it displays the values you can use to requalify the report, or it prompts you to specify a range of values. To do anything else with a hotspot, such as move it or modify it, you need to select the hotspot.

To select a hotspot:

Do one of the following:

- Hold down SHIFT, and then click a hotspot.
- Hold down CTRL, and then click a hotspot.
- Right-click a hotspot to select the hotspot and then display a shortcut menu.

Changing the Hotspot Label

When you first create a hotspot, it displays default text, which consists of the attribute, operator, and values on which the qualification is based. The text is created using special fields. You can change the display of the hotspot label by replacing the special fields with more descriptive text.

For example, if the data in a chart is based on country, the hotspot label might display:

Country IN Canada, Mexico, USA

You can make the label easier to understand by replacing the special fields for attribute (Country) and operator (IN) and leaving the special field for values to create the label:

Sales Report for Canada, Mexico, USA

To change the hotspot label:

1. Right-click a hotspot, and then click Edit Label.
2. In the Text Editor dialog box, change the label text as required.
   If necessary, specify a special field. These display the attribute, operator, and values used in a hotspot.
3. Specify the required formatting options.
4. If you want to see the effect of your changes in the report without closing the Text Editor dialog box, click Apply.
5. When you are satisfied with your changes, click OK.
Chapter 5: Creating Interactive Reports

Hotspot Special Fields

The three special hotspots fields—Hotspot Attribute, Hotspot Operator, and Hotspot Value—are available in the Fields list in the Text Editor dialog box. They are available only when you are editing a hotspot.

<table>
<thead>
<tr>
<th>To Display This</th>
<th>Add This</th>
</tr>
</thead>
<tbody>
<tr>
<td>The attribute users requalify when they click a hotspot.</td>
<td>Hotspot Attribute</td>
</tr>
<tr>
<td>The operator used in a hotspot.</td>
<td>Hotspot Operator</td>
</tr>
<tr>
<td>The values that appear in the requalified query.</td>
<td>Hotspot Values</td>
</tr>
</tbody>
</table>

Editing, Moving, and Resizing Hotspots

You can change the data source, qualification, or value(s) for a hotspot.

To edit a hotspot:

1. Right-click a hotspot and click Edit Hotspot.
2. In the Hotspot Wizard, make the required changes.
3. Click Finish.

You can move a hotspot anywhere in a report.

To move a hotspot:

1. Do one of the following:
   - Hold down SHIFT, then click the hotspot, and then drag it to the location you want.
   - Cut and paste by right-clicking the hotspot.

Like any design element in a report, hotspots should draw attention to, but not detract from, the content. You can resize a hotspot if it is not large enough to display its label, or if it is taking up too much room in the report.

To resize a hotspot:

1. Select the hotspot.
2. Drag one of its handles until it is the required size.
Hotspots in Interactive Reports

Interactive reports contain hotspots that provide you with the flexibility to change the data so that it reflects the information that interests you. For example, an interactive sales report might provide quarterly sales for all regions and the top ten sales representatives per region. Sales representatives can use this report to compare their performance with that of all sales representatives, or just with those in their region. They can also compare their sales with sales from other regional offices.

If the report lets users change which quarter they are looking at, then sales representatives can compare sales for their office from one quarter to the next. At the same time, if they are interested only in comparing regional sales between offices, they can concentrate on that information.

When you click a hotspot, what you are presented with depends on the qualification associated with the hotspot. You can either choose a value from a list, or specify a range of values. For example, if you used a qualification that contained the BETWEEN or NOTBETWEEN operators, you need to specify a range.

After you use a hotspot, its appearance changes, and a watermark that displays ‘Report Needs Refresh’ appears in the report.

Using Interactive Reports in BI Query Reports

The following describes how to use interactive reports in BI Query Reports. If you are using BI Web, see the BI Web Help or the BI Web User’s Guide.

To use an interactive report in BI Query Reports:

1. Click a hotspot.
2. Do one of the following:
   • If a list appears, select a value.
   • To see a list of additional values, or to select more than one value, click More.
   • If the Choose Range dialog box appears, specify the start and end values in the Between and And text boxes, and then click OK.
3. To refresh the report, on the Data menu, click Refresh, or click the Refresh button on the toolbar.

After you have used a hotspot, its appearance changes. A watermark also appears that says “Report Needs Refresh”.
If a crosstab or chart does not show all the data values used to requalify:
1. On the Tools menu, click Preferences.
2. In the Preferences dialog box, click the General tab.
3. In the When Refreshing Crosstab Or Chart Presentations In This Report area, select Show All items.
4. Click OK.
5. Refresh the report.
Chapter 6

Working with Tables

Tables display detailed data in columns. You can format the bands, columns, and entire tables to best suit the needs of your presentation.

- “About Tables” on page 93
- “Working with Bands” on page 96
- “Working with Columns” on page 101
- “Working with Data” on page 109
- “Formatting Tables” on page 115

About Tables

Tables provide a quick and easy method of presenting data. They display detailed data in columns, with headings across the top. Tables provide users with an almost unlimited framework for presenting data—including form letters, invoices, purchase orders, catalogs, and so on.

You can improve the presentation of tables by organizing data and formatting bands and columns. For example, you can stack data, show or hide bands, add charts to bands, and resize and rearrange columns.
Graphics, text labels, and OLE objects also enhance the appearance of tables and provide additional information. Report styles let you quickly create fully formatted tables, including subtotals and grand totals, that are ready for presentation.

**Understanding Tables**

Tables are made up of columns and bands of information. They are easy to work with because all the elements in a table—title, data, and column headings—are independent of each other. You can move, copy, and resize them. You can group the data and add calculations to the groups, and you can add page breaks based on those groups. In addition, you can stack columns, suppress duplicates, and add data from other tables. When you create large tables, BI Query Reports adds pages vertically to the report to accommodate all the data.

The following diagram identifies some of the elements of a typical table:
About Bands

A table is made up of columns and bands. There are five default bands.

**Default Bands**

**Report header band**—Information that appears once at the top of the table (such as a title).

**Page header band**—Information that appears at the top of each page (such as column headings).

**Detail band**—The data in each row of the query results. You can add calculations, graphics, text, and OLE objects, and you can apply exceptions to them.

**Page footer band**—Information that appears at the bottom of each page (such as page numbering and date).

**Report footer band**—Information that appears once at the bottom of the table. The default is the **End of Report** label. This band has a **Keep With Previous** option, which is selected by default. When the **Keep With Previous** option is selected, the report footer band ignores any manual page breaks. This reduces the likelihood that the report footer band will be orphaned on the final page of the report.

**Other Bands**

You can add additional bands to a table by grouping the data in the table. These bands are called:

**Group header band**—Information that appears above each group of data. Header bands are created automatically when data is grouped.

**Group footer band**—Information that appears below each group of data. Footer bands are created automatically when data is grouped. You can add calculations to the footer bands for each group.

The group header and footer bands may be hidden by default depending on the style you have applied to the report.

About Columns

A table is made up of columns and bands. A column is an object that is separate from the data it contains. It is a vertical area in a table that can contain data items, calculations, and report objects (for example, text objects and drawing objects), but it can also be completely empty. When you first insert a column, it remains empty until you populate it with data items or report objects.
You can select all objects in a column by clicking the column heading in the Column Control bar. Once the objects are selected, you can cut, copy, paste, insert, delete, anchor, move, format, and merge columns.

### Working with Bands

To perform any operation in a band, you need to select it first.

**To select a band:**
- Click inside the band, at the left most edge of the table. Make sure you click between the data items that appear in the band.

![It is easier to select bands that stack data items than it is to select bands that display data items side-by-side.](image)

**To add an item to a band:**
- Double-click the band at the outermost edge of the table. If you double-click an item in a column instead of the band, the **Properties** dialog box appears.

### Determining How a Band was Selected

A line with a handle distinguishes how a band has been selected. If the handle is on top of the line, it has been clicked once; if the handle is on the bottom, it has been double-clicked.

<table>
<thead>
<tr>
<th>A band that is clicked once displays a handle above a line.</th>
<th>A band that is double-clicked displays a handle below a line.</th>
</tr>
</thead>
</table>

### Formatting Bands

For each band, you can specify the characteristics of the font, fill, and the outline. You can display the band (for example, the company logo) on multiple pages of a report or you can apply an exception to the band.

💡 Format bands differently so you can tell them apart during report development.
To format a band:
1. Click a band to select it.
2. On the Format menu, click Properties.
3. In the Properties dialog box, specify the required options.
4. Click OK.

Controlling the Display of Bands

When you generate a report, most of the associated bands (report header, page header, detail band, and so on) are displayed by default. Group header bands are displayed only if the Stacked style is applied to a table, and group footer bands are displayed only if a style that includes subtotals has been applied to the table.

💡 For more information, see “Creating Summary Reports (Suppressing Details)” on page 97.

When you have a long report containing subtotals and grand totals, you may not always want to see all the details. A summary of totals may suffice. You can hide the details by hiding the detail band.

Similarly, if you have grouped data in a report, you can display the group header and add a color, pattern, heading, or graphic to it to make each group stand out.

Creating Summary Reports (Suppressing Details)

When you generate a report, most of the associated bands (report header, page header, detail band, and so on) are displayed by default. You can change how much detail you show in your report by hiding or showing bands.

For example, when you have a long report containing subtotals and grand totals, you may not always want to see all the details. A summary of totals may suffice. You can hide the detail by hiding the detail band.

To hide the detail bands:
1. Click anywhere in a table.
2. On the Format menu, click Table and then click Show/Hide Bands.
3. In the Show/Hide Bands dialog box, click Detail.
4. Click Hide.
5. Click OK.
Showing or Hiding Bands

You can change how much detail you show in your report by hiding or showing bands.

To show or hide a band:
1. Click anywhere in a table.
2. On the Format menu, click Table and then click Show/Hide Bands.
3. In the Show/Hide Bands dialog box, click a band.

   The header band for grouped data is hidden by default.
4. Do one of the following:
   • To display a band, click Show.
   • To hide a band, click Hide.
5. Click OK.

When you hide a band, everything within it is hidden as well. If there is a page break associated with a band, and you hide that band, the page break no longer applies. Also, if you have selected the Reset Page Number option for the band, the page numbering of your report may change.

Adding Items to a Band

When you add text labels, graphics, and clipart to tables, you add them to bands. For example, you can add a text label for a subtotal, place a graphic in a group header band, and add a logo to the page header band.

When you add an item to a band, the item appears in every band of that type. For example, an item that is added to the page header band repeats in all page header bands in the table.

To add an item to a band:
1. Double-click a band. If you click the band only once, the item will be overlaid on the report and will not be repeated in each band.
2. Do one of the following:
   • Using a drawing object, click and drag in the band.
   • Draw the object in the report, then drag it into the band.
Adding Charts to Bands

When you add a chart to a detail band, a group footer band, or a group header band, the chart changes to reflect the data for that band. This lets you add a visual representation to back up the hard data displayed in the bands. For example, if you have a table that shows cost, revenue, and profit by quarter, you can add a chart to the group footer band to show the revenue, cost, and profit for each quarter.

You can also:

- Hide a column of data in a chart and still have it appear in the table. Alternatively, you can remove a column from both the chart and the table.
- Format the labels along the x-axis.

**To add a chart to a band:**

1. Add a chart to a report using the table view:
   a. On the **Data Source** page of the **Presentation Designer** dialog box, double-click the data source used to create the table.
   b. Select the view associated with the table. The icon for a view displays a plus (+) sign.

   For more information, see “**Adding Presentations by Using Views**” on page 68.

2. Drag the chart into a band. To add the chart to a group header band, you may have to first display the band. On the **Format** menu, click **Table** and then click **Show/Hide Bands**.

3. To have the chart reflect all of the data in the table:
   a. Click the chart.
   b. On the **Format** menu, click **Properties**.
   c. In the **Properties** dialog box, click the **Options** tab, then clear **Show Data In Band**.

**Changing the Y-Axis Scale**

When you add charts to bands, their y-axis scales are proportional to the data in each band. You can specify the scales to be the same in each chart using the Chart Editor.
Applying Variable Data Fields and Bands to Tables

You can set the data fields and detail bands in tables to automatically adjust to accommodate the data in them. This feature lets you create tables with a lot of data and have the data fit the individual bands without having to resize the bands. It also ensures that when you refresh a report with data that is longer than the original, all the new data is visible. This feature can be useful when creating special reports such as purchase orders and invoices.

When you apply this feature to a report, the data fields expand or shrink to accommodate the new data. Column boundaries are maintained; where necessary, the data in the data field wraps to the next line, and the data field expands vertically. Similarly, detail bands in the table expand or shrink to accommodate the largest field they contain. If you resize the table, the data fields and detail bands adjust themselves accordingly.

You can apply this feature only to data fields in detail bands. You cannot apply it to data fields that occur in header and footer bands (for example, in stacked reports).

If a calculation does not wrap as expected, check its settings. On the Font page of the Properties dialog box, make sure that the Wrap Text option is selected.

This feature also applies to calculations and exceptions you add to a table. However, data fields do not resize for hidden bands. If you apply an exception to a table that hides the data fields, the bands do not resize.

Only textual data will wrap to the next line, not numbers or dates. Applying this feature turns on the Wrap Text setting. This feature is available for more than one table in a report. It is also available for styles, for those supplied with BI Query Reports and those that you create.

Once you apply variable fields and bands to a table, you cannot drop or paste items into a detail band and you cannot drag columns to change their order (although you can do this using the Column Control bar). It is best to apply this feature after you have formatted the table and resized it to suit the report.

It may take some time to apply this feature to tables that contain a lot of data.

To apply variable data fields and bands to a table:

1. Click anywhere in a table.
2. On the Format menu, click Table and then click Show Variable Fields & Bands.
3. If necessary, resize the table.
Problems with Text Wrap in Calculations

If you create a calculation that you expect to wrap and it does not, check its settings.

To check text wrap settings:
1. On the Format menu, click Properties.
2. In the Properties dialog box, click the Font tab.
3. On the Font page, make sure that the Wrap Text option is selected.

Working with Columns

About the Column Control Bar

To view the column controls at the top of the report window, click a table.

Using the Column Control bar, you can:
- select columns
- format columns
- cut, copy, and paste columns
- insert columns
- delete columns
- change the spacing between columns
- merge columns
- anchor items in a column
- resize columns
- reorder columns

You can select all objects in a column by clicking the column heading in the Column Control bar. Right-clicking displays the Column Menu shortcut menu.

Using the Column Control Bar

Use the Column Control bar to select a column and perform operations on that column. Right-clicking a column in the Column Control bar displays the Column Menu shortcut menu for the selected column.
To turn on the Column Control bar:
The Column Control bar is turned on by default. If it is turned off, you can turn it on.

- On the View menu, click Column Control bar. A check mark appears beside the command to indicate that it is active.

To use the Column Control bar:
1. To apply changes to the data items in a column, right-click the column in the Column Control bar.
2. In the Column Menu shortcut menu, click a command.

To select a single column:
- Click the column in the Column Control bar.

To select multiple columns:
- Hold down CTRL, and then click the columns in the Column Control bar.

To select all columns:
- Hold down ALT, and then click a column in the Column Control bar.

Adding New Columns
When you first insert a column, it will be empty until you populate it with data items or report objects. New columns are added to the left of the selected column.

To add a new column:
1. In the Column Control bar, right-click a column.
2. On the Column Menu shortcut menu, click Insert. New columns are added to the left of the column you click.

Formatting Columns
For each column, you can specify the characteristics of the font, fill, and the outline. You can display the column on multiple pages of a report or to apply an exception to it.
To format a column:

1. In the Column Control bar:
   a. Click a column.
   b. On the Format menu, click Properties.
   Alternatively,
   a. Right-click a column.
   b. On the shortcut menu, click Properties.
2. In the Properties dialog box, specify the required options.
3. Click OK.

Managing Columns over Multiple Pages

Columns that do not fit on one page when you generate a report are divided over multiple pages. You are limited to 25 pages in which to display columns. Any additional columns are not displayed. If report pages are expanded, the new data will overlap the data that is already displayed.

To prevent the division of columns over multiple pages, consider:

- Fitting all columns on one page. For more information, see "Fitting Columns on One Page" on page 105.
- Changing the orientation of the report to landscape. For more information, see “Selecting the Page Orientation” on page 78.
- Stacking the data. For more information, see “About Stacked Columns” on page 110.
- Resizing columns. For more information, see “Resizing Columns” on page 106.
- Merging columns. For more information, see “Merging Columns” on page 104.
- Wrapping text in a column if you have turned text wrapping off. Double-click the text. In the Properties dialog box, click the Font tab, then select Wrap Text.
- Deleting columns.

💡 For more information about BI Query, see the BI Query User’s Guide.

- Modifying the query to return fewer columns.
- Modifying the results to hide columns. In a results window in BI Query, on the Results menu, click Reorder Columns.
Deleting Columns

When you delete a column, all the items in the column are deleted as well. If the column contains a data item, you can re-insert it into another column at any time.

To delete a column:
1. In the Column Control bar, right-click a column.
2. In the Column Menu shortcut menu, click Delete.

Changing the Spacing Between Columns

You can change the spacing between columns in a table. For example, you can increase column spacing if the columns in a table are too close together, making the report hard to read, or decrease column spacing to fit the table on one page. Spacing is in units of 0.01 of an inch. The smallest amount of space you are allowed between columns is 0.01 of an inch; the largest amount of space you are allowed is 0.10 of an inch.

To change the spacing between columns:
1. In the Column Control bar, right-click a column.
2. Click Spacing from the Column Menu shortcut menu.
3. In the Column Spacing dialog box, type a value in the Spacing box.
4. Click OK.

Merging Columns

You can merge adjacent columns into a single column in order to make more room in a report, or to have more flexibility in how you organize your data. When you merge columns, the data in both columns remains as separate items in the resulting column, and you can move and format the data in each column individually. For example, you can place a person’s last name indented under the first name and apply a different font to it to make it stand out.

To merge columns:
1. In the Column Control bar, right-click the column you want to merge.
2. On the Column Menu shortcut menu, click Merge. The column you click is merged with the column to its left.
Combining Data Items Using Labels

You can combine data items using a label (using special fields) or using a calculation.

💡 For more information, see “Combining Data Items Using Calculations” on page 243.

To combine data items using a label:

1. Double-click a band.
2. On the **Insert** menu, click **Label**. The mouse pointer changes to a plus sign (+).
3. Using a drag-and-drop operation, draw the box in the band where you want the data items to appear.
4. In the **Text Editor** dialog box, in the **Fields** list, click **Field**.
5. In the **Data Cell Selector** dialog box, click the blue columns indicator in the **Dimensions** area.
6. In the **Choose Member** dialog box, click a column.
7. In the **Data Cell Selector** dialog box, click **OK**.
8. To add a character (such as a comma and a space) between the data items, in the **Text Editor** dialog box, type the character after the tag for the first item.
9. To add the second data item, repeat steps 4–7.
10. In the **Text Editor** dialog box, click **OK**.

Fitting Columns on One Page

If all the columns in a table do not fit on one page, you can resubmit the query and regenerate the table using the **Fit On One Page** option.

To fit all columns on a page:

1. In BI Query, submit a query.
2. On the **Results** menu, click **Show As Report** and then click **BI Query Reports**.
3. On the **Presentation** page of the **Presentation Designer** dialog box, select **Table**, and then click **Next**.
4. On the **Style** page, click **Fit On One Page**, then finish creating the table.
Anchoring Items to a Column

When you anchor an item, you are locking it to a specific position in a column. By default, items are anchored to fit the column. This means that when you resize a column, the items in it will resize as well, ensuring that they are always the same size as the column. Alternatively, you can anchor items to the left or right of a column, or unanchor them so that they ignore column settings. Unanchored items are still restricted by column boundaries, but are not locked to a specific position in the column.

You can anchor any item inside a table to a column. Most often you anchor data items, but you can also anchor graphics and text to columns. You can also float items in a table so that they are not restricted by the column boundaries.

To anchor an item to a column:

1. Select the item(s) you want anchored:
   a. In the Column Control bar, right-click the column that contains the items you want anchored.
   b. On the Column Menu shortcut menu, click Anchor.
   Alternatively,
   a. Move the items to the column.
   b. On the Layout menu, click Anchor.
2. Click the option you want from the anchor submenu.

Resizing Columns

When you resize columns, the items in the columns resize as well, as long as they are anchored to fit the column. If the items are not anchored, or if they are anchored to the left or right of a column, they will not resize with the column.

When you resize a column, the items in the column may shrink or widen, but their height does not change. You have to change the height of items in a column separately. However, if you apply the variable bands option, then the height of items does change.

To ensure items in a column are anchored to fit the column:

1. Click the item.
2. On the Layout menu, click Anchor.
3. Make sure there is a check mark beside the **Fit To Column** option. If there is no check mark, select **Fit To Column**.

**To resize a column:**

1. In the Column Control bar, position the pointer over the right boundary of the column you want to resize.
2. Drag the boundary left to narrow the column or right to widen it.

**Resizing an Item in a Column**

When you resize a column, the items in the column may shrink or widen, but their height does not change. You have to change the height of items in a column separately. However, if you apply the variable bands option, then the height of items does change.

**To resize an item in a column:**

1. Click an item.
2. Click one of the item handles.
3. Drag the item(s) to the required size.

**Autosizing Items in a Column**

The Autosize command resizes all the items in a column to the size of the largest item in the column. If there is an extremely large item in the column, autosizing resizes the item to the maximum page width. Text that does not contain line breaks wraps onto the next line.

💡 Double-click the edge of a column to autosize it according to the contents of the column (the same way as you would in Excel).

**To autosize an item in a column:**

1. In the Column Control bar, right-click the column that contains the items you want to autosize.
2. In the Column Menu shortcut menu, click **Autosize**.
Reordering Columns

You can change the order of columns when you create reports using Presentation Designer. Once you have created reports, you can use a drag-and-drop operation or cut and paste columns using the Column Control bar.

To reorder columns:

1. Click a column in the Column Control bar.
2. Drag the column to the position you want. You cannot drag columns across pages.
To move columns across pages:
1. Click the column you want to move.
2. On the Edit menu, click Cut.
3. Click a column on the page on which you want to paste the copied column.
4. On Edit menu, click Paste.

Working with Data

Once you have added a table to a report, you can move or copy the data, stack it, and suppress duplicates.

Moving and Copying Items

All the elements in a table—title, data, column headings, text labels, graphics, clipart, and calculations—are items that you can move and copy. If you select a column, then copy and paste it, the data in the first row of the detail band is copied, not the entire column (unless you paste it into another column).

To move or copy items within a table or between tables:
- Drag the items into the bands you want.

To copy items:
- Hold down CTRL, and then drag the items.

To repeat an item at the top/bottom of each page:
- Move the item into the page header or footer.

To move or copy an item from one page to another:
1. First, increase the report size.
2. Increase the size of the table (by adding and removing table frames).
3. Drag the item onto the new page, then drop the item into the band you want.

Copying a Column Item

When you are working with a table, you may want to copy a data item into an existing or new column.
To copy a column item:

1. Select an item.
2. Hold down CTRL, and then drag the item to a new location.

About Stacked Columns

Instead of displaying columns horizontally across a page, stack one on top of another. Stacking is an alternative way of organizing information so it is easier to read. You can fit more information across a page and group related information together. For example, group sales data by region and quarter.

Stacking is useful for creating different types of tables. For example, when you are creating forms such as invoices and purchase orders, you can stack customer address information under a customer’s name so that it looks like a label on the form.

When you create a report, Presentation Designer offers a choice of:

- Stacked table styles—Stacks and left-aligns sorted data, placing remaining data in columns.
- Stacked indented table styles—Stacks and indents sorted data, placing remaining data in columns.

These styles stack sorted columns in the detail bands of a table. You can also stack any column anywhere in a table.

Stacking Data

When you create a report, Presentation Designer offers a choice of stacked report styles that left-align or indent sorted columns. These styles stack sorted columns in the detail bands of a report. However, you can stack any column anywhere in a table.

You may find it easier to stack data if you merge the columns in which they appear.

To display the band before you stack data:

If you want to stack columns in the group header and the band is not displayed, you need to display it as follows:

1. Click inside the table.
2. On the Format menu, click Table and then click Show/Hide Bands.
3. Click the header band and click **Show**.
4. Click **OK**.

**To stack data:**

1. Resize the band where you want to stack columns so it is large enough to accommodate them.
2. Click an item in a column, then drag it to where you want it stacked.
3. Repeat until you have stacked all the columns that you want to stack.

   ✏️ You should sort any data items you wish to stack.

**Suppressing Duplicate Data**

Tables may display all the data from a BI Query results set, even when the data contains duplicates. This repetition may be unnecessary or may detract from report readability. To avoid this, you can conceal, or suppress, duplicated data. Suppressing duplicates is particularly useful if a report includes grouped data because it highlights the categories into which the data has been grouped. Suppressing duplicates does not remove the data; it simply hides it.

You can conceal, or suppress, duplicated data in tables.

**To suppress duplicate data:**

1. Click the column you want.
2. On the **Format** menu, click **Table**, and then click **Group and Sort**. In the **Group and Sort** dialog box, drag the column in which you want to suppress duplicates into the **Group by** list, and then click **OK**.

   ✏️ **Suppress Duplicates** is available only if the column is grouped.

If you have suppressed duplicate data, you can display it again.

**To display suppressed data:**

1. Click any item in a column that displays duplicates.
2. On the **Format** menu, click **Table**, and then click **Suppress Duplicates**.
Adding Data

There may be times when you want to add data to a table. For example, you may want to re-insert data that you have deleted or you might want to replace the data in a table with data from another query. You can add data to tables to accommodate these situations. When the new query contains additional columns, you need to add them to the original data.

To add data:

1. Double-click a band. You may need to resize the band to make room for the data item.
2. On the Insert menu, click Data Item. The mouse pointer changes to a plus sign (+).
3. Hold down the mouse and drag a rectangle in the band.
4. In the Insert Data Item dialog box, click an item.
5. Click OK.

Adding New Query Data to a Table

When the new query contains additional columns, you need to add them to the original table.

💡 For more information, see “Editing Queries and Replacing Data” on page 70.

To add new data from the query to the table:

1. In BI Query, rebuild or reload the original query, add an attribute, then submit the query.
2. On the Results menu, click Shows As Report and then click BI Query Reports.
3. In the Presentation Designer dialog box, click Finish.
4. Click the original table.
5. On the Data menu, click Data Sources.
6. In the Data Sources dialog box, click the new data source, and then click Replace. This associates the original table with the new data source.
7. Do one of the following:
   - If the Map Data dialog box appears, match the data in the original table with the data in the new data source.
   - Click Finish to let BI Query Reports match the data for you.
8. Add a column for the new data.
9. Add the data item to the column. The items that appear in the Insert Data Item dialog box are the items in the new data sources.

### Grouping Data

Grouping the data in a column makes a table easier to read. You can use the header and footer bands automatically created for each group to add and display calculations (such as subtotals) for the groups. To further enhance the look of your report, and make it easier for users to locate information, you can apply special formatting (such as colors or shading) or add page breaks to the header and footer bands.

### Breaking Data into Groups

By default, BI Query Reports groups all columns that were sorted in BI Query, and displays the columns in the order in which they were sorted. You can change the grouping and sorting options when creating a table in Presentation Designer, or afterwards using the Group and Sort dialog box.

For each group within a column, BI Query Reports automatically creates a header band and a footer band. You can use these bands to apply special formatting (such as colors or patterns), page breaks, or to add calculations (such as subtotals). Although the bands are created automatically, you can specify which bands to show or hide.

#### To break a column into groups:

- Do one or more of the following:
  - In BI Query, when you build the query, apply the Sort condition to the attribute on which you want to break the data into groups in the report. In the attribute window, click the Sort box for the attribute.
  - In BI Query, if you have already submitted the query, sort the results set. In the results set, on the Results menu, click Filter and then click Sort.

💡 For more information, see “Adding Tables to a New Report” on page 56.

- In BI Query Reports, when you create the table presentation, on the Arrange Data page of the Presentation Designer dialog box, columns sorted in BI Query are automatically placed in the Group By box. Drag columns to or from the Group By box to change the grouping, if necessary.
Unlike the other grouping methods mentioned here, the Group and Sort dialog box does not automatically adjust the order in which the columns appear in the table.

- In BI Query Reports, for an existing table, on the Format menu, click Table, and then click Group and Sort. Ensure that the columns you want to break into groups are listed in the Group By box.

**Ungrouping Data**

Regardless of whether the data in a column was initially sorted in BI Query, or subsequently grouped in BI Query Reports, you can use the Group and Sort dialog box to ungroup the data in the column.

**To ungroup a column of data:**
1. Click anywhere in a table.
2. On the Format menu, click Table and then click Group and Sort.
3. In the Group and Sort dialog box, do one of the following:
   - To sort the column, drag the column from the Group By box to the Sort By box.
   - To neither group nor sort the column, drag the column from the Group By box to the Available Items box.

**Changing the Order of Grouped Columns**

Once a table has been created, the simplest way to change the group order in the table is by using the Group and Sort dialog box in BI Query Reports.

**To change the order of grouped columns:**
1. Click anywhere in a table.
2. On the Format menu, click Table and then click Group And Sort.
3. In the Group And Sort dialog box, under Group By, select and drag a group to change the grouping order.
   - Change whether or not a column is grouped by draggging it to or from the Group By box.
   - Specify the relative priority among column groupings by moving columns up or down within the Group By box.
4. Click OK.
Formatting Tables

You can format tables to improve their readability and to make them more attractive by doing any of the following:

- add color (fills, patterns, and beveling) and lines (color, style, and width) to make key information stand out
- format text and bands using styles
- set default formatting
- change titles and column headings

All presentations can be enhanced by:

- labels
- special fields
- rich text, which lets you add additional text to presentations
- graphics, which add interest and impact

Table Properties

You can format a table by adding color (fills, patterns, and beveling) and lines (color, style, and width) to make key information stand out.

To format table:

1. Select the table.

   The easiest way to select a table is to click outside it, then drag over a small portion of its border.

2. On the Format menu, click Properties.

3. In the Properties dialog box, specify the options you want.

4. Click OK.
Setting Default Formatting for Predefined Table Styles

You can customize your preferences so that tables you create using the predefined table styles in Presentation Designer contain the formatting you prefer. You can specify the numeric format and font properties of the items that appear in a band as well as the fill and line properties of the bands themselves. The formats you set using the Table page of the Preferences dialog box are applied to any predefined table style you select in the Presentation Designer dialog box.

If you want to use the data formatting specified in the query instead of the default data format, click Use data model formats on the Style page in the Presentation Designer.

To set default formatting:

1. On the Tools menu, click Preferences.
2. In the Preferences dialog box, click the Table tab.
3. On the Table page, click the Sample box for a band. For example, to set default properties for the report header, click the Sample box under Report Header.
   - Customize the fill color for the header, footer, and detail bands so that you can easily identify them.
4. In the Properties dialog box, specify the formatting options you want and then click OK.
5. In the Preferences dialog box, click OK.
6. To apply the default formats, add a new table using any of the predefined table styles.

Adding and Removing Page Breaks

By adding a page break to a band, you can have information start on a new page. For example, when you are creating customer invoices, you can add a page break to have each customer invoice start on a new page. Similarly, you can add a title page to a table by adding a page break to the report header band. For any band in which you add a page break, you can also have the page numbering begin at 1 again on the following page. To extend the invoice example, each customer’s invoice would start at page 1.

You can add or remove page breaks to improve the readability of your table.
To add a page break:

1. Click the band after which you want the page to break. For example, to break
   pages by customer, ensure that you have grouped the data by customer, then
   select the footer band for a customer.

2. On the **Format** menu, click **Table** and then click **Page Break**.

To remove a page break:

1. Select the band to which you have applied a page break.

2. On the **Format** menu, click **Table** and then click **Page Break**.

   When you hide a band to which you have applied a page break, the page
   break (and associated page numbering, if selected) no longer applies.

To reset page numbering following a page break:

1. Select the band to which you have applied a page break.

2. On the **Format** menu, click **Table** and then click **Reset Page Number**.

To revert to sequential page numbering:

1. Select the band for which you have reset page numbering.

2. On the **Format** menu, click **Table** and then click **Reset Page Number**.

## Adding or Removing Table Frames

When you reduce the number of columns in a table to fit the table on one page,
you end up with extra pages in your report. To remove the extra pages, you have to
remove the empty table frames, then resize the report. Similarly, if you want to
expand a table to include, for example, more columns, you need to add pages to
the report, then add the table frames.

You can also add table frames horizontally (the width) and vertically (the height)
in a report.

When refreshing a report, BI Query Reports automatically determines the
number of vertical frames based on the number of rows of data in the table, and
adds or removes table frames as necessary.
To add or remove table frames:

1. Click anywhere in the table.
   - If you are adding table frames, add pages to the report first.
2. On the Format menu, click Table and then click Size.
3. In the Width box of the Table Size dialog box, specify the width of the table (in frames). Lowering the number removes frames; increasing the number adds frames.
4. In the Height box of the Table Size dialog box, specify the height of the table (in frames). Lowering the number removes frames; increasing the number adds frames.
   - You cannot decrease the height of a table below the number of frames required to display all of the rows in the table. Also, when refreshing a report, BI Query Reports automatically removes empty frames from the table.
5. Click OK.

Changing Column Headings and Titles

You can format column headings and titles in a table. You can vary the look of each column heading by changing the font. You can change a title or heading to make it more understandable, or add a special field, such as a prompt that displays prompt values in titles.

To change a column heading or a title:

1. Double-click the text.
2. In the Text Editor dialog box, type the text you want into the text box.
3. Choose the formatting options you want.
4. If you want to see the effect of your changes in the report without closing the Text Editor dialog box, click Apply.
5. When you are satisfied with your changes, click OK.

Using Styles

Styles define the characteristics of a table, such as the font, size, color, and style of the title, column headings, and data. Styles can also define groups, include calculations, and suppress duplicates. In addition, styles can contain context-sensitive information, such as the prompt value(s) used in the associated query.
There are two types of table styles:

- predefined table styles provided with BI Query Reports that appear on the Styles page of the Presentation Designer dialog box
- user-defined styles that you can create

For more information, see “Using BI Query Reports Predefined Styles” on page 52.

**User-Defined Table Styles**

User-defined table styles reflect the formatting, grouping, and calculations of the tables on which they are based. They are most useful when you apply them to tables that contain similar data. If a table style groups data, for example, by retailer, and contains calculations such as sales by customer, the style works best if you apply it to other tables that contain data for retailers and their sales.

If the table you are using does not display the data in the most effective way, you can choose a different user-defined style. Be sure that the table style you choose is suited to the type of data you are presenting.

**Creating Table Styles**

Styles that you create are saved with the extension .tpf.

**To create a table style:**

1. Create a table.
2. Organize the data in the report and apply the formatting you want.
3. If necessary, add a context-sensitive label.
4. On the Format menu, click the Table tab.
5. On the Table page, click Style and then click Save.
6. In the Save As dialog box, specify the name of the file.
7. Click Save.

**Applying Table Styles**

You can apply a user-defined table style to an existing presentation. Be sure that the table style you choose is suited to the type of data you are presenting.
When you create a user-defined table style, you save the data formats along with the style. If you apply a user-defined table style to an existing table presentation, the data formats associated with the user-defined style are automatically applied, even if you had originally specified you wanted to use the data model formats when you created the presentation.

To apply a table style:

1. Click anywhere in a table.
2. On the Format menu, click the Table tab.
3. On the Table page, click Style and then click Apply.
4. In the Open dialog box, click a style with the extension .tpf and click Open.
5. If the Map Data dialog box appears, you have selected a style that does not automatically match all the data in your report. In this case, you need to match the data.

For more information, see “Mapping Unmatched Data” on page 72.

For the best results, apply table styles through the Presentation Designer. User-defined table styles do not appear on the Style page of the Presentation Designer. To find a style, click Browse.

Modifying Table Styles

To modify a table style, you must modify a table that contains the same data as the table that uses the style you want to modify.

To modify a style:

1. Open or create a table that contains the same data as the table with the style you want to modify, then apply the style to the table.
2. Make the changes you want.
3. On the Format menu, click the Table tab.
4. On the Table page, click Style and then click Save.
5. In the Save As dialog box, overwrite the original file.
Charts are visual representations of your data and are composed of dimensions and members. You can greatly customize the appearance of your charts by adding titles, adjusting grids and scales, and so forth.

- “About Charts” on page 122
- “Working with Dimensions” on page 124
- “Working with Members” on page 126
- “Formatting Charts” on page 131
- “Working with Titles and Labels” on page 158
- “Working with Grids and Scales” on page 161
- “Working with Gridlines” on page 164
- “Working with Chart Series” on page 168
- “Working with 3D Charts” on page 168
- “Working with Data Labels” on page 170
- “Working with Dual Axis Charts” on page 172
- “Hiding Labels” on page 173
- “Working with Additional Chart Features” on page 175
About Charts

Charts are a visual representation of your data. They make abstract numbers more understandable by providing visual cues to the values and relationships that the numbers express. Information presented in a chart is clearer and more memorable than text. Charts are particularly useful for presenting conclusions or for highlighting trends, patterns, and other relationships that are not apparent in tabular data. For example, if you need to create a report that displays the long-term sales of your company’s sales performance over time, a chart is the best format for presenting this information.

This chapter describes how to use charts to present data. Other features are described elsewhere in this guide, as follows:

<table>
<thead>
<tr>
<th>To Do This</th>
<th>See This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build charts</td>
<td>“Building Presentations with Presentation Designer” on page 56.</td>
</tr>
<tr>
<td>Change data formats</td>
<td>“Specifying Data Formats” on page 221.</td>
</tr>
<tr>
<td>Add graphics, text, and Object</td>
<td>“Enhancing Report Format” on page 195.</td>
</tr>
<tr>
<td>Linking and Embedding (OLE)</td>
<td></td>
</tr>
<tr>
<td>objects; apply formatting</td>
<td></td>
</tr>
<tr>
<td>Add hotspots</td>
<td>“About Interactive Reports” on page 85.</td>
</tr>
</tbody>
</table>

Understanding Charts

A chart is a graphical representation of data. Each element (one bar in a bar chart, one slice in a pie chart, one point in a line chart) represents the total value for a numeric item (a metric) as it relates to non-numeric items (dimensions and members). In the chart below, the first bar represents the total of the individual sales for the Central region in the first quarter. The second bar represents the total sales for the Central region in the second quarter, and so on.
The following illustration displays the elements of a sample chart:

![Chart Illustration](chart-image)

The following table describes the chart elements:

<table>
<thead>
<tr>
<th>This Element</th>
<th>Represents This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>The name of the chart.</td>
</tr>
<tr>
<td>Data area</td>
<td>A group of related values, such as all the values in a column or all the members in one dimension. Markers (bars, lines, dots, bubbles) usually have the same pattern, color, or symbol. When a chart (such as a pie) contains a single member, markers may vary in pattern or color.</td>
</tr>
<tr>
<td>Y-Axis (also known as the data or numeric axis)</td>
<td>The vertical axis. Typically used to display metrics such as quantities, revenue, and so on.</td>
</tr>
</tbody>
</table>
Rearranging Data in Charts

After creating the report, you can still change the arrangement of data in a chart. For example, you can hide one or more members from being displayed in your chart.

After you create the chart, you cannot add other dimensions from your data. If you need to add one or more dimensions, recreate the chart again using Presentation Designer.

To arrange chart data:

1. Click a chart.
2. On the Format menu, click Chart, and then click Rearrange Data.
3. In the Rearrange Data dialog box, organize the data.
4. Click Close.

Working with Dimensions

Dimensions are an overall category of data that corresponds to an item on the Arrange Data tab of the Presentation Designer. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.

To understand dimensions, think of time. Time is broken down into years, months, days, hours, minutes, and seconds. Without these subcategories, time has no meaning. Nonetheless, time provides a way of understanding all the subcategories at once, as one entity.

You can make charts easier to understand by arranging the dimensions. For more on arranging dimensions, see the following topics:

- “Pivoting Dimensions in a Chart” on page 125.
- “Grouping Dimensions in a Chart” on page 125.

<table>
<thead>
<tr>
<th>This Element</th>
<th>Represents This</th>
</tr>
</thead>
<tbody>
<tr>
<td>X-Axis (also known as the category axis)</td>
<td>The horizontal axis. Typically used to display member labels.</td>
</tr>
<tr>
<td>Legend</td>
<td>A color-coded visual representation used to identify the different categories in the chart.</td>
</tr>
</tbody>
</table>
• “Changing How Dimensions are Nested in a Chart” on page 126.

Pivoting Dimensions in a Chart

Pivoting lets you see different relationships in the data. You can change your view of the data in a chart by swapping, or ‘pivoting’, the dimensions on the x-axis of a chart with those in the legend. When you change the data orientation in a chart, use a legend to help you see how the data is being charted.

For more information, see “Adding Legends” on page 143.

To pivot a dimension in a chart:

1. Click a chart.
2. On the Format menu, click Chart, and then click Rearrange Data.
3. In the Rearrange Data dialog box, to swap dimensions, click Pivot.
   Alternatively, click a dimension in the X Axis (groups) or Legend (series), box then drag it to the Legend (series) or X Axis (groups) box respectively.
4. Click Close.

Ensure that there are at least two dimensions along the axis from which you are moving the dimension. A chart must have at least one dimension along each axis.

Grouping Dimensions in a Chart

To group data, the chart must have at least three dimensions: a metrics dimension, and two or more other dimensions. If the presentation has only two dimensions, you cannot group the data.

To group dimensions in a chart:

1. Click a chart.
2. On the Format menu, click Chart, and then click Rearrange Data.
3. In the Rearrange Data dialog box, drag the dimension you want to group in the Legend (series) box or in the X Axis (groups) box to the X Axis (groups) box or the Legend (series) box, respectively.
4. Click Close.
Changing How Dimensions are Nested in a Chart

When more than one dimension lies along an axis of a chart, the chart displays the members for the second dimension ‘inside’, or nested within, the members of the first dimension. Nested members normally represent subdivisions within another higher-level dimension. Nesting lets you change the emphasis, or relative importance, of nested dimensions within the chart.

For example, if you are analyzing product sales over the past four quarters, you might want to create a chart with products nested within quarters. If you notice an anomaly for a particular product, you can change the nesting to quarterly sales per product.

To change how dimensions in a chart are nested:

1. Click a chart.
2. On the Format menu, click Chart, and then click Rearrange Data.
3. In the Rearrange Data dialog box, click a dimension. You can change the nesting of the dimensions under X Axis (groups).
4. Drag the dimension up or down along the axis.
5. Click Close.

Working with Members

Members are a subcategory of a dimension. Member names appear along the axes or in the legend. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.

You can change the way charts appear by

- filtering data to focus on information of particular interest.
- reordering the data displayed along the axes of a chart.
- removing or hiding members to make charts more readable, eliminate distracting detail, and focus on only the information of interest.
Filtering Data

When you want to focus on information of particular interest, you can ‘filter’ the data. Filtering controls the focus in a chart by displaying the data related only to a specific member, thereby simplifying the view. You can filter one member at a time for each dimension. For example, when a chart contains sales information for products across sales regions, you may want to filter the data to see details only for a particular region.

To filter data in a chart:

1. Make sure the chart has one metrics dimension and at least two other dimensions.
2. Click the chart.
3. On the Format menu, click Chart, and then click Rearrange Data.
4. In Rearrange Data dialog box, drag a dimension to the Filter On box.
   
   📝 By default, when you drag a dimension to the Filter On box, BI Query selects the first member of the dimension. If necessary, you can filter on a different member.
5. Click Close.

When you create a chart, you can also filter the data by selecting Filter On on the Arrange Data tab of the Presentation Designer.

Filtering Using a Different Member

You can look at results for members one at a time by changing the data being filtered. When you drag a dimension into the filter, the data for the first member in the dimension is the focus of the chart. You can change the focus by displaying data for a different member. For example, if you placed the Region dimension in the filter, and the Eastern region is the first member in that dimension, the chart reflects the data for the Eastern region. However, you can easily change the focus of the chart by looking at the data for the Western region.

To filter using a different member:

1. Click the chart.
2. On the Format menu, click Chart, and then click Rearrange Data.
3. In Rearrange Data dialog box, under Filter On, click the members tool for a dimension.
4. In the Filter member dialog box, drag a member from the Available list to the Filter Member list.

5. Click Close.

6. In the Rearrange Data dialog box, click Close.

Filtering with the Filter Bar

The Filter bar is a toolbar that allows you to quickly apply a filter to your chart. After you create a filter, use the Filter bar to change the focus of the filter. For example, consider the Dashboard query Region report. If you filter on the Products.category dimension, you can use the Filter bar to display only the Accessories, Apparel, Bags, Carts, or Clubs data.

- If you do not see the Filter bar toolbar, click View, Toolbars, then Filter.
- You can add up to 18 dimensions to the Filter bar.

To filter with the Filter bar:

- Click the down arrow for the dimension you want to filter, and then click the member you want to view.

Adding Members

You can add a member to a chart. To show a member that was removed previously, you need to add the member again using the following procedure.
To add a member:
1. Click the chart.
2. On the **Format** menu, click **Chart**, and then click **Rearrange Data**.
3. In the **Rearrange Data** dialog box, click the members tool for a dimension.
4. In the **Include Members** dialog box, select in the **Members** list the member you want to add to the chart.
5. Click **Show**.
6. Click **Close**.
7. In the **Rearrange Data** dialog box, click **Close**.

**Reordering Members**

Occasionally, you may want to rearrange the order of members within a dimension to display related items together. For example, you may want to place new account executives in the first part of a chart so you can easily keep an eye on their progress, or you may want to arrange them by their performance. By changing the order of the included members in the **Include Members** dialog box, you can change the order in which the columns appear in your chart.

To reorder columns in a chart:
1. Click the chart.
2. On the **Format** menu, click **Chart**, and then click **Rearrange Data**.
3. In the **Rearrange Data** dialog box, click the members tool for a dimension.
4. In the **Include Members** dialog box, select in the **Members** list the member you want to move.
5. Click the **Up**, **Down**, **Top** or **Bottom** buttons to adjust the relative position of the selected member.

💡 To quickly sort all members, use the **Sort Ascending** or **Sort Descending** buttons.
6. Click **Close**.
7. In the **Rearrange Data** dialog box, click **Close**.
Removing or Hiding Members in Charts

Charts lose impact and become difficult to read when they contain too much data. To improve their readability, you can remove one or more members from the view. Alternatively, you can hide a member in a chart, which leaves the member in the view but hides it in the presentation. Removing or hiding a member is particularly useful if you are interested only in a subset of the data.

To remove a member from a chart:

1. Click a chart.
2. On the Format menu, click Chart, and then click Rearrange Data.
3. In the Rearrange Data dialog box, click the members tool for a dimension.
4. In the Include Members dialog box, select in the Members list the member you want to remove from the chart.
5. Click Delete.

You must leave at least one included member for each dimension.
6. Click Close.
7. In the Rearrange Data dialog box, click Close.

To hide a member in a chart:

1. Click a chart.
2. On the Format menu, click Chart, and then click Rearrange Data.
3. In the Rearrange Data dialog box, click a members tool.
4. In the Include Members dialog box, select in the Members list the member you want to hide.
5. Click Hide.
6. Click Close.

To show a removed or hidden member:

1. Click a chart.
2. On the Format menu, click Chart, and then click Rearrange Data.
3. In the Rearrange Data dialog box, click a members tool.
4. In the Include Members dialog box, select in the Members list the member you want to show.
5. Click **Show**.
6. Click **Close**.

**Formatting Charts**

Formatting charts enhances their appearance and can make them clearer for your readers.

<table>
<thead>
<tr>
<th>To make charts</th>
<th>You can</th>
</tr>
</thead>
<tbody>
<tr>
<td>easier to understand:</td>
<td>• add a legend</td>
</tr>
<tr>
<td></td>
<td>• change text labels</td>
</tr>
<tr>
<td></td>
<td>• label pie charts</td>
</tr>
<tr>
<td></td>
<td>• remove or hide a column in a chart</td>
</tr>
<tr>
<td>more attractive:</td>
<td>• turn grid lines off</td>
</tr>
<tr>
<td></td>
<td>• change perspective</td>
</tr>
<tr>
<td></td>
<td>• change the display</td>
</tr>
</tbody>
</table>

**Chart Properties**

You can display a chart on multiple pages of a report or apply an exception to a chart. For more information, see “Creating Exceptions” on page 248.

**To display a chart on multiple pages:**

1. Click a chart.
2. On the **Format** menu, click **Properties**.
3. On the **General** tab of the **Properties** dialog box, choose to repeat the chart on multiple pages of the report and/or apply an exception to the chart.
4. Click **OK**.

**Understanding Chart Types in Detail**

BI Query Reports lets you choose from the following main chart types:

<table>
<thead>
<tr>
<th>Column</th>
<th>Bar</th>
<th>Pie</th>
<th>3D</th>
</tr>
</thead>
</table>
Chapter 7: Working with Charts

Normally, you choose the chart type when you create the chart using the **Style** tab in the **Presentation Designer**. Note, however, that you can change the chart type at any time after you have created it using the **Gallery** tab in the **Chart Types** dialog box. For more information on choosing a different chart type after you have created a chart, see “Changing the Chart Type” on page 142.

Gallery chart types are the main types, such as line, bar, pie, and so forth, that are effective for most types of data. Note that the gallery chart types are the same as those you choose from when you first create a chart using **Presentation Designer**.

In addition, you can choose from several chart subtypes. These chart subtypes are described below.

### About Column Charts

A column chart displays the change in size or volume of an item over time, or the relative quantities of several different items at a particular time.

You can choose from several subtypes of column charts. The following table describes the available subtypes of column charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clustered</td>
<td>This chart type is a side-by-side group of bars. This is the standard type of two-dimensional column chart.</td>
</tr>
<tr>
<td>Absolute</td>
<td>This chart type has lines drawn on top and under each other to show the absolute relationships between data series.</td>
</tr>
<tr>
<td>Stacked</td>
<td>This chart type displays stacked groups of bars. Each stack is comprised of a sum of all series in this group. The axis is the total value of the cumulative points.</td>
</tr>
</tbody>
</table>
### About Bar Charts

A bar chart lets you compare items at a given point in time and allows you to display longer labels for bars.

You can also choose from several subtypes of bar charts. The following table describes the available subtypes of bar charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cluttered</td>
<td>This chart type is a side-by-side group of bars. This is the standard type of two-dimensional bar chart.</td>
</tr>
</tbody>
</table>
About Pie Charts

A pie chart displays the contribution of the parts to the whole.
You can choose from several subtypes of pie charts. The following table describes the available subtypes of pie charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pie</td>
<td>This chart type is the most widely used chart for displaying percentages of a total.</td>
</tr>
<tr>
<td>Ring Pie</td>
<td>This chart type is a ring variant of a pie chart. The total of all slices is placed in the center.</td>
</tr>
<tr>
<td>Proportional Pies</td>
<td>This chart type draws each pie proportional to the total that each pie represents.</td>
</tr>
<tr>
<td>Proportional Ring Pies</td>
<td>This chart type draws multiple pies proportional to the total that each pie represents with the total of all slices in the center.</td>
</tr>
</tbody>
</table>

**About 3D Charts**

A 3D chart displays trends in values across several dimensions and allows you to use special markers to display the charts.

You can choose from several subtypes of 3D charts. The following table describes the available subtypes of 3D charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rectangles</td>
<td>This chart type graphs the data points using 3D rectangles.</td>
</tr>
<tr>
<td>Pyramids</td>
<td>This chart type graphs the data points using 3D pyramids.</td>
</tr>
<tr>
<td>Columns</td>
<td>This chart type graphs the data points using 3D columns.</td>
</tr>
<tr>
<td>Floating Cubes</td>
<td>This chart type displays the data as 3D floating cubes.</td>
</tr>
</tbody>
</table>
About Area Charts

Area charts show the magnitude of change over time or the relationship of parts to a whole.

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floating Spheres</td>
<td>This chart type displays the data as 3D floating spheres.</td>
</tr>
<tr>
<td>Series Area</td>
<td>This chart type displays the series axis as a 3D area.</td>
</tr>
<tr>
<td>Series Ribbons</td>
<td>This chart type displays the series axis as 3D ribbons.</td>
</tr>
<tr>
<td>Series Bar</td>
<td>This chart type displays the series axis as 3D bars.</td>
</tr>
<tr>
<td>Group Area</td>
<td>This chart type displays the group axis as a 3D area.</td>
</tr>
<tr>
<td>Group Line</td>
<td>This chart type displays the group axis as 3D lines.</td>
</tr>
<tr>
<td>Group Bar</td>
<td>This chart type displays the group axis as 3D bars.</td>
</tr>
<tr>
<td>Surface</td>
<td>This chart type graphs all data points as a 3D surface.</td>
</tr>
<tr>
<td>Surface with Sides</td>
<td>This chart type graphs all data points as a 3D surface with solid sides.</td>
</tr>
<tr>
<td>Honeycomb Surface</td>
<td>This chart type graphs all data points as a 3D surface creating a &quot;honeycomb&quot; effect.</td>
</tr>
</tbody>
</table>
You can choose from several subtypes of area charts. The following table describes the available subtypes of area charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute</td>
<td>This chart type has area risers drawn on top of each other to show the absolute relationships between data series.</td>
</tr>
<tr>
<td>Stacked</td>
<td>This chart type has area risers stacked on top of each other. The axis is the cumulative total of all the groups.</td>
</tr>
<tr>
<td>Dual Axis Absolute</td>
<td>This chart type is a dual axis chart with area risers drawn on top of each other to show the absolute relationships between data series.</td>
</tr>
<tr>
<td>Dual Axis Stacked</td>
<td>This chart type is a dual axis chart with area risers stacked on top of each other. The axis is the cumulative total of all the groups.</td>
</tr>
<tr>
<td>Split Dual Axis Absolute</td>
<td>This chart type is a dual-Y chart with the two axes physically split into separate sections, so that you can see each axis independently.</td>
</tr>
<tr>
<td>Split Dual Axis Stacked</td>
<td>This chart type is a stacked dual-Y chart with the two axes physically split into separate sections, so that you can see each axis independently.</td>
</tr>
<tr>
<td>Percent</td>
<td>This chart type is an area version of a pie chart. Each group calculates the percent of the total required for each series. The axis is from zero to 100%.</td>
</tr>
</tbody>
</table>

**About Line Charts**

Line Charts show trends over time.
You can choose from several subtypes of line charts. The following table describes the available subtypes of line charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute</td>
<td>This chart type draws lines draw on top and under each other to show the absolute relationships between data series.</td>
</tr>
<tr>
<td>Stacked</td>
<td>This chart type has lines stacked on top of each other. The axis is the cumulative total of all the groups.</td>
</tr>
<tr>
<td>Dual Axis Absolute</td>
<td>This chart type is also called a Dual-Y line chart because any series can be assigned to either of the two axes.</td>
</tr>
<tr>
<td>Dual Axis Stacked</td>
<td>This chart type is also called a Stacked Dual-Y line chart because separate stacks will be created for the data on each of the two axes.</td>
</tr>
<tr>
<td>Split Dual Axis Absolute</td>
<td>This chart type is a split dual axis chart with the two axes physically split into separate sections so that each can be seen independently.</td>
</tr>
<tr>
<td>Split Dual Axis Stacked</td>
<td>This chart type is a split dual axis stacked chart with the two axes physically split into separate sections so that each can be seen independently.</td>
</tr>
<tr>
<td>Percent</td>
<td>This chart type is a line version of a Pie chart. Each group calculates the percent of the total required for each series. The axis ranges from zero to 100%.</td>
</tr>
</tbody>
</table>

**About Stock Charts**

Stock Charts allow you to track data that changes over time, such as mutual funds, stocks, currency rates, rainfall, and temperatures.
You can choose from several subtypes of stock charts. The following table describes the available subtypes of stock charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hi Lo</td>
<td>This chart type plots high and low values. This chart type is effective in charting closing stock prices.</td>
</tr>
<tr>
<td>Hi Lo Close</td>
<td>This chart displays the high and low values along with highlighting the closing value.</td>
</tr>
<tr>
<td>Hi Lo Open Close</td>
<td>This chart displays the high and low values along with highlighting the opening and closing values.</td>
</tr>
</tbody>
</table>

**About Radar Charts**

Radar Charts allow you to make relative comparisons between items or show trends over time.

You can choose from several subtypes of radar charts. The following table describes the available subtypes of radar charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Line</td>
<td>This chart type has multiple axes along which you can plot data. Radar charts are useful when you want to look at several different factors all related to one item.</td>
</tr>
<tr>
<td>Area</td>
<td>This chart type has stacked radar charts on multiple axes.</td>
</tr>
<tr>
<td>Polar</td>
<td>This chart type is a circular chart that you can use to plot two measures objects.</td>
</tr>
<tr>
<td>Dual Axis Polar</td>
<td>This chart type is a dual axis chart used to plot two measure objects.</td>
</tr>
</tbody>
</table>
Chapter 7: Working with Charts

About Scatter Charts

Scatter charts show uneven intervals, or clusters, of data and are useful for finding patterns or trends.

You can choose from several subtypes of scatter charts. The following table describes the available subtypes of scatter charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scatter</td>
<td>This chart type is a standard X-Y plot. It requires two values per marker, X and Y, in that order.</td>
</tr>
<tr>
<td>Dual Axis Scatter</td>
<td>This chart type is a Dual-Y scatter chart. It requires two values per marker, X and Y, in that order.</td>
</tr>
<tr>
<td>Bubble</td>
<td>This chart type requires three values per marker, X, Y, and Z, in that order. This chart type uses an X-Y plot where the marker size depends on Z.</td>
</tr>
</tbody>
</table>

About Special Charts

Special Charts are specialized charts such as funnel, Pareto, and gauge charts.
There are several subtypes of special charts. The following table describes the available subtypes of special charts:

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Histogram</td>
<td>This chart type is the standard histogram chart. This chart is a bar chart representing a frequency distribution; heights of the bars represent observed frequencies. There are no series or groups in this chart type.</td>
</tr>
<tr>
<td>Horizontal Histogram</td>
<td>This chart type is a bar chart representing a frequency distribution; lengths of the bars represent observed frequencies. There are no series or groups in this chart type.</td>
</tr>
<tr>
<td>Pareto</td>
<td>This chart type graphically summarizes and displays the relative importance of the differences between groups of data. This chart is a specialized version of a histogram that ranks the categories in the chart from most frequent to least frequent. This type of chart is best if you want to see a quantity listed from highest to lowest such as receivables by state.</td>
</tr>
<tr>
<td>Funnel</td>
<td>A funnel chart is a funnel-shaped pie chart. Like a pie chart, a funnel chart plots a single metrics axis. Funnel charts are sometimes used to show sales information such as the number of leads, the number of calls, and the number of actual sales.</td>
</tr>
<tr>
<td>Gauge</td>
<td>A gauge chart displays data in an analog gauge format similar to a car's speedometer.</td>
</tr>
</tbody>
</table>
Changing the Chart Type

With BI Query, you can choose from two main types of charts:

- Gallery chart types
- Custom chart types

Both Gallery and Custom chart types have chart subtypes that you can use.

You can change the chart type at any time. That is, if you create a chart and do not like the result, you do not have to recreate it using Presentation Designer.

### Gallery Chart Types

Gallery chart types are the main types, such as line, bar, pie, and so forth, that are effective for most types of data. Note that the gallery chart types are the same as those you choose from when you first create a chart using Presentation Designer.

**To use a chart type from the gallery:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Types**.
3. Click the **Gallery** tab, and then click a chart type in the list.
4. If necessary, change any of the layout/formatting options for the new chart.
5. Click **Apply**.
6. Click **OK**.

### Custom Chart Types

Custom chart types are for use in specific situations such as charts for large data sets, surveys, and so forth.

<table>
<thead>
<tr>
<th>Chart Subtype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gantt</td>
<td>A Gantt chart is a bar chart often used in project management. A Gantt chart provides a graphical illustration of a schedule helping you monitor specific tasks in a project. Specifically, the horizontal axis represents time and the vertical axis represents tasks in the project.</td>
</tr>
</tbody>
</table>
To use a custom chart type:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Types.
3. On the Custom tab, under Categories, click the category you want to use, and then click a chart type.
4. Click Apply.
5. Click OK.

Adding Legends
A legend makes a chart easier to read and helps the reader understand how the data is being charted. Two-dimensional charts do not display a legend when you create them, but you can add one.

- You cannot add a legend to 3D charts.
- A legend does not add information that is not already available.

To add a legend:
1. Click a chart.
2. On the Format menu, click Chart, and then click Show Legend.

Formatting Chart Legends
With BI Query Reports you can change the position of the legend markers, and you can also change the position and style of the legend box.

The following options are unavailable for 3D, area, and histogram charts.

To format a chart legend:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Options.
3. On the Look tab, select the Show Legend check box.
4. Do any of the following:
   - To change the position of the legend markers, in the Markers and Text list, click either Markers to Left of Text, Markers to Right of Text, Text Centered on Marker, Markers Above Text, or Markers Below Text.
• To change the position of the legend box, in the **Layout** list, click either **Legend on Right Side**, **Legend on Left Side**, or **Legend Below Chart**.

• To change the style of the legend box, in the **Box Style** list, click either **No Frame**, **Single Line Frame**, **Double Line Frame**, **Beveled Frame**, or **Reverse Beveled Frame**.

5. Click **Apply**.

6. Click **OK**.

💡 You can also format the text, background, and so forth of the legend. For more information, see “**Formatting Chart Elements**” on page 146.

### Automatically Arranging Chart Elements

With **Auto Arrange**, you can automatically rearrange multiple elements on your chart. You can automatically arrange such elements as the title, subtitle, text labels, legend, and so forth.

For example, if you have a chart that has overlapping text labels, you could manually resize and/or move the text labels. Instead of trying to resize or move the text, you can use **Auto Arrange** to correct the overlapping text. Consider the following example:

**Before auto-arrange**

**After auto-arrange**

#### To automatically arrange chart elements:

1. Double-click the chart.

2. On the **Format** menu, click **Chart**, and then click **Auto Arrange**.

💡 You can also manually arrange chart elements. To manually arrange an element, double-click the chart, then click the element you want to move, and then drag the element to the position you want.
Removing or Hiding a Column in a Chart

Charts lose impact and become difficult to read when they contain too much data. To improve their readability, you can remove one or more columns from the view. Alternatively, you can hide a column in a chart, which leaves the column in the view but hides it in the presentation. Removing or hiding a column is particularly useful if you only want to view a subset of the data.

**To remove a column in a chart:**

1. Click a chart.
2. On the Format menu, click Chart, and then click **Rearrange Data**.
3. In the **Rearrange Data** dialog box, click the members tool [ ] for a dimension.
4. In the **Include Members** dialog box, select in the **Members** list the column you want to remove from the chart.
5. Click **Delete**.
6. Click **Close**.
7. In the **Rearrange Data** dialog box, click **Close**.

**To hide a column in a chart:**

1. Click a chart.
2. On the Format menu, click Chart, and then click **Rearrange Data**.
3. In the **Rearrange Data** dialog box, click a members tool [ ].
4. In the **Include Members** dialog box, select in the **Members** list the column you want to hide.
5. Click **Hide**.
6. Click **Close**.

**To show a removed or hidden member:**

1. Click a chart.
2. On the Format menu, click Chart, and then click **Rearrange Data**.
3. In the **Rearrange Data** dialog box, click a members tool [ ].
4. In the **Include Members** dialog box, select in the **Members** list the member you want to show.
5. Click **Show**.
6. Click **Close**.
Formatting Chart Elements

A chart element is any other part of a chart other than lines or text. For example, the bars of a bar chart are chart elements. You can format the fill color, background, and so forth of the element.

To format an element of a chart:

1. Double-click the chart, and then click the element you want to format.
2. On the Format menu, click Chart, and then click Format.
3. On the Fill tab, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the color</td>
<td>Under Color, click a color.</td>
</tr>
<tr>
<td>Add a pattern to the element</td>
<td>Click Pattern, and then click a pattern.</td>
</tr>
<tr>
<td></td>
<td>If necessary, click the Foreground button to change the foreground color and/or click the Background button to change the background color.</td>
</tr>
<tr>
<td></td>
<td>Click OK.</td>
</tr>
<tr>
<td>Add a gradient to the element</td>
<td>Click Gradient, and then click a gradient.</td>
</tr>
<tr>
<td></td>
<td>Click OK.</td>
</tr>
</tbody>
</table>

You can also create your own gradients or customize existing gradients. For more information, see “Customizing Chart Gradients” on page 147.
1. Double-click the chart, and then click the gradient you want to customize.
2. On the Format menu, click Chart, and then click Format.
3. On the Fill tab, click Gradient, and then click the gradient you want to customize.
4. Click Advanced Options.
5. Make any changes to the gradient you want, and then click OK.
6. Click OK.

To do this

---

Add a texture to the element

Click Texture, click the tab for the type of texture you want, and then click a texture.

Click OK.

You can also customize existing textures. For more information, see “Customizing Chart Element Textures” on page 148.

Add a picture to the element

Click Picture, and then click a picture.

Click OK.

You can also customize existing pictures or add new pictures. For more information, see “Customizing Chart Element Pictures” on page 148.

---

4. Click OK.

Customizing Chart Gradients

A gradient is a steady change of color from a lighter area to a darker area. You can customize existing chart gradients by changing the appearance, color, and/or shape of the gradient.

To customize a gradient:

1. Double-click the chart, and then click the gradient you want to customize.
2. On the Format menu, click Chart, and then click Format.
3. On the Fill tab, click Gradient, and then click the gradient you want to customize.
4. Click Advanced Options.
5. Make any changes to the gradient you want, and then click OK.
6. Click OK.
7. Do one of the following:
   • In the Save As box, type a new name for the gradient, and then click OK.
   • In the Save As dialog box, click OK, and then click Yes to overwrite the previous gradient.

Customizing Chart Element Textures

You can customize existing chart element textures by changing the orientation and/or type of the texture.

To customize a texture:
1. Double-click the chart, and then click the texture you want to customize.
2. On the Format menu, click Chart, and then click Format.
3. On the Fill tab, click Texture.
4. Click the tab with the texture you want to change, and then click the texture.
5. Click Advanced Options.
6. Make any changes to the texture you want, and then click OK.

Customizing Chart Element Pictures

You can customize the appearance of pictures on elements.

To customize a picture:
1. Double-click the chart, and then click the picture you want to customize.
2. On the Format menu, click Chart, and then click Format.
3. On the Fill tab, click Picture.
4. Click Advanced Options.
5. Click Flip Vertical, Flip Horizontal, or Flip Both.
6. Click OK.

Adding Your Own Pictures to the Picture Gallery

You can add your own personal pictures to the picture gallery.
To add a picture to the picture gallery:
1. Double-click the chart, and then click a picture.
2. On the Format menu, click Chart, and then click Format.
3. On the Fill tab, click Picture, and then click Advanced Options.
4. Under Picture File Name, click Browse.
5. Locate the picture file, click it, and then click Open.
6. Click OK.

Formatting Lines
You can format the color, style, and/or thickness of the lines in your chart.

To format a line:
1. Double-click the chart, and then click the line you want to format.
2. On the Format menu, click Chart, and then click Format.
3. On the Line tab, do any of the following:
   • Under Color, click the line color you want.
   • In the Style list, click the line style you want.
   • In the Thickness list, click the line thickness you want.
4. Click OK.

Formatting Text
You can format the text on your chart to change the font, size, style, and so forth.

To format text:
1. Double-click the chart, and then click the text you want to format.
2. On the Format menu, click Chart, and then click Format.
3. Do any of the following:
   • Under Color, click the color you want.
   • In the Font list, click the font you want.
   • In the Size list, click the size of the font you want.
   • In the Box list, click the type of outline you want to appear around the text.
   • In the Rotation list, click the text rotation you want.
4. Click **Apply**.
5. Click **OK**.

### Formatting Bar Charts

With bar charts, you can change the overlap, gap width, and shape of the risers. In addition, you can add depth to your bar chart.

**To format a bar chart:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Options**.
3. On the **General** tab, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change how much risers within each</td>
<td>Move the <strong>Overlap</strong> slider to the left to</td>
</tr>
<tr>
<td>category overlap each other</td>
<td>increase how much the risers overlap, or</td>
</tr>
<tr>
<td></td>
<td>move the slider to the right to decrease the</td>
</tr>
<tr>
<td></td>
<td>amount of overlap.</td>
</tr>
<tr>
<td><img src="https://example.com" alt="Note" /> This</td>
<td>At <strong>-100</strong>, the bars within each group</td>
</tr>
<tr>
<td>option is only available with</td>
<td>will overlap each other. At <strong>+100</strong>, the</td>
</tr>
<tr>
<td>clustered bar charts.</td>
<td>bars will be as far apart as possible</td>
</tr>
<tr>
<td></td>
<td>without overlapping the next category.</td>
</tr>
</tbody>
</table>

| Change the gap width between each group | Move the **Gap Width** slider to the left to |
| of bar risers in each category         | decrease the gap width between each group of |
|                                        | bars, or move the slider to the right to    |
|                                        | increase the distance between each group of |
|                                        | bars.                                       |
| ![Note](https://example.com) This      | In the **Riser Shape** list, click either    |
| option is only available if you clear  | **Rectangle**, **Beveled Box**, or **Reverse** |
| the **Use Depth** check box.           | **Beveled Box**.                            |

This option is only available with clustered bar charts.
### Formatting Pie Charts

With pie charts, you can tilt, rotate, explode, and/or change the depth of the pie(s).

**To format a pie chart:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Options**.

---

<table>
<thead>
<tr>
<th><strong>To</strong></th>
<th><strong>Do this</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Format the error bar</td>
<td>Select the <strong>Show Error Bar</strong> check box, select the <strong>Has Middle Value</strong> check box, and then move the <strong>Width</strong> slider to width you want.</td>
</tr>
<tr>
<td>Add depth to the chart</td>
<td>Select the <strong>Use Depth</strong> check box, and then do any of the following:</td>
</tr>
<tr>
<td></td>
<td>• Move the <strong>Depth</strong> slider to the left to decrease the depth, or move the slider to the right to increase the depth.</td>
</tr>
<tr>
<td></td>
<td>• Move the <strong>Direction</strong> slider to the left or to the right to adjust the direction of the chart.</td>
</tr>
</tbody>
</table>

4. Click **Apply**.
5. Click **OK**.
3. On the **General** tab, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tilt the pie(s)</td>
<td>Move the <em>Pie Tilt</em> slider to the left to show more of the top of the pie(s), or move the slider to the right to show more of the side of the pie(s).</td>
</tr>
<tr>
<td>Change the depth of the pie(s)</td>
<td>Move the <em>Pie Depth</em> slider to the left to decrease the thickness of the pie(s), or move the slider to the right to increase the thickness of the pie(s).</td>
</tr>
<tr>
<td>Rotate the pie(s)</td>
<td>Move the <em>Pie Rotation</em> slider to rotate the pie(s).</td>
</tr>
<tr>
<td>Explode the pie(s)</td>
<td>Move the <em>Explode Pie</em> slider to the right to increase the space between the sections of the pie(s).</td>
</tr>
<tr>
<td></td>
<td>For more information on formatting a single pie slice, see “Working with 3D Charts” on page 168.</td>
</tr>
<tr>
<td>Independently adjust the orientation of the pie regardless of its original size</td>
<td>Clear the <em>Keep aspect ratio constant</em> check box.</td>
</tr>
</tbody>
</table>

4. Click **Apply**.

5. Click **OK**.

**Formatting Line Charts**

With line charts, you can show/hide markers and change their size and shape; show/hide lines; and apply depth to the lines.

**To format a line chart:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Options**.
3. On the **General** tab, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Format size and shape for all of the markers | Select the **Show Markers on Lines** check box and then move the **Size** slider to the left to make the markers smaller, or move the slider to the right to make the markers larger.  
In the **Shape** list, click the shape that you want. For more information on only changing markers for a specific series, see “Changing the Shape of Markers in a Series” on page 154. |
| Hide the lines                       | Clear the **Show Lines** check box.                                                                                                                                                                     |
| Add depth to the chart               | Select the **Use Depth** check box, and then do any of the following:  
  • Move the **Depth** slider to the left to decrease the depth, or move the slider to the right to increase the depth.  
  • Move the **Direction** slider to the left or to the right to adjust the direction of the chart. |

4. Click **Apply**.  
5. Click **OK**.

**Detaching or Deleting a Pie Chart Slice**

You can detach or delete a pie chart slice for added emphasis.

**To detach or delete a pie or funnel chart element:**

1. Double-click the pie chart and then click the slice you want to change.  
2. On the **Format** menu, click **Chart**, and then click **Series**.  
3. On the **General** tab, do one of the following:
Chapter 7: Working with Charts

- To detach the slice, move the slider to the right.
  The higher the number, the further the slice will move away from the pie.
- To delete the slice, click **Delete Slice**.
- To restore the pie to its original form, click **Restore Pie**.

4. Click **Apply**.
5. Click **OK**.

### Changing the Shape of Individual Risers

With bar, column, and histogram charts, you can change the shape of individual risers. You can choose to show the riser(s) as a **Rectangle**, **Beveled Box**, or **Reverse Beveled Box** shape.

You can only change the shape of risers on charts that do not use depth. To remove depth, double-click the chart, then click **Format**, then click **Chart**, then click **Options**, and then clear the **Show Depth** check box.

**To change the shape of risers:**
1. Double-click the chart and then click a riser.
2. On the **Format** menu, click **Chart**, and then click **Series**.
3. On the **General** tab, in the **Shape** list, click either **Rectangle**, **Beveled Box**, or **Reverse Beveled Box**.
4. Click **Apply**.
5. Click **OK**.

### Changing the Shape of Markers in a Series

With line, radar, bubble, or scatter charts, you can change the size and/or shape of markers in a series. For example, you might want to emphasize one series over another by changing the size and/or shape of its markers.

**To change the size and/or shape of the markers in a series:**
1. Double-click the chart and then click a marker.
2. On the **Format** menu, click **Chart**, and then click **Series**.
3. On the **General** tab, select the **Show Markers** check box.
4. Do any of the following:
• To change the size of the markers, move the **Size** slider to the right to increase the size, or move it to the left to decrease the size.
• In the **Shape** list, click a shape for the markers.
• To draw a step line between markers, select the **Show Step Line** check box.

5. Click **Apply**.
6. Click **OK**.

**Showing Data Labels on Markers**

Data labels show the actual values from the cells in your data sheet.

**To show data labels on markers:**
1. Double-click the chart and then click a marker.
2. On the **Format** menu, click **Chart**, and then click **Series**.
3. On the **Data Labels** tab, select the **Show Data Labels** check box.
4. Click **Apply**.
5. Click **OK**.

**Adding a Trend Line**

Trend lines show a graphical representation of trends in a data series. You can add trend lines to data series in unstacked 2D area, bar, bubble, column, line, and scatter charts. You can draw Linear, Logarithmic, Polynomial, or Exponential trend lines. You can also draw a Moving Average line that is a sequence of averages computed from the data points in the series. A Moving Average line smooths the fluctuations in the data points in the series.

**To add a trend line:**
1. Double-click the chart and then click a marker.
2. On the **Format** menu, click **Chart**, and then click **Series**.
3. Click the **Trendline** tab, select the **Show Trendlines** check box, and then do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Choose a trend line type</td>
<td>In the <strong>Regression Type</strong> list, click <strong>Linear, Logarithmic, Polynomial, Exponential, Standard Deviation, Mean, or Moving Average</strong>.</td>
</tr>
<tr>
<td></td>
<td>• For a Polynomial trend line, type the degree of linear regression in the <strong>Order</strong> box. This value must be greater than one, but no greater than the number of groups in the chart.</td>
</tr>
<tr>
<td></td>
<td>• For a Moving Average trend line, type the period over which the moving average line should be drawn in the <strong>Period</strong> box.</td>
</tr>
<tr>
<td>Show the equation for the trend line</td>
<td>Select the <strong>Show Equation</strong> check box.</td>
</tr>
<tr>
<td></td>
<td>This option is not available if you are using a Moving Average.</td>
</tr>
<tr>
<td>Show the coefficient values for the trend line</td>
<td>Select the <strong>Show Coefficients Values</strong> check box.</td>
</tr>
<tr>
<td></td>
<td>This option is not available if you are using a Moving Average.</td>
</tr>
<tr>
<td>Use the same color for the trend line as the series</td>
<td>Select the <strong>Show Color same as Series</strong> check box.</td>
</tr>
</tbody>
</table>

4. Click **Apply**.

5. Click **OK**.
Changing the Color Mode

By default, BI Query Reports displays a different colored riser or marker for each series. However, you can change the color mode of the riser or marker to match the data series or category.

The following options are not available in area, bubble, gauge, line, pie, polar, radar, and scatter charts.

To change the color mode:

1. Double-click the chart.
2. On the Format menu, click Chart, and then click Options.
3. On the Look tab, do one of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Have all risers use a different color riser for each series that is defined in the data sheet</td>
<td>In the Color Mode list, click Color by Series.</td>
</tr>
<tr>
<td>Have all risers in a category use the same color</td>
<td>In the Color Mode list, click Color by Categories.</td>
</tr>
<tr>
<td>Have all risers use a color according to their height</td>
<td>In the Color Mode list, click Exact Color by Height.</td>
</tr>
</tbody>
</table>

4. Click Apply.
5. Click OK.
Chapter 7: Working with Charts

Working with Titles and Labels

A title is text that you add to a certain area of a chart. You can add a title that appears above the chart; a subtitle that appears below the chart, and so forth. A label uses information from the data source to identify elements in a chart.

Adding a Title

You can define a chart title to give your chart a name. By default, the chart title appears at the top of your chart.

To add a title to your chart:

1. Double-click the chart.
2. On the Format menu, click Chart, and then click Titles.
3. Select the Title check box, and then type the title.
4. Click Apply.
5. Click OK.

Adding a Subtitle

In addition to a title, you can define a subtitle that provides additional information about your chart. By default, the subtitle is centered at the top of your chart, directly below the title.

To add a subtitle to your chart:

1. Double-click the chart.
2. On the Format menu, click Chart, and then click Titles.
3. Select the Subtitle check box, and then type the subtitle.
4. Click Apply.
5. Click OK.

Adding a Footnote

By default, the chart footnote appears in the bottom right corner of your chart.
To add a footnote to your chart:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Titles.
3. Select the Footnote check box, and then type the footnote.
4. Click Apply.
5. Click OK.

Adding a Category Title
A category title defines a title for your chart’s group/category axis. By default, the category title appears just above, below, or next to the category axis labels.

You cannot add a category title to Bubble, Histogram, Pie or Scatter charts.

To add a category title:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Titles.
3. Select the Category Title check box, and then type the category title.
4. Click Apply.
5. Click OK.

Adding a Value Title
A value title defines a title for the primary numeric (Y1) axis in your chart.

If you have a dual axes chart, you can also add a second Y2 axis.

To add a value title:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Titles.
3. Select the Value Title (Y1) check box, and then type the value title.
4. Click Apply.
5. Click OK.

Adding an X-Axis Title
Histogram, Bubble, and Scatter charts include a numeric X-axis.
To add an X-axis title to your chart:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Titles.
3. Select the X-Axis check box, and then type the X-axis title.
4. Click Apply.
5. Click OK.

Adding a Series Axis Title

In 3D charts, the series labels that are normally displayed in the legend area are plotted along a secondary group (O2) axis. In the default configuration, these series labels are drawn on the lower left side of the 3D cube. You can add a series axis title to describe further the information charted on the series axis.

You can only add a series axis title to 3D (surface) charts.

To add a series axis title to your chart:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Titles.
3. Select the Category Title check box, and then type the series axis title.
4. Click Apply.
5. Click OK.

Adding Pie Chart Labels

We recommend that you use labels instead of legends for pie charts. A legend makes it difficult to visually connect the legend colors to the pie segments.

To add pie chart labels:
1. Double-click the pie chart.
2. On the Format menu, click Chart, and then click Options.
3. On the Data Labels tab, select the Show Labels check box, and then do one of the following:
   • Click Labels on Slices.
   • Click Labels outside Slices.
4. Click Apply.
5. Click **OK**.

**Formatting X-Axis Labels**

You can change the way labels appear for the members along the x-axis of a chart. You can display the labels:
- as the member description
- as the member name
- as the member name and description
- with a number
- with the items in the first row of data

**To format x-axis labels:**
1. Click the chart.
2. On the **Format** menu, click **Properties**.
3. On the **Options** tab, click an item in the **Display Row Data Labels Using** list.
4. Click **OK**.

---

**Working with Grids and Scales**

**Changing Where the Scale Labels Appear**

You can display the scale to the left (default), right, or on both sides of your chart. In addition, you can make the axis descending instead of ascending (default).

You cannot change the location of the scale labels for funnel, radar, or polar charts.

**To change where the scale labels appear:**
1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Grid Scales**.
3. If necessary, click the axis tab that you want to adjust.
4. On the **General** tab, click a location for the scale labels.
5. Click **Apply**.
6. Click **OK**.
Creating a Descending Axis

By default, most chart axes appear in ascending order. However, you can also create a descending axis.

- Some types of charts do not have an ascending axis (such as a pie or spectral chart). Therefore, if you want to change the direction of an axis, you must select the **Draw categories in reverse order** check box in step 4 below to change the direction of the axis.

- You cannot create a descending axis for 3D (surface) charts.

**To create a descending axis:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Grid Scales**.
3. If necessary, click the axis tab that you want to adjust.
4. On the **General** tab, select the **Make this axis descending** check box.
5. Click **Apply**.
6. Click **OK**.

Hiding the Axis Line

For certain types of charts, the axis line appears by default. However, you can also hide the axis line.

- You cannot hide the axis line for 3D (surface) charts.

- To hide the axis line, you must not use depth in your charts. That is, you must be using 2D charts if you want to hide the axis line. To turn off depth in your chart, double-click the chart, then click **Format**, then click **Chart**, then click **Options**, and then clear the **Use Depth** check box.

**To hide the axis line:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Grid Scales**.
3. If necessary, click the axis tab that you want to adjust.
4. On the **General** tab, clear the **Show the Axis Line on the Chart** check box.
5. Click **Apply**.
6. Click **OK**.
Displaying a Logarithmic Scale

Be default, charts display a linear scale. However, you can display a logarithmic scale instead of a linear scale.

To display a logarithmic scale:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab that has the scale you want to change.
4. On the Scales tab, select the Use Logarithmic Scale on this Axis check box.
5. Click Apply.
6. Click OK.

Removing Zero from a Scale

Sometimes, depending on the data in your chart, you might want to remove zero from your chart’s scale. Removing the zero from a scale can provide a better visual display of your data when the data values are similar. Consider the following examples:

Example 1: zero displayed on scale  
Example 2: zero removed from scale

As you can see in Example 2 above, the contrast between the two values is greater when you remove the zero from the scale.
To remove zero from a scale:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab that has the scale you want to change.
4. On the Scales tab, clear the Always include Zero in this Scale check box.
5. Click Apply.
6. Click OK.

Setting the Minimum/Maximum Value of the Scale

You can manually set the minimum and/or maximum value(s) for the chart’s scale. This allows you to customize the scale rather than accepting the default scale.

To set the minimum/maximum value of the scale:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab that has the scale you want to change.
4. On the Scales tab, do any of the following:
   • To set the maximum value for the scale, select the Use Manual Setting for check box, and then type a value in the Maximum Value box.
   • To set the minimum value for the scale, select the Use Manual Setting for check box, and then type a value in the Minimum Value box.
5. Click Apply.
6. Click OK.

Working with Gridlines

Hiding Major or Minor Gridlines

By default, both major and minor gridlines appear in your chart. You can hide these gridlines at any time.

You cannot hide minor gridlines for 3D (surface) charts.
To hide major or minor gridlines:

1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab that has the gridline you want to hide.
4. On the Grids tab, do any of the following:
   - On the Major Gridlines tab, clear the Show Gridlines check box.
   - On the Minor Gridlines tab, clear the Show Gridlines check box.
5. Click Apply.
6. Click OK.

About Gridline Formats

BI Query Reports can display several types of gridlines. The following table details these gridlines:

<table>
<thead>
<tr>
<th>Gridline Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Regular Grids</strong></td>
<td>Displays grids that span the entire chart. For example, consider a column chart. The Regular Grids option displays lines that span the entire chart.</td>
</tr>
<tr>
<td><strong>Grids and Ticks</strong></td>
<td>Displays grids that span the entire chart and ticks that span the axis only. For example, consider a column chart. The Grids and Ticks option displays grids that span the entire chart and smaller ticks that span the axis.</td>
</tr>
<tr>
<td><strong>Inner Ticks</strong></td>
<td>Displays ticks that span the inner axis only. For example, consider a column chart. The Inner Ticks option displays ticks that span the inside of the axis.</td>
</tr>
<tr>
<td><strong>Outer Ticks</strong></td>
<td>Displays ticks that span the outer axis only. For example, consider a column chart. The Outer Ticks option displays ticks outside of the axis.</td>
</tr>
<tr>
<td><strong>Spanning Ticks</strong></td>
<td>Displays ticks that span the entire axis. For example, consider a column chart. The Spanning Ticks option displays ticks that span the axis.</td>
</tr>
</tbody>
</table>
Changing the Gridline Format

By default, BI Query Reports displays major gridlines in the **Regular Grids** format, while it displays minor gridlines in the **Spanning Ticks** format. You can change the format of both of these gridlines at any time.

**To change the gridline format:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Grid Scales**.
3. If necessary, click the axis tab that has the gridline you want to change.
4. On the **Grids** tab, do any of the following:
   - On the **Major Gridlines** tab, in the **Grid Style** list, click a grid style.
   - On the **Minor Gridlines** tab, in the **Grid Style** list, click a grid style.

   For more information on grid styles, see “About Gridline Formats” on page 165.
5. Click **Apply**.
6. Click **OK**.

Formatting Gridline Intervals

You can manually format both major or minor gridline(s) at any time to add extra detail to your chart. For example, if your chart has intervals at 500, 1000, and 1500, you can have BI Query Reports draw the chart intervals at 250, 500, 750, and so forth.

For major gridlines, BI Query Reports automatically calculates the number of major gridlines on a numeric axis. If you want to use a manual number of major gridlines, you must specify an interval number. As an example, an interval value of 30 in a range of values between zero and 90 will produce three gridlines.

For minor gridlines, BI Query Reports draws one minor gridline between each major gridline. If you want to specify a different number of minor gridlines between each major gridline, you must type a count value. This value determines how many gridlines BI Query Reports will draw between each major gridline.

Minor gridlines are not available for 3D (surface) charts.
To format gridline intervals:

1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab for the axis containing the gridline you want to format.
4. On the Grids tab, do any of the following:
   - Click the Major Gridlines tab, select the Use Manual Grid check box, and then type a value in the Interval Value box.
   - Click the Minor Gridlines tab, select the Use Manual Grid check box, and then type a value in the Count Value box.
5. Click Apply.
6. Click OK.

Drawing a Custom Gridline

With BI Query Reports, you can draw a custom gridline anywhere in your chart.

To draw a custom gridline:

1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab for the axis to which you want to add the gridline.
4. On the Grids tab, select the Draw Custom Line At check box, and then type a value for where you want the line to appear in the box.
5. Click Apply.
6. Click OK.

💡 To make your custom gridline more visible, you may want to hide the chart’s major and/or minor gridlines. For more information, see “Hiding Major or Minor Gridlines” on page 164.
Working with Chart Series

Changing How a Series Appears

In area, bar, and column charts, you can change the format in which risers appear. You can select Default for Chart Type, Line, Riser, or Area. For example, you can change an area riser in an area chart to always display as a column or line riser, or you could change a column riser in a column chart to always display an area or line.

To change how a series appears:
1. Double-click the chart, and then click the element you want to change.
2. On the Format menu, click Chart, and then click Series.
3. On the General tab, in the Always Show Selected Series As list, click how you want to display the series.
4. Click Apply.
5. Click OK.

Working with 3D Charts

Choosing a 3D Viewing Angle

BI Query Reports allows you to customize your 3D chart using a wide variety of 3D viewing angles.

To choose a 3D viewing angle:
1. Double-click the 3D chart.
2. On the Format menu, click Chart, and then click 3D View.
3. Click the 3D viewing angle you want.
4. Click Apply.
5. Click OK.
Customizing a 3D Viewing Angle

You can also customize any 3D viewing angle. Not only can you pan, rotate, or move your 3D chart to anywhere on the screen, but you can also adjust the thickness of the frame walls as well as stretch and shrink them.

To customize a 3D viewing angle:

1. Double-click the 3D chart.
2. On the Format menu, click Chart, and then click 3D View.
3. Click the 3D view you want to customize, and then click Advanced Options.
4. Do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotate the 3D view</td>
<td>Click the Rotate tab, and then use the ( X, Y, ) and ( Z ) buttons to rotate the view.</td>
</tr>
<tr>
<td>Pan the 3D view</td>
<td>Click the Pan tab, and then use the ( X, Y, ) and Zoom buttons to pan the view.</td>
</tr>
<tr>
<td>Change the thickness of the walls</td>
<td>Click the Walls tab, and then use the Length and Thickness ( X, Y, ) and ( Z ) buttons to change the thickness of the walls. Under Length or Thickness, select the Link check box to link the ( Y ) and ( Z ) length and thickness to ( X ). That is, if you modify ( X ), ( Y ) and ( Z ) are resized proportionally.</td>
</tr>
<tr>
<td>Move the 3D view within the chart frame</td>
<td>Click the Move tab, and then use the ( X, Y, ) and ( Z ) buttons to move the 3D view within the frame.</td>
</tr>
</tbody>
</table>

5. Click Apply.
6. Click OK.
Chapter 7: Working with Charts

Working with Data Labels

BI Query reports allows you to show or hide data labels in area, bar, column, and line charts. In addition, you can change the location and format of the data labels.

You cannot show data labels for area or 3D charts.

To show data labels:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Options.
3. On the Data Labels tab, select the Show Data Labels check box.
4. Do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show the data labels outside their associated riser in the chart</td>
<td>In the Labels Location list, click <strong>Outside Maximum</strong>.</td>
</tr>
<tr>
<td>Show the data labels inside their associated riser in the chart</td>
<td>In the Labels Location list, click <strong>Inside Maximum</strong>.</td>
</tr>
<tr>
<td>Show the data labels centered in their associated riser in the chart</td>
<td>In the Labels Location list, click <strong>Center</strong>.</td>
</tr>
<tr>
<td>Show the data labels at the base of their associated riser in the chart</td>
<td>In the Labels Location list, click <strong>Base of Chart</strong>.</td>
</tr>
<tr>
<td>Show the values from the data sheet at the corresponding location on each riser</td>
<td>In the Label Format list, click <strong>Value</strong>.</td>
</tr>
<tr>
<td>Show the series labels</td>
<td>In the Label Format list, click <strong>Label</strong>.</td>
</tr>
<tr>
<td>Show both the series labels and the values from the data sheet</td>
<td>In the Label Format list, click <strong>Label &amp; Value</strong>.</td>
</tr>
</tbody>
</table>

5. Click Apply.
6. Click OK.
Working with Pie Chart Data Labels

With BI Query Reports, you can customize the labels of your pie charts. For example, you can show the labels on the pie chart slices or on the side of the chart.

To work with pie chart labels:

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Options**.
3. On the **Data Labels** tab, do any of the following:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Show the numerical values for each pie slice | Select the **Show Values** check box, and then do any of the following:  
  - Select the **Show Values as Percentage** check box if you want to show the data value as a percentage of the total.  
  - Click **Values on Slices** or **Values outside Slices**. |
| Show the text labels for each pie slice | Select the **Show Labels** check box, and then click **Labels on Slices** or click **Labels outside Slices**. |
| Show a leader line from the pie slice to the data value and/or series label | Select the **Show Leader Lines** check box. |
| ![Warning](image) You must show the values or labels outside the slices before you can show the leader lines. | |
| Show the slice labels on the side of the chart rather than next to each slice | Select the **Labels on Sides** check box. |
| ![Warning](image) You must show the values or labels outside the slices before you can show the labels on the side of the chart. | |
4. Click **Apply**.
5. Click **OK**.

### Formatting Data Label Numbers

To add detail to your chart, you can format the data label numbers. For example, you can add a dollar sign ($) to numbers on the data labels to identify them as currency figures.

You must show the data labels before you can format the numbers. For more information, see “Working with Data Labels” on page 170.

**To format data label numbers:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Options**.
3. On the **Numbers** tab, in the **Category** list, click a category, and then make any changes you want such as the number of decimal places, and so forth.
4. Click **Apply**.
5. Click **OK**.

### Working with Dual Axis Charts

#### Moving Elements to the Primary or Secondary Axis

With a dual axes chart, half of the series are drawn on the primary numeric axis (Y1) and the other half are drawn on the secondary numeric axis (Y2). You can change what elements appear on either axis at any time.

**To move elements between primary and secondary axes:**

1. Double-click the chart.
2. On the **Format** menu, click **Chart**, and then click **Options**.
3. On the **Dual Y Options** tab, do any of the following:
   - Under **Primary (Y1) Axis**, click the element(s) you want to move to the secondary axis, and then click ➡️.
   - Under **Secondary (Y2) Axis**, click the element(s) you want to move to the primary axis, and then click ⬅️.
4. Click Apply.
5. Click OK.

Adjusting the Split Position

With a split dual axes chart, you can adjust the position of the line that divides the two physical numeric axes (Y1 and Y2).

To adjust the split position:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Options.
3. On the Dual Y Options tab, move the Split Position slider to the left or the right to adjust the position of the split line.
4. Click Apply.
5. Click OK.

💡 By default, the dual axes split line appears in a split dual axes chart. If you want to hide this line, clear the Show Axis Split check box.

Hiding Labels

Hiding Axis Labels

By default, both axes have labels. In certain situations, you might want to hide the axis label.

To hide an axis label:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab that has the scale you want to hide.
4. On the Labels tab, clear the Show Labels for this Axis check box.
5. Click Apply.
6. Click OK.

💡 You can also hide axis labels by selecting the chart, clicking Format, then Chart, then Options, then clicking the Data Labels tab, and then clearing the Show Data Labels check box.
Hiding the Minimum/Maximum Value Label

By default, the chart editor displays the minimum and maximum values on the scale. If needed, you can hide these values.

To hide the minimum or maximum value label:

1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab that has the scale you want to change.
4. On the Labels tab, do any of the following:
   - To hide the maximum value label on the scale, select the do not Show Maximum Value Label check box.
   - To hide the minimum value label on the scale, select the do not Show Minimum Value Label check box.
5. Click Apply.
6. Click OK.
Working with Additional Chart Features

Staggering the Category or X-Axis Labels

If you have many items displayed on the category or X-axis, the labels can be difficult to read. Staggering these labels can make them more legible.

To stagger the category or X-axis label:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. Click the X Axis or Category Axis tab.
4. On the Labels tab, select the Stagger Value Label check box.
5. Click Apply.
6. Click OK.

Displaying a Manual Number of Categories

The category axis labels show how BI Query Reports groups or categorizes data in the chart. By default, BI Query Reports draws all labels on the category axis. However, you can decide to have BI Query Reports draw only some of the labels. For example, suppose the category axis labels are MON, TUE, WED, THU, FRI. If you set the Between Labels is set to 2, BI Query Reports will only draw the MON, WED, and FRI labels.

This feature is not available for 3D charts.

To display a manual number of categories:
1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. Click the X Axis or Category Axis tab.
4. On the Labels tab, select the Use manual Number of Categories check box.
5. In the Between Labels box, type the number of labels you want to appear between the category labels.
6. Click Apply.
7. Click OK.
Formatting Axis Label Numbers

For added detail, you can format the numbers appear on the axis label of your chart. For example, you can add a dollar sign ($) to numbers that represent currency in your chart.

To format the axis label numbers:

1. Double-click the chart.
2. On the Format menu, click Chart, and then click Grid Scales.
3. If necessary, click the axis tab for the axis that has numbers.
4. On the Numbers tab, in the Category list, click a category, and then make any changes you want, such as the number of decimal places, and so forth.
5. Click Apply.
6. Click OK.
Crosstabs, like charts, are made up of members and dimensions that display data in multidimensional format. You can format crosstabs to control page breaks, resize cells, and so forth.

- “About Crosstabs” on page 177
- “Working with Dimensions” on page 180
- “Working with Members” on page 182
- “Formatting Crosstabs” on page 189

About Crosstabs

Crosstabs display data in multidimensional format, which can assist in answering these questions:

- How many units did our Midwest office sell this year? This quarter?
- Which sales representative sold the most? When were his/her peak months? When was his/her worst week?

Crosstabs also let you pivot the data to view it from different perspectives, which can assist in answering these questions:

- Does sales experience determine performance?
Chapter 8: Working with Crosstabs

• Did commissions or pricing affect how our products sold?

Crosstabs let you see not only information, but also relationships between business variables, enabling you to uncover trends, anomalies, problems, and opportunities.

This chapter describes how to use crosstabs to present data. It also describes other features as outlined below:

<table>
<thead>
<tr>
<th>To Do This</th>
<th>See This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build crosstabs</td>
<td>“Building Presentations with Presentation Designer” on page 56.</td>
</tr>
<tr>
<td>Change data formats</td>
<td>“Specifying Data Formats” on page 221.</td>
</tr>
<tr>
<td>Add graphics, text, and OLE objects; apply formatting</td>
<td>“Enhancing Report Format” on page 195.</td>
</tr>
<tr>
<td>Add hotspots</td>
<td>“About Interactive Reports” on page 85.</td>
</tr>
</tbody>
</table>

Understanding Crosstabs

Crosstabs display data in a matrix of rows and columns, with headings appearing across both the top and sides. You can rapidly rearrange the data in order to view it from different perspectives—to compare sales figures for multiple products, analyze the performance of regional sales staff, and identify quarterly and annual trends. You can also quickly add calculations and exceptions.
Crosstabs are powerful organizational and analytical tools that enable you to analyze your data and discover the relationships among the different dimensions. The following illustration identifies the parts of a crosstab:

<table>
<thead>
<tr>
<th>This Element</th>
<th>Represents This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>An overall category of data that corresponds to an item on the <strong>Arrange Data</strong> page of the Presentation Designer. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.</td>
</tr>
<tr>
<td>Member</td>
<td>Subcategory of a dimension. Member names appear along the axes or in the legend.</td>
</tr>
</tbody>
</table>

The **Arrange Data** page of the **Presentation Designer** dialog box specifies the way that data is organized in crosstabs.

The following table describes data organization for the **Arrange Data** page:
Rearranging Data in Crosstabs

After the report is created, you can still change the arrangement of data in a crosstab.

To rearrange crosstab data:
1. Double-click a crosstab.
2. On the Format menu, click Crosstab, then click Rearrange Data. This command is not available if the crosstab has not been refreshed.
3. In the Rearrange Data dialog box, organize the data.
4. Click Close.

Working with Dimensions

Dimensions are an overall category of data that corresponds to an item on the Arrange Data page of the Presentation Designer. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.

To understand dimensions, think of time. Time is broken down into years, months, days, hours, minutes, and seconds. Without these subcategories, time has no meaning. Nonetheless, time provides a way of understanding all the subcategories at once, as one entity.

You can make crosstabs easier to understand by arranging the dimensions in them. You can change the way dimensions appear by pivoting a crosstab or by moving a dimension from one axis to another. You can also change the appearance of a dimension by nesting it within another dimension.
Pivoting Dimensions in a Crosstab

Pivoting lets you see different relationships in the data. You can change your view of the data in a crosstab by swapping, or ‘pivoting’, the dimensions in the columns with those in the rows (that is, the dimensions move from one axis to another). You can pivot individual dimensions, or you can pivot the entire crosstab.

To pivot a dimension in a crosstab:
1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, then click Rearrange Data.
3. In the Rearrange Data dialog box, drag the dimension to the desired axis.

Important: There must be more than one dimension under Columns and Rows if you want to drag a dimension to a different axis.

To swap all the dimensions from one axis to another:
1. Double-click the crosstab to activate it.
2. Do any of the following:
   • On the Format menu, click Crosstab, and then click Pivot.
   or
   • On the Format menu, click Crosstab, then click Rearrange Data. In the Rearrange Data dialog box, click Pivot.
   or
   • Double-click the upper-left corner cell (the pivot cell) of the crosstab.
   or
   • Right-click the crosstab, and then click Pivot.

Changing How Dimensions are Nested

When more than one dimension lies along an axis of a crosstab, the crosstab displays the members for the second dimension ‘inside’, or nested within, the members of the first dimension. Nested members normally represent subdivisions within another higher-level dimension. Nesting lets you change the emphasis, or relative importance, of nested dimensions within the crosstab.

For example, if you are analyzing product sales over the past four quarters, you can create a crosstab with products nested within quarters. If you notice an anomaly for a particular product, you can change the nesting to quarterly sales per product.
To change how dimensions in a crosstab are nested:

1. Double-click a crosstab to activate it.
2. On the **Format** menu, click **Crosstab**, and then click **Rearrange Data**.
3. In the **Rearrange Data** dialog box, click a dimension.
4. Drag the dimension up or down within the **Rows** or **Columns** box, or drag it from one box to the other. To swap dimensions along the top of the crosstab with dimensions along the side, click **Pivot**.
5. Click **Close**.

**Working with Members**

Members are a subcategory of a dimension. Member names appear along the axes or in the legend. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.

You can change the way crosstabs appear by:

- filtering data to focus on information of particular interest
- reordering the data displayed along the rows and columns of a crosstab
- removing or hiding members to make crosstabs more readable, eliminate distracting detail, and focus on only the information of interest
- drilling down on a member, or up to a parent, to see more or less detailed information

**Filtering Data**

When you want to focus on information of particular interest, you can ‘filter’ the data. Filtering controls the focus in a crosstab by displaying the data related only to a specific member, thereby simplifying the view. You can filter one member at a time for each dimension. For example, when a crosstab contains sales information for products across sales regions, you can filter the data to see details only for a particular region.

**To filter data in a crosstab:**

1. Make sure the crosstab has at least one metrics dimension and two other dimensions.
2. On the **Format** menu, click **Crosstab**, and then click **Rearrange Data**.
3. In **Rearrange Data** dialog box, drag a dimension under **Filter On**.
4. Click **Close**.

> When you create a crosstab, you can filter the data by selecting **Filter On** on the **Arrange Data** page of the **Presentation Designer**.

### Filtering Using a Different Member

You can look at results for members one at a time by changing how you filter the data. When you drag a dimension into the filter, the data for the first member in the dimension is the focus of the crosstab. You can change the focus by displaying data for a different member. For example, if you placed the Region dimension in the filter, and the Eastern region is the first member in that dimension, the crosstab reflects the data for the Eastern region. However, you can easily change the focus of the crosstab by looking at the data for the Western region.

**To filter using a different member:**

1. On the **Format** menu, click **Crosstab**, and then click **Rearrange Data**.
2. In **Rearrange Data** dialog box, drag a dimension under **Filter On**.
3. In the **Filter member** dialog box, drag a member from the **Available** list to the **Filter Member** list.
4. Click **Close**.
5. In the **Rearrange Data** dialog box, click **Close**.
Filtering with the Filter Bar

The Filter bar is a toolbar that allows you to quickly apply a filter to your chart. After you create a filter, use the Filter bar to change the focus of the filter. For example, consider the Dashboard query Region report. If you filter on the Products.category dimension, you can use the Filter bar to display only the Accessories, Apparel, Bags, Carts, or Clubs data.

- If you do not see the Filter bar toolbar, click View, Toolbars, then Filter.
- You can add up to 18 dimensions to the Filter bar.

To filter with the Filter bar:

- Click the down arrow for the dimension you want to filter, and then click the member you want to view.

Adding Members

You can add members to a crosstab. To show members that you previously removed, you need to add them again using the procedure described below.

To add members:

1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, and then click Rearrange Data.
3. In the Rearrange Data dialog box, click the members tool for a dimension.
4. In the **Include Members** dialog box, select in the **Members** list the member you want to add.

   - **Note:** For dimensions with multiple levels, click the 
     in the **Dimension** list to expand the levels of a dimension. To display the members of a level in the **Members** list, click the name of the level in the **Dimension** list.

5. Click **Show**.

6. Click **Close**.

7. In the **Rearrange Data** dialog box, click **Close**.

---

**Reordering Members**

Occasionally, you may want to rearrange the order of members within a dimension to display related items together. For example, you may want to place new account executives in the first part of a crosstab so you can easily keep an eye on their progress, or you may want to arrange them by their performance. By changing the order of the included members in the **Include Members** dialog box, you can change the order that the columns appear in your crosstab.

**To reorder members in a crosstab:**

1. Double-click a crosstab to activate it.
2. On the **Format** menu, click **Crosstab**, and then click **Rearrange Data**.
3. In the **Rearrange Data** dialog box, click the members tool 
   for a dimension.
4. In the **Include Members** dialog box, select in the **Members** list the member you want to move.

   - **Note:** For dimensions with multiple levels, click the 
     in the **Dimension** list to expand the levels of a dimension. To display the members of a level in the **Members** list, click the name of the level in the **Dimension** list.

5. Click the **Up**, **Down**, **Top**, or **Bottom** buttons to adjust the relative position of the selected member.

   - **Note:** To quickly sort all members, use the **Sort Ascending** or **Sort Descending** buttons.

6. Click **Close**.

7. In the **Rearrange Data** dialog box, click **Close**.
Chapter 8: Working with Crosstabs

Removing or Hiding Members in a Crosstab

Crosstabs lose impact and become difficult to read when they contain too much data. To improve readability, you can remove one or more members from the view. Alternatively, you can hide a member in a crosstab, which leaves the member in the view (the data for the member will still be used in calculations) but hides it in the presentation. Removing or hiding a member is particularly useful if you are interested only in a subset of the data.

To quickly remove all but one or two members of a crosstab, use the Keep Only command.

To remove a member from a crosstab:

1. Double-click a crosstab to activate it.
2. Click a member (or hold down SHIFT, and then click to select a range of members).
3. On the Format menu, click Crosstab, and then click Delete Members.

Alternatively,

1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, and then click Rearrange Data.
3. In the Rearrange Data dialog box, click the members tool for a dimension.
4. In the Include Members dialog box, select in the Members list the member you want to remove.

For dimensions with multiple levels, click the in the Dimension list to expand the levels of a dimension. To display the members of a level in the Members list, click the name of the level in the Dimension list.

5. Click Delete.
6. Click Close.
7. In the Rearrange Data dialog box, click Close.

To hide a member in a crosstab:

1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, and then click Rearrange Data.
3. In the Rearrange Data dialog box, click the members tool for a dimension.
4. In the **Include Members** dialog box, select in the **Members** list the member you want to hide.

   ![Tip](image)
   For dimensions with multiple levels, click the **+** in the **Dimension** list to expand the levels of a dimension. To display the members of a level in the **Members** list, click the name of the level in the **Dimension** list.

5. Click **Hide**.

6. Click **Close**.

7. In the **Rearrange Data** dialog box, click **Close**.

**To keep only a certain member:**

1. Double-click a crosstab to activate it.

2. Click the member you want to keep (or hold down SHIFT, and then click to select a range of members).

3. On the **Format** menu, click **Crosstab**, and then click **Keep Only**.

Alternatively,

1. Double-click a crosstab to activate it.

2. On the **Format** menu, click **Crosstab**, and then click **Rearrange Data**.

3. In the **Rearrange Data** dialog box, click the members tool **†** for a dimension.

4. In the **Include Members** dialog box, select in the **Members** list the member you want to keep.

   ![Tip](image)
   For dimensions with multiple levels, click the **+** in the **Dimension** list to expand the levels of a dimension. To display the members of a level in the **Members** list, click the name of the level in the **Dimension** list.

5. Click **Keep Only**.

6. Click **Close**.

7. In the **Rearrange Data** dialog box, click **Close**.

**Drilling on Members in a Crosstab**

You can change a crosstab to have it show you more or less detailed information by drilling down or up on members within the crosstab. For example, if you are viewing the sales for various regions, and notice that one region stands out from the others, you could drill down on that region to look at the sales for individual stores from within the region.
If you use a hotspot to refresh an interactive crosstab while you are drilled down on a member, you will have to collapse the crosstab (drill up) and expand it again (drill down) before you can see the new data. A better way of shifting the crosstab to look at different data is by using the Filter bar.

To drill down on a member in a crosstab:
1. Double-click a crosstab to activate it.
2. Click a member.
3. On the Format menu, click Crosstab, then click Drill Down.

If the selected member does not have children within the crosstab, the Drill Down command is not available.

To drill up on a member in a crosstab:
1. Double-click a crosstab to activate it.
2. Click a member.
3. On the Format menu, click Crosstab, then click Drill Up.

If the selected member does not have parents within the crosstab, the Drill Up command is not available.

Displaying Aggregate Values
If a member in a crosstab has children, but you have not yet drilled down on the member to display the children, the values you see in that member’s row or column are the aggregate values for the member. These aggregate values are the combined value of all the member’s children’s values. The aggregate values may be sums, averages, or whatever is appropriate for the particular column or row.

By default, when you drill down on a member, BI Query Reports displays only the children’s values. If you want to display the aggregate values as well when drilling down, you must set the Show parent aggregation value when drilling preference.

To display the aggregate values when drilling:
1. On the Tools menu, click Preferences.
2. In the Preferences dialog box, click Crosstab.
3. On the Crosstab page, select the Show parent aggregation value when drilling preference.
4. Click OK.
If you set this preference when you have already drilled down on a member, you must drill down on the member again before the aggregate values appear.

Formatting Crosstabs

Formatting crosstabs serves several purposes. You can:
- format crosstabs to improve their readability and make them more attractive
- set defaults for fonts and colors, for the size of cells, and for selecting cells
- apply different formatting to the headings and data, and shade nested dimensions to make them stand out
- control where page breaks occur and resize crosstabs to better fit them into a report

Working with Crosstabs

Depending on what you want to do with a crosstab, the following describes how to access a crosstab.

To select a crosstab:
- Click inside it.

To activate a crosstab:
- Double-click inside it.

To move a crosstab:
1. Click inside a crosstab.
2. Drag it to a new location in the report.

Selecting an Item

To show selection tabs:
1. On the Tools menu, click Preferences.
2. In the Preferences dialog box, click the Crosstab tab.
3. On the Crosstab page, select the Show selection tabs check box.
4. Click OK.
To select a single cell:
1. Double-click a crosstab to activate it.
2. Click inside the cell.

To select a row of cells:
1. Double-click a crosstab to activate it.
2. Click the black selection tab in the member label for that row.

To select random cells:
1. Double-click a crosstab to activate it.
2. Hold down CTRL, and then click the individual cells.

To select a range of cells:
1. Double-click a crosstab to activate it.
2. Click the first cell in the range you want, hold down SHIFT, and then click the last cell in the range you want.

To select all the cells in a crosstab:
1. Double-click a crosstab to activate it.
2. Click in the cell at the top, left-hand corner of the crosstab.

To select a crosstab label:
1. Double-click a crosstab to activate it.
2. Select a member label, hold down CTRL, and then click the black selection tab for that member.

**Setting Default Formatting for Crosstabs**

You can customize your preferences so that the crosstabs you create display the formatting you prefer. You can specify the font properties of the items that appear in cells, as well as the fill properties of the cells. When you set default formatting for a crosstab, then refresh it or rearrange it (so that it displays new members), the formatting of the new cells is copied from other similar cells.
For example, consider a crosstab that shows sales for all four quarters of 1997 and 1999. When you refresh the crosstab and the new data includes sales for all four quarters of 1998, the new values are formatted like the values for Q1 1997 and 1999. Similarly, when you rearrange the crosstabs, the new cells retain their formatting no matter where in the crosstab they appear.

### To set default formatting for a crosstab:

1. On the **Tools** menu, click **Preferences**.
2. In the **Preferences** dialog box, click the **Crosstab** tab.
3. On the **Crosstab** page, click the **Sample** box for a label cell or data cell.
4. In the **Properties** dialog box, specify the required formatting options.
5. Specify options for setting the sizes of cells (rows and columns) and for selecting cells.
6. Click **OK**.

   When you create a new crosstab, it uses the default formatting that you set using the above procedure.

### Controlling Page Breaks for a Crosstab

You can control page breaks in a crosstab to display only the information you want on each page of a report, or to improve the report’s readability. If crosstabs are larger than one page, they break between the members of the first (highest-level) dimension along each axis; members do not split across pages. For example, if the Region dimension appears on the columns, any member that does not fit entirely on one page moves to the next horizontal page. Similarly, if the Countries dimension appears on the rows, any member that does not fit entirely on one page moves to the next vertical page.

Instead of using the default page breaks in a crosstab, you can specify your own. You can specify which dimension a crosstab should break on. You can also choose not to break the crosstab in any particular spot; in that case, whatever does not fit on one page appears on the next.

### To control page breaks for a crosstab:

1. Double-click a crosstab to activate it.
2. On the **Format** menu, click **Crosstab**, and then click **Page Breaks**.
3. In the **Page Breaks** dialog box, specify the options you want.
Chapter 8: Working with Crosstabs

4. Click OK.

Resizing Crosstabs and Cells
You can resize an entire crosstab or the cells within it. Resizing is useful if you are trying to improve the appearance of a crosstab, fit it on one page, make room for a graphic or an annotation to a cell, or emphasize a particular member. You can resize a crosstab automatically; it sizes to fit the data. You can also manually resize individual members and dimensions.

To resize a crosstab:
1. Click a crosstab.
2. Move the pointer to a selection line, and when the pointer changes to a double-headed arrow ↔, drag the selection line to resize the crosstab to the size you want.

To resize cells:
1. Double-click a crosstab to activate it.
2. Select the cells you want to resize.
3. Move the pointer to the line below or to the right of the cells, and when the pointer changes to a double-headed arrow ↔, drag the selection line to increase or decrease the size of the cells.

Autosizing Cells in a Crosstab
Autosize adjusts the size of the crosstab’s cells. The cells of a crosstab are set to the minimum size possible for them to fit the data found within them.

To autosize cells in a crosstab:
1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, and then click Autosize.

Formatting Crosstabs, Members, and Data
You can format an entire crosstab or the individual cells and text within it. This lets you enhance the look of the crosstab or change the way you display the numbers. You can specify the characteristics of the font, fill, and the outline. For example, bevel the labels to create a three-dimensional look.
To format an entire crosstab:
1. Click a crosstab.
2. On the **Format** menu, click **Properties**.
3. In the **Properties** dialog box, specify the options you want.
4. Click **OK**.

To format members and data:
1. Double-click a crosstab to activate it.
2. Do one of the following:
   - To select an individual cell, click a cell.
   - To select an entire row or column, click a label.
3. On the **Format** menu, click **Properties**.
4. In the **Properties** dialog box, specify the options you want.
5. Click **OK**.
You can improve the appearance of your reports by adding text, graphics and objects, headers and footers, and so forth.

- “Enhancing Report Format” on page 195
- “Managing Pages” on page 196
- “Working with Text” on page 197
- “Graphics and Objects” on page 211
- “Formatting Objects in a Report” on page 217
- “Creating Headers and Footers” on page 220
- “Specifying Data Formats” on page 221
- “Specifying a Number Format” on page 222
- “Creating Report Backgrounds” on page 226

**Enhancing Report Format**

You can format your reports to achieve exactly the look you want. You can add a number of elements and then specify how you want them to look.
You can control and improve layout by changing orientation, print order, number of pages.

You can add titles to reports, additional column headings, context-sensitive titles, page numbering, the prompt values you inserted into the corresponding queries, and text created in other applications.

You can give reports a consistent look and provide consistent information using backgrounds, graphics such as your company logo, headers, and footers.

You can add text, graphics, rich text, shapes, lines, and borders that enhance the content of reports and add visual impact.

You can specify the formats you want when numbers, dates, and times do not use the appropriate formats.

You can add variable information to reports to reflect the data on which reports are based. For example context, sensitive information provides a means to control the content of titles, page numbering, dates, and times.

This chapter describes how to format elements that are common to reports, tables, charts, and crosstabs. Formatting other elements is described elsewhere in this guide, as outlined below:

<table>
<thead>
<tr>
<th>To Format This</th>
<th>See This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tables</td>
<td>“Working with Tables” on page 93.</td>
</tr>
<tr>
<td>Charts</td>
<td>“Formatting Charts” on page 131.</td>
</tr>
<tr>
<td>Crosstabs</td>
<td>“Formatting Crosstabs” on page 189</td>
</tr>
</tbody>
</table>

Managing Pages

Adding and Removing Pages

If you are creating large, multi-page reports containing tables, crosstabs, and charts, you may want to change the size of the reports.

To add and remove pages:

1. On the Format menu, click Report, and then click Size.
2. In the Report Size dialog box, type or select a width and height for the report.
3. Click **OK**.

**Adding Page Numbers**

Page numbering provides a road map for using your report. Add a page number by adding a label with a special field, which you can insert through the Text Editor. If you add a page number to a report, repeat it on multiple pages. A number appears on all pages that will print and a question mark (?) appears on all pages that do not print.

💡 For more information, see “Special Fields Reference” on page 205.

To add a page number:

1. On the **Insert** menu, click **Label**. The mouse pointer changes to a plus sign (+).
2. Drag a rectangle in the report where you want the page numbers to appear.
3. In the **Text Editor** dialog box, click **Page Number** from the **Fields** list.
4. Specify formatting options.
5. When you are satisfied with your changes, click **OK**.

**Working with Text**

You can improve the content and appearance of your report by:

- adding text labels (for example, titles and additional column headings)
- adding rich text (for example, detailed notes, instructions, and files)
- copying text from another application
- adding context-sensitive items (such as titles and page numbering)
- adding prompts and prompt values

**Adding Text Labels**

When you want to add new information to a report—for example, titles, additional column headings, and notes—you can add it as a label. You can also change default labels, such as column headings and titles in tables, to more accurately reflect the information the tables contain. Any formatting you apply to a label affects all the text in the label. If you want to apply different formatting to different areas of the text, use rich text.
When you add text labels to tables, you add them to bands. When you add an item to a band, the item appears in every band of that type. For example, an item that is added to the page header band repeats in all page header bands in the table.

**To add a label:**

1. On the **Insert** menu, click **Label**. The mouse pointer changes to a plus sign (+). To add a label to a table, first double-click a band; otherwise the object is overlaid on the table.
2. Drag a rectangle in the report where you want the text to appear.
3. In the **Text Editor** dialog box, type the text, and then specify the formatting options you want.

   ![Tip] For more information, see “Formatting Text” on page 209.

4. Do any of the following:
   - If you want to add special fields, click an item from the **Fields** list. For more information, see “Special Fields Reference” on page 205.
   - The **Wrap Text** check box lets you display text on more than one line rather than on one long line.
5. When you are satisfied with your changes, click **OK**.

**Adding Rich Text**

When you want to add a large amount of text to a report—for example, detailed notes, instructions, even entire files that you have created in another application—you can add it as ‘rich text’. Rich text, or text in Rich Text Format (RTF), is a Microsoft standard for including formatting commands with text. In BI Query Reports, you can apply different formatting to different areas of rich text.

![Tip] When you add text to tables, add it to bands.

**To add rich text:**

1. On the **Insert** menu, click **Rich Text**. The mouse pointer changes to a plus sign (+). To add a rich text object to a table, first double-click the band into which you are adding the object.
2. Drag a rectangle in the report where you want the text to appear.
3. In the **Rich Text Editor** dialog box, type the desired text.
4. To format any part of the text, select it, then specify the formatting options you want.
If you want to see the effect of your changes in the report without closing the Text Editor dialog box, click Apply.

For more information, see “Formatting Text” on page 209.

5. When you are satisfied with your changes, click OK.

Pasting Text from Another Application

You can add text from other applications as rich text. When you paste the text, formatting—bold, italics, or different fonts—is preserved.

To paste text from another application:

1. Copy the text to the Clipboard in the source application.
2. Return to BI Query Reports.
3. On the Edit menu, click Paste.

About Hyperlinks

Adding hyperlinks to text in your report extends the amount of information you can make available to the people reading your reports. For example, you can add a hyperlink to a Sales report that links to another report with an up-to-date list of sales people, their territories, and their quotas.

Like hyperlinks on Web sites, hyperlinks in reports support the standard complement of Uniform Resource Locator (URL) protocols, such as HTTP, FTP, and FILE. You can link to Web resources or online help systems. You can also set up an e-mail link, for example, so those reading the report can send comments about the report to a predefined recipient. You can link to local resources such as BI Query data models and reports files stored locally, PDF documents, or any other associated file type. Unlike hyperlinks on Web sites, BI Query Reports hyperlinks support Hummingbird Repository Retrieval Protocol (HRRP) which allows links to reports and data models stored in the BI Server Repository. Hyperlinking published reports provides report readers, and in particular BI Web report readers, with n-tier linking information.
**Supported URL Protocols**

BI Query supports the following protocols for URLs:

<table>
<thead>
<tr>
<th>Protocol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTTP</td>
<td>The Hypertext Transfer Protocol (HTTP) defines the format and transmission method of documents over the Web. For example, the following URL, <a href="http://www.hummingbird.com">http://www.hummingbird.com</a> specifies the address of the Hummingbird Web site.</td>
</tr>
<tr>
<td>Secure HTTP</td>
<td>HTTPS is a secure form of HTTP using the Secure Sockets Layer (SSL) protocol. In the following example, <a href="https://secureSite">https://secureSite</a> secureSite is the address (domain name or IP address) of a site protected by the SSL protocol.</td>
</tr>
<tr>
<td>HRRP</td>
<td>The Hummingbird Repository Retrieval Protocol (HRRP) lets you access files in a BI Server Repository through a browser. In the following example, hrrp://r1/MyModel/report/SalesUK.rep SalesUK.rep is a report in the MyModel data model stored in the Repository. For more information, see “Hummingbird Repository Retrieval Protocol (HRRP)” on page 201.</td>
</tr>
<tr>
<td>FTP</td>
<td>The File Transfer Protocol (FTP) lets you transfer files between your machine and the machine specified in the URL. For example, the following URL, ftp://ftp.isi.edu/in-notes/rfc1123.txt retrieves a document that describes the File Transfer Protocol. In this example, the folder access is public (accessible by anyone) in contrast to restricted server access that requires a valid user account and a specific port number.</td>
</tr>
</tbody>
</table>
For the File Transfer Protocol (FTP), use the following URL syntax for a user account that lets you access the server:

```
somename:pswd@ftp.servername.com:#####/path/folder
```

where `somename` is the user name (followed by a colon), `pswd` is the password (followed by the “at” symbol @), `ftp.servername.com` is the server address (followed by a colon), `#####` is the port number, and `/path/folder` is the path to the folder.

**Hummingbird Repository Retrieval Protocol (HRRP)**

In addition to the standard URL protocols, BI Query also supports a special protocol for specifying resources in a BI Server Repository: the Hummingbird Repository Retrieval Protocol (HRRP). Using this protocol, you can open data models and reports stored in the Repository. (You can also run the queries associated with each report you open.)

When you access the URL for a data model, the data model opens in a new instance of BI Query. When you access the URL for a report, the report opens in a new instance of BI Query Reports.

URLs that use HRRP take the following form:

```
Protocol Description
mailto The mailto protocol specifies the format for e-mail addresses. For example, you can use the following URL,
mailto:hbi-support@kingston.hummingbird.com
to contact Hummingbird BI Technical Support.

file The file protocol specifies the format for local or network resources. For example, the following URL,
file:///C:\temp\readme.html
specifies a file on the C drive.

For added convenience, when you are browsing for a file, you can filter your list of available files to see only:
- BI files (*.rep, *.gqu, *.gql)
- Internet files (*.htm, *.html)
- PDF files (*.pdf)

**File Transfer Protocol Syntax**

For the File Transfer Protocol (FTP), use the following URL syntax for a user account that lets you access the server:

```
somename:pswd@ftp.servername.com:#####/path/folder
```

where `somename` is the user name (followed by a colon), `pswd` is the password (followed by the “at” symbol @), `ftp.servername.com` is the server address (followed by a colon), `#####` is the port number, and `/path/folder` is the path to the folder.
where repository_id is the ID for the Repository, pkg_name is the XML namespace of the data model that stores the document you want to open, document_type is the type of document you want to open, and repository_segment is the particular document you want to open (either a report or an entire data model).

The default repository_id for any BI Server Repository is r1. The pkg_name (namespace) for a data model and its objects is the same as the name of the data model (without the file extension). The following table describes the possible values for document_type:

<table>
<thead>
<tr>
<th>document_type</th>
<th>Associated Resource</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>datamodel</td>
<td>Data model file</td>
<td>Do not supply a file extension (gql or gqu) when specifying a data model.</td>
</tr>
<tr>
<td>report</td>
<td>BI Query Reports file</td>
<td>Supply the usual file extension (rep) to specify reports created in BI Query Reports.</td>
</tr>
<tr>
<td>xreports</td>
<td>Standard Reports file</td>
<td>Supply a file extension of .xml to specify a Standard Reports file.</td>
</tr>
</tbody>
</table>

Applying a Hyperlink

When the user moves the mouse pointer over a label or text that links to a URL, the pointer changes to a hand to indicate that the text is a hyperlink.

To apply a hyperlink:

1. Right-click a label or text, and then click Add Hyperlink. The Edit Hyperlinks dialog box opens.
2. From the Address list, click the type of URL you want to add.
   If you click ftp://, the dialog box displays information according to the URL syntax you type to access an FTP server. If you specify the mailto: format, the dialog box displays boxes that let you specify the e-mail addresses of recipients and the subject of the e-mail.
3. Do one of the following:
   - In the text box on the right, type the URL for the required resource.
If you type the protocol in this box (such as http://), the dialog box automatically strips it off and updates the selection in the adjacent list accordingly.

- Click **Browse** to locate the file you want.

The **Browse** button is unavailable if you click either the **mailto:** or the **ftp://** protocol.

4. To add a field to the hyperlink, click **Insert Field**, and then click the field you want.

- For more information, see “Using Fields in Hyperlinks” on page 207.

5. Click **OK**.

**Example: Applying Hyperlinks**

This example describes using hyperlinks to provide easy access to specific reports from a master list.

**To create a list of reports with hyperlinks:**

1. In BI Query Reports, on the **File** menu, click **New**.
2. Add a label to the report. In the **Text Editor** dialog box, type the name of a published report to which you want to link, and then click **OK**.
3. On the **Edit** menu, click **Add Hyperlink**.
4. In the **Address** list, click **http://**, and then click **Browse**.
5. In the **Retrieve HRRP Document** dialog box, click the published report to which you want to link, and then click **OK**.
6. Click **OK**.
7. Repeat steps 2 to 6 for each additional report you want to add.
8. Save the report, and publish it if necessary.

**Editing and Removing Hyperlinks**

**To edit a hyperlink:**

1. Right-click an existing hyperlink and from the shortcut menu, click **Edit Hyperlink**. The **Hyperlinks** dialog box opens.
2. Make changes as necessary and click **OK**.
To remove a hyperlink:

- Right-click an existing hyperlink and from the shortcut menu, click **Remove Hyperlink**.

Adding Context-Sensitive Items

You can use special fields to add context-sensitive items such as titles, page numbers, times, and dates to reports. Special fields let you add variable information to a report (such as the prompt values you inserted into the corresponding query, the view name of a presentation, and so on).

💡 For more information, see “Special Fields Reference” on page 205.

For example, if the query you used to generate a report includes a prompt, you can create a context-sensitive title that identifies the value on which the report is based (such as **Shipments to: USA**, where **USA** is the value you entered into the prompt).

💡 For more information, see “About Prompts and Prompt Values” on page 206.

To add a context-sensitive title, page numbers, time, or date:

1. On the **Insert** menu, click **Label**. The mouse pointer changes to a plus sign (+).
2. Drag a rectangle in the report where you want the object to appear.
3. In the **Text Editor** dialog box, click an item from the **Fields** list. For example, **Prompt Value**.

💡 When you add a context-sensitive label that uses a prompt value, it is good practice to click **Default Data Source** from the list of data sources. This ensures that the label applies to any report, and it is particularly useful when you want to save the report as a style, then apply that style to other reports.

4. Specify any further information for which you are prompted. For example, if you click **Prompt Value**, you need to also specify the view you are using and confirm the prompt value.
5. Type any additional text into the text box.
6. Specify the formatting options you want.
7. If you want to see the effect of your changes in the report without closing the **Text Editor** dialog box, click **Apply**.

💡 This is particularly useful when you are using fields and want to see how the actual data will appear before committing your changes.
8. When you are satisfied with your changes, click **OK**.

**Special Fields Reference**

When you add a label or hyperlink, you can include a field. Some of these fields can help describe a view; others, like page numbering, can provide road maps for using your report.

The following table describes the available fields.

<table>
<thead>
<tr>
<th>Choose This</th>
<th>To Add This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Author</td>
<td>The person who created the report. This does not change when the report is subsequently modified by a different person.</td>
</tr>
<tr>
<td>Creation Date/Time</td>
<td>The date and time the report was created. It does not change, even when you open the report at a later time.</td>
</tr>
<tr>
<td>Current Date/Time</td>
<td>The current date and time. It changes each time you open the report. You can format the way in which this data is inserted.</td>
</tr>
<tr>
<td>Data Source Date/Time</td>
<td>The date and time a specific data source was created.</td>
</tr>
<tr>
<td>Field Name</td>
<td>The coordinates of a value from a view. For example, in a crosstab, if you specify a value in Products for 1998, the special field displays “Products/1998”.</td>
</tr>
<tr>
<td>Field</td>
<td>A value from a view. In the Data Cell Selector dialog box, choose the view you want, then choose a member from each dimension. Otherwise, BI Query Reports inserts the value from the first cell that meets the requirements.</td>
</tr>
<tr>
<td>Filter Dimensions</td>
<td>The dimensions, if any, that are in the filter for the crosstab or chart you are using. You need to specify the view you want.</td>
</tr>
<tr>
<td>Hotspot Attribute</td>
<td>The attribute that users are requalifying when they click a hotspot. (Available only if a hotspot is selected.)</td>
</tr>
<tr>
<td>Hotspot Operator</td>
<td>The operator used in a hotspot. (Available only if a hotspot is selected.)</td>
</tr>
</tbody>
</table>
### About Prompts and Prompt Values

You can use prompts to change the data in reports. If the query you use to generate a report includes a prompt, you can insert a different value into the query each time that you submit it.

In a report, you can add a label that displays the prompt value you inserted into the query so that you can determine what limits, if any, were set on the query that created certain data sources. If you generate the same report and you insert a different prompt value each time, the prompt value displayed in the label changes accordingly.

<table>
<thead>
<tr>
<th>Choose This</th>
<th>To Add This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hotspot Values</td>
<td>The values that appear in the requalified query. (Available only if a hotspot is selected.)</td>
</tr>
<tr>
<td>Last Modified By</td>
<td>The person who last saved the report.</td>
</tr>
<tr>
<td>Last Modified Date/Time</td>
<td>The date and time the report was last saved.</td>
</tr>
<tr>
<td>Page Number</td>
<td>The page number.</td>
</tr>
<tr>
<td>Prompt Value</td>
<td>The prompt value(s) used in the query. You need to specify the view you want, then confirm the prompt value.</td>
</tr>
<tr>
<td>Report Filename</td>
<td>The name of the report in which you are working.</td>
</tr>
<tr>
<td>Total Pages</td>
<td>The total number of pages in the report.</td>
</tr>
<tr>
<td>View Name</td>
<td>The name of a specific view. You need to specify the view you want.</td>
</tr>
<tr>
<td>X-Axis Dimensions</td>
<td>The name of the dimensions on the horizontal axis of the crosstab or chart you are using. You need to specify the view.</td>
</tr>
<tr>
<td>Y-Axis Dimensions</td>
<td>The name of the dimensions on the vertical axis of the crosstab or chart you are using. You need to specify the view you want.</td>
</tr>
</tbody>
</table>
If you refresh a report that uses a prompt and you want to replace the current values with new values, make sure that you delete the current values first. In the qualification dialog box, click the List icon, click Delete All Entries, and then enter the values on which you want the report to be based.

Using Fields in Hyperlinks

Inserting a field in a hyperlink can greatly extend its usefulness. For example, you can:

- include the report file name, last modified by, and last modified date fields in the subject line of a mailto link so the e-mail recipient knows when the report was last modified and by whom when answering questions.
- create a summary-detail set of reports by passing values from the summary report to the detail report.

Detailed instructions for creating the hyperlinks described in these examples are provided in the following topics.

For additional examples of using fields in hyperlinks, see the various dashboard reports provided with the Retail Golf sample data model.

Example: Providing Report Details In E-Mail Subject

This example describes how to create a hyperlink that will automatically create a new e-mail message with the destination address and subject line already populated with up-to-date information on the report.

To provide report details in an e-mail subject line:

1. In BI Query Reports, add a label to the report. In the Text Editor dialog box, type Comments?, and then click OK.
2. With the label selected, on the Edit menu, click Add Hyperlink. In the Edit Hyperlink dialog box:
   a. In the Address list, click mailto:
   b. In the box to the right, type the address of the person to whom you would want to send comments (such as admin@yourcompany.com).
   c. Click in the Subject box.
   d. In the Insert Field list, click Report filename.
   e. In the Subject box, type a colon (:) followed by a space. This is simply to separate the fields for readability.
f. In the Insert Field list, click Last modified Date/Time.
g. In the Subject box, type a colon (:) followed by a space.
h. In the Insert Field list, click Last modified by.

3. Click OK.

Example: Summary Detail Reports

This example describes how to create a hyperlink that displays the name of a category in a summary report, and when clicked will open the associated detail-level report by providing the category name as a prompt value.

This example uses BI Server API parameters (such as &cmd=refresh) that BI Query Reports is unable to interpret. To use the report in this example, you would have to publish it to your repository and access it via BI Web. For more information on BI Server API options, see the BI Server Programmer’s Guide.

To create a detail-level report:

1. In BI Query, using the Sales Roadmap window of the Retail Golf sample data model:
   a. Select the Product Name and Category attributes from the Product data object.
   b. Select the Quantity attribute from the Sales Detail data object and apply the SUM function to it.
   c. Add a qualification to the Category attribute, and select the Category prompt.

2. Run the query (using any valid prompt value) and send the results to BI Query Reports.

3. In Presentation Designer, click Table, and then click Finish.

4. Save the report (give it a name such as Detail), and then publish it.

To create a summary report:

1. In BI Query, using the Sales Roadmap window of the Retail Golf sample data model, select the Product Name, Unit Price, Unit Cost, Category, and Subcategory attributes from the Product data object.

2. Run the query and send the results to BI Query Reports.

3. In the Presentation Designer, click Table, and then click Finish.

4. Click the data in the Category column, then press the Delete key.
5. Add a label to the report. In the Text Editor dialog box, from the Fields list, click Field.

6. In the Data Cell Selector dialog box, under Dimensions, click Columns.

7. In the Choose Member dialog box, click Category.

8. Click OK.

9. Click OK. The label should now display the word Accessories.

10. On the Edit menu, click Add Hyperlink.

11. In the Edit Hyperlink dialog box:
   - In the Address list, click http://.
   - Click Browse.

12. In the Retrieve HRRP Document dialog box, click the detail report (Detail.rep) you had published previously, and click OK.

13. In the Edit Hyperlink dialog box, at the end of the address, type the following:
   &cmd=refresh&showform=missing&!Category=

14. From the Insert Field list, click Field.

15. In the Data Cell Selector dialog box, under Dimensions, click Columns.

16. In the Choose Member dialog box, click Category. The hyperlink displayed in the Edit Hyperlink dialog box should look something like this:
   r1/RetailGolf/report/Detail.rep?layer=admin&cmd=refresh
   &showform=missing&!Category=[Field...:Query Results 6{Product.category,*}]

17. Click OK. The label should now display the word Accessories with the hyperlink style.

18. Drag the label into the first row of the Category column.

19. Save the report (give it a name such as Summary), and then publish it.

20. In BI Web, open the summary report. You can click the entries in the Category column to open the associated detail report.

**Formatting Text**

You can specify the appearance of text or rich text by controlling:

- font
- size
- color
• justification
• formatting (bold, italics, and underline)

💡 For information about formatting text in tables, see “Formatting Columns” on page 102. For formatting text in crosstabs, see “Formatting Crosstabs, Members, and Data” on page 192.

For text, you can:
• wrap text, which lets you display text on more than one line rather than on one long line
• add special fields

💡 For more information, see “Special Fields Reference” on page 205.

For rich text, you can add bullets.

To format text or rich text:
1. Double-click the text.
2. In the Text Editor or Rich Text Editor dialog box, specify options using the formatting buttons or the Font and Size boxes.
3. Click OK.

Adding Color to Text

You can specify text color in the Text Editor or in the Properties dialog box.

To add color to text:
1. Right-click the text, and then click Edit Text.
2. In the Text Editor dialog box, click the color palette tool , and then choose a color.
3. Click OK.

To add color using the Properties dialog box:
1. Click a text label.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the Font tab, then choose a color from the Color list.
4. Click OK.
If some of the colors you select do not appear, you may have to change the color palette you are using in your Windows Display Properties.

To change the palette:
1. On the Windows Start menu, click Settings and then click Control Panel.
2. Double-click Display.
3. Click the Settings tab.
4. Select the Color Palette.

💡 For more information on changing the Windows color palette, see the Windows documentation.

Graphics and Objects

Graphics
You can insert graphics, or clips from the Clip Gallery, into your report. Supported graphic file formats include:
- Windows Bitmap (.bmp, .dib)
- Tagged Image File Format (.tif, .tiff)
- Windows Metafile (.wmf)
- JPEG File Interchange Format (.jpg, .jpe, .jpeg)
- Graphics Interchange Format (.gif .gif87)
- Portable Network Graphic (.png)

Clips include clip art, pictures, sounds, video clips, and animations.

Lines, Rectangles, and Ellipses
Lines, rectangles, and ellipses are ‘drawing objects’. Drawing objects organize information in reports and separate one area from another. In tables, for example, vertical lines between columns and horizontal lines below column headings serve to organize information. Lines separate presentations in reports and act as borders. For example, to add a border, draw a small line and drag it into the detail band of a table. The line will repeat for every row in the detail band and therefore it will look like one continuous line.
Objects
You can insert an OLE object or a bitmap into your report. The object can be:
- linked to the source application so that any changes to the object in its source application are also reflected in the object inserted into the report
- embedded in your report

Adding Graphics
You can insert a graphic or clipart image into your report.

To add a graphic:
1. On the Insert menu, click Picture and then click From File. Click inside a report.
2. In the Open dialog box, click the type of graphic you want to insert from the Files of Type list.
3. Locate the file you want to insert, and then click Open.
Alternatively,
1. Open a graphic.
2. Copy the graphic to the Clipboard.
3. In BI Query Reports, click Edit and then click Paste.

The Layout menu provides tools for moving, grouping, and aligning objects.

Adding Drawing Objects
Lines, rectangles, and ellipses are drawing objects that can be added to improve the readability, appearance, and organization of your report.

To add a lines, rectangles, or ellipses:
1. On the Insert menu, click Drawing Object.
2. Click the object you want to draw from the submenu—Line, Rectangle, Round Rectangle, or Ellipse. The mouse pointer changes to a plus sign (+).
3. Drag the selected shape in the report where you want the object to appear.
4. Format the drawing object.

The Layout menu provides tools for moving, grouping and aligning objects.
Formatting and Editing Drawing Objects

You can specify how selected objects are filled as well as their line properties. You can display objects (for example, the company logo) on multiple pages of a report, or apply an exception to them.

To format a drawing object:
1. Do one of the following:
   - Double-click an object.
   - Click an object. On the Format menu, click Properties.
2. In the Properties dialog box:
   - For rectangles and ellipses, click the Line, Fill, or General tab.
   - For lines, click the Line or General tab.
3. Specify the options you want.
4. Click OK.

Adding Color to Drawing Objects

You can specify the line color of any drawing object. For a rectangle or an ellipse, you can specify the color of the fill or the color of the pattern used in the object.

To add color to a drawing object:
1. Click the object.
2. On the Format menu, click Properties.
3. To specify the color of the fill and pattern for a rectangle or ellipse, in the Properties dialog box, click the Fill tab. Click Fill Color or Pattern Color.
   To specify the color of a line, in the Properties dialog box, click the Line tab. Click Line Color.
4. In the Color dialog box, click the color.
5. Click OK.
6. In the Properties dialog box, click OK.

If some of the colors you select do not appear, you may have to change the color palette you are using in your Windows Display Properties.
To change the color palette:

1. On the Windows Start menu, click Settings, and then click Control Panel.
2. Double-click Display.
3. Click the Settings tab.
4. Select a Color Palette.

💡 For more information, consult the Windows documentation.

Adding Linked Objects

You can link the OLE object, or bitmap file you are inserting, to the source document.

To link an object:

1. In BI Query Reports, on the Insert menu, click Object.
2. Click in the report where you want the object to appear.
3. In the Insert Object dialog box, click Create From File.
4. Do one of the following:
   • In the File text box, type the path and the file name.
   • Click Browse, then locate the file you want.
5. If you would like the link to be represented by an icon rather than by the object itself, select the Display As Icon check box.
6. Select the Link check box.
7. Click OK.

The Layout menu provides tools for moving, grouping, and aligning objects.

Editing Linked Objects

You must edit a linked object in the source application. You can use the Links dialog box to find linked objects in a report. The changes you make appear in the linked object in the report, as well as in the source.
To edit a linked object:

1. Open an object, double-click a linked object in the report. The object opens in the source application. Alternatively,
   a. Click a linked object.
   b. On the Edit menu, click Links.
   c. In the Links dialog box, click the object.
   d. Click Open Source. The object opens in the source application.

2. In the source application, edit the object. The changes are also made to the object in the report.

3. Close the source application.

Viewing and Managing Linked Objects

The Links dialog box displays information about links used in the current report and lets you edit, update, change, or remove those links.

To manage linked objects:

1. On the Edit menu, click Links.

2. In the Links dialog box, click the link you want to change.

3. Click Update Now to update the link.

4. For the Updates option:
   - Click Manual to update the link only when you want.
   - Click Automatic to update the link automatically whenever a change is made to the source document.

5. Do one of the following:
   - Click Open Source to open the source document of the object.
   - Click Change Source to change a link.
   - Click Break Link to remove the connection with the source document, which causes the linked object to become an embedded object, and then click Yes.
Adding Embedded Objects

You can embed an OLE object or a bitmap file into a report. Before embedding an object, be sure that both BI Query and the source application are running and that you have saved the source file. The source application must also support linking and embedding.

To embed an object in a report:
1. In BI Query Reports, on the **Insert** menu, click **Object**.
2. Click in the report where you want the object to appear.
3. To insert an existing object, do the following:
   a. In the **Insert Object** dialog box, click **Create From File**.
   b. Type the path and file name into the **File** box or click **Browse** and locate the file you want.
   c. Click **OK**.
4. To create a new object and insert it, do the following:
   a. In the **Insert Object** dialog box, click **Create New**.
   b. Click an object type in the list, and then click **OK**.
   c. Create the file.
   d. Click in the BI Query Reports window to exit the source application.

The **Layout** menu provides tools for moving, grouping, and aligning objects.

Editing Embedded Objects

You edit an embedded object in the source application.

To edit an embedded object:
1. Click an embedded object.
2. Right-click the object, and choose **Edit OLE Object** from the right-click menu.
   The object opens in the source application.
3. Edit the object.
4. Click in the BI Query Reports window to exit the source application.
Formatting Objects in a Report

Selecting Objects

To perform any operation on an object, you need to select it first. To select an object, click it.

To activate an object, double-click it. To select multiple objects, click the first object, hold down SHIFT, and then click the other objects. To turn a selection on or off, hold down CTRL, and then click an object to turn the selection on or off.

Copying and Pasting Objects

You can copy and paste objects within a report.

To copy and paste an object:
1. Click an object.
2. On the Edit menu, click Copy.
3. Move to the desired location.
4. On the Edit menu, click Paste.

Alternatively,
1. Click an object.
2. Hold down CTRL, and then drag the object to the required location.

Aligning Text and Graphics

You can align text and graphics along their top, bottom, right, left, or center points.

To align text and graphics:
1. Click the first object.
2. Hold down SHIFT, and then click any additional objects.
3. On the Layout menu, click Align, and then click an alignment option.

If you are aligning data items or text objects, only the box surrounding the text is affected.
To align the data inside the box:
1. Click the data inside the box.
2. On the Format menu, click Properties.
3. Click the Font tab.
4. Change the justification.
5. Click OK.

Making Objects the Same Size

Objects are sized according to the largest selected object. If items are Fit To Column, they will not resize.

To make objects the same size:
- Click the first object, hold down SHIFT, and then click any additional objects.

To make the objects the same width:
- On the Layout menu, click Make Same Size, and then click Width.

To make the objects the same height:
- On the Layout menu, click Make Same Size, and then click Height.

Spacing Objects Evenly

The Space Evenly Horizontally option spaces objects evenly across the page based on the location of the selected objects to the furthest left and the furthest right of the page. All other selected objects are spaced evenly between these two objects.

The Space Evenly Vertically option spaces objects evenly down the page based on the location of the selected objects closest to the top and bottom of the page. All other selected objects are spaced evenly between these two objects.

To space objects evenly:
- Click the first object, hold down SHIFT, and then click any additional objects.

To space objects evenly across the page:
- On the Layout menu, click Space Evenly, and then click Horizontally.

To space objects evenly down the page:
- On the Layout menu, click Space Evenly, and then click Vertically.
Using Snap to Grid

When you use Snap to Grid option, objects are automatically placed on the closest grid point when you draw, move, or resize them, even if the grid is not displayed.

Any objects that were placed before you enable the Snap To Grid setting remain in their original positions. To position them on the grid you must move them manually.

To use Snap to Grid:
1. To change the properties associated with grid lines, on the Layout menu, click Grid Settings.
2. In the Grid Settings dialog box, select the Snap to Grid check box.
3. Click OK.

Showing Grid Lines

Grid lines can help you align objects on the page. The grid appears on the screen as a series of horizontal and vertical dotted lines, but the grid lines do not print.

To show grid lines:
1. On the Layout menu, click Grid Settings.
2. In the Grid Settings dialog box, click the Show Grid Lines check box.
3. Click OK.

Changing Grid Settings

You can change the properties associated with grid lines in reports.

To change grid settings:
1. On the Layout menu, click Grid Settings.
2. In the Grid Settings dialog box, ensure that you have selected the Show Grid Lines check box.
3. In the Horizontal Spacing and/or Vertical Spacing box(es), type or select the horizontal and/or vertical line spacing.
4. Click OK.
Creating Headers and Footers

Headers and footers contain information that appears on each page of a report, such as page numbers, dates, company logos, graphics, and so on. You can also create your own headers and footers. You can customize them using the header and footer bands in tables, adding repeating objects to reports, and using page backgrounds.

Tables

If a report includes a table that spans multiple pages, adding items to the page header or footer bands adds them to each page of the report. You can create headers and footers using a table by adding items to the page header and page footer bands.

Repeating Objects

The text and graphics you add to a report can appear on multiple pages. For example, if you are creating a background, you may want your company logo, a horizontal or vertical line, or a border to display on every page. Your report may contain footers on odd-numbered pages that are different than footers on even-numbered pages. You can create headers and footers using a repeating object by adding objects to multiple pages.

Using Tables

Every table has a header and footer area designated by the page header band and the page footer band. When you add objects to these bands, they are repeated on every page on which the table appears. For example, if you have a company logo that you want at the top of each page, you can add it to the page header band.

To create a header and footer using a table:

1. Find the header or footer band. Usually, you can locate the page header band by looking for the band that contains the column headings. You can locate the page footer band by looking for the band that contains the date and page number.

2. Double-click the header or footer band.

3. Add text, graphics, or special fields.
To repeat column headings on each page, move them to the page header band.

**Using Repeating Objects**

Use repeating objects to display text and graphics, added from a report, on multiple pages. Your report may contain footers on odd-numbered pages that are different from footers on even-numbered pages.

You can change a repeating object only on the page you created it, and not on another page of the report.

**To create a header and footer using a repeating object:**

1. Add text, graphics, or special fields (such as a page number) to a report.
2. Select the items.
3. On the *Format* menu, click *Properties*.
4. In the *Properties* dialog box, click the *General* tab.
5. On the *General* page, in the *Repeat Every* area, specify how often you want the object to appear horizontally and vertically:
   - To display an object on every page, specify 1 and 1.
   - To display an object only on odd-numbered pages, specify 2 horizontally, 2 vertically, or both.
6. Click *OK*.

**Specifying Data Formats**

When results are returned from the database in BI Query, the format in which they are displayed (the ‘display format’) may not be how you want them represented in a report. You can specify different formats for different purposes.

**Specifying a Format for Null Values**

By default, null values are displayed as `<null>`. You can display null values using any value you want. To reduce clutter in a table, you can display nulls as blanks.

**To specify the format for null values:**

1. Click a null value.
2. On the *Format* menu, click *Properties*. 
If the rows and columns in a crosstab contain only null values, you can hide those rows/columns. On the Format menu, click Crosstab, and then click Hide Null Rows & Columns.

3. On the Format page of the Properties dialog box, type a format for the null value into the Show Null As box.

4. Click OK.

Specifying a Number Format

You can choose from, and modify, a number of predefined formats for numeric data. For example, you can include a prefix (such as a currency symbol—$, £, ¥, and so on) or a suffix (such as % or ¢). You can specify the number of decimal places and display numbers in exponent notation or as a percentage. You can show numbers in tens, thousands, and so on.

To specify the format for a positive or negative number:

1. Click a number.
2. On the Format menu, click Properties.
3. On the Format page of the Properties dialog box, click a predefined format or click the Edit button beside the Positive Number list or the Negative Number list to modify a format.
4. If you are modifying a format, in the Define Numeric Format dialog box, make the required changes.
5. Click OK.
6. In the Properties dialog box, click OK.

Specifying a Date and Time Format

You can choose from a number of predefined formats for dates and times. You can also use date/time formatting to display only one part of a date, for example, only the year.

For data that displays date plus time, you can display dates without the time. Instead of 08/10/2001 1:00:00, you can display the date more understandably as October 8, 2001. If the time is not needed, do not include it.
To specify the format for a date or time:

1. Click a date or time.
2. On the Format menu, click Properties.
3. On the Format page of the Properties dialog box, click a predefined format or click the Edit button beside the Date/Time list to modify a format.
4. If you are modifying a format, in the Define Date/Time Format dialog box, make the changes you want.
5. Click OK.
6. In the Properties dialog box, click OK.

About Converting Two and Four-Digit Years

When you type a two-digit year, or import a data source that contains two-digit years, BI Query Reports automatically converts them to four-digit years. This ensures that your reports are unaffected by dates that involve the century change from 1999 to 2000.

To enable BI Query Reports to convert two-digit years, you need to specify the range of dates in your data, then establish whether dates are sliding or fixed. The start and end years of sliding dates are incremented by one each time the current year changes. The start and end years of fixed dates do not change.

Two-digit years are converted by adding a century according to the date window you specify. A date window consists of a start year and an end year that is 99 years after the start year. A century is added to two-digit years so that they fall on or between the start year and the end year of the date window.

The type of date you specify applies to all Hummingbird business intelligence products, so what you specify in one product affects all other products you use. Consider your organization’s requirements carefully before choosing a date type.

You use the Date Entry dialog box to specify a start year for your data. BI Query Reports automatically calculates an end year that is 99 years after the start year. When you type two-digit years in BI Query Reports, BI Query Reports adds a century prefix so that the years fall on or between the start year and the end year displayed.
Two-Digit Year Conversion

A date window with a start year of 1918 and an end year of 2017, adds the century 19 to all two-digit years greater than or equal to 18 and the century 20 to all two-digit years less than or equal to 17. For example, when you enter 45, it is converted to 1945, when you enter 15, it is converted to 2015.

If the date window is a Sliding date window, the start year changes to 1922 and the end year changes to 2021 when the current year changes, for example, from 2001 to 2002. If you have specified dates as fixed, the years remain the same—1921 and 2020.

Changing the Date Window

If you change the date window after you have entered two-digit years, the new date window is not applied to the dates you have already entered. Changes you make to the date window in one Hummingbird business intelligence product affect all other Hummingbird business intelligence products.

Converting Two-Digit Years

To convert two-digit years to four-digit years:

1. On the Tools menu, click Date Entry.
2. In the Date Entry dialog box, type the start year for the date window. The end year is calculated automatically.
3. Click Sliding or Fixed.
4. Click OK.

If you change the date window after you have entered two-digit years, the new date window is not applied to the dates you have already entered.

Specifying a Format for Strings

By default, strings are displayed as they appear in the data. For example, a telephone number might appear as 5551212. You can apply a format to the string by including additional information (such as a punctuation mark or a code) or excluding unwanted information, making the strings more intuitive for those reading the report.
Specifying a Number Format

To use string formatting, you create a template string for the data; the template can contain special control characters that dictate the data format. The following special characters are available:

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Inserts a character from the original data (in sequence).</td>
</tr>
<tr>
<td>_</td>
<td>Suppresses a character in the original data (in sequence).</td>
</tr>
<tr>
<td>*</td>
<td>Inserts the remaining characters in the original data.</td>
</tr>
<tr>
<td>\</td>
<td>Inserts the next character as is. Use this character to include one of the special formatting characters as itself. For example, type # to insert the # symbol.</td>
</tr>
</tbody>
</table>

To insert any other character, type it where you want it to appear in the string.

To specify the format for strings:
1. Click the object containing the string to which you want to apply the new format.
2. On the Format menu, click Properties.
3. On the Format page of the Properties dialog box, click a predefined format or click the Edit button beside the String list to modify a format.
4. If you are modifying a format, in the Define String Format dialog box, type the template formatting string you want to apply to the data. Use the special characters described above.
5. Click OK.
6. In the Properties dialog box, click OK.

String Formatting Example
A database stores telephone numbers as 13-character strings (for example, 6135554355x26). To format this data as a recognizable phone number, you can create the following template:

(###) ####-####_ Ext. \#

If you apply this template, BI Query Reports formats the value 6135554355x26 as
Creating Report Backgrounds

About Report Backgrounds

Backgrounds let you apply a consistent look from report to report. When you are creating reports on a regular basis, backgrounds eliminate the need to specify formats each time. They are particularly important when you want to create professional-looking reports for external use—to be sent to clients, customers, or shareholders. Backgrounds provide company identification and help you adhere to corporate standards by using consistent logos, mastheads, and text.

Backgrounds define a report’s overall look. They can include lines, borders, colors, graphics, and page numbering. They can also include text objects that are not associated with particular data, for example, rich text objects and text labels but not special fields that contain prompt values from a query.

When you create a background, you can display objects on multiple pages of a report or on specific pages. For example, you can add a border and display it on every page, or your corporate logo on just the first page.

💡 For more information, see “Using Repeating Objects” on page 221.

Creating Report Backgrounds

You can create backgrounds in a new report or using an existing report.

🔍 When you create a background, you must save the corresponding report. If you do not save the report, you will not be able to edit the background and will have to recreate it.

To create a background:

1. Create a report.
2. Add the required items to the background.
   💡 For more information, see “Using Repeating Objects” on page 221.
3. Format the items, arrange them, and specify on which pages of the report you want them to appear.
4. On the File menu, click Save As.
5. In the Save As dialog box, save it first as a Report (*.rep), then as a Template (*.tpl).

**To modify a background:**

1. Open the corresponding report.
2. Make the required changes.
3. Save the report.
4. Apply the changes to the background by saving over the original background.

### Applying Backgrounds

You can apply backgrounds to any report. If you want to replace a background in a report, simply apply the new background.

⚠️ You cannot have multiple backgrounds in one report. If you apply one background to a report and then apply a second background to it, the second background overrides the first.

**To apply a background:**

1. On the Format menu, click Report, and then click Set Background.
2. In the Open dialog box, click a background with the extension .tpl.
3. Click Open.

**To remove the background:**

1. On the Format menu, click Report, and then click Clear Background.
Performing Calculations

By adding user-defined or pre-defined calculations and exceptions to reports, you can increase the usefulness of your reports.

- “Calculations and Exceptions” on page 229
- “Working with Calculations” on page 237
- “Examples of Calculations” on page 243
- “Using Exceptions” on page 247
- “Examples of Exceptions” on page 251

Calculations and Exceptions

You can perform a wide variety of calculations that increase the usefulness of reports.

Predefined Calculations

Adding predefined (standard) calculations lets you quickly add totals, averages and so on. Examples include: total sales, a count of customers in each sales region, and the average amount of orders placed by your customers this month.
User-Defined Calculations

To perform calculations other than the predefined ones, you can create your own using BI Query Reports’ sophisticated calculation capability. For example, you can create a calculation to show what percentage of revenues are being contributed by each regional sales office.

Multi-Pass Calculations

You can perform multi-pass calculations where one calculation is based on another calculation that is based on yet another calculation. For example, consider the following diagram of a multi-pass calculation:

![Multi-Pass Calculation Diagram]

In this example, there are two separate base calculations, A and M. All calculations at the lowest level (D, E, P, and Q) are performed first. Next, calculations at the middle level (B, C, N, and O) are performed next. Finally, calculations at the highest level (A and M) are performed.

BI Query Reports performs calculations in the background, so you are free to carry out other activities.

Exceptions

You can highlight exceptions based on the calculations you create. Exceptions let you rank performance, emphasize important numbers, and create summary reports.

Types of Calculations

You can perform four types of calculations: numeric, string, date/time, and logical.
Numeric

Numeric calculations use one or more arithmetic operators (+, -, *, /, ^) to calculate values. For example:

Gross Margin = (Revenue - Cost)/Revenue

String

String calculations manipulate text strings, which are text enclosed in double quotation marks (" "). You can use string calculations to combine text from several table columns, change the case (capitalization) of text characters, and find and replace occurrences of certain text characters in cells. For example:

Full name = 'First Name' + " " + 'Last Name'

Date/Time

Date/time calculations manipulate dates and times. You can use date/time calculations to isolate the relevant part of a date (such as the time, the day of the week, the month, or the year). For example:

Month = Month ('Order Date')

Logical

Logical calculations evaluate a condition and return 1 if the condition is true and 0 if the condition is false. You can use a logical calculation to test whether a value meets a condition before using it in other formulas. Logical calculations use the logical operators < (less than), > (greater than), = (equal), <> (not equal), <= (less than or equal), >= (greater than or equal), Not, And, and Or. For example:

Status = IF ('Account Balance' >= 0, 'Account Balance', "Overdrawn")

About Functions

Functions are built-in formulas that perform specific calculations. Because functions perform calculations automatically, you can use them to create calculations quickly and easily.

When you add an aggregate function to a table, it is prefaced with the letters ff.
## About By Argument

A By argument is a syntactical argument that identifies:

- a column of data that is acting as the control
- a column that is being acted upon

In the calculation:

```plaintext
Avg (‘Amount’) By ‘Month’
```
Month is the control by which Amount is averaged. Each time the data for Month changes, an average is calculated for Amount.

About Expressions

To build calculations and exceptions, you need to build expressions. Expressions can be as simple as numbers or column names, or they can be as complex as a multi-part conditional If statement. You can create expressions using metrics, operators, functions, and constants.

Examples of common expressions are:

Variance = Revenue - Plan
Percent Variance = ((Revenue - Plan)/Plan * 100)
Margin = Revenue - Cost
Net Profit Margin = Net Income/Sales
Revenue per Employee = ('Total Sales' / 'Total Employees')
Full Name = 'First Name' + “ ” + ‘Last Name’
July Bonus = IF ('July Sales' >= 10000 , 'July Sales' * .15 , IF ('July Sales' >= 5000 , 'July Sales' * .10 , 'July Sales' * .02))
Remaining Credit = If ('Credit Limit' > 'Current Receivable') , ('Credit Limit' - 'Current Receivable') , "Over Credit Limit")
Renew with Gift = If ({Renewal} = "Y" Or

Operators Table

Operators indicate what to do with the values in an equation. You can apply arithmetic, comparison, and logical operators.

Arithmetic Operators

Arithmetic operators are mathematical symbols that indicate the operation you want to perform. Arithmetic operators are referred to as Operators in the Calculations dialog box.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plus</td>
<td>+ (plus sign)</td>
</tr>
<tr>
<td>Minus</td>
<td>- (hyphen)</td>
</tr>
<tr>
<td>Times</td>
<td>* (asterisk)</td>
</tr>
<tr>
<td>Divide</td>
<td>/ (forward slash)</td>
</tr>
</tbody>
</table>
Chapter 10: Performing Calculations

Comparison Operators
Comparison operators are symbols that indicate comparisons between a member/column in a view and another value. Comparison operators return a logical value of either TRUE or FALSE. Comparison operators are referred to as **Conditional Operators** in the **Calculations** dialog box.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Negative</td>
<td>- (hyphen)</td>
</tr>
<tr>
<td>Power</td>
<td>^ (chevron)</td>
</tr>
</tbody>
</table>

Logical Operators
Logical operators define the relationship between two parts of an expression in a conditional statement. For example, two parts of a statement may have to be TRUE for the result to be TRUE: If A And B = C then TRUE, if not then FALSE. The “And” in the previous statement is a logical operator. Logical operators are part of **Conditional Operators** in calculations. There are three logical operators used in BI Query Reports: Not, And, Or.
Syntax Table

The following table lists the syntax used in creating calculations.

<table>
<thead>
<tr>
<th>To Do This</th>
<th>Use This</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control the order of operations and identify the arguments of a function.</td>
<td>Parentheses ( )</td>
<td>(15+10) x 2</td>
</tr>
<tr>
<td>Separate the two extremes of a range.</td>
<td>Colon:</td>
<td>‘Western Region’: ‘Eastern Region’:</td>
</tr>
<tr>
<td>Separate the arguments in an argument list.</td>
<td>Comma,</td>
<td>“Rent”, “Electricity”, “Phone”</td>
</tr>
<tr>
<td>Commas are not used in numbers as separators. For example, the number one thousand is represented as 1000 in calculations, not as 1,000.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Enclose attribute names in calculations.</td>
<td>Single quote ‘ ’</td>
<td>‘Western Region’ There is a space between Western and Region and therefore there needs to be single quotes around them.</td>
</tr>
<tr>
<td>Enclose the name(s) of external views referenced in a calculation.</td>
<td>Brackets [ ]</td>
<td>['View 2 (Amount.hcr)']</td>
</tr>
</tbody>
</table>
Chapter 10: Performing Calculations

Precedence Table

BI Query Reports performs operations in calculations in a certain order of precedence. For example, in the calculation 15+10 x 2, the order of precedence is to multiply 10 by 2, then add 15. However, if you want to add 15 to 10, then multiply the sum by 2, you must specify the order of precedence using parentheses: (15+10) x 2.

<table>
<thead>
<tr>
<th>Level</th>
<th>Operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Parentheses ( )</td>
</tr>
<tr>
<td>2</td>
<td>NOT</td>
</tr>
<tr>
<td>3</td>
<td>Negative (-)</td>
</tr>
<tr>
<td>4</td>
<td>Power (^)</td>
</tr>
<tr>
<td>5</td>
<td>Times (*); Divide (/); AND</td>
</tr>
<tr>
<td>6</td>
<td>Plus (+); Minus (-); OR</td>
</tr>
<tr>
<td>7</td>
<td>Equals (=); Less than (&gt;); Greater than (&lt;); Not equal to (&lt;&gt;)</td>
</tr>
</tbody>
</table>
Working with Calculations

Predefined and User-Defined Calculations

You can add a wide range of predefined or user-defined calculations to tables and crosstabs in reports.

Calculations are stored in views. When you add a calculation to one presentation (such as a sum to a crosstab), it is also added to any other presentation (such as a chart) that is linked to the first presentation through the view. Calculations that you add to views are available in a list that you can choose from.

Predefined

For frequently-performed calculations, BI Query Reports provides a number of predefined (standard) calculations. You can add all types of predefined calculations to tables (Average, Sum, Sum Distinct, Count, Count Distinct, Minimum, Maximum, Percent of Total, and Standard Deviation).

💡 For a description of a nested dimension, see “Changing How Dimensions are Nested in a Chart” on page 126.

You can add basic calculations (Average, Sum, Count, CountAll, Minimum, and Maximum) to crosstabs. Adding a total to the outermost dimension in a crosstab adds a grand total, while adding a total to a nested dimension adds a subtotal.

User-Defined

When you need to add calculations other than those provided by BI Query Reports, you can create your own. You can add a wide range of sophisticated calculations to tables and crosstabs.
Adding Predefined Calculations to Tables

When you add predefined calculations to tables, you can add them to one column or multiple columns. For example, you can sum or count the items in more than one column at once. Keep in mind that you need to know whether to add the calculation to an entire column or to a group of data within the column. For example, adding a sum to a table creates a grand total; adding a sum to a group of data creates a subtotal.

- If the footer is not displayed, adding a calculation to a group displays it automatically.
- When you add a calculation (such as Running Count All) to a table that does not have group breaks, the calculation appears as a new column in the table.

To add a predefined calculation to a table:

1. To add a single calculation, click a value in a column. To add a calculation to more than one column, hold down CTRL, and then click a value in each column.
2. On the Tools menu, click Calc-O-Matic.
3. In the Calc-O-Matic dialog box, click a calculation.
4. To apply the calculation to one or more groups, click the group(s) under On.
5. To apply the calculation to the entire column as a grand total, click Entire Column.
6. Click OK.

Adding a Grand Total

Adding a sum to a table creates a grand total; adding a sum to a group of data creates a subtotal.

To add a grand total to a table:

1. Click an item in the column you want to total.
2. On the Tools menu, click Calc-O-Matic.
3. In the Calc-O-Matic dialog box, click Sum in the Function list.
4. In the On list, click Entire Column.
5. Click **OK**.

**Adding Calculations to Groups**

When you add a predefined calculation to a table, you need to decide whether you are adding it to a group of data within a column, an entire column of data, or multiple columns. For example, adding a sum to a group of data creates a subtotal, but adding a sum to a table creates a grand total.

- If the footer is not displayed, adding a calculation to a group displays it automatically.
- When you add a calculation (such as **Running Count All**) to a table that does not have group breaks, the calculation appears as a new column in the table.

**To add a calculation in groups in a table:**

1. Click an item in a column.
2. On the **Tools** menu, click **Calc-O-Matic**.
3. In the **Calc-O-Matic** dialog box, click a calculation (for example, click **Sum**).
4. To apply the calculation to one or more groups within the column(s), click the group(s) under **On**.
5. Click **OK**.

**Adding Predefined Calculations to Crosstabs**

You can add basic calculations (Average, Sum, Count, CountAll, Minimum, and Maximum) to crosstabs. If you add a calculation to a member in a crosstab and then hide the member, the calculation becomes invalid.

**To add a predefined calculation to a crosstab:**

1. Double-click a crosstab to activate it.
2. Click a column or row heading.
3. On the **Tools** menu, click **Calc-O-Matic**.
4. In the **Calc-O-Matic** dialog box, click a calculation.
5. Click **OK**.
Chapter 10: Performing Calculations

Adding Totals

Adding a total to the outermost dimension adds a grand total, while adding a total to a nested dimension adds a subtotal.

To add a total to a crosstab:
1. Double-click a crosstab to activate it.
2. Click the first label in the range you want to total, then hold down SHIFT, and then click the last label in the range.
4. In the Calc-O-Matic dialog box, click a calculation (for example, click Sum).
5. Click OK.

Adding User-Defined Calculations to Tables

When you need to add calculations to tables other than those provided by BI Query Reports, you can specify your own.

To add a user-defined calculation to a table:
1. Click a table.
2. On the Tools menu, click Calculations.
3. In the Calculations dialog box, click New.
4. Click the Description tab.
5. On the Description page, type a name and description, or use the default name.
6. Click the Editor tab.
7. On the Editor page, create the expression. You can double-click items from the Members and Functions lists to include them in the expression, or type them into the Expression text box. Each item appears in the Expression text box.
8. To check the syntax of the calculation, click Check.
9. Click OK.

When you insert numbers into calculations, do not use commas. For example, the number one thousand is entered as 1000, not as 1,000.
Adding User-Defined Calculations to Crosstabs

When you need to add calculations to crosstabs other than those provided by BI Query Reports, you can specify your own.

To add a user-defined calculation to a crosstab:
1. Double-click a crosstab to activate it.
2. On the Tools menu, click Calculations.
3. In the Calculations dialog box, click New.
4. In the Dimension List dialog box, click the dimension to which you want to add the calculation.
5. Click OK.
6. In the Calculations dialog box, click the Description tab.
7. On the Description page, type a name and description, or use the default name.
8. Click the Editor tab.
9. On the Editor page, create the expression. You can double-click items from the Members and Functions lists to include them in the expression, or type them into the Expression text box. Each item appears in the Expression text box.
10. To check the syntax of the calculation, click Check.
11. Click OK.

When inserting numbers into calculations, do not use commas. For example, enter one thousand as 1000 (not 1,000).

Naming and Describing Calculations

Use the Name tab in the Calculations dialog box to name and describe calculations.

To name and describe a calculation:
1. Click a table. Double-click a crosstab to activate it.
2. On the Tools menu, click Calculations.
3. Click the List tab.
4. On the List page, click a calculation.
5. Click the Description tab.
6. On the Description page, type a name and description.
7. Click **OK**.

**Editing Calculations**

You can modify the name, description, or expression for any calculation you added to a table or crosstab.

**To edit a calculation:**
1. Right-click a calculation.
2. Click **Calculations** from the shortcut menu.
3. Edit the calculation.
4. To check the syntax, click **Check**.
5. Click **OK**.

**Deleting Calculations**

You can delete calculations using the **Delete** button in the **Calculations** dialog box. If another calculation depends on a deleted calculation, it becomes invalid. You then need to either edit or delete the calculation.

**To delete a calculation:**
1. Click a table or crosstab.
2. On the **Tools** menu, click **Calculations**.
3. Click the **List** tab.
4. On the **List** page, click the calculation that you want to delete.
5. Click **Delete**.

You cannot undo this action even if you click **Cancel** in the **Calculations** dialog box.

6. Click **OK**.

**Creating a Calculation Using the ALL Function**

💡 For a description of the ALL function, see the Help for BI Query Reports.
You can use the ALL function in a crosstab to create a calculation that is based on all members in a dimension. This function includes all visible members except calculated members. When you create an expression, the ALL function lets you specify all the members in a dimension at once instead of individually. You can use ALL with any cell-based function, for example, Sum, Avg, Count, and so on.

To create a calculation using the ALL function:
1. Click a crosstab.
2. On the **Tools** menu, click **Calculations**.
3. Click the **List** tab.
4. On the **List** page, click **New**.
5. In the **Dimension List** dialog box, click the dimension on which you want to base the calculation and in which you want the calculation to appear.
6. Click the **Editor** tab.
7. On the **Editor** page, double-click **Cell-Based Functions** in the **Functions** list, then double-click a function.
8. Click inside the parentheses in the **Expression** text box, then type ALL.
9. To check the syntax of the calculation, click **Check**.
10. Click **OK**.

**Examples of Calculations**

**Combining Data Items Using Calculations**

You can combine data items using a calculation. You can modify the calculation shown below when you create reports or use it as an example when creating your own calculations.

To combine data items using a calculation:
1. Click anywhere in a table.
2. On the **Tools** menu, click **Calculations**.
3. In the **Calculations** dialog box, click **New**.
4. Click the **Description** tab.
5. On the **Description** page, type a name and description for the combined data item.
6. Click the **Editor** tab.

7. On the **Editor** page, double-click **Columns** under **Members** to display the list of available data items, then double-click the data item you want to appear first in the combined item.

8. Click at the end of the expression, then type + (plus sign).

9. To add a character (such as a space or comma) between the two data items, click inside the **Expression** text box.

10. Type the character and enclose it in double-quotes: “,”.

11. Type + (plus sign).

12. Double-click the second data item under **Members** that you want to combine.

13. If one of the data items you are combining is numeric, you must convert it to a string:
   a. Under **Functions**, double-click **Type Converters**.
   b. Double-click **Str**.
   c. Click inside the brackets for Str ( ), then enter the data item by following step 7.

   For example, to join a data item containing employee last names with a data item containing their salaries, the expression would look like:

   `'staff.last_name' + ': ' + Str('staff.salary')`

14. To check the syntax of the calculation, click **Check**.

15. Click **OK**.

**Creating a Percent of Total in a Crosstab**

In a report, you can add calculations that are based on other calculations. For example, Percent of Total is a commonly used calculation that shows the percentage of any value to the whole (such as what percentage a country’s sales are to total sales). In this example, you first calculate total sales and then you add a second calculation that specifies a cross-reference to the cell that contains the grand total (total sales).

**To create a percent of total in a crosstab:**

1. In a crosstab, add a grand total. For example, to add a percent of total to a crosstab of sales by country, add a grand total to the Amount column.

2. Select the crosstab.
3. On the **Tools** menu, click **Calculations**, and then click the **List** tab.
4. On the **List** page, click **New**.
5. In the **Dimensions** dialog box, click **Metrics**, and then click **OK**.
6. Click the **Editor** tab.
7. On the **Editor** page, specify the member for which you want to calculate the percent of total. For example, double-click **Metrics** under **Members**, then double-click **Sum Amount**.
8. In the **Expression** box, click at the end of the expression, then type a slash (/).
9. Click **Cell Select**.
10. In the **Data Cell Selector** dialog box, in the **Dimensions** box, click the cell (first the column, then the row) containing the calculation.

   For example:
   a. In the **Data Cell Selector** dialog box, under **Dimensions**, click the blue icon on the right side of *(every:Metrics)*, and then click **Sum Amount** from the **Choose Member** dialog box.
   b. Click the blue icon on the right side of *(every:Description)*. Click the row containing the grand total from the **Choose Member** dialog box.
11. Click **OK**.
12. In the **Calculations** dialog box (**Editor** page), click at the end of the expression, type * (asterisk), then type 100. For example, ‘sales.ord_amount’/{'Calc1’,’sales.ord_amount’}*100
13. Click **OK**.

### Replacing Numeric Values with Text Strings

You can replace numeric values in calculations with text strings. This is useful if you want to replace codes with descriptive labels or numbers that meet a certain condition with a warning. For example, if you are tracking overdue accounts, you can create a report that displays the text **Overdrawn** for any account with a negative balance.
To replace a numeric value with a text string, add a conditional If-Then-Else expression as follows:

1. In the first part of the expression, set up the condition. For example, if you are comparing two values, check whether the first value is greater than the second value.

2. In the second part of the expression, assign the text string to the values that meet the condition.

3. In the third part of the expression, assign the text string to the values that do not meet the condition.

4. To check the syntax, click Check.

5. Click OK.

Example: Replacing a Numeric Value with a Text String

To create a column that lists the remaining credit for customers, displaying the text Overdrawn for those customers who have exceeded their credit limit, create the following expression:

If ('Receivable'>'Credit Limit', "Overdrawn", 'Credit Limit')

Pointing to a Specific Value

Occasionally, you may want to create calculations that point to a value in a specific cell in a table or crosstab.

To point to a specific cell:

1. Create a new calculation.

2. On the Editor page of the Calculations dialog box, click Cell Select.

3. In the Data Cell Selector dialog box, under Dimensions, click the icon on the right side of the dimension you want.

4. In the Choose Member dialog box, click the item containing the value you want to use.
5. In the **Data Cell Selector** dialog box, under **Dimensions**, click the icon on the right side of the dimension you want. For example, click the icon for Rows.

6. In the **Choose Member** dialog box, click the row number containing the value you want to use. To determine which row contains the value you want:
   - Click a row.
   - Check the sample value listed in the **Sample Values** box. If it is not the value you want, choose another row.

7. Click **OK**.

8. In the **Calculations** dialog box, finish creating the expression.

9. To check the syntax, click **Check**.

10. Click **OK**.

**Example: Pointing to a Specific Value**

You may have a column called Conversion Rates that contains currency-conversion rates for the U.S., Canada, and other countries. You can specify a cell containing a specific value, such as the conversion rate for Canadian dollars, in a calculation using the **Cell Selector**. When you refresh the report, the calculation always points to the updated value of the specified cell.

**For example, to specify a U.S. conversion rate:**

1. On the **Editor** page of the **Calculation** dialog box, click **Cell Select**.
2. Click the blue icon on the right side of the Columns item.
3. Choose the Conversion Rates item.
4. Click the icon on the right-side of the Rows item. If the U.S. rate is in Row 4, click **Row 4**.
5. Click **OK** to close the **Cell Select**.
6. Finish creating the expression.

**Using Exceptions**

BI Query Reports lets you add exceptions to your reports. Exceptions highlight important information so you can see it easily. For example, you can highlight sales that are below a certain threshold or employees whose performance exceeds certain targets. Exceptions are also useful when you want to create summary reports or reports that rank performance.
Exceptions are normally highlighted using a particular font, style, color, or graphic. They can also be represented by data, objects—such as bands in a table—and graphics. You can flag exceptions when they match the calculation you have created, when they do not match, or both.

If your reporting environment includes BI Server and you have the appropriate system permissions, you can create exceptions that trigger events. This type of exception is created in the same way as other exceptions except you do not have to choose formatting options or apply it to an object in the report.

Creating Exceptions

Creating exceptions is a two-part process. You begin by creating the expression on which your exception is based. Then you apply the exception.

💡 For more information, see “Applying Exceptions” on page 249.

To create an exception:

1. Click a table to activate it. Alternatively, double-click a crosstab.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, click New and then click the Description tab.
4. On the Description page, type a name and description.
5. Click the Editor tab.
6. On the Editor page, specify the condition for the exception. For example, to create an exception that identifies sales that are greater than $1,000,000:
   a. Double-click Columns under Members.
   b. Double-click Order Amount, click in the Expression box, then type \(> \) (greater than), then type 100000. Do not include If at the beginning of the expression.
      
      The Expression looks like this: ‘Sales.order_amount’>100000.
6. To check the exception syntax, click Check.
8. To highlight values when they meet the exception, select the True check box. To specify a different format for values that meet the exception, click True.
   To highlight values when they do not meet the exception, select the False check box. To specify a different format for values that do not meet the exception, click False.
9. Click OK then apply the exception.
Naming and Describing Exceptions
Use the Description tab in the Exceptions dialog box to name and describe exceptions.

To name and describe an exception:
1. Click a table or a crosstab.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, click an exception.
4. Click the Description tab.
5. On the Description page, type a name and description.
6. Click OK.

Applying Exceptions
You can apply exceptions to data or to objects such as bands in a table, text, graphics, or other presentations (charts and crosstabs). You can control whether the data or object is visible when the exception is true, false, or both true and false.

For example, if you want to display a chart only when sales are below target, you create the chart, then apply the exception to it, setting the display status to When True. You can reuse exceptions, applying them to more than one object in a report. You cannot apply more than one exception to the same object. However, you can work around this by adding multiple objects.

Applying Exceptions to Data
Normally, you apply an exception to the same data you used to create it. For example, if you want to highlight sales greater than $100,000 in a bold green font, you create the exception using the Sales column and apply it to the column.

To apply an exception to data:
1. Select the data. For example, click an item in a table.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the General tab.
4. On the General page, make sure that the presentation you used to create the exception is displayed in the Source View box. If it is not, click it from the Source View list.
5. Choose the exception from the **Exception Name** list.

6. If you want to link the exception to a specific cell in a crosstab, click **Cell Select**, then click the cell.

7. Under **Display Status**, click an item.

8. Click **OK**.

## Applying Exceptions to Objects

You can also apply exceptions to text, graphics, presentations, bands, and other objects. Applying exceptions to objects lets you hide or display the object according to the exception. For example, if a particular cost center is more than 25% over budget, you can display a chart containing a breakdown of its expenses. You can also display only the top ten sales representatives or add graphics, such as a gold star, beside the names of those representatives who exceed their quota.

**To apply an exception to an object:**

1. Click an object.

2. On the **Format** menu, click **Properties**.

3. In the **Properties** dialog box, click the **General** tab.

4. On the **General** page, click the presentation that you used to create the exception from the **Source View** list.

5. In the **Exception Name** list, click an exception.

6. If you want to link the exception to a specific cell in a table or crosstab, click **Cell Select**, then use the **Data Cell Selector** dialog box to choose a cell.

7. Click an item under **Display Status**.

8. Click **OK**.

When you apply an exception to the detail bands of a table and specify that they should display only when the data in them matches the exception, the bands that do not match automatically collapse to avoid gaps in the table.

For example, you might want to select empty bands and remove the exception. To display them, on the **Format** menu, click **Table** and then click **Expand**.

## Deleting Exceptions

You can delete an exception from the list of exceptions. If you delete an exception, you will not be able to use it again in the report.
To delete an exception:
1. Select either a table or a crosstab.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, click the exception that you want to delete.
4. Click Delete.

   ! You cannot undo this action even if you click Cancel in the Exceptions dialog box.

5. Click OK.

Removing Exceptions

You can remove an exception that was previously applied to data or an object. If you remove an exception, you can re-apply it.

To remove an exception:
1. Select the object that has the exception applied to it.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the General tab.
4. On the General page, click "<no exception>" on the Exception Name list.
5. Click OK.

Examples of Exceptions

An Exception that Ranks the Top Ten

Many organizations like to rank performance. For example, you might want to rank the top ten sales representatives, mutual funds, or production lines. You can create a calculation that ranks performance, then use an exception to display only the top ten. You can easily change this exception to display only the top five or bottom ten.

To rank the top ten performers:
1. When you create the query in BI Query, apply a descending sort on the attribute you want to rank.
2. In BI Query Reports, add a calculation to show the ranking.
3. Add an exception that looks for the top ten.
4. Apply the exception to the detail bands of the table.

Example of the Top-Ten Calculation

1. Click a table.
2. On the Tools menu, click Calculations.
3. In the Calculations dialog box, click New and then click the Description tab.
4. On the Description page, type Rank in the Name box.
5. Click the Editor tab.
6. On the Editor page, double-click Simple Aggregate under Functions, then double-click Running Count.
7. Double-click Columns under Members, then double-click Sales.
8. Click OK.

Example of the Top-Ten Exception

1. Click a table.
2. On the Tools menu, click Exceptions.
3. In the Exception dialog box, click New and then click the Description tab.
4. On the Description page, type Top Ten.
5. Click the Editor tab.
6. On the Editor page, double-click Columns under Members, then double-click Rank.
7. Type <= (less than or equal to) at the end of the expression, then type 10.
8. Click OK.

Example of Applying the Top-Ten Exception

1. In the table, click the detail band.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the General tab.
4. On the General page, click Top Ten on the Exception Name list.
5. Click Show When True and click OK.
An Exception that Highlights Performers

One of the most common ways that organizations use exceptions is to highlight the best or worst performers. You can create an exception that checks values against a certain metric, then highlight the numbers that fall above or below that metric.

To highlight the best and worst performers:

1. Click a table.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, click New and then click the Description tab.
4. On the Description page, type Best and Worst Performers in the Name box.
5. Click the Editor tab.
6. On the Editor page, click True.
7. In the True Style Properties dialog box, click the Line tab.
8. On the Line page, click No Line and then click OK.
9. On the Editor page, click False.
10. In the False Style Properties dialog box, click the Font tab.
11. In the Color list, click Red.
12. Click the Line tab.
13. On the Line page, click No Line and then click OK.
14. On the Editor page, double-click Columns under Members, then double-click Sales.
15. Type > (greater than), then type 3000000.
16. Click OK.
17. In the table, click the Sales item.
19. In the Properties dialog box, click the General tab.
20. In the Exception Name list, click Best and Worst Performers.
21. Click Show Always.
22. Click OK.
Creating Summary Reports

A summary report can contain many rows of data but display only the data that meets a certain criteria. You can also use exceptions to create summary reports. Summary reports serve two purposes. For example, you can create a report that displays account information for all your customers. Then, if your manager wants a report that lists only those customers who have exceeded their credit limit, you can turn the report into a summary report by hiding the customers who have not exceeded their credit limit.

To create a summary report:

1. Click a table.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, click New and then click the Description tab.
4. On the Description page, type Over Credit Limit in the Name box.
5. Click the Editor tab.
6. On the Editor page, double-click Columns under Members and then double-click Remaining Credit.
7. Click at the end of the expression and type > (greater than), then type 0.
8. Click OK.
9. Click a detail band.
11. In the Properties dialog box, click the General tab.
12. In the Exception Name list, click Over Credit Limit.
13. Click When True.
14. Click OK.

Highlighting Alternate Rows

If all of the rows in a table are formatted in the same way, you can create an exception that highlights every other row. This visually breaks up the information in the table and makes it easier to read.

To highlight alternate rows:

1. Click the table.
2. On the Tools menu, click Exceptions.
3. On the **List** page of the **Exceptions** dialog box, click **New** and then click the **Description** tab.

4. On the **Description** page, name the exception. For example, call it **GreenBars**.

5. Click the **Editor** tab.

6. On the **Editor** page, type the following expression:
   \[ \text{ffrunningcount( )} / 2 = \text{int}(\text{ffrunningcount ( )} / 2) \]

7. Click **True**.

8. In the **True Style Properties** dialog box:
   a. Click the **Line** tab.
   b. Click **No Line**.
   c. Click **OK**.

9. On the **Editor** page, click **False**.

10. In the **False Style Properties** dialog box, click the **Fill** tab:
    a. Click **Fill Color**, and then click a light green color.
    b. Click **OK**.
    c. Click the **Line** tab.
    d. Click **No Line**.
    e. Click **OK**.

11. In the **Exception** dialog box, click **OK**.

12. Click the detail band.

13. On the **Format** menu, click **Properties**.

14. In the **Properties** dialog box, click the **General** tab.

15. On the **General** page, click **GreenBars** from the **Exception Name** list and make sure **Show Always** is selected.

16. Click **OK**.

**Creating an Exception Using the ALL Function**

The ALL function in a crosstab lets you create an exception that is based on all members in a dimension.
To create an exception using the ALL function:

1. Click a crosstab.
2. On the **Tools** menu, click **Exceptions**.
3. On the **List** page of the **Exceptions** dialog box, click **New**.
4. Click the **Editor** tab.
5. On the **Editor** page, double-click **Cell-based Functions** in the **Functions** list and then double-click a function.
6. Click inside the parentheses in the **Expression** text box, type ALL, press the space bar, then type the name of the dimension in which the members are contained.
7. Finish creating the expression. For example, the expression could be: 
   
   ```
   Sum (ALL regional_offices.country_Dimension) > 20000
   ```
8. To check the syntax of the calculation, click **Check**.
9. Click **OK**.
Working with BI Server

With BI Server, you can publish reports to a repository. In addition, you can set report security levels based on individual users or groups.

- “About BI Server” on page 257
- “About Security” on page 259
- “User and Group Structures” on page 260
- “Setting Security for Reports” on page 261
- “About Scheduling” on page 262

About BI Server

If you are in a BI Server environment, you can take advantage of BI Server’s publishing, retrieving, and security features.
The BI Server repository is a storehouse for enterprise information produced using BI applications. If you have been assigned the appropriate system permissions, you can publish BI Query information to the repository and you can retrieve information you have published as well as that published by others. By publishing to the repository, you ensure that the information is accessible to other users from both desktop and laptop, as well as over the corporate intranet in the BI Web Personal Portfolio. Because you can set security on items you publish, publishing also provides a secure way to share your information with other users.

Specific terms are used to distinguish server-related actions from local (computer-based) actions. Locally saved data (on your desktop computer) is saved or loaded. Material stored on the BI Server Repository is published or retrieved.

In order to publish a data model, you must first save it locally. Once you save a data model locally and published it, queries based on that data model can also be published. In order to retrieve a query, you must open a local copy of a published data model or retrieve a data model from the repository.

Publishing and retrieving require that you log on to BI Server.

### Publishing Reports to the Repository

You can publish a report to the repository using BI Query Reports. The data model with which it is associated must have been published first. You can also publish reports from BI Query when you publish the data model on which they are based, but some publishing options are available only when you publish a report from BI Query Reports. Publishing reports makes it possible to share them with other users and to schedule them to refresh automatically.

To publish reports, you need the **Publish Reports** system permission.

#### To publish a report:

1. In BI Query Reports, log on to the BI Server repository.
   - If the reports you are publishing are in a network or Internet environment, make sure that their file names do not contain spaces or special characters. This avoids problems that can occur with different naming conventions. Examples of special characters are &, <, >, “, and so on.
2. With a saved report (based on a published data model) open, on the **File** menu, click **Publish**.
3. In the **Publish to Repository** dialog box, type a description for the report. This description helps users decide whether they need to look at it.
4. To publish the report to a folder other than the one shown under Folder, click the browse button, and then do one of the following:
   - In the Select Folder dialog box, click the folder you want.
   - To create a new folder, select the folder under which you want the new folder to be created. Click New Folder, type a name for the new folder, and then click OK.

5. Click Set Security. The Set Security dialog box opens. Use it to view and assign read, write, and refresh permissions to control which users and groups can access the report. For more information, see “Setting Security for Reports” on page 261.

6. To provide a printable version of the report for BI Web users, select the Publish Acrobat (.pdf) check box.

7. Click Publish.

Retrieving Reports from the Repository

You can view and modify published reports (depending on your security permissions) by retrieving the report from the repository.

To retrieve a published report:
1. On the File menu, click Retrieve.
2. In the Retrieve Report dialog box, click the report, and then click OK.

About Security

For any item you publish, there may be people in your organization who need access to the information contained in it, people who need customized views of it, and people who should not see it at all. You must secure the data so that it can be viewed or changed only by the people with the authority to do so.

You can control individual as well as group access to the information you publish—granting or denying general access while providing individual exceptions as necessary. You exercise this control based on a structure of users and groups that the BI Server administrator creates.
Depending upon your needs, the administrator may make it possible for you to grant system permissions to other users, such as the ability to schedule queries, reports, and hypercubes. For information on these permissions and on how they are assigned, see the *BI Server Administrator’s Guide*.

**User and Group Structures**

Your log on name and password identify you as a user in a structure of users and groups created by your BI Server administrator. The administrator assigns system permissions that determine the extent to which you can use the features of BI Server, such as:

- the ability to publish
- the ability to retrieve
- the ability to schedule the items you publish

**Granting and Denying Access**

Using the user and group structure provided by your administrator, you can grant or deny access to the items you publish. If you find that you cannot use features or perform activities appropriate to your work, ask your administrator to review the system permissions that have been assigned to you. The table below describes how users inherit group access.

<table>
<thead>
<tr>
<th>Inheritance Rule</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group members inherit their group’s access.</td>
<td>When you grant or deny access to a group, all members of the group inherit that setting (if a group has access, each member has access and if a group is denied access, each member is denied it).</td>
</tr>
<tr>
<td>Members of more than one group inherit from the groups that grant access.</td>
<td>If a member of a group that is granted access is also a member of another group that is denied access, then the group that has access prevails. The member has access.</td>
</tr>
</tbody>
</table>
Setting Security for Reports

You can set security for a report (by item), or you can set by user and group. In the former instance, you select the report first, and then set security for users and groups. In the latter instance, you select a user or a group first, and then select the report for which you want to set security.

To set security:

1. Open the Set Security dialog box.
2. To set security by user and group rather than by report (item), click the Set By User and Group tab.
3. To give access, click Grant. To not give access, click Deny. To allow a user or group to assume security settings from the group of which it is a member, click Inherit.
4. When you have set security for as many items and as many users and groups as you want, click OK.

Inheritance Rule | Description
--- | ---
Member security settings override inherited group settings. | You can give a group member a setting different from that of its group. When you do, the overriding setting always applies to that member, even when you make it a member of other groups. You can remove an overriding setting to let a member inherit from the group again.

The symbols that indicate access settings are as follows:

Symbol | Description
--- | ---
Green light. Access specifically granted. |
Red “no entry” symbol. Access specifically denied. |
Green check. A granted access that has been inherited. |
Red “x”. A denied access that has been inherited. |
5. Publish the report.

### About Scheduling

Scheduling regulates the flow of information from the database by processing the enterprise’s queries and reports in a managed time frame. Jobs can be scheduled to run once or repeatedly, at specific intervals, during less busy times, or when a specific event has occurred. Scheduling also provides a variety of ways to distribute information.

For more information on scheduling, see the *BI Server Scheduling User’s Guide*.

### Scheduling a Report

From BI Query Reports, you can schedule published reports to run at specific times or after specific events have occurred, and you can specify output destination. You do not have to be present at the local computer, and it does not have to be running.

**To schedule a report:**

1. Open the report.

2. On the **File** menu, click **Schedule**, and then click **Report**. The **Schedule Job** dialog box opens.

   ![Light bulb icon](image)

   For more details about scheduling and the **Schedule Job** dialog box, see the BI Server Scheduler Help or the *BI Server Scheduling User’s Guide*.

3. On the **Info** page, type a job name, click a priority, and then type a description of the report. This page displays errors and other system messages for the scheduled job in the **Messages** text box.

4. Click the **When** tab, and then specify the schedule for refreshing the report.

5. Click the **Actions** tab, and then specify the actions you want performed.

6. Click **OK**.

### Using Report Exceptions to Trigger Events

![Light bulb icon](image)

For more information on scheduling, see the *BI Server Scheduling User’s Guide*. 
You can create an exception in a report that triggers an event in the Scheduler. The event triggered can be either the refreshing of a report or the running of a query. This type of exception is created the same way as other report exceptions, with one difference: instead of choosing formatting options or applying the exception to an object in the report, you associate the exception with an event.

To trigger a scheduled job based on an exception requires at least two items:
- the report that contains the exception that serves as the trigger
- the report that refreshes or the query that runs when the exception is true

**To trigger a job using a report exception:**
1. In BI Query Reports, open the report that will contain the exception you want to trigger your event-based job.
   - If you create a report exception to trigger an event, you do not need to apply the exception to any object in the report.
2. Click the column on which to create the exception.
3. On the **Tools** menu, click **Exceptions**.
4. In the **Exception List**, select the exception(s) that will trigger running the job. If no exception is available, click **New**.
5. Click the **Description** tab, and then type a name and description for the exception.
6. Click the **Editor** tab, and then formulate the exception expression.
7. Click **Events**.
8. In the **Trigger Events** dialog box, click an event. If the event you want is unavailable, you can create it.
9. Click **OK**.
10. In the **Exceptions** dialog box, click **OK**.
11. Schedule the job that you want to be triggered by the report exception.
12. In the **Schedule Job** dialog box, click the **When** tab.
13. In the **Frequency** area, click **Event-based**.
14. In the **Events** area, select the check box to select the event you named in step 8.
15. When you have finished scheduling the job, click **OK**.
DM integrates seamlessly with BI Query Reports so that you can save your reports to a DM library.
- “About DM” on page 265

About DM

DM transforms document-based electronic information into knowledge assets with an enterprise-ready platform that facilitates the capture, sharing, and protection of corporate content resources. User queries are easily executed across global DM repositories, enabling users to find and control documents and easily distribute them for review, collaboration, and publication with project teams inside and outside the traditional corporate landscape.

DM Integration with Hummingbird BI

You can use Hummingbird BI with DM to:
- save a Hummingbird BI report to a DM library
- save a PDF version of a Hummingbird BI report to a DM library
- open a Hummingbird BI report saved in a DM library
You can also perform basic tasks common to all document types saved in a DM library (such as print, copy, and so forth).

**Installing DM Integration**

To use DM with Hummingbird BI, you must have BI Query Reports installed. You can install BI Query Reports either before or after installing DM integration.

**To install DM Integration:**

1. Set up your DM server for Hummingbird BI Query Reports integration. For more information, see the chapter “Configuring Application Integration For DM” in your *DM Administration Guide*.
2. Log on to your DM library.
3. Click **My Options**, and then click the **Optional Components** tab.
4. Expand the **DM Application Integration** option.
5. Expand the **Integration Options for Other Applications** option.
6. Select the **ODMA Integration** check box.
7. Click the **Install Components** button located immediately below **Display Options**. (One or more installation dialog boxes may open.)
8. Log off from DM.

A new DM menu is added to BI Query Reports.

**Saving a Report to a DM Library**

You can save Hummingbird BI reports to a DM library in either regular (`.rep`) or Adobe Acrobat Portable Document format (`.pdf`).

**To save a Hummingbird BI report to a DM library:**

1. In Hummingbird BI Query Reports, open the report that you want to save, point to **Save As** on the **DM** menu, and then click **Report (.rep)**.
2. Complete the dialog boxes that open. For more information, consult your DM user documentation.
To save a PDF version of a Hummingbird BI report to a DM library:

1. In Hummingbird BI Query Reports, open the report that you want to save, point to **Save As** on the **DM** menu, and then click **Acrobat (.pdf)**.
2. Complete the dialog boxes that open. For more information, consult your DM user documentation.

**Opening a Report from a DM Library**

With DM integration installed, you can open a Hummingbird BI report that has been saved in a DM library.

**To open a Hummingbird BI report from a DM library:**

1. In Hummingbird BI Query Reports, on the **DM** menu, click **Open**.
2. Complete the dialog boxes that open. For more information, consult your DM user documentation.
Accessibility and Technical Support

This section provides information on the following:

- “General Accessibility” on page 269
- “Technical Support” on page 271

General Accessibility

Hummingbird products are accessible to all users. Wherever possible, our software adheres to Microsoft Windows interface standards and contains a comprehensive set of accessibility features.

Access Keys

All menus have associated access keys (mnemonics) that let you use the keyboard, rather than a mouse, to navigate the user interface (UI). These access keys appear as underlined letters in the names of most UI items. (If this is not the case, press ALT to reveal them.) To open any menu, press ALT and then press the key that corresponds with the underlined letter in the menu name. For example, to access the File menu in any Hummingbird application, press ALT+F.
Once you have opened a menu, you can access an item on the menu by pressing the underlined letter in the menu item name, or you can use the arrow keys to navigate the menu list.

**Keyboard Shortcuts**

Some often-used menu options also have shortcut (accelerator) keys. The shortcut key for an item is listed beside it on the menu.

**Directional Arrows**

Use the directional arrows on the keyboard to navigate through menu items or to scroll vertically and horizontally. You can also use the directional arrows to navigate through multiple options. For example, if you have a series of radio buttons, you can use the arrow keys to navigate the possible selections.

**Tab Key Sequence**

To navigate through a dialog box, press the TAB key. Selected items appear with a dotted border. You can also press SHIFT+TAB to go back to a previous selection within the dialog box.

**SPACEBAR**

Press the SPACEBAR to select or clear check boxes, or to select buttons in a dialog box.

**ESC**

Press the ESC key to close a dialog box without applying new settings.

**Enter**

Press the ENTER key to select the highlighted item or to close a dialog box and apply the new settings. You can also press the ENTER key to close all About boxes.

**ToolTips**

ToolTips appear for all functional icons. This feature lets users use Screen Reviewers to make interface information available through synthesized speech or through a refreshable Braille display.
Microsoft Accessibility Options

Microsoft Windows environments contain accessibility options that let you change how you interact with the software. These options can add sound, increase the magnification, and create sticky keys.

To enable/disable Accessibility options:

1. In Control Panel, double-click Accessibility Options.
2. In the Accessibility Options dialog box, select or clear the option check boxes on the various tabs as required, and click Apply.
3. Click OK.

If you installed the Microsoft Accessibility components for your Windows system, you can find additional Accessibility tools in the Accessibility program group on the Start menu.

Technical Support

Administrators can contact Hummingbird Technical Support to report problems or suggest enhancements. We require product and company information before we can investigate any problems. For your convenience, the Hummingbird BI Configuration Manager utility can quickly assemble most of the required information and automatically add it to an e-mail message. Even the address is automatically filled in, so all you need to do is add a description of your problem to the body of the message and click Send. For more information on using the Hummingbird BI Configuration Manager utility, consult the utility’s online help.

To start the Hummingbird BI Configuration Manager utility:

- On the Start menu, navigate to the program group folder for your BI application (BI Server or BI Query), then click BI Configuration Manager.

For Technical Support services, please use the contact information for your area, or visit the Technical Support web site at:
Using the Trace Utility

Hummingbird provides a trace utility with the software to help troubleshoot problems you are having. The trace utility simplifies problem-solving by monitoring the activity of your products. If you are having problems with the software, Technical Support may ask you to run the trace utility, reproduce the problem, save the trace information, and send us the resulting trace file.

To run the trace utility, double-click \texttt{trace.exe} from one of the following locations:

\texttt{Program Files\Hummingbird\BI\Query}
\texttt{Program Files\Hummingbird\BI\Server}

For information on configuring the trace utility, see Trace Help.

\url{http://www.hummingbird.com/support}

\textbf{Hummingbird Ltd.}
\textit{1 Sparks Avenue, Toronto, Ontario, Canada M2H 2W1}

<table>
<thead>
<tr>
<th>Region</th>
<th>Tel:</th>
<th>Fax:</th>
<th>Email:</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America</td>
<td>1 800 486 0095 (8:00 am - 8:00 pm EST)</td>
<td>1 613 548 7616</td>
<td>\texttt{<a href="mailto:hbi-support@kingston.hummingbird.com">hbi-support@kingston.hummingbird.com</a>}</td>
</tr>
<tr>
<td>Europe (Except UK and Scandinavia)</td>
<td>+33 1 55 35 96 80 (9:00 am-6:00 pm GMT + 1hr)</td>
<td>+33 1 42 61 31 87</td>
<td>\texttt{<a href="mailto:fr-bi-support@hummingbird.com">fr-bi-support@hummingbird.com</a>}</td>
</tr>
<tr>
<td>UK and Scandinavia</td>
<td>+44 (0)118-902-9507 (9:00 am-5:00 pm GMT)</td>
<td>+44 (0) 118 978 9325</td>
<td>\texttt{<a href="mailto:uk-support@hummingbird.com">uk-support@hummingbird.com</a>}</td>
</tr>
<tr>
<td>Other Locations</td>
<td>+1 613 548 4355 (8:00 am-8:00 pm EST)</td>
<td>+1 613 548 7616</td>
<td>\texttt{<a href="mailto:hbi-support@kingston.hummingbird.com">hbi-support@kingston.hummingbird.com</a>}</td>
</tr>
</tbody>
</table>
Symbols

# formatting character 225
* formatting character 225
.hcr files 20
.pdf 81
\ formatting character 225
_ formatting character 225

Numerics

3D charts
   about 135
   changing the thickness of walls 169
   moving 169
   panning 169
   rotating 169
3D viewing angle
   changing 169
   customizing 169
A
   about gridlines 165
   accessibility, general 269

Acrobat, (PDF) format 81
activating tables 217
adding
   bands 95
   bitmaps 216
   borders 226
calculations to groups 239
category titles 159
charts 58, 59
charts to bands 99
charts to tables 99
color to drawing objects 213
color to text 210
columns 102
columns, new query 112
crosstabs 62, 63
data items 112
drawing objects 212
footer bands 113
footnotes to reports 158
gradients 146
grand total 240
grand totals 238, 244
graphics 212
header bands 113
hotspots 87
labels to pie charts 160
linked objects 214
members to charts 128
members to crosstabs 184
objects to bands 98, 220
OLE objects 212, 216
page breaks 116, 191
page numbers 197
pages 196
pictures to the gallery 148
pie chart labels 160
predefined calculations 239
predefined calculations to tables 238
presentations 64, 68
prompts 206
rich text 198
subtitles 158
table frames 117
tables 56
tables, existing reports 57
text files 198
text labels 197
textures to chart elements 148
titles to reports 158
totals 240
trend lines 155
user-defined calculations 240, 241
value titles 159
adding exceptions 248
creating summary reports 254
highlighting alternative rows 254
to highlight data 247
Adobe Acrobat 81
aggregate values
displaying 188
aligning
data inside a box 218
objects, graphics 217
text 217
aligning objects
showing grid lines 219
snap to grid 219
spacing evenly 218
ALL function 243, 255
anchoring items to columns 106
applying
data highlighting 250
exceptions to data 249
exceptions to objects 250
exceptions, overview 249
hyperlinks 202
layout templates 227
report backgrounds 227
table styles 119
templates 227
variable data fields to tables, bands 100
area charts 42
about 136
arithmetic operators 233
arranging 60, 64
axes in charts 125
axes in crosstabs 181
chart metrics 124
columns 108
crosstab data 64
crosstab metrics 64
data in charts 60, 124
dimensions 126, 181
attributes. See columns.
auto-arrange 144
automatically arranging elements 144
automatically resizing items 107
automation controller 28
autosizing
column items 107
crosstab cells 192
axes
changing 125, 181
creating descending 162
axis label numbers
changing format of 176
axis labels
hiding 173
staggering 175
axis line, hiding 162
B
backgrounds 226, 227
creating 226
bands 95
adding charts 99
adding headers and footers 95
adding objects 95, 98
detail, hiding 97
displaying 97
formatting 96
page header, footer 220
resize preferences 75
selecting 95, 96
showing detail 95
showing, hiding 95, 98
suppressing duplicates 95, 111
y-axis size 99
bar charts 38–40
about 133
adding depth 150
changing the gap width 150
changing the overlap width 150
changing the shape of risers 150
formatting 150
beveled box
using for risers 154
BI Cube Creator
starting from Reports 30
BI Login dialog box 26
BI Query Reports
log on 26
standalone 26
starting from BI Query 26
table styles, defined 52
BI Server
overview 257
repository defined 258
BI Server Repository 202
bitmaps 212
embedding 216
By argument, overview 232

C
Calc-O-Matic dialog box 238, 239
calculations 230
adding to crosstabs 239, 241
adding to tables 240
ALL function 243
automatic resizing 100
By argument 232
combining columns 243
creating in crosstabs 241
creating in tables 240
date/time 231
deleting 242
editing 242
exceptions 230
expressions 233
functions 231
logical 231
multi-pass 230
naming and describing 241
numeric 231
order of precedence 236
percent of total 244
pointing to a specific value 246, 247
predefined 229, 237, 238, 239
predefined in tables 238
replacing numeric values with text strings 245
string 231
syntax 235
text wrap problems 101
use of arrow 235
use of brackets, braces 235
use of colon and comma 235
use of parentheses 235
use of single quote 235
use-defined 241
user-defined 230, 237, 240
Calculations dialog box
Editor page 240, 245
categories
displaying a manual number of 175
category title
adding 159
cells
autosizing in crosstabs 192
resizing 192
changing
axes in charts 125
axes in crosstabs 181
color 210
data by using prompts 206
data sources 71, 72
filtered data 127, 183
grid settings 219
nested dimensions 126, 181
characters
inserting/deleting in reports 225
chart elements
adding gradients 146
adding patterns 146
adding textures 146
chart types
about 131
area 42
dual axis 40
line 40
pie 43
three-dimensional 44
understanding 131
charts 22
overview 22, 37
adding a legend 143
adding members 128
adding to bands 99
adding to existing reports 59
adding to reports 58
adding to tables 99
arranging data 60, 124, 126
building 58
choosing types 58
creating 58
data gathering 51
dimensions 124
examples 37–44
filtering data 127, 128
formatting, overview 131
grouping items 125
hiding columns 130, 145
if data values not shown 92
pivoting dimensions 125
properties 131
refresh 74
removing and hiding members 130
removing columns 130, 145
reordering members 129
Choose Member dialog box 105, 245, 246
Choose Range dialog box 87, 91
choosing a 3D viewing angle 168
clipart
adding 212
selecting 217
coefficient values
showing for a trend line 155
colons in calculations 235
color
adding to drawing objects 213
adding to text 210
palette 211, 213
color mode
changing 157
colors
changing 146
column charts
about 132
Column Control bar 94, 101, 104, 107
columns 94
adding new 102
anchoring items 106
autosizing 107
changing the order 114
combining using calculations 243
defined 95
deleting 104
fitting on a page 105
formatting 102
formatting headings 118
grouped 114
hiding in charts 130, 145
items 109
managing 103
merging 104
new query data 112
over multiple pages 103
properties 102
removing in charts 130, 145
reordering 108
resizing 106
selecting 101
title formatting 118
combining columns 243
comma separated value 80, 82
commas in calculations 235
comparison operators 234
context-sensitive titles 204
controlling page breaks 191
converting two-digit years 223, 224
about 223
example 223
copying
items 109
objects 217
presentations 69
presentations to other application 82
tables and crosstabs 82
text 199
copying and pasting table items 109
creating
calculations 240
calculations in crosstabs 241
calculations in groups 239
calculations in tables 240
calculations, ALL function 243
exceptions 248
grand totals 238
headers and footers 220
hotspots 87
interactive reports 86, 87
report backgrounds 226
summary reports 254
text labels 197
titles 197
totals 240
user-defined calculations 240, 241
crosstabs 64, 181
overview 22, 44, 177, 178
accessing 189
activating 189
adding members 184
adding percent of total 244
adding titles 197
adding to existing reports 63
adding to reports 62
arranging data 64, 181
autosizing cells 192
building 62
calculations 241
changing filtered data 183
choosing an analysis mode 67

copying and pasting 82

creating 62

data filtering 182

data gathering 51
default formatting 190
defined 178
dense, defined 46
dimensions 180
examples 45–49
filtering data 183, 184
formatting 189, 192
hiding members 186
if data values not shown 92
options 190
page breaks 191
pivoting 181
predefined calculations 239
redefining a metrics member 65
refreshing 74
removing members 186
reordering members 185
resizing 192
selecting 189
selecting labels 190
sparse, defined 46
totals 240

CSV. See comma separated value.
curly brackets in calculations 235
currency 176
custom chart types
about 142

using 143
customizing
axis label numbers 176

D
data
adding new columns 112
arranging 60, 64, 124, 180
arranging in crosstabs 64
changing 206
changing source 71
changing what is filtered 183
changing what’s filtered 127
copying table items 109
default formatting 66
formatting 192
gathering 87
gathering for crosstabs 51
gathering for tables 49
grouping results 50
guidelines for gathering 49
in charts 60
in crosstabs 64
mapping new 72
qualifying 87
reducing null values 46
refreshing 91
replacing 70
retaining source data formatting 66
sorting in crosstabs 64
stacking in tables 110
summarizing in charts 60
suppressing duplicates 111
y-axis in bands 99
Data Cell Selector dialog box 105, 246
data fields
  automatic sizing 100
  variable 100
data formats 222
  null values 221
  strings 224
data highlighting 249
  overview 247
  applying 249
  applying exceptions 250
  creating exceptions 248
data items 94
  adding 112
  combining 105, 243
data label numbers, formatting 172
data labels
  showing 170
  showing on markers 155
  working with 170
data model
  retaining data format 66
data sheet values
  showing 170
data sources
  overview 22
  changing 71, 72
  defined 23
  for hotspots 90
  removing 73
  saving with reports 76
types 20
Data Sources dialog box 73, 112
data values 92
database
  distributing revisions 84
  reconnecting 77
date 176, 223
  context-sensitive 204
  formats 222
  formatting 223
Date Entry dialog box 224
date/time calculations 231
default
  crosstab formatting 190
  crosstab options 190
default data formatting 66
Define Date/Time Format dialog box 223
Define Numeric Format dialog box 222
Define String Format dialog box 225
defining formats 223
deleting
  calculations 242
  columns 104
  current values 29
  exceptions 250, 251
  pie chart slices 153
dense crosstab 46
depth
  adding to bar charts 150
  adding to pie charts 151
  in line charts 152
  describing exceptions 249
detaching
  pie chart slices 153
detail bands 94, 95, 98
  hiding 97
  variable 100
detailed data sources 20
Dimension List dialog box 241
dimensions 181
  adding a subtotal 240
  filtering 127, 128, 183, 184
  grouping in charts 125
  nested, arranging 126, 181
  overview 124, 180
  pivoting in charts 125
  pivoting in crosstabs 181
  removing 127, 182
displaying
  aggregate values 188
  bands 97
  dates 223, 224
  grid lines 219
  null values 221
  strings 224
  suppressed data 111
distributing reports 83, 84
  using the database 84
drawing a custom gridline 167
drawing objects 211
  adding 212
  adding color 213
  formatting, editing 213
drilling 188
  members in crosstabs 187
dual axis charts 40, 172
duplicate data 111
  eliminating 49
  hiding 111
E
  editing
    backgrounds 226
    bands 96
    calculations 242
    embedded objects 216
    grid settings 219
    Hotspot Wizard 90
    hotspots 89, 90
    hyperlinks 203
    linked objects 214
    queries 70, 71
    elements
      changing the color 146
e-mailing reports as attachments 84
  embedded objects, editing 216
  entering dates 223
  equations
    showing for trend lines 155
trend lines
  exceptions 249
  overview 230
  ALL function 255
  applying 249
  applying to objects 250
  automatic resizing 100
  creating 248
deleting 250
  examples 251–253
  expressions 233
  highlighting data 247
Index

naming and describing 249
removing 251
triggering Scheduler event 263
exploding pie charts 151
exponential regression type 156
exporting reports 79
Acrobat (PDF) 81
Excel 82
HTML, complete 81
HTML, single file 81
text (CSV) 82
viewing 82
expressions, overview 233

F
fields
  in hyperlinks 207
fields, in labels 205–206
file protocol 201
File Transfer Protocol (FTP) 200, 201
Filter bar 128, 184
filtering data 127, 182
  charts 127, 128
  crosstabs 182, 184
fixing display errors automatically 144
fonts
  changing the size 149
  changing the style 149
footer bands
  adding 113
footers 220
  repeating object 221
footnote

adding 158
formatting
  axis 176
  bands 96
  bar charts 150
  charts, overview 131
  column headings, titles 118
columns 102
crosstabs 192
crosstabs page breaks 191
crosstabs, overview 189
data 192
data label numbers 172
date and time 222, 223
defaults for tables 116
drawing objects 213
enhancing reports 195
line thickness 149
lines 149
members 192
null values 221
numbers 222
pie charts 151
presentations 115
strings 224
table column headings, titles 118
tables 115
text 149, 209
text boxes 149
x-axis labels 161
formatting characters
  # 225
formatting crosstabs 181
  pivoting 181
FTP. See File Transfer Protocol.
functions
  overview 231
  ALL 243, 255

G
gallary chart types
  about 142
gallery chart types
  using 142
gap width
  changing 150
gradients
  adding 146
  changing the color 147
  customizing 147
group
  footer bands 113
  header bands 113
Group Breaks dialog box 114
group footer bands 94, 95
group header bands 95
grouped columns 114

H
header bands
  adding 113
headers 220
  repeating object 221
hiding
  axis labels 173
  bands 97, 98
columns in charts 130, 145
duplicate data 111
lines in line charts 152
major gridlines 164
members in charts 130, 145
members in crosstabs 186
drawing custom 167
  hiding minor or major 164
types 165
grids and ticks 165
group
  calculations 239
  subtotals 239
grid 219
  changing settings 219
  settings 219
Grid Settings dialog box 219
gridlines
  about 165
  changing the format of 166
  changing the styles of 166
minimum/maximum labels 174
minor gridlines 164
repetitive data 111
zeros in a scale 163
highlighting specific data 249, 254
alternate rows 254
using exceptions 247
hotspots 86
  adding 87
  as column headings 89
  as labels 89
  as titles 89
changing labels 89
choosing range of values 87
data source 90
editing 90
moving 90
qualification 91
qualifications 87
resizing 90
selecting 89
working with 89
HRRP. See Hummingbird Repository Retrieval Protocol.
HTTP. See Hypertext Transfer Protocol.
HTTPS. See Secure Hypertext Transfer Protocol.
Hummingbird accessibility 269
Hummingbird Repository Retrieval Protocol (HRRP) 201
hyperlinks
  applying 202
  defined 199
  editing 203
  including a field 205
  removing 204
  using buttons as 199
  with fields 207
HyperText Transfer Protocol (HTTP) 200
immediate interaction 67
importing text 199
Include Members dialog box 130, 145
inner ticks 165
Insert Data Item dialog box 112, 113
Insert Object dialog box 214
inserting
calculations in groups 239
calculations in tables 238
columns 102
data items 112
grand totals 238
graphics 212
headers and footers 220
members in charts 128
members in crosstabs 184
page breaks 116, 191
page numbers 197
predefined calculations 238, 239
rich text 198
text labels 197
titles 197
totals 240
user-defined calculations 240, 241
inserting a manual gridline 166
inserting exceptions 248
creating summary reports 254
highlighting alternative rows 254
interactive reports 86, 87, 91
adding hotspots 86
definition 85, 87
gathering data 87
items
adding to tables 112
anchoring to a column 106
autosizing in columns 107
combine using calculations 243
copying 109
in page header and footer 109
moving, copying 109
resizing 107
selecting 189

pie charts 160
selecting in crosstabs 190
versus legends 160
x-axis, formatting 161
layout grid 219
layout templates 226
applying 227
creating 226
leader lines
  showing on pie charts 171
legends
  adding 143
  adding to charts 143
  box style 143
  changing the position of 143
  in pie charts 160
  layout 143
  working with 143
line charts 40
  about 137
  changing the size and shape of markers 152
  formatting 152
  hiding markers 152
  showing/hiding lines 152
  using depth 152
linear regression type 156
lines
  adjusting thickness 149
  changing the color 149
  changing the style 149
  formatting 149
linked objects

J
jobs, scheduling
  using report exceptions 263
joining columns 104

K
keep with previous 95

L
labels 105, 197
  adding 197
  adding to pie charts 160
  hiding the minimum/maximum 174
  hotspots, changing 89
  including a field 205
  moving 161
changing 215
editing 214
updating 215
Links dialog box 214, 215
local reports, opening 28
log on 26
logarithmic regression type 156
logarithmic scales
displaying 163
logical
calculations 231
operators 234
M
mailto protocol 201
major gridlines
hiding 164
manual gridlines
inserting 166
Map Data dialog box 72, 120
mapping unmatched data 72
markers
changing the shape of 154
changing the size and shape 152
changing the size of 154
hiding in line charts 152
showing data labels on 155
maximum value for scale 164
mean 156
members
overview 126, 182
adding 128, 184
drilling 187
formatting 192
formatting x-axis labels 161
hiding in charts 130, 145
hiding in crosstabs 186
removing in charts 130, 145
removing in crosstabs 186
removing, hiding in charts 130
reordering in charts 129
showing hidden members 145
merging columns 104
metrics
arrange 64
arranging 60
arranging in charts 124
arranging in crosstabs 180
redefining a member 65
minimum value for scale 164
modifying
calculations 242
column size 106
data by using prompts 206
date, time formats 222
grid settings 219
hotspots 89
items 107
number formats 222
more 126
moving average 156
moving hotspots 90
multi-pass calculations 230
multiple objects
selecting 217
Index

N
naming exceptions 249
nested relationships
  in charts 126
  in crosstabs 181
normal interaction 67
null values
  defined 46
  reducing 46
number formats 222
numbers
  customizing on an axis label 176
  formatting on data labels 172
numeric calculations 231
numeric values 222
  replacing with text strings 245
O
objects
  adding 212
  adding to bands 98
  applying exceptions 250
  columns 95
  copying 217
  embedding 216
  linked 214
  linking 215
  making same size 218
  on multiple pages 220, 221
  pasting 217
  selecting 217
  spacing evenly 218
OLE automation 28
OLE objects 212
  adding 212
  embedding 216
  linking 214
opening local reports 28
operators
  arithmetic 233
  comparison 234
  logical 234
options
  opening reports 73
  refresh 74
order of columns 108
organizing data in charts 60, 124
organizing data in crosstabs 64, 180
outer ticks 165
overlap, correcting 144
P
page breaks 98, 191
  adding to tables 116
Page Breaks dialog box 191
page numbers
  adding 197, 204
  context-sensitive 204
  resetting 98, 116
pages
  adding, removing 196
  fitting a column 105
footer band 94, 95, 220
header band 94, 95, 220
orientation for printing 78
Index

panning a 3D chart 169
pasting
  objects 217
  presentations 69
pasting text 199
patterns
  adding 146
percent 176
percent of total, example 244
pictures
  adding to chart elements 146
  adding your own picture 148
  customizing 148
  flipping 148
  formatting 148
  selecting 217
pictures gallery
  adding your own picture 148
pie chart slices
  detaching or deleting 153
pie charts 43
  about 134
  adding labels 160
  changing the depth 151
  exploding 151
  formatting 151
labels on slices 171
labels versus legends 160
rotating 151
showing leader lines 171
showing numerical values 171
showing slice labels on the side of the chart 171
showing text labels 171
showing values as a percentage 171
tilting 151
working with data labels 171
pivoting dimensions 181
charts 125
crosstabs 181
planning reports
  gathering data 49–51
  identifying users 34
  presenting data 34–48
table styles 51
pointing to a specific value, example 247
polynomial regression type 156
predefined calculations 237, 238, 239
  overview 229
  creating 238
preferences 73
crosstabs 190
default formatting for tables 116
query prompts 75
refresh 74
report opening options 73
resizing bands 75
Preferences dialog box 73, 74, 92
Crosstab page 191
Table page 116
Presentation Designer dialog box 24, 57
  Arrange Data page 64, 113, 179
Data Source page 58, 63, 99
Presentation page 58, 105
Table page 116
presentations
  overview of types 21
  adding to reports 64
changing type 70
checking view name 68
choosing 34–49
copying and pasting 69
copying to other applications 82
fine-tuning data 70
formatting 115
refreshing charts, crosstabs 74
using views to link 69
views 68
presenting data
  charts 37
crosstabs 44
tables 34
previewing before printing 79
primary axis
  moving elements to 172
printer driver 83
printing 77
  page orientation 78
previewing 79
print order 78
reports 77, 83
to a text file 79
prompts
  adding 204
modifying data 206
preferences 75
refreshing reports 75
properties
  bands 96
  charts 131
columns 102
tables 115
Properties dialog box 101, 103, 115, 193, 222
  Format page 222
  General page 131, 250
  General tab 249
  Options page 99, 161
protocols
  file 201
  FTP 200
  HTTP 200
  HTTPS 200
  mailto 201
  SSL 200
publishing
  automatically to PDF 81
  reports 258
Q
qualifying
  data 87
data values 92
queries
  editing 70, 71
query results
  overview 24
turning into reports 23
R
radar charts
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>about 139</td>
</tr>
<tr>
<td>Rearrange Data dialog box</td>
</tr>
<tr>
<td>125, 182</td>
</tr>
<tr>
<td>rearranging</td>
</tr>
<tr>
<td>chart metrics 60</td>
</tr>
<tr>
<td>crosstab metrics 64</td>
</tr>
<tr>
<td>data in charts 60, 124</td>
</tr>
<tr>
<td>data in crosstabs 64, 180</td>
</tr>
<tr>
<td>Recent dialog box 27</td>
</tr>
<tr>
<td>rectangles 154</td>
</tr>
<tr>
<td>refreshing</td>
</tr>
<tr>
<td>charts, crosstabs 74</td>
</tr>
<tr>
<td>data 28, 91</td>
</tr>
<tr>
<td>report options 28</td>
</tr>
<tr>
<td>reports that use a prompt 29</td>
</tr>
<tr>
<td>reports, automatically 30</td>
</tr>
<tr>
<td>reports, manually 29</td>
</tr>
<tr>
<td>reports, query prompts 75</td>
</tr>
<tr>
<td>regression type</td>
</tr>
<tr>
<td>choosing 156</td>
</tr>
<tr>
<td>exponential 156</td>
</tr>
<tr>
<td>linear 156</td>
</tr>
<tr>
<td>logarithmic 156</td>
</tr>
<tr>
<td>polynomial 156</td>
</tr>
<tr>
<td>regular grids 165</td>
</tr>
<tr>
<td>removing</td>
</tr>
<tr>
<td>calculations 242</td>
</tr>
<tr>
<td>columns 104</td>
</tr>
<tr>
<td>columns in charts 130, 145</td>
</tr>
<tr>
<td>dimensions 127, 182</td>
</tr>
<tr>
<td>exceptions 250, 251</td>
</tr>
<tr>
<td>hyperklinks 204</td>
</tr>
<tr>
<td>members in charts 130, 145</td>
</tr>
</tbody>
</table>
interactive 85, 86, 87
new 26
opening 28
preferences for opening 73
print options 77
printing 77, 83
printing to text file 79
publishing 258
refresh options 28
refreshing 28
refreshing data 77
retrieving 259
saving 76
saving with data sources 76
scheduling 262
security 259
setting security 261
triggering scheduled job 263
repository
defined 258
ID 202
opening reports 27, 28
publishing reports 258
retrieving reports 259
starting BI Query Reports 25
working offline 26
reset page number 98, 116
resizing
column items 107
columns 106
crosstabs, cells 192
hotspots 90
items in a column 107
objects 218
Retrieve Data dialog box 27
Retrieve Report dialog box 27, 259
retrieving data for crosstabs 51
retrieving reports 259
revising hotspots 89
rich text 210
adding 198
Rich Text Editor dialog box 198, 210
risers
beveled box 154
changing the color of 157
changing the shape of
risers 154
changing the shape of in bar charts 150
reverse beveled box 154
using the same color for all risers 157
rotating a 3D chart 169
rotating pie charts 151
round brackets in calculations 235
rows, suppressing duplicates 111
running BI Query Reports 26
from BI Query 26
standalone 26
saving
locally, reports and results 77
reports, overview 76
scale labels
moving 161
scales
S
saving
Index

displaying logarithmic 163
removing zero from 163
setting the minimum/maximum value 164
scatter charts
about 140
scheduling jobs
using report exceptions 263
scheduling reports 262
secondary axis
moving elements to 172
Secure Hypertext Transfer Protocol (HTTPS) 200
Secure Sockets Layer protocol (SSL) 200
security
granting and denying access to reports 260
inheritance rules 260
published reports 259
setting for reports 261
users and groups 260
selecting
all crosstab cells 190
bands 96
crosstab label 190
data formats for nulls 221
data formats for numbers 222
data formats for strings 224
date, time formats 222
hotspots 89
items 189
random cells 190
range of cells 190
row of cells 190
single cell 190
series
changing the display of 168
displaying as a line chart 168
displaying as an area chart 168
series axis
adding a title 160
series axis title 160
series labels
showing 170
series, displaying as a riser 168
setting
crosstab options 190
default formatting 190
preferences 73
report backgrounds 227
Show/Hide Bands dialog box 97, 98
showing
bands 97, 98
data sheet values 170
hidden members 145
selection tabs 189
series labels 170
showing data labels 170
showing the coefficient values 155
single quotes in calculations 235
size 197
objects 218
text 197
slices
detaching or deleting 153
snap to grid 219
spanning ticks 165
sparse crosstab 46
special charts
   about 140
special fields 204
specific value calculations 246
specifying
   crosstab options 190
data formats for nulls 221
data formats for numbers 222
data formats for strings 224
date, time
   formats 222
date, time formats 222
page breaks 191
table size 117
split position
   adjusting 173
   moving 173
square brackets in calculations 235
SSL. See Secure Sockets Layer protocol.
stacking data 110
stacking data in tables 110
staggering axis labels 175
standard deviation 156
starting B Query Reports
   automation controller 28
starting BI Query Reports
   overview 25
   from BI Query 26
standalone 26
starting Hummingbird programs from
Reports 30
starting other Hummingbird programs
   from the Standard toolbar 30
   from the Tools menu 31
step line
   showing 154
stock charts
   about 138
String
   functions 243
   type converter 243
string calculations 231
styles 195
   applying for tables 119
   changing for presentations 70
   creating for tables 119
default for crosstabs 190
for reports 226
   modifying for tables 120
reports 195
tables 52, 118
tables, user defined 119
   user-defined 52
subtitle
   adding 158
subtotals
   adding to nested dimensions 240
   adding to tables 238
summary data sources 20
summary reports 247, 254
suppressed data, displaying 111
suppressing duplicate data 111
**T**

Table Size dialog box 118  
Tables 99  
- Overview 21, 34, 93, 94  
- Adding 56  
- Adding charts 99  
- Adding grand totals 238  
- Adding to existing reports 57  
- Adding to reports 56  
- Adding, removing frames 117  
- Choosing styles 57  
- Column headings, titles 118  
- Columns 95  
- Copying and pasting 82  
- Copying items 109  
- Creating 56  
- Creating styles 119  
- Data gathering 49  
- Default formatting 116  
- Detail bands, automatic sizing 100  
- Examples 35–36  
- Formatting 115  
- Formatting bands 96  
- Modifying styles 120  
- Moving 109  
- Page breaks 116  
- Predefined calculations 238  
- Predefined styles 52  
- Properties 115  
- Showing, hiding bands 98  
- Style types 118  
- Styles 119  

Subtotals 238  
User defined styles 119  
User-defined styles 52  
Technical Support 271  
Text 197  
- Adding 197  
- Adding rich text 198  
- Aligning 217  
- Changing the color 149  
- Changing the size 149  
- Copying 199  
- Formatting 149, 209  
- Importing 199  
- Pasting 199  
- Replacing numeric values 245  
Text box  
- Adding 149  
- Formatting 149  
Text Editor dialog box 89, 118, 197  
Text objects 197, 204  
- Adding 197, 198, 204  
- Context-sensitive titles 204  
- Rich text 198  
- Text labels 197  
Text wrap  
- Checking settings 101  
Textures  
- Adding to chart elements 146  
- Adding to elements 148  
Three-dimensional charts 44  
Time 176  
- Context-sensitive times 204
formats 222
time periods. See dates
title
   adding 158
titles 197
   adding 197
      context-sensitive 204
totals, adding 240
trend lines
   adding 155
   choosing a type 155
      showing the equation 155
triggers jobs
   using report exceptions 263
two-digit years 223
   converting 224
V
   value title
      adding 159
   variable
      bands 95
      data fields 100
   view name 68
   viewing angle
      choosing 168
   viewing angle of a 3D charts
      customizing 169
   views
      defined 23, 68
      linking presentations 69
W
   walls
      changing the thickness of 169
   watermark 91
   work locally 26
   working offline 26
   working with columns 101
   working without repository access 26
X
   x-axis 125, 181
Y
   y-axis 181
Z
   zeros, removing from scales 163