Related Documentation and Services

Manuals
All manuals are available in print and online. The online versions require Adobe Acrobat Reader 5.0 and are installed only if you do a Complete installation. Your Hummingbird product comes with the following manuals:

<table>
<thead>
<tr>
<th>Manual</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>BI Query Installation Guide</td>
<td>Determine system requirements and install BI Query and BI Query Reports.</td>
</tr>
<tr>
<td>BI Query Queries User’s Guide</td>
<td>Query corporate databases and export data to other applications.</td>
</tr>
<tr>
<td>BI Query Data Models User’s Guide</td>
<td>Create and manage data models and update records in the database.</td>
</tr>
<tr>
<td>BI Query Reports User’s Guide</td>
<td>Produce reports using BI Query Reports from data obtained using BI Query.</td>
</tr>
<tr>
<td>BI Query Chart Editor User’s Guide (PDF Only)</td>
<td>Use advanced features to edit charts created in BI Query Reports.</td>
</tr>
</tbody>
</table>

Help
The online Help is a comprehensive, context-sensitive collection of information regarding your Hummingbird product. It contains conceptual and reference information, and detailed, step-by-step procedures to assist you in completing your tasks.

Release Notes
The release notes for each product contain descriptions of the new features and details on release-time issues. They are available in both print and HTML. The HTML version can be installed when you install the software. Read the release notes before installing your product.
Professional Services
Hummingbird offers consulting and training services worldwide. Working alongside your technical and non-technical staff, Professional Services can help you identify areas where improved information management can enhance your business performance. As well, we can provide training on how to use your Hummingbird products. If requested, we can design courses that are tailored to meet your organization’s specific needs. These courses can take place at your workplace or at our own training centers. To register, or for more information, pricing, and detailed course outlines, contact Hummingbird Professional Services.

<table>
<thead>
<tr>
<th>Telephone</th>
<th>+1-613-548-4355 ext. 1700</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fax</td>
<td>+1-613-548-7801</td>
</tr>
<tr>
<td>Email</td>
<td><a href="mailto:proservices@hummingbird.com">proservices@hummingbird.com</a></td>
</tr>
<tr>
<td>Website</td>
<td><a href="http://www.hummingbird.com">www.hummingbird.com</a></td>
</tr>
</tbody>
</table>

Hummingbird Exposé Online
Hummingbird Exposé Online is an electronic mailing list and online newsletter. It was created to facilitate the delivery of Hummingbird product-related information. It also provides tips, help, and interaction with Hummingbird users. To subscribe/unsubscribe, browse to the following web address:

http://www.hummingbird.com/expose/about.html

User Groups and Mailing Lists
The user group is an unmoderated, electronic mailing list that facilitates discussion of product-related issues to help users resolve common problems and to provide tips, help, and contact with other users.

To join a user group:
Send an e-mail to listserv@hummingbird.com. Leave the Subject line blank. In the body of the e-mail message, type the following:

subscribe hbi-users Your Name

To unsubscribe:
Send and e-mail to the listserv address. Leave the Subject line blank, and type unsubscribe hbi-users in the body of the e-mail message.

To post messages to the user group:
Send your e-mail to:

hbi-users@hummingbird.com

To search the mailing list archives:
Go to the following web site:

http://www.hummingbird.com/support/usergroups.html
# Contents

## Chapter 1: Basic Concepts

Welcome to Hummingbird BI Query Reports ........................................................ 3
  - About Reports ................................................................................................ 3
  - Detailed and Summary Data ........................................................................ 3

Presentations Show Off Your Data ................................................................. 4
  - Tables Present Results ................................................................................ 5
  - Charts Visualize Data ............................................................................... 6
  - Crosstabs Analyze Data .......................................................................... 7
  - Data Sources and Views ....................................................................... 7

Turning Query Results into Reports .............................................................. 8
  - Letting the Designer Do Most of the Work ......................................... 9

## Chapter 2: Getting Started

Starting BI Query Reports ....................................................................................... 13
  - Starting BI Query Reports from BI Query .......................................... 13
  - Starting BI Query Reports on Its Own ..................................................... 14
  - Using an Automation Controller ......................................................... 18

Opening and Refreshing Reports ........................................................................ 18
  - Opening Local Reports from BI Query Reports .................................. 18
  - Refresh Options .................................................................................... 19

## Chapter 3: Planning Reports

Overview ................................................................................................................... 23
  - Identifying Types of Users ..................................................................... 23

Presenting Data ......................................................................................................... 24
  - Tables .................................................................................................... 24
  - Charts .................................................................................................. 27
  - Crosstabs ............................................................................................. 34
Gathering Data ................................................................................................................................. 39
  Tables ................................................................................................................................................. 39
  Charts and Crosstabs ............................................................................................................................ 40
Building Tables ................................................................................................................................. 41
  Using BI Query Reports Predefined Styles ......................................................................................... 41
  Using Your Own Styles .......................................................................................................................... 42

Chapter 4: Creating Reports ............................................................................................................. 43
Overview ................................................................................................................................................ 45
Building Presentations ......................................................................................................................... 45
  Adding to Reports ................................................................................................................................. 46
  Adding to Existing Reports .................................................................................................................... 53
Editing Queries and Replacing Data ...................................................................................................... 62
  Changing the Data Source ..................................................................................................................... 62
  Editing Queries ...................................................................................................................................... 63
  Mapping Unmatched Data ..................................................................................................................... 65
  Removing Data Sources ....................................................................................................................... 66
Setting Preferences ............................................................................................................................... 66
  Preferences for Opening a Report ......................................................................................................... 67
  Refresh Preferences ............................................................................................................................... 68
  Setting Other Report Preferences ......................................................................................................... 69
Saving Reports ........................................................................................................................................ 70
  Saving Reports with Data Sources ......................................................................................................... 70
  Reconnecting to the Database ............................................................................................................... 72
Printing Reports ....................................................................................................................................... 72
  Specifying the Print Order ..................................................................................................................... 73
  Selecting the Page Orientation ............................................................................................................... 74
  Previewing a Report ............................................................................................................................... 74
  Printing to a Text File ............................................................................................................................. 74
Exporting Reports .................................................................................................................................... 75
  Acrobat (PDF) Format .............................................................................................................................. 76
  HTML Format ........................................................................................................................................ 77
  Quicksheet Format ................................................................................................................................. 77
  Text (CSV) Format .................................................................................................................................. 77
  Viewing an Exported Report ................................................................................................................... 78
  Copying Presentations to Other Applications ....................................................................................... 78
Distributing Reports ................................................................. 79
Mailing Reports ................................................................. 79
Using the Database ........................................................... 80

Chapter 5: Creating Interactive Reports 81
Overview ...................................................................................... 83
Creating Interactive Reports .............................................. 84
About Hotspots ................................................................. 84
Gathering the Data .............................................................. 85
Working with Hotspots ......................................................... 85
Adding Hotspots ................................................................. 85
Selecting Hotspots ............................................................... 89
Changing the Hotspot Label ............................................... 89
Editing Hotspots ................................................................. 91
Moving Hotspots ................................................................. 91
Resizing Hotspots ............................................................... 92
Hotspots in Interactive Reports .............................................. 92

Chapter 6: Presenting Results in Tables 95
Overview ...................................................................................... 97
Understanding Tables .......................................................... 97
About Bands ................................................................. 98
About Columns ................................................................. 99
Working with Bands .............................................................. 100
Formatting Bands ............................................................... 100
Adding Group Header and Footer Bands ......................... 101
Controlling which Bands Display .................................... 102
Adding Items to a Band ......................................................... 105
Adding Charts to Bands ...................................................... 106
Applying Variable Data Fields and Bands to Tables .......... 108
Chapter 1

Basic Concepts

Welcome to Hummingbird BI Query Reports 3
About Reports 3
Detailed and Summary Data 3

Presentations Show Off Your Data 4
Tables Present Results 5
Charts Visualize Data 6
Crosstabs Analyze Data 7
Data Sources and Views 7

Turning Query Results into Reports 8
Letting the Designer Do Most of the Work 9
Welcome to Hummingbird BI Query Reports

Hummingbird BI Query Reports is the reporting tool used with Hummingbird BI Query. It works seamlessly with BI Query to present data in a variety of presentation styles—tables, charts, and crosstabs. The reports created using this tool assist your organization in making business decisions.

About Reports

Reports are summaries or collections of information about an aspect of an organization’s business. They contain views of the current data in your organization’s database, organized and formatted the way you prefer. They can contain data from one or more queries, data sources, or databases. How much information you present in a report, and how you present it depends on who your readers are, what information they need, and for what purpose they are using that information.

You can create reports that combine tables, crosstabs, and charts to answer every type of business question. You can create reports from multiple queries, add sophisticated calculations, and highlight exceptions in the data. In addition, you can integrate information from different corporate sources, then distribute it internally and externally using anything from electronic mail to the World Wide Web.

Create a report by adding presentations to it. Presentations are the tables, charts, and crosstabs you build from the data you gathered. You can include as many presentations in a report as you want. Once you create a report, you can add hotspots to it to make it interactive and you can distribute it.

Detailed and Summary Data

You can use detailed or summary data sources when creating reports.

**Detailed data sources** (.hcr files)—Present the day-to-day activities of the enterprise and are stored as columns and rows. With detailed data, you can answer questions about how your business is doing, such as:

- How many units did we sell last month?
- What did our New York retailer buy last month?
- How much did each sales representative sell last month?
Summary data sources (.hc files)—Present the results of consolidations done on detailed data. It contains the totals, averages, and other algebraic results rather than the detail-level data. With summarized data, you can answer a series of related questions, such as:

- How many units did our Midwest office sell this year, and this quarter?
- Which sales representatives sold the most?
- When were their peak months?
- When was their worst week?

In short, summarized data lets you see relationships between business variables, enabling you to uncover trends, anomalies, problems, and opportunities.

Presentations Show Off Your Data

Presentations are the tables, crosstabs, and charts that you use to present data to your readers. Select one of three presentation types based on the types of data that you want to display:

- Use tables to display detailed data.
- Use crosstabs to display summary data.
- Use charts to display trends and exceptions over time.

By determining which presentation type, or combination of types, best suits the data you want to use, you can create a focused report. It can highlight the information that interests audiences such as upper management, potential clients, or the general public.
Tables Present Results

Tables provide a quick and easy way of presenting data. They display detailed data in columns, with a heading across the top and in bands. Using the report styles provided with BI Query Reports, or using your own styles, you can create fully formatted tables including subtotals and grand totals, that are ready for presentation. You can also rearrange columns, break data into groups, add calculations and exceptions, or create completely free-form tables.

Tables give you the freedom to create a different layout every time. You can drag and drop text anywhere in the table, elsewhere in the report, or even into another open report. Tables provide you with an almost unlimited framework for presenting data, from form letters to invoices, purchase orders, catalogs, and so on. Using tables, you can answer questions such as:

- How many units did we sell last month?
- What did our New York retailer buy last month?
- How much did each sales representative sell last month?

<table>
<thead>
<tr>
<th>Sales by Region</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Product</strong></td>
</tr>
<tr>
<td>Gift Baskets</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Charts Visualize Data

Charts display data in a graphical format. They let you summarize and rearrange your data to help you recognize patterns, trends, and other relationships that may not be apparent in tables or crosstabs. They also let you present conclusions that have a strong visual impact. For example, they can show at a glance a company’s revenues over several years, inventories at different plants, or the account executive who was the biggest revenue generator last quarter. Because they present information graphically, charts make it easy for the reader to extract information from a report.

You can add a chart to any band in a table. When you add a chart to a detail band, a group footer band, or a group header band, the chart changes to reflect the data for that band. This lets you to add a visual representation to back up the hard data displayed in the bands. For example, if you have a table that shows cost, revenue, and profit by quarter, you can add a chart to the group footer band that will display the revenue, cost, and profit for each quarter.

Revenue by Quarter

![Chart showing revenue by quarter](chart.png)
Crosstabs Analyze Data

Crosstabs let you summarize and view your data dynamically. They display data in a matrix of rows and columns, with headings that appear across the top and sides of the crosstab. You can easily rearrange the data to view it from different perspectives. For example, you can compare sales figures for multiple products, analyze the performance of regional sales staff, and identify quarterly and annual trends. You can also add sophisticated calculations and highlight data using exceptions.

Crosstabs are powerful organizational and analytical tools that let you analyze your data and discover the relationships among the different dimensions.

<table>
<thead>
<tr>
<th></th>
<th>Central</th>
<th>East</th>
<th>West</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Cost</td>
<td>Revenue</td>
<td>Cost</td>
</tr>
<tr>
<td>Almond Bark</td>
<td>400,512</td>
<td>452,349</td>
<td>223,890</td>
</tr>
<tr>
<td>Assorted Nuts</td>
<td>2,275,100</td>
<td>2,653,120</td>
<td>1,781,820</td>
</tr>
<tr>
<td>Assorted Truffles, 12 piece</td>
<td>3,626,100</td>
<td>4,079,370</td>
<td>3,131,910</td>
</tr>
<tr>
<td>Assorted Truffles, 11 piece</td>
<td>4,863,249</td>
<td>5,180,130</td>
<td>2,800,952</td>
</tr>
<tr>
<td>Cartoon Figures</td>
<td>206,960</td>
<td>367,042</td>
<td>129,760</td>
</tr>
<tr>
<td>Chocolate Chips</td>
<td>296,729</td>
<td>286,719</td>
<td>160,296</td>
</tr>
<tr>
<td>Chocolate Computer</td>
<td>1,229,040</td>
<td>1,385,910</td>
<td>662,560</td>
</tr>
<tr>
<td>Gelf Balls</td>
<td>492,022</td>
<td>553,162</td>
<td>200,580</td>
</tr>
<tr>
<td>Vanilla Buttercream</td>
<td>142,128</td>
<td>169,572</td>
<td>88,960</td>
</tr>
</tbody>
</table>

Data Sources and Views

When you're creating a report with multiple presentations, you can create the presentations using data sources or views.

A **data source** stores raw data. For example, when you submit a query in BI Query and send the results to BI Query Reports, a data source is created to store the query results. Data sources don’t change, even when you change the data displayed in presentations. For example, you can change the data by adding calculations or removing dimensions from crosstabs.
A view  Stores a portion of data from a data source. Views are created when you create presentations. They store calculations, exceptions, and the arrangement of the data. For example, when you create a table and add subtotals, a view stores the subtotal calculations and how the data is arranged in the table. When you create different presentations using the same view, you can manipulate the data in one presentation and add calculations to it, and those changes will be automatically reflected in another presentation. In this way, views link presentations.

You can use data sources and views for the following purposes:

- Use the same data source to create different presentations. For example, you can create a table and a chart using the same query results.
- Use a view to create different presentations. When you use the same view, the changes you make to one presentation are automatically reflected in the other. For example, if you create a crosstab and add a sum calculation, then create a chart using the same view as the crosstab, the chart shows the sum calculation.
- Use multiple data sources and views in the same report. For example, you can create a table using a query about sales offices and representatives, then use another data source to create a chart showing product sales.

Turning Query Results into Reports

Business users and administrators with access to BI Query Reports can turn query results into reports that present detailed results in tables, summarize information in crosstabs, and display data visually in charts.

To turn query results into reports:

1. In BI Query, select attributes that will become the report elements.
2. Run the query.
3. On the Results menu, click Show as Report, and then click BI Query Reports.
4. Using Presentation Designer, create the report.
You can use query results to do the following:

- Create different presentations in a report using the same query results.
- Include data from multiple query results (and multiple databases) in one report.
- Replace the data in a presentation with data from another query.
- When reports contain data that changes regularly, you can ensure they display the most current data by refreshing them each time you open them, and rerunning the query or queries they use.

**Letting the Designer Do Most of the Work**

BI Query Reports Presentation Designer lets you quickly turn queries into reports. The designer is a simple, powerful tool that transforms source data into fully formatted tables, charts, and crosstabs with a few clicks of the mouse. The designer contains styles that make it possible to create fully formatted, presentation-quality reports and also provides a head start in creating custom reports.
Chapter 2

Getting Started

Starting BI Query Reports 13
Starting BI Query Reports from BI Query 13
Starting BI Query Reports on Its Own 14
Using an Automation Controller 18

Opening and Refreshing Reports 18
Opening Local Reports from BI Query Reports 18
Refresh Options 19
Starting BI Query Reports

BI Query Reports is the reporting tool for BI Query. The two applications are dependent on each other for data and reporting needs. How you start BI Query Reports depends on where you are in the reporting process:

- If you’re creating a report from a new BI Query results set, start BI Query Reports from BI Query.
- If you’re maintaining a report, start BI Query Reports on its own. When you start BI Query Reports, the BI Server Login dialog box may appear. This indicates that your corporate environment includes a central storehouse for reports called the BI Server Repository. You can log in and use the repository, or you can work offline. If you log in, you can publish reports to the repository, set permissions on them, retrieve them, and schedule them.

You can also run BI Query Reports using an automation controller.

**Note:** BI Query Reports is installed with BI Query. For installation instructions, see the BI Query Installation Guide.

Starting BI Query Reports from BI Query

To create new reports, start BI Query Reports from BI Query.

**To start BI Query Reports from BI Query:**

1. In BI Query, open or retrieve a results set. For information on using BI Query, see the BI Query Help.
2. On the Results menu, click Show as Report and then click BI Query Reports.
Starting BI Query Reports on Its Own

You start BI Query Reports on its own when you are using or maintaining existing reports. The Open preference determines how a report opens.

To start BI Query Reports on its own:

1. On the Start menu, click Programs, then Hummingbird BI, Hummingbird BI-Query, and BI Query Reports.

2. If the BI Server Login dialog box appears, do one of the following:
   - To work without repository access, select Work Offline.
To access the repository, type your user name, password and domain (if applicable). If you’re unsure what information to provide in this dialog box, check with your administrator.

If you need to publish, retrieve, schedule, or set permissions on reports, you can log on to the repository at any time.

3 In the Welcome to BI Query Reports window, click an icon for the appropriate report option.
Report Options

To create a report using Presentation Designer:

1. In the Welcome dialog box, click Presentation Designer.

   **Note:** You can use this option only if a data source is available.

2. Using Presentation Designer, create the report.

To open a report you recently used:

1. In the Welcome dialog box, click Recent Report.
2. In the Recent dialog box, select the report, and click Open.
To open a report stored on your computer or local network:

1. In the Welcome dialog box, click Local Report.
2. In the Open dialog box, locate and select the report, and click Open.

To open a report stored in the repository:

The Repository Report option is available only if you’ve logged in to the BI Server Repository.

1. In the Welcome dialog box, click Repository Report.
2. In the Retrieve Report dialog box, locate and select the report, and click OK.
To create a new report:

1. In the Welcome dialog box, click New Report.

2. If the Retrieve Data dialog box appears, select a data option, and click OK.

Using an Automation Controller

You can run BI Query Reports using an automation controller—a development tool or application that lets users and third-party developers write scripts and create applications that drive automation objects. Using an automation controller (such as Microsoft Visual Basic), you can open, refresh, print, save, and publish reports to the World Wide Web.

Opening and Refreshing Reports

Opening Local Reports from BI Query Reports

Once BI Query Reports is started, you can open reports saved to your computer. If you’re working in the BI Server environment, you can retrieve reports saved to your computer or local network.

The way reports open is determined by the Open preference. If you saved a report with its data sources, refresh it to work with the data in the report.

To open a report stored on your computer or local network:

1. On the File menu, click Open.

2. In the Open dialog box, locate a file and then click Open.

3. If the Retrieve Data dialog box appears, select an option and then click OK.
Refresh Options

If you are creating the same report on a regular basis (for example, weekly sales reports or quarterly income statements) you need to ensure that it contains the latest data. In BI Query Reports, you can refresh the data in reports to keep them up-to-date.

There are several options for refreshing reports:

• manually refresh a report when you open it
• set a report to refresh automatically each time it is opened
• be prompted each time you open the report whether to refresh the report or to show existing data instead

When you create a report, you set your preference for opening the report. Choose whether you want the report refreshed automatically, not refreshed, or if you want to be prompted each time you open the report.

If your reporting environment includes BI Server, you can schedule reports for distribution. When scheduled reports run, they are automatically refreshed to ensure that the data they contain is current.

Whether you refresh from BI Query Reports or while scheduling, you can insert different values into the query in response to prompts. This lets you run the same report based on different information (such as a different sales region) each time.

Note:

• Depending on the complexity of the queries, and the amount of data they return, refreshing data may take some time.
• If any query uses a connection file that does not store your password, you're prompted for it. If BI Query cannot find the data model associated with a query, you are prompted to find it.

If you refresh a report that uses a prompt, and you want to replace the current values with new values, make sure that you delete the current values first.
To delete the current values from a prompt:
1. In BI Query, in the Enter Value dialog box, click the List icon.
2. Choose Delete All Entries.
3. Click the Data Values icon, then select the values on which you want the report to be based.

Manual Refresh
If a report is not set to automatically refresh, you can manually refresh the report either when you open it or after it’s open.

To refresh a report:
Do one of the following:
• If the report is already open, on the Data menu, click Refresh.
• Open the report. If the Retrieve Data dialog box opens, click Refresh the Data and then click OK.

Automatic Refresh
You can set a report to refresh each time it is opened. The options for opening and refreshing are report-level preferences, so set them for each report you create.

To set a report to refresh each time it is opened:
1. With the report open, on the Tools menu, click Preferences.
2. On the General page of the Preferences dialog box, click Refresh the Data.
3. Click OK.
Chapter 3
Planning Reports

Overview
Identifying Types of Users 23

Presenting Data
Tables 24
Charts 27
Crosstabs 34

Gathering Data
Tables 39
Charts and Crosstabs 40

Building Tables
Using BI Query Reports Predefined Styles 41
Using Your Own Styles 42
Overview

Organizations have many departments, such as Finance, Human Resources, Sales, Marketing, Purchasing, Production, Distribution, and Customer Service. Each department works with different types of data and therefore they each have unique reporting needs.

If you’re designing reports for other users, you need to talk to them to identify their business questions. You also need to classify the different types of users and choose report designs that answer their questions and reflect their particular skill levels. Once you know what types of reports various users require, you can decide on which presentation type you want to use in the reports, then gather the data using BI Query.

Identifying Types of Users

Report authors create reports for distribution to other users. They create the best reports by knowing which type of user they are targeting:

- Users who read reports—They benefit most from an interface that lets them open reports with the click of a button, either from a link on a Web page or from a button in a data model.
- Users who analyze data—They analyze the data in existing reports. If the reports are interactive, users can re-qualify the data using hotspots.
Presenting Data

According to who your users are, decide what type of data they need and how best to present it to them.

Tables

The most common way of presenting data in a report is to use tables, but not all data makes a useful table. You need to determine whether a table is a good solution to your business question and whether you have the right data to create the table.

Tables work best for presenting detailed data, preparing forms, and creating large lists of information. For example, you can use tables to answer questions such as:

- How many units did we sell last month?
- What did our New York retailer buy last month?
- How much did each sales representative sell last quarter?

If you need to present summary-level information in a matrix, a crosstab is a better solution. If you want to communicate results visually, use a chart instead.
Invoices, Purchase Orders, and Other Forms

You can use BI Query to extract data from the database, then create a form in BI Query Reports using the results. You can use forms to generate monthly invoices, purchase orders, and form letters. For example, you can prepare a form for a targeted mailing to customers who match certain criteria, such as customers in the United States who placed orders totalling over $500 in the last year or customers in New York with invoices 30 days past due.

Company XYZ

PURCHASE ORDER

<table>
<thead>
<tr>
<th>Vendor</th>
<th>Address</th>
<th>Ship To</th>
</tr>
</thead>
<tbody>
<tr>
<td>A. Chocolate</td>
<td>1, Mont Royal</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Montreal, PQ</td>
<td></td>
</tr>
<tr>
<td></td>
<td>H5M 244</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Canada</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Description</th>
<th>Unit Price</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>Almond Milk</td>
<td>$0.30</td>
<td>$1.80</td>
</tr>
<tr>
<td>Vanilla Ice</td>
<td>$0.14</td>
<td>$0.43</td>
</tr>
<tr>
<td></td>
<td></td>
<td>$2.23</td>
</tr>
<tr>
<td>Sales Tax</td>
<td>$1.19</td>
<td></td>
</tr>
<tr>
<td>Shipping</td>
<td>$0.00</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>$2.23</td>
</tr>
</tbody>
</table>

Approval

Payment

- Check
- Cash
- Credit Card

Name ____________________  Expire Date ________
Lists and Catalogs

You can use BI Query Reports to produce a wide range of lists and catalogs for all facets of your organization: price lists, parts catalogs, employee lists, inventory lists, and so on. You can prepare catalogs and price lists for internal use or to distribute using e-mail or the World Wide Web.
Effective charts are simple. They don’t use a lot of fancy graphic options that can clutter the data and confuse your reader.

Charts

Not all data makes a useful chart. Before you create a chart, you need to consider the type of data you’re charting and choose the chart type to which it is best suited. You also need to choose the best chart type for the conclusion you want to present:

• Bar charts (see page 28)
• Dual axis charts (see page 30)
• Line charts (see page 31)
• Area charts (see page 32)
• Pie charts (see page 33)
• Three-dimensional charts (see page 34)

Use the following table to choose the best chart to display your data:

<table>
<thead>
<tr>
<th>To Show This</th>
<th>Use This</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data that changes over time</td>
<td>• Line</td>
<td>Annual sales for the last 10 years; 30-day stock trend;</td>
</tr>
<tr>
<td></td>
<td>• Bar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Stacked bar</td>
<td>Exports and imports between 1988 and 1998</td>
</tr>
<tr>
<td></td>
<td>• 3D bar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Area</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Stock</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Stacked area</td>
<td></td>
</tr>
<tr>
<td>Data at a single point in time</td>
<td>Horizontal bar</td>
<td>1998 sales for a family of products;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1998 sales and costs by month;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Number of employees per sales office</td>
</tr>
<tr>
<td>Parts of the whole</td>
<td>• Pie</td>
<td>Percent of sales by region;</td>
</tr>
<tr>
<td></td>
<td>• Percent bar</td>
<td>Market share</td>
</tr>
<tr>
<td></td>
<td>• Percent Area</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Doughnut</td>
<td></td>
</tr>
</tbody>
</table>
Charts aren’t a good choice for showing a lot of data. If you need to present detailed data in a report, consider using a table. If you need to present summary data in a matrix, a crosstab is a better solution.

**Bar Charts**

Bar charts show the change in size or volume of a single item or illustrate comparisons among several items over time. Categories are organized horizontally, and values vertically, to emphasize variation over time. For example, you can plot cost and revenue by product.
Grouped bar charts let you chart the values for an extra dimension. For example, if you want to plot sales by quarter for each region in a single chart, you can use a grouped bar chart. For the best readability, make grouped bar charts as simple as possible—with no more than three to four members per group. Grouped bar charts need a legend to identify the members being charted.

![Grouped Bar Chart](image)

**Central Sales**

**East Sales**

**West Sales**
Dual Axis Charts

Dual axis charts allow you to make relative comparisons based on different criteria. They plot two sets of bars for the same item and can use different scales and grids for each set. You can use a dual axis bar chart to plot the number of years that account executives have been with your company, along with their annual sales. This lets you to determine if there is a correlation between experience and performance.
Line Charts

Line charts show trends in data at equal intervals, displaying increases and decreases and illustrating relationships between members in a dimension. You can use the slope of the line to analyze the rate of change of the values when you are plotting a single dimension (for example, monthly sales for 1998) or to compare rates of change when you are plotting multiple dimensions (for example, monthly sales for 1996, 1997, and 1998).

Line charts are particularly effective when you are plotting a lot of members. Line charts give a smoother, more detailed comparison of time-oriented data than is possible in a bar chart. For example, plotting monthly sales figures in a bar chart results in a cluttered chart; a line chart gives a cleaner, more accurate picture of growth.
Area Charts

Area charts emphasize the magnitude of change over time by showing the area under the curve created by each member. The large, shaded surface indicates volume, similar to a bar chart. An area chart that plots a single column or row of data is more decorative than a line chart but provides the same information. By displaying the sum of the plotted values, an area chart shows the relationship of parts to a whole.

Note: Avoid using more than four or five areas in the chart.
**Pie Charts**

Pie charts show the relationship or proportion of parts to the whole. A pie chart plots one column or row of data, with each member in the column or row represented by one slice of the pie. The size of a slice corresponds to the percentage it represents of the total value for the members. In business reports, a pie chart is often used to show the share or percentage of individual categories in relation to a whole, such as market share, the mix of assets in a mutual fund, or the distribution of budget expenditures.

![Pie Chart: Sales by Country](image)

**Suggestions:**

- To maintain clarity, use no more than six pie segments.
- Avoid using a legend with pie charts since a legend makes it difficult to visually connect the legend colors to the pie segments. Instead, use labels.
- Avoid using multiple pies since they can be confusing. Alternatively, use a percent bar or area chart.
- Use a proportional pie chart when you need to compare the relative sizes of two pies to convey important information.

**Note:** Never compare more than two proportional pies; this makes a chart unreadable.
Three-dimensional Charts

Three-dimensional charts compare values along three axes. Three-dimensional charts can show data that would otherwise require a series of two-dimensional charts—for example, sales by region, country, or salesperson over a number of years. They make trends easy to recognize and are the best option for presenting large data sets and showing the relationships between them. For example, you can compare four quarters of sales performance in one division with the performance of other divisions. Using three-dimensional charts, you can choose between different data markers—such as cone, cylinder, and pyramid—to lend dramatic effects.

Crosstabs

Not all data makes a useful crosstab. Before you create a crosstab, you need to consider whether a crosstab is a good solution to your business problem and whether you have the right data to create one. Crosstabs work best for summary-level, multidimensional information. To present detailed data in a report, consider using a table. To communicate results visually, use a chart.

For typical scenarios, see the following sections:

- sales analysis (page 35)
- profit and loss reporting (page 36)
- manufacturing quality (page 37)
Sales Analysis Scenario

One of the most common uses for crosstabs is sales analysis. Putting sales data into crosstabs enables you to analyze results by product, sales representative, and region over time, discovering growth patterns and trends that were previously hidden. You can ask questions such as:

- Which products drove revenue?
- Has this changed over time?
- Why did results drop in the last quarter?
- Is a particular sales representative or region responsible?
- Does discount influence sales?

The following table lists the dimensions you might want to analyze in a Sales Analysis crosstab and some of the attributes to include in the query.

<table>
<thead>
<tr>
<th>To Analyze This</th>
<th>Include These Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Region</td>
<td>• Country (if applicable)</td>
</tr>
<tr>
<td></td>
<td>• State/Province</td>
</tr>
<tr>
<td></td>
<td>• Sales Office</td>
</tr>
<tr>
<td></td>
<td>• Sales Representative</td>
</tr>
<tr>
<td>Date</td>
<td>• Year</td>
</tr>
<tr>
<td></td>
<td>• Quarter</td>
</tr>
<tr>
<td></td>
<td>• Month</td>
</tr>
<tr>
<td>Product</td>
<td>• Product Category</td>
</tr>
<tr>
<td></td>
<td>• Product</td>
</tr>
<tr>
<td>Metrics</td>
<td>• Revenue</td>
</tr>
<tr>
<td></td>
<td>• Cost</td>
</tr>
<tr>
<td></td>
<td>• Quantity</td>
</tr>
<tr>
<td></td>
<td>• Gross Margin</td>
</tr>
<tr>
<td></td>
<td>• Gross Margin%</td>
</tr>
</tbody>
</table>
You can also include attributes in a query that return data about specific customers. Before you do, however, think about how many customers you have and how often you sell to them. If you have a lot of customers but don’t sell to any of them on a regular basis, or if each sales representative has sole responsibility for certain customers, you’ll generate a *sparse* crosstab containing a lot of *nulls*. *Dense* crosstabs, on the other hand, are more readable and easier to navigate. They also make trends easier to spot.

**Null Value**  A null indicates that there is no value for a combination of members (for example, that Assorted Truffles aren’t sold in Canada).

**Sparse**  A crosstab is sparse if a relatively high percentage of the possible combinations of members across dimensions contains null values.

**Dense**  A crosstab is dense if a relatively high percentage of the possible combinations of members across dimensions contains values.

**Profit and Loss Reporting Scenario**

Most organizations have to produce profit and loss reports (income statements). Transforming this data into a multidimensional Profit and Loss crosstab enables you to track a much wider range of variance. You use this crosstab to ask questions such as:

- Why is Travel & Entertainment (T&E) over budget?
- How much did we spend on T&E in relation to total expenses?
- How does T&E for this quarter compare with last quarter? What about last year?
- Is more staff travelling, or is a particular department or individual causing the variance?
- Which suppliers are we purchasing the most from?
- Can we leverage our purchasing power to gain a discount?
The following table lists dimensions you might want to analyze in a Profit and Loss crosstab and some of the attributes to include in the query:

<table>
<thead>
<tr>
<th>To Analyze This</th>
<th>Include These Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Income statement line items</td>
<td>• Revenue (Sales, Discounts)</td>
</tr>
<tr>
<td></td>
<td>• Cost of Goods (Materials, Shipping, Conversion)</td>
</tr>
<tr>
<td></td>
<td>• General &amp; Administration Expenses (Accommodation, Professional, Interest, General, Administration, Depreciation)</td>
</tr>
<tr>
<td></td>
<td>• Other Income/Expenses</td>
</tr>
<tr>
<td></td>
<td>• Tax</td>
</tr>
<tr>
<td>Date</td>
<td>• Year</td>
</tr>
<tr>
<td></td>
<td>• Quarter</td>
</tr>
<tr>
<td></td>
<td>• Month</td>
</tr>
<tr>
<td>Cost center</td>
<td>• Region</td>
</tr>
<tr>
<td></td>
<td>• Department (Sales, Marketing, Manufacturing, Shipping, R&amp;D)</td>
</tr>
<tr>
<td>Metrics</td>
<td>• Budget</td>
</tr>
<tr>
<td></td>
<td>• Forecast</td>
</tr>
<tr>
<td></td>
<td>• Actual</td>
</tr>
<tr>
<td></td>
<td>• Variance</td>
</tr>
</tbody>
</table>

Manufacturing Quality Scenario

Quality is of key importance in manufacturing. If you’re a manufacturer, creating a Manufacturing Quality crosstab lets you closely monitor quality as well as the impact of poor quality on the number of units produced and their cost.

You can track variance between the number of units actually produced and the number of units planned. If production is off track, you can quickly discover whether it is a result of an unusual number of faulty units, downtime, or slow production runs. You can ask questions such as:

• Are there any runs that are off target? Why?
• Was it because of excessive downtime, or was there an unusual number of faulty units?
• Is this run consistently off plan, or was it a one-time occurrence?
• Is a particular product or component causing the problem, or was there a delay at one stage of the run?

The following table lists the dimensions you might want to analyze in a Manufacturing Quality crosstab, as well as some of the attributes to include in the query:

<table>
<thead>
<tr>
<th>To Analyze This</th>
<th>Include These Attributes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Products</td>
<td>• Product Category</td>
</tr>
<tr>
<td></td>
<td>• Product</td>
</tr>
<tr>
<td></td>
<td>• Component</td>
</tr>
<tr>
<td>Production runs</td>
<td>• Plant</td>
</tr>
<tr>
<td></td>
<td>• Run</td>
</tr>
<tr>
<td>Work stages</td>
<td>• Setup</td>
</tr>
<tr>
<td></td>
<td>• Production</td>
</tr>
<tr>
<td></td>
<td>• Quality Control</td>
</tr>
<tr>
<td></td>
<td>• Packing</td>
</tr>
<tr>
<td>Date</td>
<td>• Year</td>
</tr>
<tr>
<td></td>
<td>• Quarter</td>
</tr>
<tr>
<td></td>
<td>• Month</td>
</tr>
<tr>
<td></td>
<td>• Week</td>
</tr>
<tr>
<td></td>
<td>• Day</td>
</tr>
<tr>
<td></td>
<td>• Hour</td>
</tr>
<tr>
<td></td>
<td>• Minute</td>
</tr>
<tr>
<td>Metrics</td>
<td>• Number of Planned Units</td>
</tr>
<tr>
<td></td>
<td>• Number of Hours</td>
</tr>
<tr>
<td></td>
<td>• Number of Actual Units</td>
</tr>
<tr>
<td></td>
<td>• Number of Faulty Components</td>
</tr>
<tr>
<td></td>
<td>• Downtime</td>
</tr>
</tbody>
</table>
Gathering Data

Once you’ve determined the requirements for a report, you can gather the data you need.

Tables

The data you present in a table starts with a query to the corporate database using BI Query. The attributes you choose in the query correspond to the columns in your table. To save yourself extra work in your report, follow these guidelines when you formulate your query:

• If you want to group certain information in a report and apply calculations to it, sort the corresponding data in BI Query.

• Eliminate duplicate data in the query using one of the following:
  - Distinct modifier—On the Query menu, click Modifiers, then click Distinct.
  - Aggregate function (such as SUM)—Click the Function box in the attribute window.

Grouping Results

You can group results in a report to present related information together and make your report easier to read. Once you’ve grouped results, you can then apply calculations such as subtotals to each group. For example, if you create a list of products in various product categories and include the revenues they generate, it makes sense to group products in the same product category together rather than having them dispersed throughout your report. You can then add a subtotal to determine the total revenue for each product category.

When you group data, header and footer bands are added to each group. These bands separate the groups and provide an area to stack columns, add subtotals, and place additional information. You can also create a page break for each group (useful for invoices where you want each customer’s invoice starting on a new page).
You can specify how to sort results before running a query, or after retrieving the results. You cannot sort the data in the report itself, but you can edit the query and then replace the data source containing the unsorted data with the data source containing sorted data. Presentation Designer in BI Query Reports automatically groups any columns that were sorted in BI Query.

**To group results:**

1. When you build the query in BI Query, apply the sort condition to the attribute on which you want to group the data in the report.

2. Do one of the following:
   - In the attribute window, click **Sort** for the attribute.
   - If you have already run the query, sort the results set. On the **Results** menu, click **Filter** and then click **Sort**.

**Charts and Crosstabs**

The data you present in a chart starts with a query to the corporate database using BI Query. When you create a chart, the detailed data you retrieve from BI Query is converted into summary data. To save yourself extra work in your report, follow these guidelines when you formulate the query.

- Ensure that the data is multidimensional. It should contain information on at least three dimensions of your business, such as Product, Region, and Metrics.
- Ensure that some of the data is numeric so that you can measure your success. For example, it should contain metrics such as Units Sold, Revenue, Cost, and Margin.
- Keep the number of attributes/dimensions in your query small (two to five).
- Ensure that descriptive columns don’t contain too many values. Charts communicate most effectively with seven or fewer values along one axis.
- Ensure that the data is evenly distributed.
- Focus on one business problem per chart. Don’t try to answer every question in a single chart or crosstab.
- Identify the critical time period. (If you need to compare results over quarters, don’t include monthly or weekly data.)
Building Tables

If you decide that you want to present data in a table, you have a number of ways you can build it:

• Specify default settings for tables, then select the Default style on the Style page of the Presentation Designer dialog box.
• Use one of the other styles that appear on the Style page of the Presentation Designer dialog box.
• Create and use user-defined table styles.

Using BI Query Reports Predefined Styles

Using BI Query Report styles is useful if you want to take advantage of their automatically applied formats. You can choose a table style using Presentation Designer. With each style you can choose to add totals to numeric columns. The following table styles ship with BI Query Reports:

<table>
<thead>
<tr>
<th>Use This</th>
<th>To Do This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Columnar</td>
<td>Arrange data in columns.</td>
</tr>
<tr>
<td>Free-form</td>
<td>Leave columns unanchored.</td>
</tr>
<tr>
<td>Stacked</td>
<td>Stack and left-align sorted data, placing remaining data in columns.</td>
</tr>
<tr>
<td>Stacked Indented</td>
<td>Stack and indent sorted data, placing remaining data in columns.</td>
</tr>
<tr>
<td>Default</td>
<td>Format tables according to the default style you specify.</td>
</tr>
</tbody>
</table>

See “Setting Default Formatting” on page 130.

Before building a table using the default style, you must specify what that style looks like. On the Table page of the Preferences dialog box, you can specify formats for:

• the data that appears in each band
• the text in each band
• the colors of borders and bands
Using Your Own Styles

Like the default style, user-defined styles are useful for creating reports that all have the same look and feel. Unlike the default style, user-defined styles apply to more than just the formatting of a table.

You create user-defined styles by saving a table as a template. The template stores the formats, the column grouping, and the calculations that appeared in the original table.

When you create a table using Presentation Designer, you can browse for the user-defined styles, then use them as the basis for the new table. They are most useful when you use them to build tables that contain similar data. For example, if a table style groups data (for example, by retailer) and contains calculations (such as sales by customer), the style works best if you use it to build other tables that contain data for retailers and their sales.
Chapter 4

Creating Reports

Overview 45

Building Presentations 45
Adding to Reports 46
Adding to Existing Reports 53

Editing Queries and Replacing Data 62
Changing the Data Source 62
Editing Queries 63
Mapping Unmatched Data 65
Removing Data Sources 66

Setting Preferences 66
Preferences for Opening a Report 67
Refresh Preferences 68
Setting Other Report Preferences 69

Saving Reports 70
Saving Reports with Data Sources 70
Reconnecting to the Database 72

Printing Reports 72
Specifying the Print Order 73
Selecting the Page Orientation 74
Previewing a Report 74
Printing to a Text File 74

Exporting Reports 75
Acrobat (PDF) Format 76
HTML Format 77
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quicksheet Format</td>
<td>77</td>
</tr>
<tr>
<td>Text (CSV) Format</td>
<td>77</td>
</tr>
<tr>
<td>Viewing an Exported Report</td>
<td>78</td>
</tr>
<tr>
<td>Copying Presentations to Other Applications</td>
<td>78</td>
</tr>
<tr>
<td><strong>Distributing Reports</strong></td>
<td>79</td>
</tr>
<tr>
<td>Mailing Reports</td>
<td>79</td>
</tr>
<tr>
<td>Using the Database</td>
<td>80</td>
</tr>
</tbody>
</table>
Overview

The report creation process involves the following general steps:

1. Gathering the data—You can create reports using new data, existing data, or views from other presentations.
2. Adding it to reports using presentations—The tables, charts, and crosstabs that deliver your message.
   
   You can add as many presentations to a report as you want. You can also easily re-qualify the data in a presentation by adding hotspots to the report.
3. Working with the report and making it available:
   - set preferences, save, and print it
   - work with it offline using spreadsheet applications such as Microsoft Excel or Quicksheet (spreadsheet application used on Palm hand held computer)
   - export it in a number of formats and view it in Adobe Acrobat or on the World Wide Web
   - distribute it using the repository and e-mail

Building Presentations

By determining which presentation type or combination of types best suits the data you want to use, you can focus a report on the information that interests your audience—whether that’s upper management, potential clients, or the general public.

When you build presentations, Presentation Designer steps you through the process, prompting you to select a presentation type, a style, and an organization for the data. Use the Presentations Designer to:

- add tables to a report
- add charts to a report
- add crosstabs to a report

You can also build presentations to add to existing reports.
Adding to Reports

Adding Tables
Tables are best suited for detailed data and creating large lists of information.

To add a table to a report:

1. With results displayed in BI Query, on the Results menu, click Show as Report, and then click BI Query Reports.

2. On the Presentation page of the Presentation Designer dialog box, click Table, then click Next.
3 On the Style page, choose a table style from the available list or, to choose a style that you or someone in your organization has created, click Browse.

4 Click Next.
5 On the Arrange Data page, drag a column up or down in the Columns list to specify the order in which you want the columns to appear.

6 Click Finish.

Adding Charts
Charts are a visual way of presenting summaries of your data. Charts are particularly useful for presenting conclusions or for highlighting trends, patterns, and other relationships that are not apparent in tabular data.
To add a chart to a report:

1. With results displayed in BI Query, on the Results menu, click Show as Report, and then click BI Query Reports.

2. On the Presentation page of the Presentation Designer dialog box, click Chart, then click Next.
3 On the Style page, click a chart type and sub-type.

4 Click Next.

5 On the Arrange Data page:
   - Make any changes you want in the default arrangement by dragging the data from one location and dropping it in another.
   - To focus a chart on a particular item, select Filter On, then drag the item into the Filter On box. Filtering controls the focus in a chart by displaying only the data related to a specific member, thereby simplifying the view.

For more information, see “Filtering Data” on page 157.
Chapter 4: Creating Reports

6 Click Finish.

Adding Crosstabs

Crosstabs display data in multidimensional format. You can use them to uncover trends, anomalies, problems, and opportunities.
To add a crosstab to a report:

1. With results displayed in BI Query, on the Results menu, click Show as Report, and then click BI Query Reports.

2. On the Presentation page of the Presentation Designer dialog box, click Crosstab, then click Next.

3. On the Arrange Data page:
   - Make any changes you want in the default arrangement by dragging the data from one location and dropping it into another.
   - To filter a crosstab on an item, select Filter On, then drag the item into the Filter On box. This controls the focus of a crosstab by displaying only the data related to this item.

For more information, see “Filtering Data” on page 157.
4 Click Finish.

Adding to Existing Reports

Adding Tables

When you add a table to an existing report, you can use the same data source used by another table, chart, or crosstab in the report, or you can use a new data source.

To add a table to an existing report:

1 With results displayed in BI Query, on the Results menu, click Show as Report, and then click BI Query Reports.

   If you want to retrieve new data:

   a) In BI Query retrieve new query results, then send the results to BI Query Reports.

   b) Create a table.
c) Close the report that contains the new data, but don’t save it. This adds the corresponding data source to the current session.

d) In the report in which you want to add the table, on the Insert menu, click **Table**.

2 On the **Data Source** page of the **Presentation Designer** dialog box, click a data source.

The **Data Source** page shows the data sources used in the reports you’ve created or opened and refreshed during the current session. As you create or open new reports, their data sources are added to the bottom of the list.

3 Click **Next**.

4 On the **Style** page, select a table style. To choose a style that you or someone in your organization has created, click **Browse**, then locate and open the template.

5 Click **Next**.

6 On the **Arrange Data** page, drag a column up or down in the **Columns** list to specify the order that you want the columns to appear.

7 Click **Finish**.
Adding Charts

When you add a chart to an existing report, you can use the same data source used by another table, chart, or crosstab in the report, or you can use a new data source.

To add a chart to an existing report:

1. Do one of the following:
   - If you’ve already retrieved the data you want to include in your report, on the Insert menu, click Chart.
   - If you want to retrieve new data:
     a) In BI Query, retrieve new query results, then send the results to BI Query Reports.
     b) Create a chart.
     c) Close the report that contains the new data, but don’t save it. This adds the corresponding data source to the current session.
     d) In the report in which you want to add the chart, on the Insert menu, click Chart.

2. On the Data Source page of the Presentation Designer dialog box, click a data source.
The available data sources correspond to the reports you’ve created during the current session. They appear in the order in which you retrieved the corresponding data using BI Query.

3 Click Next.

4 On the Style page, click a chart type, click a chart subtype, and then click Next.

5 On the Arrange Data page, make any changes you want in the default arrangement by dragging the data from one location and dropping it into another.

6 Click Finish.
Adding Crosstabs

When you add a crosstab to an existing report, you can use the same data source used by another table, chart, or crosstab in the report, or you can use a new data source.

To add a crosstab to an existing report:

1. Do one of the following:
   - If you’ve already retrieved the data you want to include in your report, on the Insert menu, click Crosstab.
   - If you want to retrieve new data:
     a) In BI Query, retrieve new query results, then send the results to BI Query Reports.
     b) Create a crosstab.
     c) Close the report that contains the new data, but don’t save it. This adds the corresponding data source to the current session.
     d) In the report in which you want to add the crosstab, on the Insert menu, click Crosstab.

2. On the Data Source page of the Presentation Designer dialog box, click a data source.
3 The Data Source page shows the data sources used in the reports you’ve created or opened and refreshed during the current session. As you create or open new reports, their data sources are added to the bottom of the list.

4 Click Next.

5 On the Arrange Data page, make any changes you want in the default arrangement by dragging the data from one location and dropping it in another.

6 Click Finish.
Adding Presentations

You can add more than one presentation to a report so that you can focus on different aspects of your business. For example, one presentation can show product sales per region, while another can show the top performing sales representatives in each region.

You may want to add a presentation that uses the data in an existing report, but presents it in a different way. For example, if you have a report that presents summarized data in a chart, you can also add a table that provides the details of that data.

You can include as many presentations as you like in a report, using the same data source or a new data source.

Adding Presentations by Using Views

When you create a presentation, BI Query Reports creates a subset of data called a view. A view is the ‘middle layer’ between a presentation and the corresponding data file. A view stores calculations, exceptions, and the arrangement of the data.

The data sources and views that are available to you are listed in the Data Sources dialog box. Views are listed under the data sources from which they were created. For example, if you used a sales query to create a table, the view for the table is listed under the Sales data source in the Data Sources dialog box.

To add a presentation using a view:

1. In a report, on the Insert menu, click a presentation type. For example, on the Insert menu, click Chart to add a chart to your report.

2. On the Data Source page of the Presentation Designer dialog box, double-click the icon beside the data source used to create the original presentation. For example, to use a crosstab view, double-click the icon beside the data source used to create the crosstab.

The Data Source page shows the data sources used in the reports you opened. As you open new reports, their data sources are added to the bottom of the list.
3 From the list of views, select the view associated with the original presentation. The icon for a view has a plus sign (+) in the upper right-hand corner.

4 Click Finish.

If you need, you can verify the view name for a presentation:

To check the view name for a presentation:
1 Click the presentation.
2 On the Format menu, click Properties.
3 In the Properties dialog box, click the General tab.
4 The view name appears in the Source View box.
Using Views to Link Presentations

You can use views to link presentations. When you create different presentations using the same view, you can manipulate the data in one presentation and add calculations to it. Those changes will be automatically reflected in another presentation. For example, you can create a crosstab, hide members you don’t need, and add a sum. When you create a chart using the view of the crosstab, the chart shows the same arrangement of data as the crosstab, including the sum.

Copying and Pasting Presentations

The Copy command lets you create a duplicate of the selected object. You can copy all objects including graphics, text, and presentations. You can copy tables, charts, and crosstabs and paste them anywhere in a report.

To copy and paste a presentation within BI Query Reports:

1. Select a presentation. To select a table, click outside of it, then drag over a portion of its border.
2. On the Edit menu, click Copy.
3. Click in the report where you want the presentation to appear.
4. On the Edit menu, click Paste.

Changing the Presentation Type

After creating your presentation, you may want to try a different presentation style for your data.

To change the presentation:

1. Select a presentation on the Insert menu.
2. On the Data Source page of the Presentation Designer dialog box, double-click the data source used to create the original presentation. The Data Source page shows the data sources used in the reports you’ve opened. As you open new reports, their data sources are added to the bottom of the list.
3. From the list that appears, select the view associated with the original presentation. The icon for a view displays a plus (+) sign.
4. If you no longer need the original presentation, delete it.
Editing Queries and Replacing Data

There may be times when you create a presentation, format it, and then realize that you want to fine-tune the data. Instead of going back to BI Query, rebuilding the query, then redoing all your work in the presentation, you can replace the data in the original presentation with new data.

**Note:** If you change the data for a table by adding new attributes to the query, you must add the corresponding data items to the table because they don’t appear automatically.

Changing the Data Source

When you change the data in a report, BI Query Reports matches the new data to the original. When it can’t match any items in the data, you need to match them yourself.

To replace the data source:

1. Open a report and select the presentation. On the Data menu, click Data Sources.
2. In the Data Sources dialog box, select the data source, and click Replace. This associates the original presentation with the new data source.

If the Data Sources command is not available, refresh the report and then click the Refresh tool on the toolbar or, on the Data menu, click Refresh.
If there is unmatched data, the Map Data dialog box opens. Map the unmatched data. Click OK. For more information, see “Mapping Unmatched Data” on page 65.

If there is unmatched data and the presentation is a chart or crosstab, the Arrange Data page of Presentation Designer opens. Arrange the new data source and click OK. The data source is replaced and the report view is revised.

**Editing Queries**

You can edit the query associated with an open report (for one data source at a time) and replace the data without having to initially refresh the report. For example, you need to sort a column, add an attribute, change a qualification, or create a new qualification. Perhaps you want to create another query, or add another presentation to a report. To make these changes, it is necessary to load a query in BI Query for editing, then update the results in Reports.

**To edit a query and replace the data:**

1. Do one of the following:
   - Open a report and select the presentation. On the Data menu, click Edit Query.
   - Open a report and select the presentation. On the Data menu, click Data Sources. In the Data Sources dialog box, select a data source and click Edit Query.

2. BI Query opens either the Show Query or Super Query design window. Edit the query and run it to obtain new results.

3. On the Results menu, click Show as Report, then click BI Query Reports.
4 The Replace Data Source dialog box opens.

Select an option:

**Replace an Existing Data Source**—Type a name in the Data Source Name box and click OK. If the columns match and the presentation is a table, the data source is replaced and the report view is revised.

If there is unmatched data, the Map Data dialog box opens. Map the unmatched data. Click OK. For more information, see “Mapping Unmatched Data” on page 65. If there is unmatched data and the presentation is a chart or crosstab, the Arrange Data page of Presentation Designer opens. Arrange the new data source and click OK. The data source is replaced and the report view is revised.

**Create a New Presentation**—Click OK. The Presentation Designer dialog box opens. Create the presentation and click Finish. For more information, see “Adding to Existing Reports” on page 53.

5 Save the report.
Chapter 4: Creating Reports

Mapping Unmatched Data

When you apply new data to a presentation, you must match the columns and dimensions in a presentation with those from the new data source. If the data you're trying to match is very different, it may not make sense to try matching it. Instead, it may be easier to create a new presentation and delete the old one. If you're replacing the data in a chart or crosstab, and the new data source contains more items than the old, items that aren't matched are filtered.

To map new (unmapped) data:

1. In the Map Data dialog box, click an item in the Unmapped new data list box.

2. Do one of the following:
   - Drag and drop it to the area beside an item icon in the Map 'DataSource' list.
   - Right-click the item and click Cut on the popup menu. Right-click the area beside an item icon in the Map 'DataSource' list and click Paste on the popup menu.
3 Continue until you’ve matched the items. To unmap an item, drag and drop it to the Unmapped new data list box. Alternatively, select it and press Delete on the keyboard.

4 Click OK.

**Removing Data Sources**

You can remove data sources you are not using in a report.

**To remove a data source:**

1 On the Data menu, click Data Sources.

2 In the Data Sources dialog box, select a data source.

3 Click Remove, then click OK.

**Setting Preferences**

On the General page of the Preferences dialog box, you can set preferences for:

- opening and refreshing reports
- refreshing charts and crosstabs
- refreshing reports that contain the same prompts
- displaying the Welcome window
- resizing bands when you place items into them

**Note:** The options for opening and refreshing are report-level preferences, so set them for each report you create.
Preferences for Opening a Report

You have a number of options for specifying how to open reports.

- If you always want a report to contain the most recent data, set the report to refresh when it opens. This is useful for reports whose data changes frequently because opening them reruns the associated query or queries and displays the latest data.

- If you’re distributing a report using the scheduler or e-mail, you may want to show the data that appeared the last time it was refreshed. This reduces the load on the database and ensures that everyone is reading the same version of the report.

- You can have BI Query Reports ask you if you want a report refreshed or to show existing data each time you open it. The default preference is set to ‘Ask me each time’.

The options for opening are report-level preferences, so set them for each report you create.

To set preferences for opening a report:

1. On the Tools menu, click Preferences.

2. On the General page of the Preferences dialog box, choose whether you want reports refreshed automatically, not refreshed, or if you want to be prompted each time you open a report.

3. Click OK.
Refresh Preferences

The options for refreshing are report-level preferences, so set them for each report you create.

To set preferences for refreshing a report:

1. On the Tools menu, click Preferences.
2. On the General page of the Preferences dialog box, select the preferences you want for refreshing the report. You can specify:
   - How to refresh crosstabs or chart presentations in a report.
   - How to refresh a report that uses data from more than one query, and the queries contain the same prompt value.
3. Click OK.

Refreshing Charts and Crosstabs

If a report contains a chart or crosstab, you can specify how they should be refreshed. When refreshing crosstabs or chart presentations in a report, choose one of the following:

- display all the items in the data
- display only the items currently shown

Example 1: If you refresh a report and a new product is introduced, you can decide whether to include the new product in the presentation.

Example 2: A report contains a pie chart showing the percentage of total sales for last quarter in Canada and the United States. The report contains a hotspot, which you re-qualify to include data for Mexico. You can specify that when you refresh the report, the pie chart shows all the items in the data (Canada, United States, and Mexico) or only the current two items (Canada and United States).


**Refreshing Reports with the Same Prompts**

If a report uses data from more than one query, and the queries contain the same prompt, you can specify how to be prompted. When you refresh reports using data from more than one query, and the queries contain the same prompt, by default, you are required to insert the same value each time you’re prompted. Instead, you can set a preference:

- to insert a value into the prompt only once
- to insert the same value each time you’re prompted (default)

For example, a report contains a table that shows sales for the current quarter, and the associated query contains a prompt for region. The report also contains a pie chart showing the contribution of each sales office to that quarter’s sales, and that query also contains a prompt for region. Unless you’ve set the preference to be prompted once, when you refresh the report, you’re prompted for the region twice.

**Setting Other Report Preferences**

You can set whether the Welcome window displays when you start BI Query Reports. You can also set whether bands automatically resize when you place items into them.

**To set preferences:**

1. On the Tools menu, click Preferences.

2. On the General page of the Preferences dialog box, select or deselect the following options:
   - When Starting BI Query Reports, display the Welcome Window.
   - When placing items in a band, resize band automatically.

3. Click OK.
Saving Reports

Once you’ve specified how a report opens, you can save it. You can save reports in any location. However, in order to distribute reports with a data model (using either the repository or the database), you must save them in the Reports subfolder of the folder where the data model is stored.

**Note:** If you're working in a BI Server environment, you must save reports before you can publish them to the repository.

**To save a report:**

1. On the File menu, click Save.
2. If the Save As dialog box appears, specify the name, file type, and location for the report.
3. Click Save.

**Saving Reports with Data Sources**

You may need to maintain reports on a computer that is not connected to a database. For example, you may start a report at the office, then decide to finish it at home. In this case, you can download the report and its data sources to a common location on your laptop computer, work on the report at home, and the next day reconnect to the database to retrieve the most up-to-date data.
You must refresh reports that have been saved with their data sources if you want to work with the data in them. Refreshing reports retrieves the data from local data sources. If you don’t want to work with that data, you can show the existing data instead. You may have to set open preferences to show the data in the format you want.

When you save a report with its data sources, its good practice to create a new folder for them. This keeps the report and its data sources separate from other reports, which helps eliminate confusion about which data sources belong with which reports.

**To save reports and results:**

1. On the File menu, click Work Locally, and click Save Locally As.
2. In the Save Locally As dialog box, specify a name and location for the report.
3. Click Save.

**Note:** When you work in a report that has been saved locally, you can’t publish or schedule that report until you reconnect to the database.
Reconnecting to the Database

If you’ve saved a report locally with results and want to refresh it using the most up-to-date data, you have to reconnect to the database.

**Note:** A report saved locally must be refreshed from its local data source before refreshing it from the database.

To reconnect to the database:

1. Open a report.
2. On the File menu, click Work Locally, then click Reconnect to Database.
3. The Retrieve Data dialog box opens. Select the option to refresh the data. If a message prompts you to refresh the report, click Yes.

Printing Reports

The Windows Print dialog box lets you specify how to print a report and whether to print it to a printer or a file. The options in this dialog box depend on the printer to which your computer is connected.

By default, pages print horizontally from left to right. Before you print a report, you may want to change this order. For example, your report might contain four pages, with a table spanning two pages vertically, a chart beside the first page of the table, and a crosstab beside the second page of the table. Unless you change the print order, the first page of the table prints first, then the chart, then the second page of the table, then the crosstab.
Before you print a report, you can:

- specify the print order
- choose the page orientation
- preview a report

To print a report:

1. On the File menu, click Print.
2. In the Print dialog box, specify the options you want.
3. Click OK.

Specifying the Print Order

Print order is established by a section break (a white line) between the pages of the report. To specify the print order, click in the blank space between the pages. For example, to print the pages of a report vertically instead of horizontally, click in the blank space between the vertical pages.

Blank pages can be created when a report contains a large table and a large crosstab, or when refreshing the data retrieves less information. Blank pages don’t print when at the end of a report, but they do print when they are within a report. To avoid printing blank pages, change the printing order or rearrange the report information.
Selecting the Page Orientation

Page Orientation specifies whether the report should print with its top along the short edge of the paper (portrait) or along the long edge of the paper (landscape).

To select the page orientation:
2. Select Portrait or Landscape.
3. Click OK.

Previewing a Report

You can view a report as it will appear on the printed page before submitting it to the printer.

To preview a report:
1. On the File menu, click Print Preview.
2. The print preview window appears.
3. Use the buttons at the top of the window to zoom in and out, show two pages at a time, and scroll through the report.
4. If the report appears as you would like it to appear in print, you can submit it to the printer by clicking Print. Otherwise, click Close to close the print preview window and return to the report.

Printing to a Text File

You can transfer your report to a disk file instead of directly to a printer.

To print to a text file:
1. On the File menu, click Print.
2. In the Print dialog box, select Print to File, then click OK.
3. In the Print to File dialog box, specify a file name and location, then click Save.
Exporting Reports

Exporting lets you extend the usefulness of your reports by letting you export your report to different formats so that the data in your report can be used in other applications. You can export reports in the following formats:

**Acrobat (.pdf)**—Lets you view and print reports using Adobe Acrobat Reader.

**HTML**—Lets you view reports using version 4.0 or later of Netscape Navigator or Internet Explorer.

**Quicksheet**—Lets you transfer reports to a Palm handheld computer for use in Quicksheet, a fully functional spreadsheet application. Each presentation in a report is placed in its own Quicksheet worksheet.

**Text (.csv)**—Reports exported in Comma-Separated Values (CSV) format can be imported easily into other applications, such as Microsoft Excel.

<table>
<thead>
<tr>
<th>This type of export</th>
<th>Creates these files</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acrobat (.pdf)</td>
<td>.pdf</td>
</tr>
<tr>
<td>HTML</td>
<td>.htm, .css, .jpg, and .gif</td>
</tr>
<tr>
<td>Quicksheet (.qsh)</td>
<td>.qsh</td>
</tr>
<tr>
<td>Text (.csv)</td>
<td>.csv</td>
</tr>
</tbody>
</table>

**To export a report:**

1. On the File menu, click Export, and choose an option from the submenu:
   - Acrobat (.pdf)
   - HTML
   - Quicksheet (.qsh)
   - Text (.csv)
If the exported reports are used in a network or Internet environment, do not use spaces or special characters (such as &, <, >, ", and so on) in file names. This avoids problems that can occur with different naming conventions.

2 In the Save As dialog box, specify the name and location for the report. If you’re saving the report in HTML format, you must save it in a folder separate from other HTML reports.

![Save As dialog box](image)

3 Click Save.

**Note:** If you move an exported report to a new location, make sure you copy all of the files.

### Acrobat (PDF) Format

Before exporting a report to .pdf format, make sure the columns in your report provide ample space for their contents. If the content of a column is too close to the edge of the column, the content may not appear in the .pdf.

Adobe supports certain fonts for Acrobat. Using these fonts in reports can ensure more consistent formatting when you export them. For further information, see the user documentation for Acrobat.

In Acrobat, you may achieve a more accurate page layout when you print reports if you turn off the default Fit to Page setting in the Print dialog box. You can also set up BI Query Reports to automatically publish a .pdf every time you publish a report with a data model from within BI Query.

**To automatically publish a .pdf every time a report is published:**

1 On the Start menu, click Run.

2 In the Run dialog box, type regedit, then click OK.
3 In the Registry Editor, go to:

\texttt{HKEY\_LOCAL\_MACHINE\SOFTWARE\Hummingbird\BI\ Query\ Reports}

4 Double-click \texttt{PublishPDFonOLE} and set the value to \texttt{T} (for True). By default, the value is set to \texttt{F} (for False), in which case only those reports that were last published to \texttt{.pdf} will be published to \texttt{.pdf} in future.

\textbf{HTML Format}

When you open an HTML report in a browser, you open its \texttt{report\_name.htm} file first. This opens the first page of the report along with a toolbar that you can use to navigate through the report.

\textbf{Quicksheet Format}

Quicksheet is a fully functional spreadsheet application used on the Palm handheld computer. You can use Quicksheet to view reports on your Palm handheld computer. You can edit the reports on the Palm, then transfer them, still in Quicksheet format, back to your computer. If you’re running Microsoft Excel, you can also view and edit the reports in Excel. Each presentation in a report is placed into its own Quicksheet worksheet.

You can download data to the Quicksheet format from tables and crosstabs, but not from charts. If a report contains a combination of presentations, only the data from tables and crosstabs is downloaded.

Exporting a report in Quicksheet format simply downloads a Quicksheet file. To use it and transfer it to the Palm, you must have the appropriate software installed on your computer.

For complete information, visit the Cutting Edge Software Web site at:

\texttt{http://www.cesinc.com}

\textbf{Text (CSV) Format}

Also called comma-separated values format, you can use text format to import reports into spreadsheet applications, such as Microsoft Excel, and analyze them offline. If Excel is installed on your computer, opening the report automatically places it into an Excel worksheet. You can then perform advanced calculations and other manipulations on the data.
Viewing an Exported Report

To open a report in HTML format, open the report's `report_name.htm` file. To print reports from a Web browser, open the Acrobat (.pdf) version of the report using Adobe Acrobat Reader.

To view an exported report:

1. Open an Internet browser.
2. On the File menu, click Open.
3. In the Open dialog box, find the file, then click Open.

Copying Presentations to Other Applications

You can export reports by copying and pasting tables and crosstabs from BI Query Reports into other applications and then you can perform additional tasks on them. For example, you can paste a table into Microsoft Excel, then apply advanced statistical calculations to the data. You can also copy and paste charts, but they’re copied/pasted as graphics or pictures, not OLE-objects, and therefore cannot be manipulated.

To copy a presentation to another application:

1. In BI Query Reports, select the presentation. To select a table, click outside of it, then drag over a portion of its border. To select a crosstab, click inside it.
2. On the Edit menu, click Copy.
3. Open another application.
4. On the Edit menu, click Paste.
Distributing Reports

You can distribute reports using e-mail, the corporate database, or the BI Server repository. You can distribute new and revised reports to other users running BI Query Reports as follows:

- If you’re working in a BI Server environment and you have the appropriate permissions, you can publish reports to the repository. This lets users retrieve reports using BI Query Reports or their Web browser.
- You can distribute them using the scheduler.
- You can distribute them using e-mail.

Before distributing a report across your organization, make sure that the users who receive it use the same printer driver (preferably a PostScript printer driver) that you used to create the report. A printer driver determines the amount of printable area on a sheet of paper, the available fonts, and the amount of space each font uses.

You can make sure that reports print the same for everyone by designing them using a PostScript printer driver that corresponds to the printer to which reports are printed. Make sure that everyone who will be printing the reports uses the same driver. If anyone uses a different printer driver or printer, test the reports on their printers to ensure that they still print correctly. If a report doesn’t print correctly, adjust the layout to accommodate the different printers or printer drivers.

Mailing Reports

If you’re running an e-mail application on your computer, you can easily distribute reports as attachments with your mail messages. You can use any mail application that supports Microsoft Messaging API (MAPI), such as Microsoft Exchange or Microsoft Internet Mail, to send mail directly from BI Query Reports.

To distribute a report using e-mail from BI Query Reports:

1. On the File menu, click Send. If a report is open, BI Query Reports automatically attaches the file to your message.
2. If you haven’t saved the report, do so at the prompt.
3 When the mail client opens, specify the subject and recipient(s).
4 Send the message.

Using the Database

Sites that use the database as the means of distributing revisions to BI Query data models can also use it to distribute reports. Administrators need to save reports in a Reports subfolder in the folder where the data model is stored. When users load the data model from the database, the reports are loaded too. For more information, see the BI Query Data Models User’s Guide.
Chapter 5

Creating Interactive Reports

Overview 83
Creating Interactive Reports 84
About Hotspots 84
Gathering the Data 85

Working with Hotspots 85
Adding Hotspots 85
Selecting Hotspots 89
Changing the Hotspot Label 89
Editing Hotspots 91
Moving Hotspots 91
Resizing Hotspots 92

Hotspots in Interactive Reports 92
Overview

Interactive reports let you change the data they contain without having to recreate the queries and generate new reports each time you want to examine the data from a different perspective. These reports are interactive because you click a hotspot to specify new criteria for the data, then refresh the report to obtain that data.

For example, an interactive report that shows sales data for different sales regions can include a hotspot that lets users specify the sales regions they want represented in a report. Using the hotspot, sales managers can either focus on a specific region to examine whether it is meeting its projections, or compare sales in one region with those in the other regions to determine which regions are the most productive.

If your corporate reporting environment includes BI Server, you can also use interactive reports on the Web. If you’re using Hummingbird BI Web, see the Help for that product.

Benefits of Interactive Reports

Interactive reports provide the flexibility administrators and users need by letting them:

• change data directly in a report
• focus a report on the information that interests them
• compare data from different perspectives
• serve a wide audience using one report

Creating Interactive Reports

You can make existing reports interactive, or you can create interactive reports from scratch, by adding hotspots and using them as titles, labels, or column headings. A hotspot is a button that is linked to a qualification in the associated query; clicking it lets users change the values on which the report is based.

When you create an interactive report, you provide data in the presentation type (table, chart, or crosstab) that you want. You also add one or more hotspots that let you requalify the report and obtain new data. You can create hotspots anywhere in a report.

A report whose associated query contains a prompt also lets you qualify the report. However, it doesn’t provide a visual cue, like a hotspot, to indicate that you can requalify the report. Also, while you can choose to requalify a report using a hotspot, a report with a prompt always prompts you to qualify the data in your report when you refresh it.

About Hotspots

To make a report interactive, you add hotspots to it. Before adding hotspots to a report:

• In the query, qualify the attribute that you want the user to change using the hotspot.
• Ensure that you select the correct data source (.hc or .hcr) in the Data Source page of the Hotspot Wizard.

To use a hotspot, click it. When you click it, the options you’re presented with depend on the qualification associated with the hotspot. Either a list of values appears, or the Choose Range dialog box appears.

A hotspot can change the data for one attribute. To re-qualify on more than one attribute, add more than one hotspot to the report.
Gathering the Data

The data in an interactive report starts with a query to the corporate database using BI Query. The query must include the qualification on which the hotspot will be based. For example, to create a hotspot that lets you change the sales regions, you need to qualify the Sales Region attribute in the query. It doesn’t matter what values are used to qualify in the query, since you can specify values using the Hotspot Wizard in BI Query Reports.

While you can normally qualify attributes in a query with data values, prompts, or variables, the attribute for a hotspot must be qualified using data values. If you link a hotspot to a prompt or variable, it is removed from the query when you use the hotspot to requalify the report.

Working with Hotspots

Adding Hotspots

A hotspot is a button that is linked to a qualification in the query used to generate a report. Clicking it lets users change the value(s) on which the report is based. A hotspot can change the data for one attribute. To requalify on more attributes, add additional hotspots to the report.
To add a hotspot:

1. Do one of the following:
   - Submit a query that includes a qualification, then generate a report by adding a presentation.
   - Refresh a report by clicking the Refresh tool on the toolbar or clicking Refresh on the Data menu.

2. In the report, on the Insert menu, click Hotspot.

3. Position the cursor where you want the hotspot to appear, then hold down the mouse and drag. Make the hotspot large enough to display the text you want, but not so large that it dominates the page.

4. On the Data Source page of the Hotspot Wizard, select a data source, then click Next.

Only the data sources that contain at least one qualification are displayed. If the data source has an `.hr` extension, its hotspot can requalify tables. If the data source has an `.hc` extension, its hotspot can requalify charts and crosstabs.
5 On the Qualification page, select an attribute, then click Next.

6 On the Values page, the values specified in the query qualification are displayed under Selected values.

If a data values results file exists, Get Data Values retrieves values from it. Load Database Values retrieves values from the database even when a data values results file exists.
To add additional values to the hotspot:

a) Click Get Data Values or Load Database Values.

b) Select the values that you want under Available Values, then click Add.

Load Database Values is available only after you click Get Data Values.

7 To prevent users from specifying values by typing them, deselect Allow Users to Type Values. You may want to prevent users from typing values for security reasons.

8 Click Finish.

If your reporting environment includes BI Server, and you have the appropriate permissions, publish the report to the repository and ensure that you grant refresh permissions to users who will view the report. For example, the following report contains several hotspots, one of which is clicked to display a drop-down list of data values (North American regions).

Once you create a hotspot, you can move it, resize it, and change its label.
Selecting Hotspots

When you click a hotspot, it displays the values you can use to requalify the report, or it prompts you to specify a range of values. In order to do anything else with a hotspot, such as move it or modify it, you need to select the hotspot.

To select a hotspot, do one of the following:

- Shift+click
- Ctrl+click a hotspot
- Right-click a hotspot to select the hotspot and display a pop-up menu

Changing the Hotspot Label

When you first create a hotspot, it displays default text, which consists of the attribute, operator, and values on which the qualification is based. The text is created using special fields. You can change the display of the hotspot label by replacing the special fields with more descriptive text.

For example, if the data in a chart is based on country, the hotspot label might display:

Country IN Canada, Mexico, USA

You can make the label easier to understand by replacing the special fields for attribute (Country) and operator (IN) and leaving the special field for values to create the label:

Sales Report for Canada, Mexico, USA
To change the hotspot label:

1. Right-click a hotspot and click Edit Label.
2. In the Text Editor dialog box, change the label text as required.

If necessary, specify a special field. These display the attribute, operator, and values used in a hotspot.

3. Specify the required formatting options.
4. Click OK.
Chapter 5: Creating Interactive Reports

Hotspot Special Fields
The three special hotspots fields—Hotspot Attribute, Hotspot Operator, and Hotspot Value—are available in the Fields list in the Text Editor dialog box. They are available only when you’re editing a hotspot.

<table>
<thead>
<tr>
<th>To display this</th>
<th>Add this</th>
</tr>
</thead>
<tbody>
<tr>
<td>The attribute users requalify when they click a hotspot.</td>
<td>Hotspot Attribute</td>
</tr>
<tr>
<td>The operator used in a hotspot.</td>
<td>Hotspot Operator</td>
</tr>
<tr>
<td>The values that appear in the re-qualified query.</td>
<td>Hotspot Values</td>
</tr>
</tbody>
</table>

Editing Hotspots
You can change the data source, qualification, or value(s) for a hotspot.

To edit a hotspot:
1. Right-click a hotspot and click Edit Hotspot.
2. In the Hotspot Wizard, make the required changes.
3. Click Finish.

Moving Hotspots
You can move a hotspot anywhere in a report.

To move a hotspot, do one of the following:
- Shift+click the hotspot, then drag it to the location you want.
- Cut and paste by right-clicking the hotspot.
Resizing Hotspots

Like any design element in a report, hotspots should draw attention to, but not detract from, the content. You can resize a hotspot if it is not large enough to display its label, or if it is taking up too much room in the report.

To resize a hotspot:
1. Select the hotspot.
2. Drag one of its handles until it is the required size.

Hotspots in Interactive Reports

Interactive reports contain hotspots that provide you with the flexibility to change the data so that it reflects the information that interests you. For example, an interactive sales report might provide quarterly sales for all regions and the top ten sales representatives per region. Sales representatives can use this report to compare their performance with that of all sales representatives, or just with those in their region. They can also compare their sales with sales from other regional offices.

If the report lets them change which quarter they are looking at, they can compare sales for their office from one quarter to the next. At the same time, if they are interested only in comparing regional sales between offices, they can concentrate on that information.

When you click a hotspot, what you’re presented with depends on the qualification associated with the hotspot. You can either choose a value from a list, or specify a range of values. For example, if you used a qualification that contained the BETWEEN or NOTBETWEEN operators, you need to specify a range.

After you use a hotspot, its appearance changes, and a watermark that displays ‘Report Needs Refresh’ appears in the report.
To use an interactive report in BI Query Reports:

1  Click a hotspot.

2  Do one of the following:
   - If a list appears, select a value.
   - To see a list of additional values, or to select more than one value, click More.
   - If the Choose Range dialog box appears, specify the start and end values in the Between and And text boxes, then click OK.

3  To refresh the report, on the Data menu, click Refresh, or click the Refresh tool on the toolbar.

After you have used a hotspot, its appearance changes. A watermark also appears that says “Report Needs Refresh”.

The following describes how to use interactive reports in BI Query Reports. If you’re using BI Web, see the BI Web Help or the BI Web User’s Guide online document.
If a crosstab or chart doesn't show all the data values used to requalify:

1. On the Tools menu, click Preferences. The Preferences dialog box, General page is displayed.

2. In the When refreshing crosstab or chart presentations in this report area, select Show all items.

3. Click OK.

4. Refresh the report.
# Presenting Results in Tables

**Overview**  
Understanding Tables  
About Bands  
About Columns  

**Working with Bands**  
Formatting Bands  
Adding Group Header and Footer Bands  
Controlling which Bands Display  
Adding Items to a Band  
Adding Charts to Bands  
Applying Variable Data Fields and Bands to Tables  

**Working with Columns**  
Using the Column Control Bar  
Adding New Columns  
Formatting Columns  
Managing Columns over Multiple Pages  
Deleting Columns  
Changing the Spacing Between Columns  
Merging Columns  
Combining Data Items Using Labels  
Fitting Columns on One Page  
Anchororing Items to a Column  
Resizing Columns  
Reordering Columns
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Data</td>
<td>121</td>
</tr>
<tr>
<td>Moving and Copying Items</td>
<td>121</td>
</tr>
<tr>
<td>Stacking Data</td>
<td>122</td>
</tr>
<tr>
<td>Suppressing Duplicate Data</td>
<td>123</td>
</tr>
<tr>
<td>Adding Data</td>
<td>125</td>
</tr>
<tr>
<td>Formatting Tables</td>
<td>129</td>
</tr>
<tr>
<td>Table Properties</td>
<td>130</td>
</tr>
<tr>
<td>Setting Default Formatting</td>
<td>130</td>
</tr>
<tr>
<td>Adding and Removing Page Breaks</td>
<td>132</td>
</tr>
<tr>
<td>Adding or Removing Table Frames</td>
<td>133</td>
</tr>
<tr>
<td>Changing Column Headings and Titles</td>
<td>134</td>
</tr>
<tr>
<td>Using Styles</td>
<td>135</td>
</tr>
</tbody>
</table>
Overview

Tables provide a quick and easy method of presenting data. They display detailed data in columns, with headings across the top. Tables provide users with an almost unlimited framework for presenting data—including form letters, invoices, purchase orders, catalogs, and so on.

You can improve the presentation of tables by organizing data and formatting bands and columns. For example, you can stack data, show or hide bands, add charts to bands, and resize and rearrange columns.

Graphics, text labels, and OLE objects also enhance the appearance of tables and provide additional information. Report styles let you quickly create fully formatted tables, including subtotals and grand totals, ready for presentation.

Understanding Tables

Tables are made up of columns and bands of information. They are easy to work with because all the elements in a table—title, data, and column headings—are independent of each other. You can move, copy, and resize them. You can group the data and add calculations to the groups, and you can add page breaks based on those groups. In addition, you can stack columns, suppress duplicates, and add data from other tables. When you create large tables, BI Query Reports adds pages vertically to the report to accommodate all the data.
The following diagram some of the elements of a typical table:

```
<table>
<thead>
<tr>
<th>Report header band</th>
<th>Page header band</th>
<th>Detail band</th>
<th>Group footer band</th>
<th>Page footer band</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

### About Bands

A table is made of columns and bands. There are five default bands.

#### Default Bands

**Report header band**—Information that appears once at the top of the table (such as a title).

**Page header band**—Information that appears at the top of each page (such as column headings).

**Detail band**—The data in each row of the query results. You can add calculations, graphics, text, and OLE objects, and you can apply exceptions to them.
Page Footer band—Information that appears at the bottom of each page (such as page numbering and date).

Report Footer band—Information that appears once at the bottom of the table. The default is the End of Report label.

Other Bands
You can add additional bands to a table by grouping the data in the table. These bands are called:

Group header band—Information that appears above each group of data. Header bands are created automatically when data is grouped.

Group footer band—Information that appears below each group of data. Footer bands are created automatically when data is grouped. You can add calculations to the footer bands for each group.

Note: The group header and footer bands may be hidden by default depending on the style you’ve applied to the report.

About Columns
A table is made of columns and bands. A column is an object that is separate from the data it contains. It is a vertical area in a table that can contain data items, calculations, and report objects (for example, text objects and drawing objects) but it can also be completely empty. When you first insert a column, it remains empty until you populate it with data items or report objects.

You can select all objects in a column by clicking the column heading in the Column Control bar. Once the objects are selected, you can cut, copy, paste, insert, delete, anchor, move, format, and merge columns.
Working with Bands

To perform any operation in a band, you need to select it first.

**To select a band:** click inside the band, at the left most edge of the table. Make sure you click between the data items that appear in the band.

**Note:** It is easier to select bands that stack data items than it is to select bands that display data items side-by-side.

**To add an item to a band:** double-click the band at the outermost edge of the table. If you double-click an item in a column instead of the band, the Properties dialog box appears.

**Determining How a Band was Selected**

A line with a handle distinguishes how a band has been selected. If the handle is on top of the line, it has been clicked once; if the handle is on the bottom, it has been double-clicked.

---

A band that's clicked once displays a handle above a line. A band that's double-clicked displays a handle below a line.

---

**Formatting Bands**

For each band, you can specify the characteristics of the font, fill, and the outline. You can display the band (for example, the company logo) on multiple pages of a report or you can apply an exception to the band.
To format a band:

1. Click a band to select it.
2. On the Format menu, click Properties.

3. In the Properties dialog box, specify the required options.
4. Click OK.

Adding Group Header and Footer Bands

You can break up information in a report and have it stand out by adding header and footer bands. You can fill the bands with a color or pattern, and you can add additional information such as a subheading or graphic.

To add header and footer bands:

1. Click anywhere in a table.
2. On the Format menu, click Table, then click Group Break.
3 In the Group Breaks dialog box, under Report Data, select the columns to which you want to add a group header and footer, then click Add to move them under Break By.

4 Click OK.

Controlling which Bands Display

When you generate a report, most of the associated bands (report header, page header, detail band, and so on) are displayed by default. Group header bands are displayed only if the Stacked style is applied to a table, and group footer bands are displayed only if a style that includes subtotals has been applied to the table.

When you have a long report containing subtotals and grand totals, you may not always want to see all the details. A summary of totals may suffice. You can hide the detail by hiding the detail band.

Similarly, if you’ve grouped data in a report, you can display the group header and add a color, pattern, heading, or graphic to it to make each group stand out.

See “Creating Summary Reports—Suppressing Details” on page 103.
Creating Summary Reports—Suppressing Details

If your report has subtotals and grand totals, you can create a summary report by hiding the detail bands. When you generate a report, most of the associated bands (report header, page header, detail band, and so on) are displayed by default. You can change how much detail you show in your report by hiding or showing bands.

For example, when you have a long report containing subtotals and grand totals, you may not always want to see all the details. A summary of totals may suffice. You can hide the detail by hiding the detail band.

To hide the detail bands:

1. Click anywhere in a table.
2. On the Format menu, click Table and then click Show/Hide Bands.
3. In the Show/Hide Bands dialog box, click Detail.
4. Click Hide.
Click OK.

**Showing or Hiding Bands**

You can change how much detail you show in your report by hiding or showing bands.

**To show or hide a band:**

1. Click anywhere in a table.
2. On the Format menu, click Table and then click Show/Hide Bands.
3. In the Show/Hide Bands dialog box, click a band.
4 Do one of the following:
   • To display a band, click Show.
   • To hide a band, click Hide.

5 Click OK.

When you hide a band, everything within it is hidden as well. If there is a page break associated with a band, and you hide that band, the page break no longer applies.

Adding Items to a Band

When you add text labels, graphics, bitmaps, and clipart to tables, you add them to bands. For example, you can add a text label for a subtotal, place a bitmap in a group header band, and add a logo to the page header band.

When you add an item to a band, the item appears in every band of that type. For example, an item that’s added to the page header band repeats in all page header bands in the table.

To add an item to a band:

1 Double-click a band. If you click the band only once, the item will be overlaid on the report and won’t be repeated in each band.

2 Do one of the following:
   • Using a drawing object, click and drag in the band.
   • Draw the object in the report, then drag it into the band.
Adding Charts to Bands

When you add a chart to a detail band, a group footer band, or a group header band, the chart changes to reflect the data for that band. This lets you add a visual representation to back up the hard data displayed in the bands. For example, if you have a table that shows cost, revenue, and profit by quarter, you can add a chart to the group footer band to show the revenue, cost, and profit for each quarter.

When you add a chart to a band, the first column of data in the table is used as the labels along the x-axis. You can change which labels appear along the x-axis by rearranging the columns in the chart. You can also:

- Hide a column of data in a chart and still have it appear in the table. Alternatively, you can remove a column from both the chart and the table.
- Format the labels along the x-axis.

For more information, see “Formatting X-axis Labels” on page 169.
To add a chart to a band:

1. Add a chart to a report using the table view:
   a) On the Data Source page of the Presentation Designer dialog box, double-click the data source used to create the table.
   b) Select the view associated with the table. The icon for a view displays a plus (+) sign.

2. Drag the chart into a band. To add the chart to a group header band, you may have to first display the band. On the Format menu, click Table and then click Show/Hide Bands.

3. The first column of data is used as the labels along the x-axis. To use the data in another column as the labels along the x-axis:
   a) Click the chart.
   b) On the Format menu, click Chart and then click Rearrange Data.
   c) In the Rearrange Data dialog box, click the tool for Columns. The tool for Columns looks like:

   | Regional Office # | City     | State/Province | Country |

   d) In the Included Members dialog box, drag the column you want to use to the top of the Included Members list.
   e) Click Close, then Close again.

4. To have the chart reflect all of the data in the table:
   a) Click the chart.
   b) On the Format menu, click Properties.
c) In the Properties dialog box, click the Options tab, then deselect Show Data in Band.

Changing the Y-axis Scale
When you add charts to bands, their y-axis scales change to be proportional to the data in each band. You can change the scales to be the same in each chart using the Chart Editor.

Applying Variable Data Fields and Bands to Tables
You can set the data fields and detail bands in tables to automatically adjust to accommodate the data in them. This feature lets you create tables with lots of data and have the data fit the individual bands without having to resize the bands yourself. It also ensures that when you refresh a report with data that is longer than the original, all the new data is visible. This feature can be useful when creating special reports such as purchase orders and invoices.
When you apply this feature to a report, the data fields expand or shrink to accommodate the new data. Column boundaries are maintained; where necessary, the data in the data field wraps to the next line, and the data field expands vertically. Similarly, detail bands in the table expand or shrink to accommodate the largest field they contain. You can resize the table, and the data fields and detail bands adjust themselves accordingly.

**Note:** You can apply this feature only to data fields in detail bands. You can’t apply it to data fields that occur in header and footer bands (for example, in stacked reports).

This feature also applies to calculations and exceptions you add to a table. However, data fields do not resize for hidden bands. If you apply an exception to a table that hides the data fields, the bands don’t resize.

Only textual data will wrap to the next line, not numbers or dates. Applying this feature turns on the Wrap Text setting. This feature is available for more than one table in a report. It is also available for styles, both those supplied with BI Query Reports, and those that you create.

Once you apply variable fields and bands to a table, you cannot drop or paste items into a detail band, and you cannot drag columns to change their order (although you can do this using the Column Control bar). It is best to apply this feature after you have formatted the table and resized it to suit the report.

**Note:** It may take some time to apply this feature to tables that contain a lot of data.

To apply variable data fields and bands to a table:

1. Click anywhere in a table.
2. On the Format menu, click Table and then click Variable Fields & Bands.
3 If necessary, resize the table.

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity</th>
<th>Store Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Battle Set</td>
<td>1</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Deluxe Bag</td>
<td>3</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Woman's</td>
<td>3</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Tri Flex</td>
<td>4</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Junior Pull</td>
<td>3</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>52 inch</td>
<td>4</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Magnesium</td>
<td>1</td>
<td>Golf Boutique Dublin</td>
</tr>
</tbody>
</table>

These reports show the difference in the amount of data you can view when you apply variable fields and bands. In the second report, full product names are shown.

### Products Sold in May

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity</th>
<th>Store Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Battle Set</td>
<td>1</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Deluxe Bag</td>
<td>3</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Woman's</td>
<td>3</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Tri Flex</td>
<td>4</td>
<td>Golf Boutique Dublin</td>
</tr>
<tr>
<td>Junior Pull</td>
<td>3</td>
<td>Golf Boutique London N Live Oak</td>
</tr>
<tr>
<td>Cart</td>
<td>4</td>
<td>Golf Boutique London N Live Oak</td>
</tr>
<tr>
<td>52 inch</td>
<td>4</td>
<td>Golf Boutique London N Live Oak</td>
</tr>
<tr>
<td>Magnesium</td>
<td>1</td>
<td>Golf Boutique London N Live Oak</td>
</tr>
<tr>
<td>Spin 15</td>
<td>1</td>
<td>Golf Boutique London N Live Oak</td>
</tr>
<tr>
<td>Flack</td>
<td></td>
<td>Golf Boutique London N Live Oak</td>
</tr>
</tbody>
</table>

### Working with Columns

To see the column controls at the top of the report window, click a table. The Column Control bar appears as:

<table>
<thead>
<tr>
<th>Regional Office #</th>
<th>City</th>
<th>State/Province</th>
<th>Country</th>
</tr>
</thead>
</table>

Using the Column Control bar, you can:

- select columns
- format columns
- cut, copy, and paste columns
- insert columns
- delete columns

110
• change the spacing between columns
• merge columns
• anchor items in a column
• resize columns
• reorder columns

You can select all objects in a column by clicking the column heading in the Column Control bar. Right-clicking displays the Column Menu pop-up menu.

Using the Column Control Bar

Use the Column Control bar to select a column and perform operations on that column. Right-clicking a column in the Column Control bar displays the Column Menu pop-up menu for the selected column.

To use the Column Control bar:

1. On the View menu, click Column Control bar. A check mark appears beside the command to indicate that it is active.
2. To view columns in the controls, select a table.
3. To apply changes to the data items in a column, right-click the column in the Column Control bar.
4. In the Column Menu pop-up menu, choose a command.

To select a single column: Click the column in the Column Control bar.

To select multiple columns: Hold down the Ctrl key, then click the columns in the Column Control bar.

To select all columns: Hold down the Alt key, then click a column in the Column Control bar.
Adding New Columns
When you first insert a column, it will be empty until you populate it with data items or report objects. New columns are added to the left of the selected column.

To add a new column:

1  In the Column Control bar, right-click a column.
2  On the Column Menu pop-up menu, click Insert. New columns are added to the left of the column you click.

Formatting Columns
For each column, you can specify the characteristics of the font, fill, and the outline. You can display the column on multiple pages of a report or to apply an exception to it.

To format a column:

1  In the Column Control bar:
   a)  Click a column.
   b)  On the Format menu, click Properties.

Alternatively,

a)  Right-click a column.

b)  On the pop-up menu, click Properties.
2 In the Properties dialog box, specify the required options.

3 Click OK.

**Managing Columns over Multiple Pages**

Columns that don’t fit on one page when you generate a report are divided over multiple pages. You are limited to 25 pages in which to display columns. Any additional columns are not displayed. If report pages are expanded, the new data will overlap the data that is already displayed.

You can prevent the division of columns over multiple pages, consider:

- Fitting all columns on one page. See “Fitting Columns on One Page” on page 116.
- Changing the orientation of the report to landscape. See “Selecting the Page Orientation” on page 74.
- Stacking the data. See “Stacking Data” on page 122.
- Resizing columns. See “Resizing Columns” on page 118.
- Merging columns. See “Merging Columns” on page 115.
- Wrapping text in a column if you’ve turned text wrapping off. Double-click the text. In the Properties dialog box, click the Font tab, then select Wrap Text.
Deleting columns. See “Deleting Columns” below.

Modifying the query to return fewer columns.

Modifying the results to hide columns. In a results window in BI Query, on the Results menu, click Reorder Columns.

Deleting Columns

When you delete a column, all the items in the column are deleted as well. If the column contains a data item, you can reinsert it into another column at any time.

To delete a column:

1. In the Column Control bar, right-click a column.
2. In the Column Menu pop-up menu, click Delete.

Changing the Spacing Between Columns

You can change the spacing between columns in a table. For example, you can increase column spacing if the columns in a table are too close together, making the report hard to read, or decrease column spacing to fit the table on one page. Spacing is in units of 0.01 of an inch. The smallest amount of space you’re allowed between columns is 0.01 of an inch; the largest amount of space you’re allowed is 0.10 of an inch.

To change the spacing between columns:

1. In the Column Control bar, right-click a column.
2. Choose Spacing from the Column Menu pop-up menu.
3. In the Column Spacing dialog box, type a value in the Spacing box.
4. Click OK.
**Merging Columns**

You can merge adjacent columns into a single column in order to make more room in a report, or to have more flexibility in how you organize your data. When you merge columns, the data in both columns remains as separate items in the resulting column, and you can move and format the data in each column individually. For example, you can place a person’s last name indented under the first name and apply a different font to it to make it stand out.

**To merge columns:**

1. In the Column Control bar, right-click the column you want to merge.
2. On the Column Menu pop-up menu, click Merge.
3. The column you click is merged with the column to its left.

**Combining Data Items Using Labels**

You can combine data items using a label (using special fields) or using a calculation.

**To combine data items using a label:**

1. Double-click a band.
2. On the Insert menu, click Label.
3. Hold down the mouse and drag in the band where you want the data items to appear.
4. In the Text Editor dialog box, select Field from the Fields list.
5. In the Data Cell Selector dialog box, click the blue columns indicator in the Dimensions area.
6. In the Choose a Member dialog box, click a column.
7. In the Data Cell Selector dialog box, click OK.
8. To add a character (such as a comma and a space) between the data items, in the Text Editor dialog box, type the character after the tag for the first item.
9. To add the second data item, repeat steps 4 to 7.
10. In the Text Editor dialog box, click OK.
Fitting Columns on One Page

If all the columns in a table do not fit on one page, you can resubmit the query and regenerate the table using the Fit on One Page option.

To fit all columns on a page:

1. In BI Query, submit a query.
2. On the Results menu, click Show as Report and then click BI Query Reports.
3. On the Presentation page of the Presentation Designer dialog box, select Table, then click Next.
4. On the Style page, click Fit on One Page, then finish creating the table.
Anchoring Items to a Column

When you anchor an item, you’re locking it to a specific position in a column. Items are anchored to fit the column, by default. This means that when you resize a column, the items in it will resize as well, ensuring that they are always the same size as the column. Alternatively, you can anchor items to the left or right of a column, or unanchor them so that they ignore column settings. Unanchored items are still restricted by column boundaries, but are not locked to a specific position in the column.

You can anchor any item inside a table to a column. Most often you anchor data items, but you can also anchor graphics and text to columns. You can also float items in a table so that they are not restricted by the column boundaries.

To anchor an item to a column:

1. Select the item(s) you want anchored:
   a) In the Column Control bar, right-click the column that contains the items you want anchored.
   b) On the Column Menu pop-up menu, click Anchor.

   Alternatively,
   a) Move the items to the column.
   b) On the Layout menu, click Anchor.

2. Choose the option you want from the anchor submenu.
Resizing Columns

When you resize columns, the items in the columns resize as well, as long as they are anchored to fit the column. If the items are not anchored, or if they are anchored to the left or right of a column, they won’t resize with the column.

**Note:** When you resize a column, the items in the column may shrink or widen, but their height does not change. You have to change the height of items in a column separately. However, if you apply the variable bands option, then the height of items does change.

To ensure items in a column are anchored to fit the column:

1. Click the item.
2. On the Layout menu, click Anchor.
3. Make sure there is a check mark beside the Fit to Column option. If there is no check mark, click Fit to Column.

**To resize a column:**

1. In the Column Control bar, position the cursor over the right boundary of the column you want to resize.
2. Drag left to narrow the column or right to widen it.

Resizing an Item in a Column

When you resize a column, the items in the column may shrink or widen, but their height does not change. You have to change the height of items in a column separately. However, if you apply the variable bands option, then the height of items does change.
To resize an item in a column:
1. Click an item.
2. Click one of the item handles.
3. Drag the item(s) to the required size.

Autosizing Items in a Column
The Autosize command resizes all the items in a column to the size of the largest item in the column. If there is an extremely large item in the column, autosizing resizes the item to the maximum page width. Text that doesn’t contain line breaks wraps onto the next line.

To autosize an item in a column:
1. In the Column Control bar, right-click the column that contains the items you want to autosize.
2. In the Column Menu pop-up menu, click Autosize.

Reordering Columns
You can change the order of columns when you create reports using Presentation Designer. Once you’ve created reports, you can drag and drop or cut and paste columns using the Column Control bar.
To reorder columns:

1. Click a column in the Column Control bar.
2. Drag the column to the position you want. You cannot drag columns across pages.

To move columns across pages:

1. Click the column you want to move.
2. On the Edit menu, click Cut.
3. Click a column on the page on which you want to paste the copied column.
4. On Edit menu, click Paste.
Working with Data

Once you’ve added a table to a report, you can move or copy the data, stack it, and suppress duplicates.

Moving and Copying Items

All the elements in a table—title, data, column headings, text labels, graphics, bitmaps, clipart, and calculations—are items that you can move and copy. If you select a column, then copy and paste it, the data in the first row of the detail band is copied, not the entire column (unless you paste it into another column).

To move or copy items within a table or between tables: Drag and drop the items into the bands you want.

To copy items: Hold down the Ctrl key and drag the items.

To repeat an item at the top/bottom of each page: Move the item into the page header or footer.

To move or copy an item from one page to another:
1 First, increase the report size.
2 Increase the size of the table (by adding and removing table frames).
3 Drag the item onto the new page, then drop the item into the band you want.

Copying a Column Item

When you’re working with a table, you may want to copy a data item into an existing or new column.

To copy a column item:
1 Select an item.
2 Hold down the Ctrl key, then drag the item to a new location.
Stacking Data

Instead of displaying columns horizontally across a page, stack one on top of another. Stacking is an alternative way of organizing information so it’s easier to read. You can fit more information across a page and group related information together. For example, group sales data by region and quarter.

Stacking is useful for creating different types of tables. For example, when you’re creating forms such as invoices and purchase orders, you can stack customer address information under a customer’s name so that it looks like a label on the form.

When you create a report, Presentation Designer offers a choice of:

- **Stacked table styles**—Stacks and left-aligns sorted data, placing remaining data in columns.
- **Stacked Indented table styles**—Stacks and indents sorted data, placing remaining data in columns.

These styles stack sorted columns in the detail bands of a table. You can also stack any column anywhere in a table yourself.

**Before you stack data:**

If you want to stack columns in the group header, and the band is not displayed, you need to display it as follows:

1. Click inside the table.
2. On the Format menu, click Table and then click Show/Hide Band.
3. Click the header band and click Show.
4. Click OK.

**To stack data:**

1. Resize the band where you want to stack columns so it is large enough to accommodate them.
2. Click an item in a column, then drag it to where you want it stacked.
3. Repeat until you’ve stacked all the columns that you want to stack.

**Note:** You should sort any data items you wish to stack.
Suppressing Duplicate Data

Tables may display all the data from a BI Query results set, even when the data contains duplicates. This repetition may be unnecessary or may detract from report readability. To avoid this, you can conceal, or suppress, duplicated data. Suppressing duplicates is particularly useful if a report includes grouped data because it highlights the categories into which the data has been grouped. Suppressing duplicates does not remove the data; it simply hides it.

You can conceal, or suppress, duplicated data in Tables.
To suppress duplicate data:

1. Click the column you want.
2. On the Format menu, click Table, and then click Group and Sort. In the Group and Sort dialog box, drag the column in which you want to suppress duplicates into the Group by list, and then click OK.

If you’ve suppressed duplicate data, you can display it again.

To display suppressed data:

1. Click any item in a column that displays duplicates.
2. On the Format menu, click Table and then click Suppress Duplicates.

Note: Suppress Duplicates is available only if the column is grouped.
Adding Data

There may be times when you want to add data to a table. For example, you may want to reinsert data that you’ve deleted, or you might want to replace the data in a table with data from another query. You can add data to tables to accommodate these situations. When the new query contains additional columns, you need to add them to the original data.

To add data:

1. Double-click a band. You may need to resize the band to make room for the data item.
2. On the Insert menu, click Data Item.
3. Hold down the mouse and drag a rectangle in the band.
4. In the Insert Data Item dialog box, click an item.
5. Click OK.

Adding New Query Data to a Table

When the new query contains additional columns, you need to add them to the original table.

To add new data from the query to the table:

1. In BI Query, rebuild or reload the original query, add an attribute, then submit the query.
2. On the Results menu, click Shows as Report and then click BI Query Reports.
3. In the Presentation Designer dialog box, click Finish.
4. Click the original table.
5 On the Data menu, click Data Sources.

6 In the Data Sources dialog box, click the new data source, then click OK. This associates the original table with the new data source.

7 Do one of the following:
   - If the Map Data dialog box appears, match the data in the original table with the data in the new data source.
   - Click Finish to let BI Query Reports match the data for you.

8 Add a column for the new data.

9 Add the data item to the column. The items that appear in the Insert Data Item dialog box are the items in the new data sources.

**Breaking Data into Groups**

By default, BI Query Reports groups all sorted columns. The order of the groups is determined by the order in which you sorted the columns in BI Query. Although you can change the group order in BI Query Reports, it shouldn’t be done unless it matches the query sort order because BI Query Reports does not resolve this discrepancy.

**To break data into groups:**

1 Do one of the following:
   - When you build the query in BI Query, apply the Sort condition to the attribute on which you want to break the data into groups in the report. In the attribute window, click the Sort box for the attribute.
   - If you’ve already submitted the query, sort the results set. In the results set, on the Results menu, click Filter and then click Sort.

For more information, see “Adding Tables” on page 46.

2 Add a table.
3 On the Arrange Data page of the Presentation Designer dialog box, ensure that the columns you want to break into groups are listed in the Group by box. Sorted columns are automatically placed in this box.

4 Click Finish.

**Changing the Order of Grouped Columns**

The order of the groups is determined by the order in which you sorted the columns in BI Query. You can change the group order in BI Query Reports.

To change the order of grouped columns:

1 Click anywhere in a table.

2 On the Format menu, click Table and then click Group Break.
3 In the Group Breaks dialog box, under Break By, select a group, then click either Up or Down to change the grouping order.

![Group Breaks dialog box]

4 Click OK.

**Changing the Data that is Grouped**

You can modify groups to ungroup sorted columns and group unsorted columns.

**To change the data that is grouped:**

1 Click anywhere in a table.

2 On the Format menu, click Table and then click Group Break.

3 In the Group Breaks dialog box, do one of the following:

- To ungroup a column:
  a) Under Break By, click the group you want to remove.
  b) Click Remove to move it under Report Data.

- To group a column:
  a) Under Report Data, click the column you want to group.
  b) Click Add to move it under Break By.
Hiding Group Header and Footer Bands

Header and footer bands are added to each group. You can hide header and footer bands. In the Group Breaks dialog box, changes to the Show Header Band and Show Footer Band settings apply only to those group breaks that are currently displayed in the Break By list.

To hide group header and footer bands:

1. Click anywhere in a table.
2. On the Format menu, click Table and then click Group Break.
3. In the Group Breaks dialog box, clear Show Header Band and Show Footer Band.
4. Click OK. These changes apply to the group breaks currently displayed in the Break By list.

Formatting Tables

You can format tables to improve their readability and make them more attractive. You can:

• add color (fills, patterns, and beveling) and lines (color, style, and width) to make key information stand out
• format text and bands using styles
• set default formatting
• change titles and column headings

All presentations can be enhanced by:

• labels
• special fields
• rich text which lets you add additional text to presentations
• graphics which add interest and impact
Table Properties

You can format a table by adding color (fills, patterns, and beveling) and lines (color, style, and width) to make key information stand out.

To format table:

1. Select the table.
2. On the Format menu, click Properties.
3. In the Properties dialog box, specify the options you want.
4. Click OK.

Setting Default Formatting

You can customize your preferences so that the tables you create using the default table style in Presentation Designer contain the formatting you prefer. You can specify the numeric format and font properties of the items that appear in a band as well as the fill and line properties of the bands themselves. The formats you set using on Table page of the Preferences dialog box are applied to a table if you select the Default style in the Presentation Designer dialog box.
To set default formatting:

1. On the Tools menu, click Preferences.

2. In the Preferences dialog box, click the Table tab.

3. On the Table page, click the Sample box for a band. For example, to set default properties for the report header, click the Sample box under Report Header.

   ![Preferences dialog box]
   
   Customize the fill color for the header, footer, and detail bands so that you can easily identify them.

4. In the Properties dialog box, specify the formatting options you want and then click OK.

5. In the Preferences dialog box, click OK.

6. To apply the default formats, add a new table using the Default style.
Adding and Removing Page Breaks

By adding a page break to a band, you can have information start on a new page. For example, when you're creating customer invoices, you can add a page break to have each customer invoice start on a new page. Similarly, you can add a title page to a table by adding a page break to the report header band.

You can add or remove page breaks to improve the readability of your table.
To add a page break:

1. Click the band after which you want the page to break. For example, to break pages by customer, ensure that you've grouped the data by customer, then select the footer band for a customer.

2. On the Format menu, click Table and then click Page Break.

To remove a page break:

1. Select the band to which you applied a page break.

2. On the Format menu, click Table and then click Page Break.

Adding or Removing Table Frames

When you reduce the number of columns in a table to fit the table on one page, you end up with extra pages in your report. To remove the extra pages, you have to remove the empty table frames, then resize the report. Similarly, if you want to expand a table to include, for example, more columns, you need to add pages to the report, then add the table frames.

You can add table frames horizontally (the width) but not vertically (the height) in a report. BI Query Reports automatically adds and removes table frames vertically to accommodate the number of rows of data.

To add or remove table frames:

**Note:** If you’re adding table frames, add pages to the report first.

1. Click anywhere in the table.

2. On the Format menu, click Table and then click Size.
3 In the Width box of the Table Size dialog box, specify how many frames you want the table to contain. Lowering the number removes frames; increasing the number adds frames. The height is a fixed number that you cannot change.

![Table Size dialog box]

4 Click OK.

**Changing Column Headings and Titles**

You can format column headings and titles in a table. You can vary the look of each column heading by changing the font. You can change a title or heading to make it more understandable, or add a special field, such as a prompt that displays prompt values in titles.

**To change a column heading or a title:**

1 Double-click the text.

2 In the Text Editor dialog box, type the text you want into the text box.

![Text Editor dialog box]

3 Choose the formatting options you want.

4 Click OK.
Chapter 6: Presenting Results in Tables

Using Styles

Styles define the characteristics of a table, such as the font, size, color, and style of the title, column headings, and data. Styles can also define groups, include calculations, and suppress duplicates. In addition, styles can contain context-sensitive information, such as the prompt value(s) used in the associated query.

There are two types of table styles:

• predefined table styles provided with BI Query Reports that appear on the Styles page of the Presentation Designer dialog box
• user-defined styles that you can create

User-Defined Table Styles

User defined table styles reflect the formatting, grouping, and calculations of the tables on which they are based. They are most useful when you apply them to tables that contain similar data. If a table style groups data, for example, by retailer, and contains calculations such as sales by customer, the style works best if you apply it to other tables that contain data for retailers and their sales.

If the table you're using does not display the data in the most effective way, you can choose a different user-defined style. Be sure that the table style you choose is suited to the type of data you're presenting.

Creating Table Styles

Styles that you create are saved with the extension .tpf.

To create a style:

1 Create a table.
2 Organize the data in the report and apply the formatting you want.
3 If necessary, add a context-sensitive label.
4 On the Format menu, click the Table tab.
5 On the Table page, click Style and then click Save.
6 In the Save As dialog box, specify the name of the file.

7 Click Save.

**Applying Table Styles**

Be sure that the table style you choose is suited to the type of data you are presenting.

**To apply a table style:**

1 Click anywhere in a table.
2 On the Format menu, click the Table tab.
3 On the Table page, click Style and then click Apply.
4 In the Open dialog box, choose a style with the extension .tpf and click Open.
For more information, see “Mapping Unmatched Data” on page 65.

5 If the Map Data dialog box appears, you’ve selected a style that does not automatically match all the data in your report. In this case, you need to match the data.

**Note:** For the best results, apply table styles through the Presentation Designer. User-defined table styles do not appear on the Style page of the Presentation Designer. To find a style, click Browse.

**Modifying Table Styles**

To modify a table style, you must modify a table that contains the same data as the table that uses the style you want to modify.

**To modify a style:**

1 Open or create a table that contains the same data as the style, then apply the style to the table.

2 Make the changes you want.

3 On the Format menu, click the Table tab.

4 On the Table page, click Style and then click Save.

5 In the Save As dialog box, overwrite the original file.
Chapter 7

Working with Charts and Crosstabs

Overview 141
Understanding Charts 142
Chart Types 144
Understanding Crosstabs 145

Arranging Data in Charts and Crosstabs 146
Changing How Charts Summarize Data 148
Arranging Crosstab Data 149
Rearranging Data in Charts and Crosstabs 151

Working with Dimensions 151
Pivoting Dimensions in a Chart 152
Pivoting Dimensions in a Crosstab 153
Grouping Dimensions in a Chart 154
Changing How Dimensions are Nested 154

Working with Members 156
Filtering Data 157
Adding Members 160
Reordering Members 161
Removing or Hiding Members in Charts 162
Removing or Keeping Members in a Crosstab 163

Formatting Charts 164
Chart Properties 165
Changing the Chart Type 166
Adding Legends 167
Changing Titles and Labels 168
Adding Pie Chart Labels 169
Formatting X-axis Labels 169
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Using the Charts Editor</td>
<td>170</td>
</tr>
<tr>
<td>Removing or Hiding a Column in a Chart</td>
<td>170</td>
</tr>
<tr>
<td>Formatting Crosstabs</td>
<td>172</td>
</tr>
<tr>
<td>Working with Crosstabs</td>
<td>172</td>
</tr>
<tr>
<td>Setting Default Formatting for Crosstabs</td>
<td>174</td>
</tr>
<tr>
<td>Controlling Page Breaks for a Crosstab</td>
<td>175</td>
</tr>
<tr>
<td>Resizing Crosstabs and Cells</td>
<td>176</td>
</tr>
<tr>
<td>Autosizing Cells in a Crosstab</td>
<td>176</td>
</tr>
<tr>
<td>Formatting Crosstabs, Members, and Data</td>
<td>177</td>
</tr>
</tbody>
</table>
Overview

Charts are a visual way of presenting summaries of your data. They make abstract numbers more understandable by providing visual cues to the values and relationships the numbers express. Information presented in a chart is clearer and more memorable than text. Charts are particularly useful for presenting conclusions or for highlighting trends, patterns, and other relationships that are not apparent in tabular data. For example, if you need to create a report that shows the long-term sales of your company’s products, a chart is the best format for presenting an overview of your company’s performance over time.

Crosstabs display data in multidimensional format, which can assist in answering these questions:

- How many units did our Midwest office sell this year? This quarter?
- Which sales representative sold the most? When were his peak months? When was his worst week?

Crosstabs also let you to pivot the data to view it from different perspectives, which can assist in answering these questions:

- Does sales experience determine performance?
- Did commissions or pricing affect how our products sold?

Crosstabs let you see not only information, but also relationships between business variables, enabling you to uncover trends, anomalies, problems, and opportunities.

This chapter describes how to use charts and crosstabs to present data. Other features are described elsewhere in this guide, as outlined below:

<table>
<thead>
<tr>
<th>To Do This</th>
<th>See This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Building charts and crosstab</td>
<td>“Building Presentations” on page 45.</td>
</tr>
<tr>
<td>Change data formats</td>
<td>“Specifying Data Formats” on page 206.</td>
</tr>
<tr>
<td>Add graphics, text, and OLE objects; apply formatting</td>
<td>“Enhancing Report Format” on page 181.</td>
</tr>
<tr>
<td>Add hotspots</td>
<td>“Overview” on page 83.</td>
</tr>
</tbody>
</table>
Understanding Charts

A chart is a graphical representation of data. Each element (one bar in a bar chart, one wedge in a pie chart, one point in a line chart) represents the total value for a numeric item (a metric) as it relates to non-numeric items (dimensions and members). In the chart below, the individual sales for the Central region in the first quarter have been added up and are represented by the first bar. The second bar represents the total sales for the Central region in the second quarter, and so on.

The following illustration identifies the elements of a sample chart:
The following table describes the chart elements:

<table>
<thead>
<tr>
<th>This Element</th>
<th>Represents This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>The name of the chart. The default title is My Chart.</td>
</tr>
<tr>
<td>Data area</td>
<td>A group of related values, such as all the values in a column or all the members in one dimension. Markers (bars, lines, dots, bubbles) usually have the same pattern, color, or symbol. When a chart (such as a pie) contains a single member, markers may vary in pattern or color.</td>
</tr>
<tr>
<td>Y-axis (also data or numeric axis)</td>
<td>The vertical axis. Typically used to display metrics such as quantities, revenue, and so on.</td>
</tr>
<tr>
<td>X-axis (also category axis)</td>
<td>The horizontal axis. Typically used to display member labels.</td>
</tr>
</tbody>
</table>

**Data Organization**

The Arrange Data page of Presentation Designer displays data organization.
The following table describes data organization for the Arrange Data page:

<table>
<thead>
<tr>
<th>This Element</th>
<th>Represents This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dimension</td>
<td>An overall category of data that corresponds to an item on the Arrange Data page of the Presentation Designer. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.</td>
</tr>
<tr>
<td>Member</td>
<td>Subcategory of a dimension. Member names appear along the axes or in the legend.</td>
</tr>
<tr>
<td>Metrics</td>
<td>A category of numeric information. It contains the numbers that quantify how well your organization is doing (numbers such as units, costs, revenue, and so on). Every data source must have one Metrics dimension.</td>
</tr>
<tr>
<td>Filter</td>
<td>The focus of the chart. Filtering controls the focus by displaying the data related only to a specific member.</td>
</tr>
<tr>
<td>Legend</td>
<td>The values being plotted in two-dimensional charts.</td>
</tr>
</tbody>
</table>

**Chart Types**

A number of chart types are available:

- **Bar**—Shows the change in size or volume of an item over time or the relative quantities of several different items at a particular time.
- **Pie**—Shows the contribution of the parts to the whole.
- **3D**—Shows trends in values across several dimensions and lets you use special markers to display the data.
- **Area**—Shows either the magnitude of change over time or the relationship of the parts to the whole.
- **Line**—Shows trends over time.
Understanding Crosstabs

Crosstabs display data in a matrix of rows and columns, with headings appearing across both the top and sides. You can rapidly rearrange the data in order to view it from different perspectives—to compare sales figures for multiple products, analyze the performance of regional sales staff, and identify quarterly and annual trends. You can also quickly add calculations and exceptions.

Crosstabs are powerful organizational and analytical tools that enable you to analyze your data and discover the relationships among the different dimensions. The following illustration identifies the parts of a crosstab:

<table>
<thead>
<tr>
<th>Members of the Region dimension</th>
<th>Members of the Metrics dimension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Central</td>
<td>East</td>
</tr>
<tr>
<td>Cost</td>
<td>Order Amount</td>
</tr>
<tr>
<td>32 Inch</td>
<td>3,024</td>
</tr>
<tr>
<td>36 Inch</td>
<td>4,973</td>
</tr>
<tr>
<td>36 Inch Deluxe</td>
<td>5,953</td>
</tr>
<tr>
<td>Aluminum Plain Cast</td>
<td>7,081</td>
</tr>
<tr>
<td>Aluminum Woods</td>
<td>27,139</td>
</tr>
<tr>
<td>Battle Set</td>
<td>67,241</td>
</tr>
<tr>
<td>Bengal Set</td>
<td>16,621</td>
</tr>
<tr>
<td>Bulk 1000 Pieces</td>
<td>1,386</td>
</tr>
<tr>
<td>Classic Bag</td>
<td>25,905</td>
</tr>
</tbody>
</table>
The way that data is organized is displayed on the Arrange Data page of Presentation Designer dialog box.

Arranging Data in Charts and Crosstabs

The Arrange Data page of Presentation Designer shows how data will be displayed and summarized in the presentation.

- Columns containing text and dates become dimensions.
- Columns containing numeric data become members of the metrics dimension (also known as the variable or measures dimension).
- All items in the Included Members list appear in the presentation.
- If you want to prevent an item from appearing in the presentation, you can move it from the display area to the Available Data list.
- You can move a member out of Metrics, making it a dimension that you can then move anywhere in the display area for the presentation.

For more information, see “Changing How Charts Summarize Data” on page 148 and “Redefining a Metrics Member in a Crosstab” on page 150.
To prevent an item from appearing in the chart or crosstab:

1. On the Arrange Data page of the Presentation Designer dialog box, click a dimension in the display area for the chart or crosstab.

   Chart:

   [Diagram of Presentation Designer dialog box for chart setup]

   Crosstab:

   [Diagram of Presentation Designer dialog box for crosstab setup]

2. Drag the selected item into the Available Data list.
Changing How Charts Summarize Data

How data are summarized is displayed on the Arrange Data page of the Presentation Designer:

- Alphanumeric columns containing text and dates are listed in the Available Data area. These columns become dimensions in the chart.
- Columns containing numeric data are listed as metrics. These columns become members of the metrics dimension, and their values are plotted along the y-axis.

Occasionally, you may not want all the data in the chart to be summarized. For example, you may want to create a scatter chart containing detailed data that plots metrics along both axes of the chart. You can change how data is summarized by moving columns out of the metrics category.
To change a numeric column from a metric to a dimension (or non-metric):

1. On the Arrange Data page of the Presentation Designer dialog box, click a metric in the Available Data list.

2. Drag the selected metric to the white space at the bottom of the Available Data list and drag it into the white space at the bottom. For example, Order Year is a numeric that was originally defined as a metric. To redefine it as a dimension, drag it from the metrics category to the bottom of the list.

Arranging Crosstab Data

The Arrange Data page of the Presentation Designer dialog box shows how the data will be displayed:

- All attributes selected from the original query appear in the Available Data list box.
- Attributes with numeric data types (for example, Order Amount) appear as a second level list under the group heading Metrics (preceded by the pink triangular icon). The icon identifies the metrics dimension.
• Pink spreadsheet icons identify the members of the metrics dimension.
• Attributes defined as character or date data types (e.g. Territory, Year as a character data type, Product Name) appear below the metrics with a blue triangular icon, and are the descriptive Dimensions (non-metrics).
• The metrics values become the data in the data area.

Redefining a Metrics Member in a Crosstab

By default, any attribute with a numeric data type is identified as a member of the metrics dimension. You can convert a metrics member to a non-metrics dimension.

To convert a metrics dimension member to a non-metric dimension:

1. On the Arrange Data page of the Presentation Designer dialog box, click a metrics dimension member in the Available Data list.
2. Drag the member into the white space at the bottom of the Available Data list.

The metrics dimension member is now defined as a non-metric dimension with a blue triangle icon.

Note: When dragging a metrics dimension member to the bottom of the list, ensure you drag it to the white space. If you see a blue line at the bottom of the list, keep dragging it until the line disappears.
Chapter 7: Working with Charts and Crosstabs

Rearranging Data in Charts and Crosstabs

After the report is created, you can still change the arrangement of data in a chart or a crosstab.

To arrange chart or crosstab data:

1. In the report:
   a) Click a chart.
   b) On the Format menu, click Chart, then click Rearrange Data.

   Alternatively,
   a) Double-click a crosstab.
   b) On the Format menu, click Crosstab, then click Rearrange Data.

2. In the Rearrange Data dialog box, organize the data.

3. Click Close.

Working with Dimensions

Dimensions are an overall category of data that corresponds to an item on the Arrange Data page of the Presentation Designer. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.

To understand dimensions, think of time. Time is broken down into years, months, days, hours, minutes, and seconds. Without these subcategories, time has no meaning. Nonetheless, time provides a way of understanding all the subcategories at once, as one entity.

You can make charts and crosstabs easier to understand by arranging the dimensions in them. You can change the way dimensions appear by pivoting a chart or crosstab or by moving a dimension from one axis to another. You can also change the appearance of a dimension by nesting it within another dimension.
Pivoting Dimensions in a Chart

Pivoting lets you see different relationships in the data. You can change your view of the data in a chart by swapping, or ‘pivoting’, the dimensions on the x-axis of a chart with those in the legend. When you change the data orientation in a chart, use a legend to help you see how the data is being charted.

To pivot a dimension in a chart:

1. Click a chart.
2. On the Format menu, click Chart, then click Rearrange Data.
3. In the Rearrange Data dialog box, to swap dimensions, click Pivot.

Alternatively, click a dimension in the X axis (groups) or Legend (series), box then drag it to the Legend (series) or X axis (groups) box respectively. To move a dimension from the X axis box, there must be more than one dimension in it.

The Quarter Text dimension is dragged to Legend (series) so that it appears in the legend instead of along the x-axis of the chart.
Pivoting Dimensions in a Crosstab

Pivoting lets you see different relationships in the data. You can change your view of the data in a crosstab by swapping, or 'pivoting', the dimensions in the columns with those in the rows (that is, the dimensions move from one axis to another).

To pivot a dimension in a crosstab:

1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, then click Rearrange Data.
3. To swap dimensions, in the Rearrange Data dialog box, click Pivot. Alternatively, click a dimension under Rows or Columns, then drag it to Columns or Rows. There must be more than one dimension under Columns and Rows.
4. Click Close.

**Note:** Ensure that there are at least two dimensions along the axis from which you're moving the dimension. A chart must have at least one dimension along each axis.
To swap all the dimensions from one axis to another:

1. Double-click the crosstab to activate it.
2. Double-click in the pivot cell. The pivot cell is the top left cell of the crosstab.

**Grouping Dimensions in a Chart**

To group data, the chart must have three dimensions: a metrics dimension, and two other dimensions. If the presentation has only two dimensions, you won’t be able to group the data.

**To group dimensions in a chart:**

1. Click a chart.
2. On the Format menu, click Chart, then click Rearrange Data.
3. In the Rearrange Data dialog box, click the dimension you want to group in the Legend (series) box or in the X axis (groups) box. Drag the dimension into the X axis (groups) box.
4. Click Close.

**Changing How Dimensions are Nested**

When more than one dimension lies along an axis of a chart or crosstab, the chart or crosstab displays the members for the second dimension ‘inside’, or nested within, the members of the first dimension. Nested members normally represent subdivisions within another higher-level dimension. Nesting lets you change the emphasis, or relative importance, of nested dimensions within the chart or crosstab.

For example, if you’re analyzing product sales over the past four quarters, you might want to create a chart with products nested within quarters. If you notice an anomaly for a particular product, you can change the nesting to quarterly sales per product.
To change how dimensions in a chart are nested:

1. Click a chart.
2. On the Format menu, click Chart, then click Rearrange Data.
3. In the Rearrange Data dialog box, click a dimension. You can change the nesting of the dimensions under X axis (groups).
4. Drag the dimension up or down along the axis.
5. Click Close.
To change how dimensions in a crosstab are nested:

1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, then click Rearrange Data.
3. In the Rearrange Data dialog box, click a dimension.
4. Drag and drop a dimension up or down within the Rows or Columns box, or drag and drop it from one box to the other. To swap dimensions along the top of the crosstab with dimensions along the side, click Pivot.
5. Click Close.

Working with Members

Members are a subcategory of a dimension. Member names appear along the axes or in the legend. For example, Quarter is a dimension of data that includes the members Q1, Q2, Q3, and Q4.
You can change the way charts and crosstabs appear by:

- filtering data to focus on information of particular interest
- reordering the data displayed along the axes of a chart or along the rows and columns of a crosstab
- removing or hiding members to make charts and crosstabs more readable, eliminate distracting detail, and focus on only the information of interest

**Filtering Data**

When you want to focus on information of particular interest, you can ‘filter’ the data. Filtering controls the focus in a chart or crosstab by displaying the data related only to a specific member, thereby simplifying the view. You can filter one member at a time for each dimension. For example, when a chart contains sales information for products across sales regions, you may want to filter the data to see details only for a particular region.

**To filter data in a chart or crosstab:**

1. Make sure the chart or crosstab has one metrics dimension and two other dimensions.
2. Complete one of the following procedures:
   - Open the Rearrange Data dialog box for charts and click a chart. On the Format menu, click Chart, then click Rearrange Data.
   - Open the Rearrange Data dialog box for crosstabs. Double-click a crosstab to activate it. On the Format menu, click Crosstab, then click Rearrange Data.
3  In Rearrange Data dialog box drag a dimension under Filter On.

![Rearrange Data dialog box](image)

4  Click Close.

**Note:** When you create a chart or crosstab, you can filter the data by selecting Filter On on the Arrange Data page of the Presentation Designer.
Filtering Using a Different Member

You can look at results for members one at a time by changing the data being filtered. When you drag a dimension into the filter, the data for the first member in the dimension is the focus of the chart or crosstab. You can change the focus by displaying data for a different member. For example, if you placed the Region dimension in the filter, and the Eastern region is the first member in that dimension, the chart reflects the data for the Eastern region. However, you can easily change the focus of the chart by looking at the data for the Western region.

To filter using a different member:

1. Complete one of the following two procedures:
   - Open the Rearrange Data dialog box for charts and click a chart. On the Format menu, click Chart, then click Rearrange Data.
   - Open the Rearrange Data dialog box for crosstabs. Double-click a crosstab to activate it. On the Format menu, click Crosstab, then click Rearrange Data.

2. In Rearrange Data dialog box, under Filter On, click the member tool for a dimension.
3 In the Filter member dialog box, drag a member from the Available list to the Filter Member list.

![Filter member dialog box example]

4 Click Close.

5 In the Rearrange Data dialog box, click Close.

**Adding Members**

You can add members to a chart or a crosstab. To show members that were removed previously, you need to add them again using the procedure described below.

**To add members:**

1 Complete one of the following two procedures:
   - Open the Rearrange Data dialog box for charts and click a chart. On the Format menu, click Chart, then click Rearrange Data.
   - Open the Rearrange Data dialog box for crosstabs. Double-click a crosstab to activate it. On the Format menu, click Crosstab, then click Rearrange Data.

2 In the Rearrange Data dialog box, click the member tool for a dimension.
3 In the Included members dialog box, drag the member(s) you want to add to the chart/crosstab from the Available list to the Included Members list.

4 Click Close.

5 In the Rearrange Data dialog box, click Close.

Reordering Members

Occasionally, you may want to rearrange the order of members within a dimension to display related items together. For example, you may want to place new account executives in the first part of a chart so you can easily keep an eye on their progress, or you may want to arrange them by their performance. By changing the order of the included members in the Included members dialog box, you can change the order that the columns appear in your chart or crosstab.

To reorder members in a crosstab or columns in a chart:

1 Do one of the following:
   • Open the Rearrange Data dialog box for charts and click a chart. On the Format menu, click Chart, then click Rearrange Data.
   • Open the Rearrange Data dialog box for crosstabs. Double-click a crosstab to activate it. On the Format menu, click Crosstab, then click Rearrange Data.

2 In the Rearrange Data dialog box, click the member tool for a dimension.
3 In the Included members dialog box, drag the member(s) that you want to reorder up or down in the Included Members box.

4 Click Close.

5 In the Rearrange Data dialog box, click Close.

Removing or Hiding Members in Charts
Charts lose impact and become difficult to read when they contain too much data. To improve their readability, you can remove one or more members from the view. Alternatively, you can hide a member in a chart, which leaves the member in the view but hides it in the presentation. Removing or hiding a member is particularly useful if you’re interested only in a subset of the data.

Note: All items in the Included Members list appear in the presentation.

To remove a member from a chart:

1 Click a chart.

2 On the Format menu, click Chart, then click Rearrange Data. In the Rearrange Data dialog box, click the member tool for a dimension.

3 In the Included members dialog box, drag a member from Included Members to Available.

Note: You must leave at least one included member for each dimension.

4 Click Close.

5 In the Rearrange Data dialog box, click Close.

To show removed members, drag them from the Available list to Included Members in the same way as you would add a member.
To hide a member in a chart:
1. Click a chart.
2. On the Format menu, click Chart, then click Rearrange Data.
3. In the Rearrange Data dialog box, click a members tool.
4. In the Included members dialog box, right-click a member in the Included Members list box. The member appears dimmed in the list.
5. Click Close.

To show the hidden member:
1. Click a chart.
2. On the Format menu, click Chart, then click Rearrange Data.
3. In the Rearrange Data dialog box, click a members tool.
4. Right-click the (dimmed) hidden member in the Included Members list.
5. Click Close.

Removing or Keeping Members in a Crosstab
Crosstabs lose impact and become difficult to read when they contain too much data. To improve readability, you can remove one or more members from the view. Removing or hiding a member is particularly useful if you’re interested only in a subset of the data.

To remove a member from a crosstab:
1. Double-click a crosstab to activate it.
2. Click a member (or Shift+click to select a range of members).
3. On the Format menu, click Crosstab, then click Delete Members.

Alternatively,
1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, then click Rearrange Data.
3 In the Rearrange Data dialog box, click the member tool for a dimension.

4 In the Included members dialog box, drag a member from the Included Members list to the Available list.

5 Click Close.

6 In the Rearrange Data dialog box, click Close.

To show removed members, drag them from the Available list to the Included Members list, in the same way as you would add a member.

To keep only a certain member:

1 Double-click a crosstab to activate it.

2 Click the member (or Shift+click to select a range of members).

3 On the Format menu, click Crosstab, then click Keep Only.

**Formatting Charts**

Formatting charts enhances their appearance and can make them clearer for your readers.

| Make charts easier to understand by:     | • adding a legend |
|                                         | • changing text labels |
|                                         | • labeling pie charts |
|                                         | • removing or hiding a column in a chart |

| Make your charts more attractive by:    | • turning grid lines off |
|                                       | • changing perspective |
|                                       | • changing the display |

| Use the Advanced Charts Editor to:     | • format text labels |
|                                       | • add arrows and shapes |
|                                       | • change the color of chart elements |
Chart Properties

You can display a chart on multiple pages of a report or apply an exception to a chart.

To format a chart:

1. Click a chart.
2. On the Format menu, click Properties.
3. On the General page of the Properties dialog box, you can choose to repeat the chart on multiple pages of the report, and/or apply an exception to the chart.

4. Click OK.
Changing the Chart Type

If the chart type that you’re using does not display the data in the most effective way, you can change the chart type. Select a chart type suited to the type of data you’re charting.

To change the chart type:

1. Click a chart.
2. On the Format menu, click Properties.
3. On the Style page of the Properties dialog box, click an item under Chart Type, then click a style under Chart Sub-type.
4. Click OK.
Adding Legends

Two-dimensional charts do not display a legend when you create them, but you can add one. A legend makes a chart easier to read and helps the reader understand how the data is being charted.

Note:
- You can’t add a legend to three-dimensional charts.
- A legend does not add information that is not already available.

To add a legend:

1. Click a chart.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the Options tab.
4. On the Options page, in the Legend area, select Show Legend.
5. Click OK.
Changing Titles and Labels

You can change the titles and text labels on a chart to more accurately reflect charted information. You can change the title, subtitle, footnote, and series and group labels.

To change a title and labels:

1. Click the chart.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the Titles tab.
4. On the Titles page, make the required changes.
5. Click OK.
Adding Pie Chart Labels

It is recommended that you use labels instead of legends for pie charts. A legend makes it difficult to visually connect the legend colors to the pie segments.

To add a pie chart label:

1. Click a chart.
2. On the Format menu, click Properties.
3. On the Properties dialog box, click the Options tab.
4. In the Display Data Labels area, select Data Value Labels, Pie Group Labels, and Feeler Lines.
5. Click OK.

Formatting X-axis Labels

You can change the way labels appear for the members along the x-axis of a chart. You can display the labels:

- as the member description
- as the member name
- as the member name and description
- with a number
- with the items in the first row of data

To format x-axis labels:

1. Click the chart to select it.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the Options tab.
4. On the Options page, select an item from the Display Row Data Labels Using list.
5. Click OK.
Using the Charts Editor

You can increase your formatting options using the Charts Editor. For example, you can:

- format text labels and change their placement along the axes and in the legend
- change colors
- add patterns and fills
- remove perspective from two-dimensional charts
- alter chart direction
- change the thickness of the markers

The Charts Editor is an OLE-enabled application. It lets you edit charts within BI Query Reports; you don’t have to run the editor separately.

To format a chart using the Charts Editor:

1. Click a chart.
2. On the Format menu, click Chart, then click Advanced Editor.
3. Make the required formatting changes.
4. On the File menu, click Exit.

Removing or Hiding a Column in a Chart

Charts lose impact and become difficult to read when they contain too much data. To improve their readability, you can remove one or more columns from the view. Alternatively, you can hide a column in a chart, which leaves the column in the view but hides it in the presentation. Removing or hiding a column is particularly useful if you’re interested only in a subset of the data.

Note: All items that appear dimmed in the Available Data list appear in the presentation. If a column in the list does not appear dimmed, it won’t appear in the presentation.
Chapter 7: Working with Charts and Crosstabs

To remove a column in a chart:

1. Click a chart.
2. On the Format menu, click Chart, then click Rearrange Data.
3. In the Rearrange Data dialog box, click the member tool for a dimension.
4. In the Included Members dialog box, drag an item from the Included Members list to the Available list, then click Close. To add the column back, drag it from the Available list to the Included Members list.
5. Click Close.
6. In the Rearrange Data dialog box, click Close.

To hide a column in a chart:

1. Click a chart.
2. On the Format menu, click Chart, then click Rearrange Data.
3. In the Rearrange Data dialog box, click a member tool.
4. In the Included Members dialog box, right-click a member in the Included Members list. The member appears dimmed in the list.
5. Click Close.

To show the hidden member:

1. Click a chart.
2. On the Format menu, click Chart, then click Rearrange Data.
3. In the Rearrange Data dialog box, click a member tool.
4. Right-click the (dimmed) hidden member in the Included Members list.
5. Click Close.
Formatting Crosstabs

Formatting crosstabs serves several purposes. You can:

• format crosstabs to improve their readability and make them more attractive
• set defaults for fonts and colors, for the size of cells, and for selecting cells
• apply different formatting to the headings and data and shade nested dimensions to make them stand out
• control where page breaks occur and resize crosstabs to better fit them into a report

Working with Crosstabs

Depending on what you want to do with a crosstab, the following describes how to access a crosstab.

To select a crosstab, click inside it.

To activate a crosstab, double-click inside it.

To move a crosstab:
1 Click inside a crosstab.
2 Drag it to a new location in the report.

Selecting an Item

If the selection tabs do not appear after you’ve activated the crosstab:
1 On the Tools menu, click Preferences.
2 In the Preferences dialog box, click the Crosstab tab.
3 On the Crosstab page, select Show Selection Tabs.
To select a single cell:
1 Double-click a crosstab to activate it.
2 Click inside the cell.

To select a row of cells:
1 Double-click a crosstab to activate it.
2 Click the black selection tab in the member label for that row.

To select random cells:
1 Double-click a crosstab to activate it.
2 Press and hold down the Ctrl key, then select the individual cells.

To select a range of cells:
1 Double-click a crosstab to activate it.
2 Drag the mouse across all of the connecting cells within the range you want selected.

To select all the cells in a crosstab:
1 Double-click a crosstab to activate it.
2 Click in the cell at the top, left-hand corner of the crosstab.

To select a crosstab label:
1 Double-click a crosstab to activate it.
2 Select a member label, hold down the Ctrl key, and then click the black selection tab for that member.
Setting Default Formatting for Crosstabs

You can customize your preferences so that the crosstabs you create display the formatting you prefer. You can specify the font properties of the items that appear in cells, as well as the fill properties of the cells themselves. When you set default formatting for a crosstab, then refresh it or rearrange it (so that it displays new members), the formatting of the new cells is copied from other similar cells.

For example, consider a crosstab that shows sales for all four quarters of 1997 and 1999. When you refresh the crosstab and the new data includes sales for all four quarters of 1998, the new values are formatted like the values for Q1 1997 and 1999. Similarly, when you rearrange the crosstabs, the new cells retain their formatting no matter where in the crosstab they appear.

To set default formatting for a crosstab:

1. On the Tools menu, click Preferences.
2. In the Preferences dialog box, click the Crosstab tab.
3. On the Crosstab page, click the Sample box for a label cell or data cell.
4. In the Properties dialog box, specify the required formatting options.
5 Specify options for setting the sizes of cells (rows and columns) and for selecting cells.

6 Click OK.

7 When you create a new crosstab, it uses the default formatting that you set using the above procedure.

**Controlling Page Breaks for a Crosstab**

You can control page breaks in a crosstab to display only the information you want on each page of a report, or to improve the report’s readability. If crosstabs are larger than one page, they break between the members of the first (highest-level) dimension along each axis; members do not split across pages. For example, if the Region dimension is displayed in the columns, any member that does not fit entirely on one page moves to the next horizontal page. Similarly, if the Countries dimension is displayed in the rows, any member that does not fit entirely on one page moves to the next vertical page.

Instead of using the default page breaks in a crosstab, you can specify your own. You can specify which dimension a crosstab should break between. You can also choose not to break the crosstab in any particular spot; in that case, whatever does not fit on one page is placed on the next.

**To control page breaks for a crosstab:**

1 Double-click a crosstab to activate it.

2 On the Format menu, click Crosstab, then click Page Breaks.

3 In the Page Breaks dialog box, specify the options you want.

4 Click OK.
Resizing Crosstabs and Cells

You can resize an entire crosstab or the cells within it. Resizing is useful if you’re trying to improve the appearance of a crosstab, fit it on one page, make room for a graphic or an annotation to a cell, or emphasize a particular member. You can resize a crosstab automatically; it sizes to fit the data. You can also manually resize individual members and dimensions.

To resize a crosstab:

1. Click a crosstab.
2. Place the cursor on a selection line.
3. When the cursor changes to a double-headed arrow, hold down the mouse and drag until the crosstab is the size you want.

To resize cells:

1. Double-click a crosstab to activate it.
2. Select the cells you want to resize.
3. Position the cursor on the line below or to the right of the cells.
4. When the double-headed arrow appears, drag to increase or decrease the size of the cells.

Autosizing Cells in a Crosstab

Autosize adjusts the size of the crosstab’s cells. The cells of a crosstab are set to the minimum size possible for them to still fit the data found within them.

To autosize cells in a crosstab:

1. Double-click a crosstab to activate it.
2. On the Format menu, click Crosstab, then click Autosize.
Format Crosstabs, Members, and Data

You can format an entire crosstab or the individual cells and text within it. This lets you enhance the look of the crosstab or change the way numbers are displayed. You can specify the characteristics of the font, fill, and the outline. For example, you can bevel the labels to create a three-dimensional look.

To format an entire crosstab:

1. Click a crosstab.
2. On the Format menu, click Properties.
3. In the Properties dialog box, specify the options you want.
4. Click OK.

To format members and data:

1. Double-click a crosstab to activate it.
2. Click a cell. To select an entire row or column, click a label.
4. In the Properties dialog box, specify the options you want.
5. Click OK.
# Chapter 8

**Formatting Reports**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Enhancing Report Format</strong></td>
<td>181</td>
</tr>
<tr>
<td><strong>Managing Pages</strong></td>
<td>182</td>
</tr>
<tr>
<td>Adding and Removing Pages</td>
<td>182</td>
</tr>
<tr>
<td>Adding Page Numbers</td>
<td>182</td>
</tr>
<tr>
<td><strong>Working with Text</strong></td>
<td>183</td>
</tr>
<tr>
<td>Adding Text Labels</td>
<td>184</td>
</tr>
<tr>
<td>Adding Rich Text</td>
<td>185</td>
</tr>
<tr>
<td>About Hyperlinks</td>
<td>186</td>
</tr>
<tr>
<td>Applying a Hyperlink</td>
<td>189</td>
</tr>
<tr>
<td>Copying Text from Another Application</td>
<td>189</td>
</tr>
<tr>
<td>Adding Context-Sensitive Items</td>
<td>190</td>
</tr>
<tr>
<td>Formatting Text</td>
<td>193</td>
</tr>
<tr>
<td><strong>Graphics and Objects</strong></td>
<td>195</td>
</tr>
<tr>
<td>Adding Graphics</td>
<td>195</td>
</tr>
<tr>
<td>Adding Drawing Objects</td>
<td>196</td>
</tr>
<tr>
<td>Adding Linked Objects</td>
<td>198</td>
</tr>
<tr>
<td>Adding Embedded Objects</td>
<td>200</td>
</tr>
<tr>
<td><strong>Formatting Objects in a Report</strong></td>
<td>201</td>
</tr>
<tr>
<td>Copying and Pasting Objects</td>
<td>201</td>
</tr>
<tr>
<td>Aligning Text and Graphics</td>
<td>201</td>
</tr>
<tr>
<td>Making Objects the Same Size</td>
<td>202</td>
</tr>
<tr>
<td>Spacing Objects Evenly</td>
<td>202</td>
</tr>
<tr>
<td>Using Snap to Grid</td>
<td>203</td>
</tr>
<tr>
<td><strong>Creating Headers and Footers</strong></td>
<td>204</td>
</tr>
<tr>
<td>Using Tables</td>
<td>204</td>
</tr>
<tr>
<td>Using Repeating Objects</td>
<td>205</td>
</tr>
</tbody>
</table>
Specifying Data Formats 206
Specifying a Format for Null Values 206

Specifying a Number Format 207
Specifying a Date and Time Format 209
Converting Two and Four-Digit Years 210

Creating Report Backgrounds 212
Applying Backgrounds 214
Enhancing Report Format

You can format your reports to achieve exactly the look you want. You can add a number of elements and then specify how you want them to look.

- You can control and improve layout by changing orientation, print order, number of pages.
- You can add titles to reports, additional column headings, context-sensitive titles, page numbering, the prompt values you inserted into the corresponding queries, and text created in other applications.
- You can give reports a consistent look and provide consistent information using backgrounds, graphics such as your company logo, headers, and footers.
- Adding text, graphics, rich text, shapes, lines, and borders enhances the content of reports and adds visual impact.
- When numbers, dates, and times do not use appropriate formats, you can specify the formats you want.
- You can add variable information to reports to reflect the data on which reports are based. For example context, sensitive information provides a means to control the content of titles, page numbering, dates, and times.

This chapter describes how to format elements that are common to reports, tables, charts, and crosstabs. Formatting other elements is described elsewhere in this guide, as outlined below:

<table>
<thead>
<tr>
<th>To Format This</th>
<th>See This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table</td>
<td>“Presenting Results in Tables” on page 95.</td>
</tr>
<tr>
<td>Charts and Crosstabs</td>
<td>“Working with Charts and Crosstabs” on page 139.</td>
</tr>
</tbody>
</table>
Managing Pages

Adding and Removing Pages

If you’re creating large, multi-page reports containing tables, crosstabs, and charts, you may want to change the size of the reports.

To add and remove pages:

1. On the Format menu, click Report, then click Size.
2. In the Report Size dialog box, type a width and height for the report.
3. Click OK.

Adding Page Numbers

Page numbering provides a road map for using your report. Add a page number by adding a label with a special field, which you can insert through the Text Editor.

If you add a page number to a report, repeat it on multiple pages. A number appears on all pages that will print and a question mark (?) appears on all pages that won’t print.

To add a page number:

1. On the Insert menu, click Label.
2. Hold down the mouse and drag a rectangle in the report.

For more information, see “Special Fields Reference” on page 191.
3 In the Text Editor dialog box, select Page Number from the Fields list.

For more information, see “Formatting Text” on page 193.

4 Specify formatting options. The following sample (using the font type and size specified above) has red, bold, italic, and centre aligned formatting applied to the text and field:

5 Click OK.

Working with Text

You can improve the content and appearance of your report by:
• adding text labels (for example, titles and additional column headings)
• adding rich text (for example, detailed notes, instructions, and files)
• copying text from another application
• adding context-sensitive items (such as titles and page numbering)
• adding prompts and prompt values
Adding Text Labels

When you want to add new information to a report—for example, titles, additional column headings, and notes—you can add it as a label. You can also change default labels, such as column headings and titles in tables, to more accurately reflect the information the tables contain. Any formatting you apply to a label affects all the text in the label. If you want to apply different formatting to different areas of the text, use rich text.

When you add text labels to tables, you add them to bands. When you add an item to a band, the item appears in every band of that type. For example, an item that’s added to the page header band repeats in all page header bands in the table.

To add a label:

1. On the Insert menu, click Label. To add a label to a table, first double-click a band; otherwise the object is overlaid on the table.
2. Hold down the mouse and drag a rectangle in the report where you want the text to appear.
3. In the Text Editor dialog box, type the text, and then specify the formatting options you want.
   See “Formatting Text” on page 193.
4. Click OK.

If you want to add special fields, select an item from the Fields list.
Adding Rich Text

When you want to add a large amount of text to a report—for example, detailed notes, instructions, even entire files that you’ve created in another application—you can add it as ‘rich text’. Rich text, or text in Rich Text Format (RTF), is a Microsoft standard for including formatting commands with text. In BI Query Reports, you can apply different formatting to different areas of rich text.

**Note:** When you add text to tables, add it to bands.

**To add rich text:**

1. On the Insert menu, click Rich Text. To add a rich text object to a table, first double-click the band into which you’re adding the object.

2. Hold down the mouse and drag a rectangle in the report where you want the text to appear.

3. In the Rich Text Editor dialog box, type the required text.

4. To format any part of the text, select it, then specify the formatting options you want.

5. Click OK.
About Hyperlinks

You can link text to an online help system or other resource on the Web. In this respect, the text acts as a hyperlink—a reference in one document (your report) to another (such as a Web resource). When you click a label hyperlinked to a Web resource, BI Query Reports runs the default browser on your system and opens the specified resource. You can link to any resource that can be specified using a Uniform Resource Locator (URL).

BI Query Reports supports the standard complement of URL protocols (such as HTTP and FTP) for hyperlinks as well as e-mail and the Hummingbird Repository Retrieval Protocol.

Supported URL Protocols

BI Query supports the following protocols for URLs:

<table>
<thead>
<tr>
<th>Protocol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTTP</td>
<td>The Hypertext Transfer Protocol (HTTP) defines the format and transmission method of documents over the Web. For example, the following URL,</td>
</tr>
<tr>
<td></td>
<td><a href="http://www.hummingbird.com">http://www.hummingbird.com</a></td>
</tr>
<tr>
<td></td>
<td>specifies the address of the Hummingbird web site.</td>
</tr>
<tr>
<td>Secure HTTP</td>
<td>HTTPS is a secure form of HTTP using the Secure Sockets Layer (SSL) protocol. In the following example,</td>
</tr>
<tr>
<td>or HTTPS</td>
<td><a href="https://secureSite">https://secureSite</a></td>
</tr>
<tr>
<td></td>
<td>secureSite is the address (domain name or IP address) of a site protected by the SSL protocol.</td>
</tr>
<tr>
<td>HRRP</td>
<td>The Hummingbird Repository Retrieval Protocol (HRRP) lets you access files in a BI Server Repository through a browser. In the following example,</td>
</tr>
<tr>
<td></td>
<td><a href="http://r1/MyModel/report/SalesUK.rep">http://r1/MyModel/report/SalesUK.rep</a></td>
</tr>
<tr>
<td></td>
<td>SalesUK.rep is a report in the MyModel data model stored in the Repository.</td>
</tr>
<tr>
<td></td>
<td>For more information, see “Hummingbird Repository Retrieval Protocol (HRRP)” on page 188.</td>
</tr>
</tbody>
</table>
For the File Transfer Protocol (FTP), use the following URL syntax for a user account that lets you access the server:

```
somename:pswd@ftp.servername.com:#####/path/folder
```

where `somename` is the user name (followed by a colon), `pswd` is the password (followed by the “at” symbol @), `ftp.servername.com` is the server address (followed by a colon), `#####` is the port number, and `/path/folder` is the path to the folder.

<table>
<thead>
<tr>
<th>Protocol</th>
<th>Description</th>
</tr>
</thead>
</table>
| FTP      | The File Transfer Protocol (FTP) lets you transfer files between your machine and the machine specified in the URL. For example, the following URL,  
```  
```  
retrieves a document that describes the File Transfer Protocol. In this example, the folder access is public (accessible by anyone) in contrast to restricted server access that requires a valid user account and a specific port number.  
| mailto   | The mailto protocol specifies the format for e-mail addresses. For example, you can use the following URL,  
```  
mailto:hbi-support@kingston.hummingbird.com  
```  
to contact Hummingbird BI Technical Support.  
| file     | The file protocol specifies the format for local or network resources. For example, the following URL,  
```  
file:///C:/temp/readme.html  
```  
specifies a file on the C drive.  

For the File Transfer Protocol (FTP), use the following URL syntax for a user account that lets you access the server:
Hummingbird Repository Retrieval Protocol (HRRP)

In addition to the standard URL protocols, BI Query also supports a special protocol for specifying resources in a BI Server Repository: the Hummingbird Repository Retrieval Protocol (HRRP). Using this protocol, you can open data models and reports stored in the Repository. (You can also run the queries associated with each report you open.)

When you access the URL for a data model, the data model opens in a new instance of BI Query. When you access the URL for a report, the report opens in a new instance of BI Query Reports.

URLs that use HRRP take the following form:

```
hrrp://repository_id/pkg_name/document_type/repository_segment
```

where `repository_id` is the ID for the Repository, `pkg_name` is the XML namespace of the data model that stores the document you want to open, `document_type` is the type of document you want to open, and `repository_segment` is the particular document you want to open (either a report or an entire data model).

The default `repository_id` for any BI Server Repository is `r1`. The `pkg_name` (namespace) for a data model and its objects is the same as the name of the data model (without the file extension). The following table describes the possible values for `document_type`:

<table>
<thead>
<tr>
<th><code>document_type</code></th>
<th>Associated Resource</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>datamodel</td>
<td>Data model file</td>
<td>Do not supply a file extension (<code>.gql</code> or <code>.gqu</code>) when specifying a data model.</td>
</tr>
<tr>
<td>report</td>
<td>BI Query Reports file</td>
<td>Supply the usual file extension (.rep) to specify reports created in BI Query Reports.</td>
</tr>
<tr>
<td>xreport</td>
<td>Standard Reports file</td>
<td>Supply a file extension of .xml to specify a Standard Reports file.</td>
</tr>
</tbody>
</table>
Applying a Hyperlink

When the user moves the mouse pointer over a label or text that links to a URL, the pointer changes to a hand to indicate that the text is a hyperlink.

To apply a hyperlink:

1. Right-click a label or text, and from the pop-up menu click Add Hyperlink. The Hyperlinks dialog box opens.
2. In the text box on the right, type the URL for the required resource. You must specify a supported protocol.
   - If FTP is specified, the dialog box displays information according to the URL syntax you type to access an FTP server. If e-mail is specified, the dialog box displays boxes that let you specify the e-mail addresses of recipients. There is also a box where you can type subject text.
3. Click OK.

Editing and Removing Hyperlinks

To edit a hyperlink:

1. Right-click an existing hyperlink, and from the pop-up menu click Edit Hyperlink. The Hyperlinks dialog box opens.
2. Make changes as necessary, and click OK.

To remove a hyperlink, right-click an existing hyperlink, and from the pop-up menu click Remove Hyperlink.

Copying Text from Another Application

You can add text from other applications as rich text. When you import the text, formatting—bold, italics, or different fonts—is preserved.

To import text:

1. Copy the text to the Clipboard in the source application.
2. Return to BI Query Reports.
3. On the Edit menu, click Paste.
Adding Context-Sensitive Items

You can use special fields to add context-sensitive items such as titles, page numbers, times, and dates to reports. Special fields let you add variable information to a report (such as the prompt values you inserted into the corresponding query, the view name of a presentation, and so on).

For example, if the query you used to generate a report includes a prompt, you can create a context-sensitive title that identifies the value on which the report is based (such as Shipments to: USA, where USA is the value you entered into the prompt).

To add a context-sensitive title, page numbers, time, or date:

1. On the Insert menu, click Label.
2. Hold down the mouse and drag a rectangle in the report where you want the object to appear.
3. In the Text Editor dialog box, select an item from the Fields list. For example, Prompt Value.

Note: When you add a context-sensitive label that uses a prompt value, it is good practice to choose Default Data Source from the list of data sources. This ensures that the label applies to any report, and it is particularly useful when you want to save the report as a style, then apply that style to other reports.
4 Specify any further information for which you are prompted. For example, if you choose Prompt Value, you need to also specify the view you’re using and confirm the prompt value.

5 Type any additional text into the text box.

6 Specify the formatting options you want.

7 Click OK.

The context-sensitive title of this report identifies the value (North America) on which the report is based.

<table>
<thead>
<tr>
<th>Territory = North America</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Store Name Short</strong></td>
</tr>
<tr>
<td>California</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Colorado</td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

**Special Fields Reference**

When you add a label, you can include a field in it through the Text Editor. Some of these fields can help describe a view; others, like page numbering, can provide road maps for using your report.

The following table describes the available fields.

<table>
<thead>
<tr>
<th>Choose This</th>
<th>To Add This</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creation Date</td>
<td>The date the report was created. It does not change, even when you open the report at a later time.</td>
</tr>
<tr>
<td>Creation Time</td>
<td>The time the report was created. It does not change, even when you open the report at a later time.</td>
</tr>
<tr>
<td>Choose This</td>
<td>To Add This</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Current Time/Date</td>
<td>The current time and date. It changes each time you open the report. You can format the way in which this data is inserted.</td>
</tr>
<tr>
<td>Data Source Date</td>
<td>The date a specific data source was created.</td>
</tr>
<tr>
<td>Field</td>
<td>A value from a view. In the <strong>Data Cell Selector</strong> dialog box, choose the view you want, then choose a member from each dimension. Otherwise, BI Query Reports inserts the value from the first cell that meets the requirements.</td>
</tr>
<tr>
<td>Field Name</td>
<td>The coordinates of a value from a view. For example, in a crosstab, if you specify a value in Products for 1998, the special field displays “Products/1998”.</td>
</tr>
<tr>
<td>Filter Dimension</td>
<td>The dimensions, if any, that are in the filter for the crosstab or chart you’re using. You need to specify the view you want.</td>
</tr>
<tr>
<td>Hotspot Attribute</td>
<td>The attribute that users are requalifying when they click a hotspot. (Available only if a hotspot is selected.)</td>
</tr>
<tr>
<td>Hotspot Operator</td>
<td>The operator used in a hotspot. (Available only if a hotspot is selected.)</td>
</tr>
<tr>
<td>Hotspot Values</td>
<td>The values that appear in the requalified query. (Available only if a hotspot is selected.)</td>
</tr>
<tr>
<td>Page Number</td>
<td>The page number.</td>
</tr>
<tr>
<td>Prompt Value</td>
<td>The prompt value(s) used in the query. You need to specify the view you want, then confirm the prompt value.</td>
</tr>
<tr>
<td>Report Filename</td>
<td>The name of the report in which you’re working.</td>
</tr>
<tr>
<td>Total Pages</td>
<td>The total number of pages in the report.</td>
</tr>
<tr>
<td>View Name</td>
<td>The name of a specific view. You need to specify the view you want.</td>
</tr>
<tr>
<td>X-axis Dimensions</td>
<td>The name of the dimensions on the horizontal axis of the crosstab or chart you’re using. You need to specify the view.</td>
</tr>
<tr>
<td>Y-axis Dimensions</td>
<td>The name of the dimensions on the vertical axis of the crosstab or chart you’re using. You need to specify the view you want.</td>
</tr>
</tbody>
</table>
About Prompts and Prompt Values

You can use prompts to change the data in reports. If the query you use to generate a report includes a prompt, you can insert a different value into the query each time that you submit it.

In a report, you can add a label that displays the prompt value you inserted into the query so that you can determine what limits, if any, were set on the query that created certain data sources. If you generate the same report and you insert a different prompt value each time, the prompt value displayed in the label changes accordingly.

**Note:** If you refresh a report that uses a prompt and you want to replace the current values with new values, make sure that you delete the current values first. In the qualification dialog box, click the List icon, choose Delete All Entries, and then enter the values on which you want the report to be based.

Formatting Text

You can specify the appearance of text or rich text by controlling:

- font
- size
- color
- justification
- formatting (bold, italics and underline)

For text, you can:

- wrap text, which lets you display text on more than one line rather than on one long line
- add special fields

For rich text, you can add bullets.
To format text or rich text:
1  Double-click the text.
2  In the Text Editor or Rich Text Editor dialog box, specify options using the formatting buttons or the Font Name and Point Size boxes.
3  Click OK.

Adding Color to Text
You can specify text color in the Text Editor or in the Properties dialog box.

To add color to text:
1  Right-click the text, then choose Edit Text.
2  In the Text Editor dialog box, click the color palette tool, then choose a color.
3  Click OK.

To add color using the Properties dialog box:
1  Click a text label.
2  On the Format menu, click Properties.
3  In the Properties dialog box, click the Font tab, then choose a color from the Color list.
4  Click OK.

If some of the colors you select do not appear, you may have to change the color palette you’re using in your Windows Display Properties.

To change the palette:
1  On the Windows Start menu, click Settings and then click Control Panel.
2  Double-click Display.
3  Click the Settings tab.
4  Select the Color Palette.

For more information, consult the Windows documentation.
Graphics and Objects

Graphics
You can insert a bitmap, or clips from the Clip Gallery, into your report. This includes clip art, pictures, sounds, video clips, and animations.

Lines, Rectangles, Ellipses
Lines, rectangles, and ellipses are ‘drawing objects’. Drawing objects organize information in reports and separate one area from another. In tables, for example, vertical lines between columns and horizontal lines below column headings serve to organize information. Lines separate presentations in reports and act as borders. For example, to add a border, draw a small line and drag it into the detail band of a table. The line will repeat for every row in the detail band and therefore it will look like one continuous line.

Objects
You can insert an OLE object or a bitmap into your report. The object can be:

• linked to the source application so that any changes to the object in its source application are also reflected in the object inserted into the report
• embedded in your report

Adding Graphics
You can insert a bitmap or clipart image into your report.

To add a bitmap:
1. On the Insert menu, click Picture and then click Bitmap. Click inside a report.
2. In the Insert Object dialog box, click Create from File.
3. Click Browse, then specify the file you want.
4. Click OK.
Alternatively,

1. Open a graphic.
2. Copy the graphic to the Clipboard.
3. In BI Query Reports, click Edit and then click Paste.

The Layout menu provides tools for moving, grouping and aligning objects.

**Adding Drawing Objects**

Lines, rectangles, and ellipses are drawing objects which can be added to improve the readability, appearance, and organization of your report.

**To add a lines, rectangles, or ellipses:**

1. On the Insert menu, click Drawing Object.
2. Choose the object you want to draw from the submenu—Line, Rectangle, Round Rectangle, or Ellipse.
3. Hold down the mouse and drag the selected shape in the report where you want the object to appear.
4. Format the drawing object.

The Layout menu provides tools for moving, grouping and aligning objects.

**Formatting and Editing Drawing Objects**

You can specify how selected objects are filled and their line properties. You can display objects (for example, the company logo) on multiple pages of a report, or apply an exception to them.

**To format a drawing object:**

1. Do one of the following:
   - Double-click an object.
   - Click an object. On the Format menu, click Properties.
2 In the Properties dialog box:
   • For rectangles and ellipses, click the Line, Fill, or General tab.
   • For lines, click the Line or General tab.

3 Specify the options you want.
4 Click OK.

Adding Color to Drawing Objects
You can specify the line color of any drawing object. For a rectangle or an ellipse, you can specify the color of the fill, or the color of the pattern used in the object.

To add color to a drawing object:
1 Click the object.
2 On the Format menu, click Properties.
3 To specify the color of the fill and pattern for a rectangle or ellipse, in the Properties dialog box, click the Fill tab. Click Fill Color or Pattern Color.

To specify the color of a line, in the Properties dialog box, click the Line tab. Click Line Color.

4 In the Color dialog box, select the color.
5 Click OK.
6 In the Properties dialog box, click OK.

If some of the colors you select don’t appear, you may have to change the color palette you’re using in your Windows Display Properties.

To change the palette:
1 On the Windows Start menu, click Settings, then click Control Panel.
2 Double-click Display.
3 Click the Settings tab.
4 Select a Color Palette.
### Adding Linked Objects

You can link the OLE object, or a bitmap file you’re inserting, to the source document.

**To link an object:**

1. In BI Query Reports, on the **Insert** menu, click **Object**.
2. Click in the report where you want the object to appear.
3. In the **Insert Object** dialog box, select **Create from File**.
4. Do one of the following:
   - In the **File** text box, type the path and the file name.
   - Click **Browse**, then locate the file you want.
5. If you would like the link to be represented by an icon, rather than by the object itself, select **Display as Icon**.
6. Select **Link**.
7. Click **OK**.

The **Layout** menu provides tools for moving, grouping and aligning objects.

### Editing Linked Objects

You must edit a linked object in the source application. You can use the **Links** dialog box to find linked objects in a report. The changes you make appear in the linked object in the report, as well as in the source.

**To edit a linked object:**

1. Open an object, double-click a linked object in the report. The object opens in the source application. Alternatively,
   a) Click a linked object.
   b) On the **Edit** menu, click **Links**.
   c) In the **Links** dialog box, select the object.
   d) Click **Open Source**. The object opens in the source application.
2 In the source application, edit the object. The changes are also made to the object in the report.

3 Close the source application.

**Viewing and Managing Linked Objects**

The Links dialog box displays information about links used in the current report and lets you edit, update, change, or remove those links.

**To manage linked objects:**

1 On the Edit menu, click Links.

2 In the Links dialog box, click the link you want to change.

3 Click Update Now to update the link.

4 For the Updates option:
   • Select Manual if the link is to be updated only on request.
   • Select Automatic if it is to be updated automatically whenever a change is made to the source document. It is updated automatically by default.

5 Do one of the following:
   • Click Open Source to open the source document of the object.
   • Click Change Source to change a link.
   • Click Break Link to remove the connection with the source document, which causes the linked object to become an embedded object.
**Adding Embedded Objects**

You can embed an OLE object or a bitmap file into a report. Before embedding an object, be sure that both BI Query and the source application are running, and that you have saved the source file. The source application must also support linking and embedding.

To embed an object in a report:

1. In BI Query Reports, on the **Insert** menu, click **Object**.
2. Click in the report where you want the object to appear.
3. To insert an existing object,
   a) In the **Insert Object** dialog box, select **Create from File**.
   b) Type the path and file name into the file text box or click **Browse** and locate the file you want.
   c) Click **OK**.
   To create a new object and insert it,
   a) In the **Insert Object** dialog box, select **Create New**.
   b) Choose an object type from the list.
   c) Create the file.
   d) Click in the BI Query Reports window to exit the source application.

The Layout menu provides tools for moving, grouping and aligning objects.

**Editing Embedded Objects**

You edit an embedded object in the source application.

To edit an embedded object:

1. Double-click an embedded object. The object opens in the source application.
2. Edit the object.
3. Click in the BI Query Reports window to exit the source application.
Formatting Objects in a Report

To perform any operation on an object, you need to select it first. To select an object, click it.

To activate an object, double-click it. To select multiple objects, click the first object, hold down the Shift key, and then click the other objects. To turn a selection on or off, hold down the Ctrl key, and then click an object to turn the selection on or off.

Copying and Pasting Objects

You can copy and paste objects within a report.

To copy and paste an object:
1. Click an object.
2. On the Edit menu, click Copy.
3. On the Edit menu, click Paste.

Alternatively,
1. Click an object.
2. Hold down the Ctrl key, then drag the object to the required location.

Aligning Text and Graphics

You can align text and graphics along their top, bottom, right, left, or center points.

To align text and graphics:
1. Click the first object.
2. Shift+click any additional objects.
3. On the Layout menu, click Align.
4. Choose an alignment option from the Align submenu.

If you’re aligning data items or text objects, only the box surrounding the text is affected.
To align the data inside the box:
1. Click the data inside the box.
2. On the Format menu, click Properties.
3. Click the Font tab.
4. Change the justification.

Making Objects the Same Size
Objects are sized according to the largest selected object. If items are Fit to Column, they won't resize.

To make objects the same size: Click the first object and shift+click any additional objects.

To make the objects the same width: On the Layout menu, click Make Same Size, then click Width.

To make the objects the same height: On the Layout menu, click Make Same Size, then click Height.

Spacing Objects Evenly
The Space Evenly Horizontally option spaces objects evenly across the page based on the location of the selected objects to the furthest left and the furthest right of the page. All other selected objects are spaced evenly between these two objects.

The Space Evenly Vertically option spaces objects evenly down the page based on the location of the selected objects closest to the top and bottom of the page. All other selected objects are spaced evenly between these two objects.

To space objects evenly: Click the first object and shift+click any additional objects.

To space objects evenly across the page: On the Layout menu, click Space Evenly, then click Horizontally.

To space objects evenly down the page: On the Layout menu, click Space Evenly, then click Vertically.
Using Snap to Grid

When you use Snap to Grid, objects are automatically placed on the closest grid point when you draw, move, or resize them, even if the grid is not displayed.

**To Use Snap to Grid:**

1. To change the properties associated with grid lines, on the Layout menu, click Grid Settings.
2. In the Grid Settings dialog box, ensure the Snap to Grid option is selected.
3. Click OK.

Showing Grid Lines

Grid lines can help you align objects on the page. The grid appears on the screen as a series of horizontal and vertical dotted lines, but the grid lines don’t print.

**To show grid lines:**

1. On the Layout menu, click Grid Settings.
2. In the Grid Settings dialog box, select Show Grid Lines.
3. Click OK.

Changing Grid Settings

You can change the properties associated with grid lines in reports.

**To change grid settings:**

1. On the Layout menu, click Grid Settings.
2. In the Grid Settings dialog box, ensure that Show Grid Lines is selected.
3. Adjust the horizontal and vertical line spacing.
4. Click OK.
Creating Headers and Footers

Headers and footers contain information that appears on each page of a report, such as page numbers, dates, company logos, graphics, and so on. You can also create your own headers and footers. You can customize them using the header and footer bands in tables, adding repeating objects to reports, and using page backgrounds.

Tables
If a report includes a table that spans multiple pages, adding items to the page header or footer bands adds them to each page of the report. You can create headers and footers using a table, by adding items to the page header and page footer bands.

Repeating Objects
The text and graphics you add to a report can appear on multiple pages. For example, if you’re creating a background, you may want your company logo, a horizontal or vertical line, or a border to display on every page. Your report may contain footers on odd-numbered pages that are different than footers on even-numbered pages. You can create headers and footers using a repeating object by adding objects to multiple pages.

Using Tables
Every table has a header and footer area designated by the page header band and the page footer band. When you add objects to these bands, they are repeated on every page on which the table appears. For example, if you have a company logo that you want at the top of each page, you can add it to the page header band.
To create a header and footer using a table:

1. Find the header or footer band. Usually, you can locate the Page header band by looking for the band that contains the column headings. You can locate the Page footer band by looking for the band that contains the date and page number.

2. Double-click the header or footer band.

3. Add text, graphics, or special fields.

Using Repeating Objects

The text and graphics you add to a report can appear on multiple pages. For example, if you’re creating a background, you may want your company logo, a horizontal or vertical line, or a border to display on every page. Your report may contain footers on odd-numbered pages that are different from footers on even-numbered pages.

**Note:** You can change a repeating object only on the page you created it, not on another page of the report.

To create a header and footer using a repeating object:

1. Add text, graphics, or special fields (such as a page number) to a report.

2. Select the items.

4 In the Properties dialog box, click the General tab.

![Properties dialog box]

5 On the General page, in the Repeat Every area, specify how often you want the object to appear horizontally and vertically:

- To display an object on every page, specify 1 and 1.
- To display an object only on odd-numbered pages, specify 2 horizontally, 2 vertically, or both.

6 Click OK.

**Specifying Data Formats**

When results are returned from the database in BI Query, the format in which they’re displayed (the ‘display format’) may not be how you want them represented in a report. You can specify different formats for different purposes.

**Specifying a Format for Null Values**

By default, null values are displayed as `<null>`. You can display null values using any value you want. To reduce clutter in a table, you can display nulls as blanks.
To specify the format for null values:

1. Click a null value.
2. On the Format menu, click Properties.
3. On the Format page of the Properties dialog box, type a format for the null value into the Show NULL As Text box.
4. Click OK.

Specifying a Number Format

You can choose from, and modify, a number of predefined formats for numeric data. For example, you can include a prefix (such as a currency symbol—$, £, ¥, and so on) or a suffix (such as % or €). You can specify the number of decimal places and display numbers with a leading zero, in exponent notation, or as a percentage. You can show numbers in tens, thousands, and so on.

To specify the format for a positive or negative number:

1. Click a number.
2. On the Format menu, click Properties.
3 On the Format page of the Properties dialog box, choose a predefined format or click the Edit button beside the Positive Number list or the Negative list to modify a format.

![Properties Dialog Box](image)

4 If you're modifying a format, in the Define Numeric Format dialog box, make the required changes.

![Define Numeric Format Dialog Box](image)

A sample number with a header ($), a decimal separator (.), a grouping separator (,), and two decimal places.

5 Click OK.

6 In the Properties dialog box, click OK.
Specifying a Date and Time Format

You can choose from a number of predefined formats for dates and times. You can also use date/time formatting to display only one part of a date, for example, only the year.

For data that displays date plus time, you can display dates without the time. Instead of 08/10/2001 1:00:00, you can display the date more understandably as October 8, 2001. If the time is not needed, don’t include it.

When you enter dates, make sure you enter all four digits of the year. Similarly, when you display dates, make sure you choose a display format that uses all four digits of the year. This ensures that BI Query interprets dates correctly.

To specify the format for a date or time:

1. Click a date or time.
2. On the Format menu, click Properties.
3. On the Format page of the Properties dialog box, choose a predefined format or click the Edit button beside the Date/Time list to modify a format.
4 If you're modifying a format, in the Define Date/Time Format dialog box, make the changes you want.

5 Click OK.

6 In the Properties dialog box, click OK.

**Converting Two and Four-Digit Years**

When you type a two-digit year, or import a data source that contains two-digit years, BI Query Reports automatically converts them to four-digit years. This ensures that your reports are unaffected by dates that involve the century change from 1999 to 2000.

To enable BI Query Reports to convert two-digit years, you need to specify the range of dates in your data, then establish whether dates are sliding or fixed. The start and end years of sliding dates are incremented by one each time the current year changes. The start and end years of fixed dates don't change.
Two-digit years are converted by adding a century according to the date window you specify. A date window consists of a start year and an end year that is 99 years after the start year. A century is added to two-digit years so that they fall on or between the start year and the end year of the date window.

The type of date you specify applies to all Hummingbird business intelligence products, so what you specify in one product affects all other products you use. Consider your organization’s requirements carefully before choosing a date type.

You use the Date Entry dialog box to specify a start year for your data. BI Query Reports automatically calculates an end year that’s 99 years after the start year. When you type two-digit years in BI Query Reports, BI Query Reports adds a century prefix so that the years fall on or between the start year and the end year displayed.

**Changing the date window**

If you change the date window after you’ve entered two-digit years, the new date window isn’t applied to the dates you’ve already entered. Changes you make to the date window in one Hummingbird business intelligence product affect all other Hummingbird business intelligence products.

**Two-digit year conversion**

A date window with a start year of 1918 and an end year of 2017, adds the century 19 to all two-digit years greater than or equal to 18 and the century 20 to all two-digit years less than or equal to 17. For example, when you enter 45, it is converted to 1945, when you enter 15, it is converted to 2015.

If the date window is a Sliding date window, the start year changes to 1922 and the end year changes to 2021 when the current year changes, for example, from 2001 to 2002. If you’ve specified dates as fixed, the years remain the same—1921 and 2020.
To convert two-digit years to four-digit years:

1. On the Tools menu, click Date Entry.

2. In the Date Entry dialog box, type the start year for the date window. The end year is calculated automatically.

3. Select Sliding or Fixed.

4. Click OK.

**Note:** If you change the date window after you’ve entered two-digit years, the new date window is not applied to the dates you’ve already entered.

Creating Report Backgrounds

Backgrounds let you apply a consistent look from report to report. When you’re creating reports on a regular basis, backgrounds eliminate the need to specify formats each time. They are particularly important when you want to create professional-looking reports for external use—to be sent to clients, customers, or shareholders. Backgrounds provide company identification and help you adhere to corporate standards by using consistent logos, mastheads, and text.
Backgrounds define a report’s overall look. They can include lines, borders, colors, graphics, and page numbering. They can also include text objects that are not associated with particular data, for example, rich text objects and text labels but not special fields that contain prompt values from a query.

When you create a background, you can display objects on multiple pages of a report or on specific pages. For example, you can add a border and display it on every page, or your corporate logo on just the first page.

You can create backgrounds in a new report or using an existing report.

**Note:** When you create a background, you must save the corresponding report. If you don’t save the report, you will not be able to edit the background and will have to recreate it.

**To create a background:**

1. Create a report.
2. Add the required items to the background.
3. Format the items, arrange them, and specify on which pages of the report you want them to appear.
4. On the File menu, click Save As.
5. In the Save As dialog box, save it first as a Report (*.rep), then as a Template (*.tpl).
To modify a background:

1. Open the corresponding report.
2. Make the required changes.
3. Save the report.
4. Apply the changes to the background by saving over the original background.

Applying Backgrounds

You can apply backgrounds to any report. If you want to replace a background in a report, simply apply the new background.

**Note:** You can't have multiple backgrounds in one report. If you apply one background to a report and then apply a second background to it, the second background overrides the first.

To apply a background:

1. On the Format menu, click Report, then click Set Background.
2. In the Open dialog box, choose a background with the extension .tpl.
3. Click Open.

To remove the background, on the Format menu, click Report, then click Clear Background.
# Chapter 9

## Performing Calculations

<table>
<thead>
<tr>
<th>Calculations and Exceptions</th>
<th>217</th>
</tr>
</thead>
<tbody>
<tr>
<td>Types of Calculations</td>
<td>217</td>
</tr>
<tr>
<td>About Functions</td>
<td>218</td>
</tr>
<tr>
<td>About Expressions</td>
<td>220</td>
</tr>
<tr>
<td>Operators Table</td>
<td>220</td>
</tr>
<tr>
<td>Syntax Table</td>
<td>222</td>
</tr>
<tr>
<td>Precedence Table</td>
<td>223</td>
</tr>
</tbody>
</table>

## Working with Calculations 224

<table>
<thead>
<tr>
<th>Predefined and User-Defined Calculations</th>
<th>224</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding Predefined Calculations to Tables</td>
<td>225</td>
</tr>
<tr>
<td>Adding Predefined Calculations to Crosstabs</td>
<td>227</td>
</tr>
<tr>
<td>Adding User-Defined Calculations to Tables</td>
<td>228</td>
</tr>
<tr>
<td>Adding User-Defined Calculations to Crosstabs</td>
<td>230</td>
</tr>
<tr>
<td>Naming and Describing Calculations</td>
<td>232</td>
</tr>
<tr>
<td>Editing Calculations</td>
<td>232</td>
</tr>
<tr>
<td>Deleting Calculations</td>
<td>233</td>
</tr>
<tr>
<td>Creating a Calculation Using the ALL Function</td>
<td>233</td>
</tr>
</tbody>
</table>

## Examples of Calculations 234

<table>
<thead>
<tr>
<th>Combining Data Items Using Calculations</th>
<th>234</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a Percent of Total in a Crosstab</td>
<td>236</td>
</tr>
<tr>
<td>Replacing Numeric Values with Text Strings</td>
<td>238</td>
</tr>
<tr>
<td>Pointing to a Specific Value</td>
<td>239</td>
</tr>
</tbody>
</table>

## Using Exceptions 242

<table>
<thead>
<tr>
<th>Creating Exceptions</th>
<th>242</th>
</tr>
</thead>
<tbody>
<tr>
<td>Naming and Describing Exceptions</td>
<td>244</td>
</tr>
<tr>
<td>Applying Exceptions</td>
<td>244</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Deleting Exceptions</td>
<td>247</td>
</tr>
<tr>
<td>Removing Exceptions</td>
<td>247</td>
</tr>
<tr>
<td><strong>Examples of Exceptions</strong></td>
<td>248</td>
</tr>
<tr>
<td>An Exception that Ranks the Top Ten</td>
<td>248</td>
</tr>
<tr>
<td>An Exception that Highlights Performers</td>
<td>251</td>
</tr>
<tr>
<td>Creating Summary Reports</td>
<td>253</td>
</tr>
<tr>
<td>Highlighting Alternate Rows</td>
<td>254</td>
</tr>
<tr>
<td>Creating an Exception Using the ALL Function</td>
<td>257</td>
</tr>
</tbody>
</table>
Calculations and Exceptions

You can perform a wide variety of calculations that increase the usefulness of reports.

**Predefined calculations**  Adding predefined (standard) calculations lets you quickly add totals, averages and so on. Examples include: total sales, a count of customers in each sales region, and the average amount of orders placed by your customers this month.

**User-defined calculations**  To perform calculations other than the predefined ones, you can create your own using BI Query Reports’ sophisticated calculation capability. For example, you can create a calculation to show what percentage of revenues are being contributed by each regional sales office.

**Multi-pass calculations**  You can perform multi-pass calculations where one calculation is based on another calculation that is based on yet another calculation. BI Query Reports performs calculations in the background, so you are free to carry out other activities.

**Exceptions**  You can highlight exceptions based on the calculations you create. Exceptions let you rank performance, emphasize important numbers, and create summary reports.

**Types of Calculations**

You can perform four types of calculations: numeric, string, date/time, and logical.

**Numeric**

Numeric calculations use one or more arithmetic operators (+, -, *, /, ^) to calculate values. For example:

\[
\text{Gross Margin} = (\text{Revenue} - \text{Cost})/\text{Revenue}
\]
String
String calculations manipulate text strings, which are text enclosed in double quotation marks (" "). You can use string calculations to combine text from several table columns, change the case (capitalization) of text characters, and find and replace occurrences of certain text characters in cells. For example:

\[
\text{Full name} = \text{‘First Name’} + \ " \" + \text{‘Last Name’}
\]

Date/Time
Date/time calculations manipulate dates and times. You can use date/time calculations to isolate the relevant part of a date (such as the time, the day of the week, the month, or the year). For example:

\[
\text{Month} = \text{Month (‘Order Date’)}
\]

Logical
Logical calculations evaluate a condition and return 1 if the condition is true and 0 if the condition is false. You can use a logical calculation to test whether a value meets a condition before using it in other formulas. Logical calculations use the logical operators < (less than), > (greater than), = (equal), <> (not equal), <= (less than or equal), >= (greater than or equal), Not, And, and Or. For example:

\[
\text{Status} = \text{IF (‘Account Balance’} \geq 0, \text{‘Account Balance’}, \text{“Overdrawn”})
\]

About Functions
Functions are built-in formulas that perform specific calculations. Because functions perform calculations automatically, you can use them to create calculations quickly and easily.

**Note:** When you add an aggregate function to a table, it is prefaced with the letters **ff.**
Chapter 9: Performing Calculations

<table>
<thead>
<tr>
<th>To Do This</th>
<th>Apply This</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculate a value for an entire table</td>
<td>Simple aggregate</td>
<td>To calculate average sales:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Avg ('Sales')</td>
</tr>
<tr>
<td>Calculate a value for each group (break)</td>
<td>Grouped aggregate</td>
<td>To calculate average sales for each product:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Avg ('Sales') By 'Product'</td>
</tr>
<tr>
<td>Return unique values for each row of data in a crosstab or table</td>
<td>Cell-based</td>
<td>To calculate the average of Product 1, 2, and 3 for each row in a crosstab:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Avg('Product1', 'Product2', 'Product 3')</td>
</tr>
<tr>
<td>Return a certain value if a specified condition is met and another value if the condition is not met</td>
<td>Conditional expression</td>
<td>To calculate a $1,000 bonus for salespeople who exceed their quota and a $500 bonus for everyone else:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>if('staff.sales'&gt;'staff.quota',&quot;$1000 Bonus&quot;,&quot;$500 Bonus&quot;)</td>
</tr>
<tr>
<td>Change a data type</td>
<td>Type converter</td>
<td>To return -2:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Int (-2.7)</td>
</tr>
<tr>
<td>Manipulate dates and times</td>
<td>Date &amp; Time</td>
<td>To return the year only:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Year ('Order Date')</td>
</tr>
<tr>
<td>Perform calculations on text strings</td>
<td>String</td>
<td>To return all values in the Last Name column in lower case:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LowerCase ('Last Name')</td>
</tr>
</tbody>
</table>

About By Argument

A By argument is a syntactical argument that identifies:

- a column of data that is acting as the control
- a column that is being acted upon

In the calculation:

Avg ('Amount') By 'Month'

Month is the control by which Amount is averaged. Each time the data for Month changes, an average is calculated for Amount.
About Expressions

To build calculations and exceptions, you need to build expressions. Expressions can be as simple as numbers or column names, or they can be as complex as a multi-part conditional If statement. You can create expressions using metrics, operators, functions, and constants.

Examples of common expressions are:

- Variance = Revenue - Plan
- Percent Variance = ((Revenue - Plan)/Plan * 100)
- Margin = Revenue - Cost
- Net Profit Margin = Net Income/Sales
- Revenue per Employee = (‘Total Sales’ / ‘Total Employees’)
- Full Name = ‘First Name’ + “ “ + ‘Last Name’
- July Bonus = IF (‘July Sales’ >= 10000 , ‘July Sales’ * .15 , IF (‘July Sales’ >= 5000 , ‘July Sales’ * .10 , ‘July Sales’ * .02))
- Remaining Credit = If ((‘Credit Limit’ > ‘Current Receivable’) , (‘Credit Limit’ - ‘Current Receivable’) , “Over Credit Limit”)
- Renew with Gift = If ({Renewal} = “y” Or

Operators Table

Operators indicate what to do with the values in an equation. You can apply arithmetic, comparison, and logical operators.
Arithmetic Operators
Arithmetic operators are mathematical symbols that indicate the operation you want to perform. Arithmetic operators are referred to as Operators in the Calculations dialog box.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plus</td>
<td>+ (plus sign)</td>
</tr>
<tr>
<td>Minus</td>
<td>- (hyphen)</td>
</tr>
<tr>
<td>Times</td>
<td>* (asterisk)</td>
</tr>
<tr>
<td>Divide</td>
<td>/ (forward slash)</td>
</tr>
<tr>
<td>Negative</td>
<td>- (hyphen)</td>
</tr>
<tr>
<td>Power</td>
<td>^ (chevron)</td>
</tr>
</tbody>
</table>

Comparison Operators
Comparison operators are symbols that indicate comparisons between a member/column in a view and another value. Comparison operators return a logical value of either TRUE or FALSE. Comparison Operators are referred to as Conditional Operators in the Calculations dialog box.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Notation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal</td>
<td>=</td>
</tr>
<tr>
<td>Greater than</td>
<td>&gt;</td>
</tr>
<tr>
<td>Less than</td>
<td>&lt;</td>
</tr>
<tr>
<td>Greater than or equal to</td>
<td>&gt;=</td>
</tr>
<tr>
<td>Less than or equal to</td>
<td>&lt;=</td>
</tr>
<tr>
<td>Not equal to</td>
<td>&lt;&gt;</td>
</tr>
</tbody>
</table>
Logical Operators

Logical operators define the relationship between two parts of an expression in a conditional statement. For example, two parts of a statement may have to be true for the result to be true. If A And B = C then true, if not then false. The “And” in the previous statement is a logical operator. Logical operators are part of Conditional Operators in calculations. There are three logical operators used in BI Query Reports: Not, And, Or.

Syntax Table

The following table lists the syntax used in creating calculations.

<table>
<thead>
<tr>
<th>To Do This</th>
<th>Use This</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Control the order of operations and identify the arguments of a function.</td>
<td>Parentheses ()</td>
<td>(15+10) x 2</td>
</tr>
<tr>
<td>Separate the two extremes of a range.</td>
<td>Colon:</td>
<td>'Western Region': 'Eastern Region':</td>
</tr>
<tr>
<td>Separate the arguments in an argument list.</td>
<td>Comma,</td>
<td>“Rent”, “Electricity”, “Phone”</td>
</tr>
<tr>
<td>Note: Commas are not used in numbers as separators. For example, the number one thousand is represented as 1000 in calculations, not as 1,000.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| Enclose attribute names in calculations.             | Single quote ‘’ | ‘Western Region’  
There is a space between Western and Region and therefore there needs to be single quotes around them. |
| Enclose the name(s) of external views referenced in a calculation. | Brackets [ ] | ['View 2 (Amount.hcr)']                                                   |
| Enclose a series of member names to define a specific cell, or a range of cells. | Braces{ } | To define a data cell, define the column first, then the row (the value calculated is where Column 1 and Row 2 meet):  
('Column 1’, ‘Row 2’)  
To define a range, the values calculated are for Column 1 and all rows:  
('Column 1’, *) |
| Identify the source dimension(s) by name, when two or more members have the same name. | Arrow -> | City Dimension -> 'Paris’                                                |
**Precedence Table**

BI Query Reports performs operations in calculations in a certain order of precedence. For example, in the calculation 15+10 x 2, the order of precedence is to multiply 10 by 2, then add 15. However, if you want to add 15 to 10, then multiply the sum by 2, you must specify the order of precedence using parentheses: (15+10) x 2.

<table>
<thead>
<tr>
<th>Level</th>
<th>Operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Parentheses ( )</td>
</tr>
<tr>
<td>2</td>
<td>NOT</td>
</tr>
<tr>
<td>3</td>
<td>Negative (-)</td>
</tr>
<tr>
<td>4</td>
<td>Power ( ^ )</td>
</tr>
<tr>
<td>5</td>
<td>Times (*); Divide (/); AND</td>
</tr>
<tr>
<td>6</td>
<td>Plus (+); Minus (-); OR</td>
</tr>
<tr>
<td>7</td>
<td>Equals (=); Less than (&gt;) ; Greater than (&lt;); Not equal to (&lt;&gt; )</td>
</tr>
<tr>
<td>8</td>
<td>Less than or equal to (&lt;= ); Greater than or equal to (&gt;= )</td>
</tr>
</tbody>
</table>

When two or more operations in a calculation are on the same level, they are performed from left to right.
Working with Calculations

Predefined and User-Defined Calculations

You can add a wide range of predefined or user-defined calculations to tables and crosstabs in reports.

Calculations are stored in views. When you add a calculation to one presentation (such as a sum to a crosstab), it is also added to any other presentation (such as a chart) that is linked to the first presentation through the view. Calculations that you add to views are available in a list that you can choose from.

Predefined

For frequently-performed calculations, BI Query Reports provides a number of predefined (standard) calculations. You can add all types of predefined calculations to tables (Average, Sum, Sum Distinct, Count, Count Distinct, Minimum, Maximum, Percent of Total, and Standard Deviation).

You can add basic calculations (Average, Sum, Count, CountAll, Minimum, and Maximum) to crosstabs. Adding a total to the outermost dimension in a crosstab adds a grand total, while adding a total to a nested dimension adds a subtotal.

User-Defined

When you need to add calculations other than those provided by BI Query Reports, you can create your own. You can add a wide range of sophisticated calculations to tables and crosstabs.
Adding Predefined Calculations to Tables

When you add predefined calculations to tables, you can add them to one column or multiple columns. For example, you can sum or count the items in more than one column at once. Keep in mind that you need to know whether to add the calculation to an entire column or to a group of data within the column. For example, adding a sum to a table creates a grand total; adding a sum to a group of data creates a subtotal.

**Note:**
- If the footer is not displayed, adding a calculation to a group displays it automatically.
- When you add a calculation (such as Running Count All) to a table that does not have group breaks, the calculation appears as a new column in the table.

**To add a predefined calculation to a table:**

1. To add a single calculation, click a value in a column. To add a calculation to more than one column, control-click a value in each column.
2. On the Tools menu, click Calc-O-Matic.
3. In the Calc-O-Matic dialog box, choose a calculation.

![Calc-O-Matic dialog box](image-url)
4. To apply the calculation to one or more groups, select the group(s) under On.

![Calc-O-Matic dialog box]

5. To apply the calculation to the entire column as a grand total, click the entire column.

6. Click OK.

**Adding a Grand Total**

Adding a sum to a table creates a grand total; adding a sum to a group of data creates a subtotal.

**To add a grand total to a table:**

1. Click an item in the column you want to total.
2. On the Tools menu, click Calc-O-Matic.
3. In the Calc-O-Matic dialog box, click Sum in the Function list.
4. In the On list, click Entire Column.
5. Click OK.
Adding Calculations to Groups
When you add a predefined calculation to a table, you need to decide whether you are adding it to a group of data within a column, an entire column of data, or multiple columns. For example, adding a Sum to a group of data creates a subtotal, but adding a Sum to a table creates a grand total. When you add a calculation (such as Running Count All) to a table that does not have group breaks, the calculation appears as a new column in the table.

To add a calculation in groups in a table:
1. Click an item in a column.
2. On the Tools menu, click Calc-O-Matic.
3. In the Calc-O-Matic dialog box, click a calculation (for example, click Sum).
4. To apply the calculation to one or more groups within the column(s), select the group(s) under On.
5. Click OK.

Adding Predefined Calculations to Crosstabs
You can add basic calculations (Average, Sum, Count, CountAll, Minimum, and Maximum) to crosstabs. If you add a calculation to a member in a crosstab and then hide the member, the calculation becomes invalid.

To add a predefined calculation to a crosstab:
1. Double-click a crosstab to activate it.
2. Click a column or row heading.
4. In the Calc-O-Matic dialog box, select a calculation.

![Calc-O-Matic dialog box]

5. Click OK.

**Adding Totals**

Adding a total to the outermost dimension adds a grand total, while adding a total to a nested dimension adds a subtotal.

**To add a total to a crosstab:**

1. Double-click a crosstab to activate it.
2. Click the first label in the range you want to total, then Shift+click the last label in the range.
4. In the Calc-O-Matic dialog box, click a calculation (for example, click **Sum**).
5. Click OK.

**Adding User-Defined Calculations to Tables**

When you need to add calculations to tables—other than those provided by BI Query Reports—you can specify your own.
To add a user-defined calculation to a table:

1. Click a table.
2. On the Tools menu, click Calculations.
3. In the Calculations dialog box, click New.
4. Click the Description tab.
5. On the Description page, type a name and description, or use the default name.
6. Click the Editor tab.
7. On the Editor page, create the expression. You can double-click items from the Members and Functions lists to include them in the expression, or type them into the Expression text box. Each item appears in the Expression text box.

8. To check the syntax of the calculation, click Check.
9. Click OK.

Note: When you insert numbers into calculations, do not use commas. For example, the number one thousand is entered as 1000, not as 1,000.
Adding User-Defined Calculations to Crosstabs

When you need to add calculations to crosstabs other than those provided by BI Query Reports, you can specify your own.

To add a user-defined calculation to a crosstab:

1. Double-click a crosstab to activate it.
2. On the Tools menu, click Calculations.
3. In the Calculations dialog box, click New.
4. In the Dimension List dialog box, choose the dimension to which you want to add the calculation.
5. Click OK.
6. In the Calculations dialog box, click the Description tab.
7. On the Description page, type a name and description, or use the default name.
8. Click the Editor tab.
9 On the Editor page, create the expression. You can double-click items from the Members and Functions lists to include them in the expression, or type them into the Expression text box. Each item appears in the Expression text box.

To check the syntax of the calculation, click Check.

Click OK.

### Sales by Region

<table>
<thead>
<tr>
<th>Region</th>
<th>Product</th>
<th>Quantity</th>
<th>Cost</th>
<th>Revenue</th>
<th>Margin</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Assorted Item</td>
<td>$3,317,435</td>
<td>$6,283,608</td>
<td>$7,300,702</td>
<td>$21,072</td>
</tr>
<tr>
<td></td>
<td>Assorted Boy's 1.2 pieces</td>
<td>$5,055,605</td>
<td>$6,018,208</td>
<td>$6,070,140</td>
<td>$8,052</td>
</tr>
<tr>
<td></td>
<td>Assorted Girl's 1.9 pieces</td>
<td>$0,008,305</td>
<td>$18,098,992</td>
<td>$11,013,129</td>
<td>$1,217,975</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>$18,053,200</td>
<td>$24,299,082</td>
<td>$27,830,694</td>
<td>$3,911,420</td>
</tr>
<tr>
<td></td>
<td>BC</td>
<td>Assorted Item</td>
<td>$81,200</td>
<td>$89,618</td>
<td>$18,107</td>
</tr>
<tr>
<td></td>
<td>Assorted Boy's 1.2 pieces</td>
<td>$32,990</td>
<td>$35,993</td>
<td>$7,993</td>
<td>$7,993</td>
</tr>
<tr>
<td></td>
<td>Assorted Girl's 1.9 pieces</td>
<td>$0,008,305</td>
<td>$18,098,992</td>
<td>$11,013,129</td>
<td>$1,217,975</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>$112,400</td>
<td>$115,570</td>
<td>$23,977</td>
<td>$23,977</td>
</tr>
<tr>
<td></td>
<td>CA</td>
<td>Assorted Item</td>
<td>$193,400</td>
<td>$345,438</td>
<td>$35,387</td>
</tr>
<tr>
<td></td>
<td>Assorted Boy's 1.2 pieces</td>
<td>$150,500</td>
<td>$303,775</td>
<td>$41,307</td>
<td>$52,202</td>
</tr>
<tr>
<td></td>
<td>Assorted Girl's 1.9 pieces</td>
<td>$150,500</td>
<td>$407,818</td>
<td>$51,784</td>
<td>$64,248</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>$443,200</td>
<td>$485,033</td>
<td>$71,697</td>
<td>$86,555</td>
</tr>
<tr>
<td></td>
<td>CO</td>
<td>Assorted Item</td>
<td>$69,700</td>
<td>$77,413</td>
<td>$11,913</td>
</tr>
<tr>
<td></td>
<td>Assorted Boy's 1.2 pieces</td>
<td>$72,900</td>
<td>$101,193</td>
<td>$18,296</td>
<td>$21,956</td>
</tr>
<tr>
<td></td>
<td>Assorted Girl's 1.9 pieces</td>
<td>$60,500</td>
<td>$195,839</td>
<td>$17,545</td>
<td>$22,045</td>
</tr>
<tr>
<td></td>
<td>Total</td>
<td>$209,100</td>
<td>$385,448</td>
<td>$39,244</td>
<td>$59,709</td>
</tr>
<tr>
<td></td>
<td>GA</td>
<td>Assorted Item</td>
<td>$81,000</td>
<td>$115,838</td>
<td>$13,020</td>
</tr>
<tr>
<td></td>
<td>Assorted Boy's 1.2 pieces</td>
<td>$74,300</td>
<td>$109,493</td>
<td>$11,645</td>
<td>$22,300</td>
</tr>
<tr>
<td></td>
<td>Assorted Girl's 1.9 pieces</td>
<td>$49,500</td>
<td>$184,488</td>
<td>$17,216</td>
<td>$22,078</td>
</tr>
</tbody>
</table>

**Note:** When inserting numbers into calculations, do not use commas. For example, enter one thousand as 1000 (not 1,000).
Naming and Describing Calculations
Use the Name tab in the Calculations dialog box to name and describe calculations.

To name and describe a calculation:
1. Click a table. Double-click a crosstab to activate it.
2. On the Tools menu, click Calculations.
3. Click the List tab.
4. On the List page, select a calculation.
5. Click the Description tab.
6. On the Description page, type a name and description.
7. Click OK.

Editing Calculations
You can modify the name, description, or expression for any calculation you added to a table or crosstab.

To edit a calculation:
1. Right-click a calculation.
2. Click Calculations from the pop-up menu.
3. Edit the calculation.
4. To check the syntax, click Check.
5. Click OK.
Deleting Calculations

You can delete calculations using the Delete button in the Calculations dialog box. If another calculation depends on a deleted calculation, it becomes invalid. You then need to either edit or delete the calculation.

To delete a calculation:

1. Click a table or crosstab.
2. On the Tools menu, click Calculations.
3. Click the List tab.
4. On the List page, select a calculation that you want to delete.
5. Click Delete.

**Note:** You cannot undo this action even if you click Cancel in the Calculations dialog box.

6. Click OK.

Creating a Calculation Using the ALL Function

You can use the ALL function in a crosstab to create a calculation that is based on all members in a dimension. This function includes all visible members except calculated members. When you create an expression, the ALL function lets you specify all the members in a dimension at once instead of individually. You can use ALL with any Cell-based function, for example, Sum, Avg, Count, and so on.

To create a calculation using the ALL function:

1. Click a crosstab.
2. On the Tools menu, click Calculations.
3. Click the List tab.
5. In the Dimension List dialog box, click the dimension on which you want to base the calculation and in which you want the calculation to appear.
6 Click the Editor tab.

7 On the Editor page, double-click Cell-based Functions in the Functions list, then double-click a function.

8 Click inside the parentheses in the Expression text box, then type ALL.

9 To check the syntax of the calculation, click Check.

10 Click OK.

Examples of Calculations

Combining Data Items Using Calculations
You can combine data items using a calculation. You can modify the calculation shown below when you create reports, or use it as an example when creating your own calculations.

To combine data items using a calculation:
1 Click anywhere in a table.
2 On the Tools menu, click Calculations.
3 In the Calculations dialog box, click New.
4 Click the Description tab.
5 On the Description page, type a name and description for the combined data item.
6 Click the Editor tab.
7 On the Editor page, double-click Columns under Members to display the list of available data items, then double-click the data item you want to appear first in the combined item.
8 Click at the end of the expression, then type + (plus sign).
9 To add a character (such as a space or comma) between the two data items, click inside the Expression text box.
10 Type the character and enclose it in double-quotations marks: “,”.
11 Type + (plus sign).

12 Double-click the second data item under Members that you want to combine.

13 If one of the data items you are combining is numeric, you must convert it to a string:
   a) Under Functions, double-click Type Converters.
   b) Double-click Str.
   c) Click inside the brackets for Str ( ), then enter the data item by following step 7.

   For example, to join a data item containing employee last names with a data item containing their salaries, the expression would look like:

   ‘staff.last_name’ + “: ” + Str (‘staff.salary’)

14 To check the syntax of the calculation, click Check.

15 Click OK.
Creating a Percent of Total in a Crosstab

In a report, you can add calculations that are based on other calculations. For example, percent of total is a commonly used calculation that shows the percentage of any value to the whole (such as what percentage a country’s sales are to total sales). In this example, you first calculate total sales and then you add a second calculation that specifies a cross-reference to the cell that contains the grand total (total sales).

To create a percent of total in a crosstab:

1. In a crosstab, add a grand total. For example, to add a percent of total to a crosstab of sales by country, add a grand total to the Amount column.
2. Select the crosstab.
3. On the Tools menu, click Calculations and then click the List tab.
5. In the Dimensions List dialog box, select Metrics and then click OK.
6. Click the Editor tab.
7. On the Editor page, specify the member for which you want to calculate the percent of total. For example, double-click Metrics under Members, then double-click SUM Amount.
8. In the Expression box, click at the end of the expression, then type a slash (/).
9. Click Cell Select.
10 In the Data Cell Selector dialog box, in the Dimensions box, select the cell (first the column, then the row) containing the calculation. For example:

a) In the Data Cell Selector dialog box, under Dimensions, click the icon on the right side of *(every:Metrics), then select Sum Amount from the Choose a Member dialog box.

b) Click the icon on the right side of * (every:Description). Select the row containing the grand total from the Choose a Member dialog box.

11 Click OK.
12 In the Calculations dialog box (Editor page), click at the end of the expression, type * (asterisk), then type 100. For example, ‘sales.ord_amount’/('Calc1', 'sales.ord_amount')*100

13 Click OK.

Replacing Numeric Values with Text Strings

You can replace numeric values in calculations with text strings. This is useful if you want to replace codes with descriptive labels or numbers that meet a certain condition with a warning. For example, if you are tracking overdue accounts, you can create a report that displays the text Overdrawn for any account with a negative balance.

To replace a numeric value with a text string, add a conditional If-Then-Else expression as follows:

1 In the first part of the expression, set up the condition. For example, if you are comparing two values, check whether the first value is greater than the second value.

2 In the second part of the expression, assign the text string to the values that meet the condition.
3. In the third part of the expression, assign the text string to the values that do not meet the condition.

4. To check the syntax, click Check.

5. Click OK.

**Example: Replacing a Numeric Value with a Text String**

To create a column that lists the remaining credit for customers, displaying the text *Overdrawn* for those customers who have exceeded their credit limit, create the following expression:

\[
\text{If ('Receivable'> 'Credit Limit', "Overdrawn", 'Credit Limit')}
\]

<table>
<thead>
<tr>
<th>Customer</th>
<th>Receivable</th>
<th>Credit Limit</th>
<th>Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>A. Chocolate</td>
<td>134,000</td>
<td>190,000</td>
<td>Underdrawn</td>
</tr>
<tr>
<td>A Little of What You Fancy</td>
<td>20,000</td>
<td>30,000</td>
<td>Underdrawn</td>
</tr>
<tr>
<td>A Sweet Illusion</td>
<td>80,000</td>
<td>100,000</td>
<td>Underdrawn</td>
</tr>
<tr>
<td>A Touch of Spice</td>
<td>199,000</td>
<td>100,000</td>
<td>Overdrawn</td>
</tr>
<tr>
<td>A.C. Candies and Nuts</td>
<td>40,000</td>
<td>30,000</td>
<td>Overdrawn</td>
</tr>
<tr>
<td>Allower Cakes</td>
<td>60,000</td>
<td>50,000</td>
<td>Overdrawn</td>
</tr>
<tr>
<td>American Chocolate Delight</td>
<td>36,000</td>
<td>40,000</td>
<td>Overdrawn</td>
</tr>
<tr>
<td>Aunt Emily's Candy Store, Inc.</td>
<td>70,000</td>
<td>60,000</td>
<td>Overdrawn</td>
</tr>
<tr>
<td>Australian Chocolate Importers</td>
<td>8,000</td>
<td>10,000</td>
<td>Underdrawn</td>
</tr>
<tr>
<td>Stevan's Chocolate House</td>
<td>203,000</td>
<td>290,000</td>
<td>Overdrawn</td>
</tr>
<tr>
<td>South America Candy Store</td>
<td>35,000</td>
<td>50,000</td>
<td>Underdrawn</td>
</tr>
<tr>
<td>Delicate Chocolate Delight</td>
<td>18,000</td>
<td>20,000</td>
<td>Underdrawn</td>
</tr>
<tr>
<td>Dot of Sweetness</td>
<td>114,000</td>
<td>120,000</td>
<td>Underdrawn</td>
</tr>
</tbody>
</table>

**Pointing to a Specific Value**

Occasionally, you may want to create calculations that point to a value in a specific cell in a table or crosstab.

**To point to a specific cell:**

1. Create a new calculation.

2. On the Editor page of the Calculations dialog box, click Cell Select.

For more information, see “Adding User-Defined Calculations to Crosstabs” on page 230.
On the Editor page, the presentation view you selected is displayed in the Data View list at the bottom left. If you want to use items from a different presentation view in the calculation, choose the view from the Data View list.

3 In the Data Cell Selector dialog box, under Dimensions, click the icon on the right side of the dimension you want. For example, click the icon for columns.

![Data Cell Selector dialog box]

4 In the Choose a Member dialog box, click the item containing the value you want to use.

![Choose a Member dialog box]

5 In the Data Cell Selector dialog box, under Dimensions, click the icon on the right side of the dimension you want. For example, click the icon for Rows.
In the Choose a Member dialog box, click the row number containing the value you want to use. To determine which row contains the value you want:

- Click a row.
- Check the sample value listed in the Sample Values box. If it is not the value you want, choose another row.

Click OK.

In the Calculations dialog box, finish creating the expression.

To check the syntax, click Check.

Click OK.

**Example: Pointing to a Specific Value**

You may have a column called Conversion Rates that contains currency-conversion rates for the US, Canada, and other countries. You can specify a cell containing a specific value, such as the conversion rate for Canadian dollars, in a calculation using the Cell Selector. When you refresh the report, the calculation always points to the updated value of the specified cell.

**For example, to specify a US conversion rate:**

1. On the Editor page of the Calculation dialog box, click Cell Select.
2. Click the blue icon on the right side of the Columns item.
3. Choose the Conversion Rates item.
4. Click the icon on the right-side of the Rows item. If the US rate is in Row 4, click Row 4.
5. Click OK to close the Cell Select.
6. Finish creating the expression.
Using Exceptions

BI Query Reports lets you add exceptions to your reports. Exceptions highlight important information so you can see it easily. For example, you can highlight sales that are below a certain threshold or employees whose performance exceeds certain targets. Exceptions are also useful when you want to create summary reports or reports that rank performance.

Exceptions are normally highlighted using a particular font, style, color, or graphic. They can also be represented by data, objects—such as bands in a table—and graphics. You can flag exceptions when they match the calculation you’ve created, when they don’t match, or both.

If your reporting environment includes BI Server and you have the appropriate system permissions, you can create exceptions that trigger events. This type of exception is created in the same way as other exceptions except you do not have to choose formatting options or apply it to an object in the report.

Creating Exceptions

Creating exceptions is a two-part process. You begin by creating the expression on which your exception is based. Then you apply the exception.

To create an exception:

1. Click a table to activate it. Alternatively, double-click a crosstab.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, click New and then click the Description tab.
4. On the Description page, type a name and description.
5. Click the Editor tab.
6 On the Editor page, specify the condition for the exception. For example, to create an exception that identifies sales that are greater than $1,000,000:

   a) Double-click Columns under Members.
   b) Double-click Sales, type > (greater than), then type 1000000. Do not include if at the beginning of the expression.
   c) The Expression looks like this: `sales_amount'>1000000.

To check the exception syntax, click Check.

8 To highlight values when they meet the exception, make sure the check box beside the True button is selected. To specify a different format for values that meet the exception, click True.

   To highlight values when they don’t meet the exception, select the check box beside the False button. To specify a different format for values that don’t meet the exception, click False.

9 Click OK.

10 Apply the exception.
Naming and Describing Exceptions

Use the Description tab in the Exceptions dialog box to name and describe exceptions.

To name and describe an exception:
1. Click a table or a crosstab.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, select an exception.
4. Click the Description tab.
5. On the Description page, type a name and description.
6. Click OK.

Applying Exceptions

You can apply exceptions to data, or to objects such as bands in a table, text, graphics, or other presentations (charts and crosstabs). You can control whether the data or object is visible when the exception is true, false, or both true and false.

For example, if you want to display a chart only when sales are below target, you create the chart, then apply the exception to it, setting the display status to When True. You can reuse exceptions, applying them to more than one object in a report. You cannot apply more than one exception to the same object. However, you can work around this by adding multiple objects.

Applying Exceptions to Data

Normally, you apply an exception to the same data you used to create it. For example, if you want to highlight sales greater than $100,000 in a bold green font, you create the exception using the Sales column and apply it to the column.

To apply an exception to data:
1. Select the data. For example, click an item in a table.
2. On the Format menu, click Properties.
3 In the Properties dialog box, click the General tab.

4 On the General page, make sure that the presentation you used to create the exception is displayed in the Source View box. If it is not, choose it from the Source View list.

5 Choose the exception from the Exception Name list.

6 If you want to link the exception to a specific cell in a crosstab, click Cell Select, then choose the cell.

7 Under Display Status, click an item.

8 Click OK.

Applying Exceptions to Objects

You can also apply exceptions to text, graphics, presentations, bands, and other objects. Applying exceptions to objects lets you hide or display the object according to the exception. For example, if a particular cost center is more than 25% over budget, you can display a chart containing a breakdown of its expenses. You can also display only the top ten sales representatives or add graphics, such as a gold star, beside the names of those representatives who exceed their quota.
To apply an exception to an object:

1. Click an object.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the General tab.
4. On the General page, choose the presentation that you used to create the exception from the Source View list.
5. Choose the exception from the Exception Name list.
6. If you want to link the exception to a specific cell in a table or crosstab, click Cell Select, then use the Data Cell Selector dialog box to choose a cell.
7. Click an item under Display Status.
8. Click OK.
When you apply an exception to the detail bands of a table, and specify that they should display only when the data in them matches the exception, the bands that do not match automatically collapse to avoid gaps in the table.

For example, you might want to select empty bands and remove the exception. To display them, on the Format menu, click Table and then click Expand.

Deleting Exceptions

You can delete an exception from the list of exceptions. If you delete an exception, you won’t be able to use it again in the report.

To delete an exception:

1. Select either a table or a crosstab.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, select the exception that you want to delete.
4. Click Delete.
5. Click OK.

Note: You cannot undo this action even if you click Cancel in the Exceptions dialog box.

Removing Exceptions

You can remove an exception that was previously applied to data or an object. If you remove an exception, you can reapply it.

To remove an exception:

1. Select the object that has the exception applied to it.
2. On the Format menu, click Properties.
3. In the Properties dialog box, click the General tab.
4. On the General page, click "<no exception>" on the Exception Name list.
5. Click OK.
Examples of Exceptions

An Exception that Ranks the Top Ten

Many organizations like to rank performance. For example, you might want to rank the top ten sales representatives, mutual funds, or production lines. You can create a calculation that ranks performance, then use an exception to display only the top ten. You can easily change this exception to display only the top five or bottom ten.

To rank the top ten performers:
1. When you create the query in BI Query, apply a descending sort on the attribute you want to rank.
2. In BI Query Reports, add a calculation to show the ranking.
3. Add an exception that looks for the top ten.
4. Apply the exception to the detail bands of the table.

Example of the Top-ten Calculation:
1. Click a table.
2. On the Tools menu, click Calculations.
3. In the Calculations dialog box, click New and then click the Description tab.
4. On the Description page, type Rank in the Name box.
5. Click the Editor tab.
6. On the Editor page, double-click Simple Aggregate under Functions, then double-click Running Count.
7 Double-click Columns under Members, then double-click Sales.

[Image]

8 Click OK.

Example of the Top-ten Exception:
1 Click a table.
2 On the Tools menu, click Exceptions.
3 In the Exception dialog box, click New and then click the Description tab.
4 On the Description page, type Top Ten.
5 Click the Editor tab.
6 On the Editor page, double-click Columns under Members, then double-click Rank.
7 Type <= (less than or equal to) at the end of the expression, then type 10.
8 Click OK.

![Image of the Calculations window]

**Example of Applying the Top-ten Exception:**

1 In the table, click the detail band.
2 On the Format menu, click Properties.
3 In the Properties dialog box, click the General tab.
4 On the General page, click Top Ten on the Exception Name list.
5 Click Show When True and click OK.

<table>
<thead>
<tr>
<th>Rank</th>
<th>Salesperson</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Brie Tang</td>
<td>$2,600,621</td>
</tr>
<tr>
<td>2</td>
<td>Simon Giovann</td>
<td>$1,721,220</td>
</tr>
<tr>
<td>3</td>
<td>Pedro Gonzalez</td>
<td>$1,000,687</td>
</tr>
<tr>
<td>4</td>
<td>Dale Madison</td>
<td>$1,284,459</td>
</tr>
<tr>
<td>5</td>
<td>Nicole Savard</td>
<td>$1,277,523</td>
</tr>
<tr>
<td>6</td>
<td>Jack Netheroe</td>
<td>$1,217,791</td>
</tr>
<tr>
<td>7</td>
<td>Walter Wing</td>
<td>$1,117,881</td>
</tr>
<tr>
<td>8</td>
<td>William Oliver</td>
<td>$863,561</td>
</tr>
<tr>
<td>9</td>
<td>Tony O'Sullivan</td>
<td>$522,144</td>
</tr>
<tr>
<td>10</td>
<td>Kent Vale</td>
<td>$500,087</td>
</tr>
</tbody>
</table>
An Exception that Highlights Performers

One of the most common ways that organizations use exceptions is to highlight the best or worst performers. You can create an exception that checks values against a certain metric, then highlight the numbers that fall above or below that metric.

To highlight the best and worst performers:

1. Click a table.
2. On the **Tools** menu, click **Exceptions**.
3. In the **Exceptions** dialog box, click **New** and then click the **Description** tab.
4. On the **Description** page, type **Best and Worst Performers** in the **Name** box.
5. Click the **Editor** tab.
6. On the **Editor** page, click **True**.
7. In the **True Style Properties** dialog box, click the **Line** tab.
8. On the **Line** page, click **No Line** and then click **OK**.
9. On the **Editor** page, click **False**.
10. In the **False Style Properties** dialog box, click the **Font** tab.
11. In the **Color** list, click **Red**.
12. Click the **Line** tab.
13. On the **Line** page, click **No Line** and then click **OK**.
14. On the **Editor** page, double-click **Columns** under **Members**, then double-click **Sales**.
15 Type > (greater than), then type 3000000.

16 Click OK.

17 In the table, click the Sales item.

18 On the Format menu, click Properties.

19 In the Properties dialog box, click the General tab.

20 In the Exception Name list, click Best and Worst Performers.

21 Click Show Always.
Creating Summary Reports

A summary report can contain many rows of data but display only the data that meets a certain criteria. You can also use exceptions to create summary reports. Summary reports serve two purposes. For example, you can create a report that displays account information for all your customers. Then, if your manager wants a report that lists only those customers who have exceeded their credit limit, you can turn the report into a summary report by hiding the customers who haven’t exceeded their credit limit.

To create a summary report:

1. Click a table.
2. On the Tools menu, click Exceptions.
3. In the Exceptions dialog box, click New and then click the Description tab.
4. On the Description page, type Over Credit Limit in the Name box.
5. Click the Editor tab.
6. On the Editor page, double-click Columns under Members and then double-click Remaining Credit.
7. Click at the end of the expression and type > (greater than), then type 0.
8 Click OK.
9 Click a detail band.
10 On the Format menu, click Properties.
11 In the Properties dialog box, click the General tab.
12 In the Exception Name list, click Over Credit Limit.
13 Click When True.
14 Click OK.

<table>
<thead>
<tr>
<th>Name</th>
<th>Current Receivable</th>
<th>Credit Limit</th>
<th>Remaining Credit</th>
</tr>
</thead>
<tbody>
<tr>
<td>A Touch of Spice</td>
<td>$150,000</td>
<td>$190,000</td>
<td>-9,000</td>
</tr>
<tr>
<td>A-T Candies and Nuts</td>
<td>$40,000</td>
<td>$30,000</td>
<td>-10,000</td>
</tr>
<tr>
<td>Alligator Candy</td>
<td>$60,000</td>
<td>$50,000</td>
<td>-13,000</td>
</tr>
<tr>
<td>Aunt Emily's Candy Stores, Inc</td>
<td>$70,000</td>
<td>$60,000</td>
<td>-10,000</td>
</tr>
<tr>
<td>Bavarian Chocolate-House</td>
<td>$250,000</td>
<td>$250,000</td>
<td>-42,000</td>
</tr>
<tr>
<td>Candies for Every Occasion</td>
<td>$84,000</td>
<td>$50,000</td>
<td>-34,000</td>
</tr>
<tr>
<td>Candy Magic</td>
<td>$130,000</td>
<td>$100,000</td>
<td>-30,000</td>
</tr>
<tr>
<td>Chateau de Chocolat</td>
<td>$61,000</td>
<td>$50,000</td>
<td>-11,000</td>
</tr>
<tr>
<td>Choco Delight</td>
<td>$122,000</td>
<td>$100,000</td>
<td>-22,000</td>
</tr>
<tr>
<td>Chocolate Shoppe</td>
<td>$80,000</td>
<td>$75,000</td>
<td>-5,000</td>
</tr>
</tbody>
</table>

**Highlighting Alternate Rows**

If all of the rows in a table are formatted in the same way, you can create an exception that highlights every other row. This visually breaks up the information in the table and makes it easier to read.

**To highlight alternate rows:**
1 Click the table.
2 On the Tools menu, click Exceptions.
3 On the List page of the Exceptions dialog box, click New and then click the Description tab.

4 On the Description page, name the exception. For example, call it GreenBars.

5 Click the Editor tab.

6 On the Editor page, type the following expression:
   \[ \text{ffrunningcount( )/2 = int(ffrunningcount( )/2)} \]

7 Click True.

8 In the True Style Properties dialog box:
   a) Click the Line tab.
   b) Click No Line.
   c) Click OK.

9 On the Editor page, click False.
10 In the False Style Properties dialog box, click the Fill tab:
   a) Click Fill Color and choose a light green color.
   b) Click OK.
   c) Click the Line tab.
   d) Click No Line.
   e) Click OK.

11 In the Exception dialog box, click OK.

12 Click the detail band.

13 On the Format menu, click Properties.

14 In the Properties dialog box, click the General tab.

15 On the General page, click GreenBars from the Exception Name list and make sure Show Always is selected.

16 Click OK.

<table>
<thead>
<tr>
<th>Product Name</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Almond Bark</td>
<td>85,959</td>
</tr>
<tr>
<td>Assorted Nuts</td>
<td>101,543</td>
</tr>
<tr>
<td>Assorted Truffles, 12 piece</td>
<td>101,543</td>
</tr>
<tr>
<td>Assorted Truffles, 10 piece</td>
<td>101,543</td>
</tr>
<tr>
<td>Cartoon Figures</td>
<td>74,431</td>
</tr>
<tr>
<td>Chocolate Chips</td>
<td>56,547</td>
</tr>
<tr>
<td>Chocolate Covered</td>
<td>101,543</td>
</tr>
<tr>
<td>Golf Balls</td>
<td>101,543</td>
</tr>
<tr>
<td>Vanilla Buttercream</td>
<td>79,841</td>
</tr>
</tbody>
</table>
Creating an Exception Using the ALL Function

The ALL function in a crosstab lets you create an exception that is based on all members in a dimension.

To create an exception using the ALL function:

1. Click a crosstab.
2. On the Tools menu, click Exceptions.
4. Click the Editor tab.
5. On the Editor page, double-click Cell-based Functions in the Functions list and then double-click a function.
6. Click inside the parentheses in the Expression text box, type ALL, press the space bar, then type the name of the dimension in which the members are contained.
7. Finish creating the expression. For example, the expression could be:
   
   \[
   \text{Sum}\ (\text{ALL regional\textunderscore\textunderscore offices\textunderscore country\textunderscore Dimension} > 20000)
   \]
8. To check the syntax of the calculation, click Check.
9. Click OK.
### Chapter 10

**Working with Hummingbird BI Server**

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About BI Server</td>
<td>261</td>
</tr>
<tr>
<td>Publishing Reports to the Repository</td>
<td>261</td>
</tr>
<tr>
<td>Retrieving Reports from the Repository</td>
<td>263</td>
</tr>
<tr>
<td>About Security</td>
<td>264</td>
</tr>
<tr>
<td>User and Group Structures</td>
<td>264</td>
</tr>
<tr>
<td>Granting and Denying Access</td>
<td>265</td>
</tr>
<tr>
<td>Setting Security for Reports</td>
<td>266</td>
</tr>
<tr>
<td>About Scheduling</td>
<td>267</td>
</tr>
<tr>
<td>Scheduling a Report</td>
<td>267</td>
</tr>
<tr>
<td>Using Report Exceptions to Trigger Events</td>
<td>268</td>
</tr>
</tbody>
</table>
About BI Server

If you are in a BI Server environment, you can take advantage of BI Server’s publishing, retrieving, and security features.

The BI Server Repository is a storehouse for enterprise information produced using BI applications. If you’ve been assigned the appropriate system permissions, you can publish BI Query information to the repository and you can retrieve information you’ve published as well as that published by others. By publishing to the repository, you ensure that the information is accessible to other users from both desktop and laptop, as well as over the corporate intranet in the BI Web Personal Portfolio. Because you can set security on items you publish, publishing also provides a secure way to share your information with other users.

Specific terms are used to distinguish Server-related actions from local (computer-based) actions. Locally saved data (on your desktop computer) is saved or loaded. Material stored on the BI Server Repository is published or retrieved.

In order to publish a data model, you must first save it locally. Once you save a data model locally and published it, queries based on that data model can also be published. In order to retrieve a query, you must open a local copy of a published data model or retrieve a data model from the repository.

**Note:** Publishing and retrieving require that you login to BI Server.

Publishing Reports to the Repository

You can publish a report to the repository using BI Query Reports. The data model with which it’s associated must have been published first. You can also publish reports from BI Query when you publish the data model on which they’re based, but some publishing options are available only when you publish a report from BI Query Reports. Publishing reports makes it possible both to share them with other users and to schedule them to refresh automatically.
If the reports you’re publishing will be used in a network or Internet environment, make sure that their file names don’t contain spaces or special characters. This will avoid problems that can occur with different naming conventions. Examples of special characters are &, <, >, “, and so on.

To publish a report:

1. In BI Query Reports, log in to the BI Server repository.

2. With a saved report (based on a published data model) open, on the File menu, click Publish.

3. In the Publish to Repository dialog box, type a description for the report. This helps users decide whether they need to look at it.

To publish the report to a folder other than the one shown under Folder, click the adjacent browse button. Then do one of the following:

- In the Select Folder dialog box, select the folder you want.
- To create a new folder, select the folder under which you want the new folder to be created. Click the New Folder button, enter a name for the new folder, and click OK.

4. In the Publish to Repository dialog box, click Set Security. The Set Security dialog box opens. Use it to view and assign read, write, and refresh permissions to control which users and groups can access the report.

5. To provide a printable version of the report for BI Web users, click Publish Acrobat (.pdf).

6. Click Publish.
Retrieving Reports from the Repository

You can view and modify published reports (depending on your security permissions) by retrieving the report from the repository.

To retrieve a published report:

1. On the File menu, click Retrieve.

2. In the Retrieve Report dialog box, locate the report, and click OK.
About Security

For any item you publish, there may be people in your organization who need access to the information contained in it, people who need customized views of it, and people who shouldn’t see it at all. You must secure the data so that it can be viewed or changed only by the people with the authority to do so.

You can control individual as well as group access to the information you publish—granting or denying general access while providing individual exceptions as necessary. You exercise this control based on a structure of users and groups that the BI Server administrator creates.

Depending upon your needs, the administrator may make it possible for you to grant system permissions to other users, such as the ability to schedule queries, reports, and HyperCubes. For information on these permissions and on how they’re assigned, see the BI Server Administrator’s Guide.

User and Group Structures

Your login name and password identify you as a user in a structure of users and groups created by your BI Server administrator. The administrator assigns system permissions that determine the extent to which you can use the features of BI Server, such as:

• the ability to publish
• the ability to retrieve
• the ability to schedule the items you publish
Granting and Denying Access

Using the user and group structure provided by your administrator, you can grant or deny access to the items you publish. If you find that you can’t use features or perform activities appropriate to your work, ask your administrator to review the system permissions that have been assigned to you. The table below describes how users inherit group access.

<table>
<thead>
<tr>
<th>Inheritance Rule</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group members inherit their group’s access.</td>
<td>When you grant or deny access to a group, all members of the group inherit that setting (if a group has access, each member has access and if a group is denied access, each member is denied it).</td>
</tr>
<tr>
<td>Members of more than one group inherit from the groups that grant access.</td>
<td>What if a member of a group that is granted access is also a member of another group that is denied access? It’s the group that has access that prevails. The member has access.</td>
</tr>
<tr>
<td>Member security settings override inherited group settings.</td>
<td>You can give a group member a setting different from that of its group. When you do, the overriding setting always applies to that member, even when you make it a member of other groups. You can remove an overriding setting to let a member inherit from the group again.</td>
</tr>
</tbody>
</table>

The symbols that indicate access settings are as follows:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="green.png" alt="Green light" /></td>
<td>Green light. Access specifically granted.</td>
</tr>
<tr>
<td><img src="red.png" alt="Red “no entry” symbol" /></td>
<td>Red “no entry” symbol. Access specifically denied.</td>
</tr>
<tr>
<td><img src="green_check.png" alt="Green check" /></td>
<td>Green check. A granted access that has been inherited.</td>
</tr>
<tr>
<td><img src="red_x.png" alt="Red x" /></td>
<td>Red x. A denied access that has been inherited.</td>
</tr>
</tbody>
</table>
Setting Security for Reports

You can set security for a report (by item), or you can set by user and group. In the former instance, you select the report first, and then set security for users and groups. In the latter instance, you select a user or a group first, and then select the report for which you want to set security.

To set security:

1. Open the Set Security dialog box.

2. To set security by user and group rather than by report (item), click the Set By User and Group tab.

3. To give access, click Grant. To not give access, click Deny. To allow a user or group to assume security settings from the group of which it is a member, click Inherit.

4. When you have set security for as many items and as many users and groups as you want, click OK.

5. Publish the report.
About Scheduling

Scheduling regulates the flow of information from the database by processing the enterprise’s queries and reports in a managed time frame. Jobs can be scheduled to run once or repeatedly, at specific intervals, during less busy times, or when a specific event has occurred. Scheduling also provides a variety of ways to distribute information.

Scheduling a Report

From BI Query Reports, you can schedule published reports to run at specific times or after specific events have occurred, and you can specify output destination. You do not have to be present at the local computer, and it does not have to be running.

To schedule a report:

1. Open the report, and on the File menu, click Schedule, then Report. The Schedule Job dialog box opens.
On the Info page, enter a job name, select a priority, and enter a description of the report. This page displays errors and other system messages for the scheduled job in the Messages text box.

Click the When tab. On the When page, specify the schedule for refreshing the report.

Click the Actions tab. On the Actions page, specify the actions you want performed.

Click OK.

Using Report Exceptions to Trigger Events

You can create an exception in a report that triggers an event in the Scheduler. The event triggered can be either the refreshing of a report or the running of a query. This type of exception is created the same way as other report exceptions, with one difference: instead of choosing formatting options or applying the exception to an object in the report, you associate the exception with an event.

To trigger a scheduled job based on an exception requires at least two items:

• the report that contains the exception that serves as the trigger
• the report that refreshes or the query that runs when the exception is true

To trigger a job using a report exception:

1 In BI Query Reports, open the report that will contain the exception you want to trigger your event-based job.
2 Click the column on which to create the exception.
3 On the Tools menu, click Exceptions.
4 In the Exception List, select the exception(s) that will trigger running the job. If no exception is available, click New.
5 Click the Description tab. Type a name and description for the exception.
6 Click the Editor tab and formulate the exception expression.
7 Click Events.
8. In the Trigger Events dialog box, select an event. If the event you want is unavailable, you can create it.

9. Click OK.

10. In the Exceptions dialog box, click OK.

11. Schedule the job that you want to be triggered by the report exception.

12. In the Schedule Job dialog box, click the When tab.

13. In the Frequency area, select Event-based.

14. In the Events area, select the check box to select the event you named in step 8.

15. When you have finished scheduling the job, click OK.
Accessibility

Hummingbird products are accessible to all users. Wherever possible, we developed our software using Microsoft Windows interface standards. Depending on the product in which you are working, a subset of the following accessibility features is available.

**Access Keys**  Menus have associated access keys (mnemonics). To open any menu, press Alt and the underlined letter in the menu name as it appears on the interface. For example, to access the File menu, press Alt+F.

Once you have opened a menu, you can access an item on the menu by pressing the underlined letter in the menu item name, or you can use the arrow keys to navigate the menu list.

**Keyboard Shortcuts**  Some often-used menu options also have shortcut (accelerator) keys. The shortcut key for an item is listed beside it on the menu.

**Directional arrows**  Use directional arrows on the keyboard to navigate through menu items or to scroll vertically and horizontally. You can also use the directional arrows to navigate through multiple options. For example, if you have a series of radio buttons, you can use the arrow keys to navigate the possible selections.

**Tab key sequence**  To navigate through a dialog box, press the Tab key. Selected items appear with a dotted border. You can also press Shift+Tab to go back to a previous selection within the dialog box.

**Spacebar**  Press the Spacebar to toggle check boxes on and off or to select buttons in a dialog box.

**Esc**  Press the Esc key to close a dialog box without implementing any new settings.

**Enter**  Press the Enter key to select the highlighted item or to close a dialog box with the new settings. You can also press the Enter key to close all About boxes.

**ToolTips**  ToolTips appear for functional icons. This feature lets users use screen reviewers to make interface information available through synthesized speech or through a refreshable braille display.
**Microsoft Accessibility Options**

Microsoft Windows environments contain accessibility options that let you change how you interact with the software. This feature can add sound, increase the magnification, and create sticky keys.

To access the Microsoft Windows Accessibility options, open Control Panel and click Accessibility.

If you installed the Microsoft Accessibility components for your Windows system, you can also find other Accessibility tools on the Start menu under Programs/Accessories/Accessibility.

**To add the Accessibility components:**

1. In Control Panel, double-click Add/Remove Programs.
2. On the Setup tab, select the Accessibility Options check box and click Apply.
3. Click OK.

**Technical Support**

Contact your system administrator for assistance. The administrator is most familiar with the organization’s particular configuration. If the problem isn’t resolved, the system administrator can contact Hummingbird Technical Support to report problems or suggest enhancements. We require product and company information before we can investigate any problems, so please fill-out the electronic form on the Hummingbird web site or phone in/fax us the corresponding information before contacting Technical Support.
For Technical Support services, please use the contact information for your area.

**Hummingbird Ltd.**
1 Sparks Avenue, North York, Ontario, Canada M2H 2W1

<table>
<thead>
<tr>
<th>Region</th>
<th>Contact Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>North America</td>
<td>Tel: 1 800 486 0095 (8:00 am - 8:00 pm EST)</td>
</tr>
<tr>
<td></td>
<td>Fax 1 613 548 7616</td>
</tr>
<tr>
<td></td>
<td>Email: <a href="mailto:hbi-support@kingston.hummingbird.com">hbi-support@kingston.hummingbird.com</a></td>
</tr>
<tr>
<td>Europe (Except UK and Scandanavia)</td>
<td>Tel: +33 1 55 35 96 80 (9:00 am-6:00 pm GMT + 1hr)</td>
</tr>
<tr>
<td></td>
<td>Fax: +33 1 42 61 31 87</td>
</tr>
<tr>
<td></td>
<td>Email: <a href="mailto:fr-bi-support@hummingbird.com">fr-bi-support@hummingbird.com</a></td>
</tr>
<tr>
<td>UK and Scandanavia</td>
<td>Tel: +44 (0)118-902-9507 (9:00 am-5:00 pm GMT)</td>
</tr>
<tr>
<td></td>
<td>Fax: +44 (0) 118 978 9325</td>
</tr>
<tr>
<td></td>
<td>Email: <a href="mailto:uk-support@hummingbird.com">uk-support@hummingbird.com</a></td>
</tr>
<tr>
<td>Other Locations</td>
<td>+1 613 548 4355 (8:00 am-8:00 pm EST)</td>
</tr>
<tr>
<td></td>
<td>+1 613 548 7616</td>
</tr>
<tr>
<td></td>
<td><a href="mailto:hbi-support@kingston.hummingbird.com">hbi-support@kingston.hummingbird.com</a></td>
</tr>
</tbody>
</table>

**Using the Trace Utility**
Hummingbird provides a trace utility with the software to help troubleshoot problems you are having. The trace utility simplifies problem-solving by monitoring the activity of your products. If you are having problems with the software, Technical Support may ask you to run the trace utility, reproduce the problem, save the trace information, and send us the resulting trace file.

To run the trace utility, double-click `trace.exe` in the following path:

```
Program Files\Hummingbird\BI\Utility
```

For information of configuring the trace utility, see Trace Help.
Index

**Numerics**

3D charts ...................................................... 144

A

accessibility features ........................................... 273
Acrobat, (PDF) format ........................................... 76
activating tables .................................................. 201
adding
bands .............................................................. 98
bitmaps .......................................................... 195, 200
borders ............................................................. 212
calculations to groups ........................................... 227
charts .............................................................. 48, 55
charts to bands .................................................... 106
charts to tables ................................................... 106
color to drawing objects ....................................... 197
color to text ........................................................ 194
columns ............................................................. 112
columns, new query ............................................. 125
crosstabs .......................................................... 190
data items .......................................................... 125
drawing objects .................................................... 196
grand total ........................................................ 228
grand totals ....................................................... 226, 236
hotspots ............................................................. 85
linked objects ....................................................... 198
members to charts, crosstabs ................................. 160
objects to bands .................................................. 105, 204
OLE objects ........................................................ 195, 200
page breaks ....................................................... 132, 175
page numbers ..................................................... 182
pages .............................................................. 182
pie chart labels ................................................... 169
predefined calculations ......................................... 227
predefined calculations to tables ............................ 225
presentations ....................................................... 59
prompts ............................................................. 193
rich text ............................................................ 185
table frames ....................................................... 133
tables ............................................................... 46
tables, existing reports ......................................... 53
text files ............................................................ 185
text labels .......................................................... 184
totals ............................................................... 228
user-defined calculations ....................................... 228, 230
adding exceptions ................................................. 242
creating summary reports ..................................... 253
highlighting alternative rows .................................. 254
to highlight data .................................................. 242
Adobe Acrobat ...................................................... 76
aligning
data inside a box ................................................. 202
objects, graphics ................................................. 201
text ................................................................. 201
aligning objects
showing grid lines ................................................. 203
snap to grid ....................................................... 203
spacing evenly .................................................... 202
ALL function ....................................................... 233, 257
anchoring items to columns .................................... 117
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>applying</td>
<td></td>
</tr>
<tr>
<td>data highlighting</td>
<td>245</td>
</tr>
<tr>
<td>exceptions to data</td>
<td>244</td>
</tr>
<tr>
<td>exceptions to objects</td>
<td>245</td>
</tr>
<tr>
<td>exceptions, overview</td>
<td>244</td>
</tr>
<tr>
<td>hyperlinks</td>
<td>189</td>
</tr>
<tr>
<td>layout templates</td>
<td>214</td>
</tr>
<tr>
<td>report backgrounds</td>
<td>214</td>
</tr>
<tr>
<td>table styles</td>
<td>136</td>
</tr>
<tr>
<td>templates</td>
<td>214</td>
</tr>
<tr>
<td>variable data fields to tables, bands</td>
<td>109</td>
</tr>
<tr>
<td>area charts</td>
<td>32, 144</td>
</tr>
<tr>
<td>arithmetic operators</td>
<td>221</td>
</tr>
<tr>
<td>arranging</td>
<td></td>
</tr>
<tr>
<td>axes in charts</td>
<td>152</td>
</tr>
<tr>
<td>axes in crosstabs</td>
<td>153</td>
</tr>
<tr>
<td>chart metrics</td>
<td>151</td>
</tr>
<tr>
<td>columns</td>
<td>119</td>
</tr>
<tr>
<td>crosstab data</td>
<td>149</td>
</tr>
<tr>
<td>crosstab metrics</td>
<td>146</td>
</tr>
<tr>
<td>data in charts</td>
<td>151</td>
</tr>
<tr>
<td>data in charts, crosstabs</td>
<td>146</td>
</tr>
<tr>
<td>dimensions</td>
<td>154</td>
</tr>
<tr>
<td>attributes. See columns.</td>
<td></td>
</tr>
<tr>
<td>automatically resizing items</td>
<td>119</td>
</tr>
<tr>
<td>automation controller</td>
<td>18</td>
</tr>
<tr>
<td>autosizing</td>
<td></td>
</tr>
<tr>
<td>column items</td>
<td>119</td>
</tr>
<tr>
<td>crosstab cells</td>
<td>176</td>
</tr>
<tr>
<td>axes, changing</td>
<td>152, 153</td>
</tr>
<tr>
<td>BI</td>
<td></td>
</tr>
<tr>
<td>BI Login dialog box</td>
<td>14</td>
</tr>
<tr>
<td>BI Query Reports</td>
<td></td>
</tr>
<tr>
<td>login</td>
<td>14</td>
</tr>
<tr>
<td>standalone</td>
<td>14</td>
</tr>
<tr>
<td>starting from BI Query</td>
<td>13</td>
</tr>
<tr>
<td>table styles, defined</td>
<td>41</td>
</tr>
<tr>
<td>BI Server</td>
<td></td>
</tr>
<tr>
<td>overview</td>
<td>261</td>
</tr>
<tr>
<td>repository defined</td>
<td>261</td>
</tr>
<tr>
<td>BI Server Repository</td>
<td>188</td>
</tr>
<tr>
<td>bitmaps</td>
<td>195</td>
</tr>
<tr>
<td>embedding</td>
<td>200</td>
</tr>
<tr>
<td>By argument, overview</td>
<td>219</td>
</tr>
<tr>
<td>C</td>
<td></td>
</tr>
<tr>
<td>Calc-O-Matic dialog box</td>
<td>225, 228</td>
</tr>
<tr>
<td>calculations</td>
<td>217</td>
</tr>
<tr>
<td>adding to crosstabs</td>
<td>227, 230</td>
</tr>
<tr>
<td>adding to tables</td>
<td>228</td>
</tr>
<tr>
<td>ALL function</td>
<td>233</td>
</tr>
<tr>
<td>automatic resizing</td>
<td>109</td>
</tr>
<tr>
<td>By argument</td>
<td>219</td>
</tr>
<tr>
<td>combining columns</td>
<td>234</td>
</tr>
<tr>
<td>creating in crosstabs</td>
<td>230</td>
</tr>
<tr>
<td>creating in tables</td>
<td>228</td>
</tr>
<tr>
<td>date/time</td>
<td>218</td>
</tr>
<tr>
<td>deleting</td>
<td>233</td>
</tr>
<tr>
<td>editing</td>
<td>232</td>
</tr>
<tr>
<td>exceptions</td>
<td>217</td>
</tr>
<tr>
<td>expressions</td>
<td>220</td>
</tr>
<tr>
<td>functions</td>
<td>218</td>
</tr>
<tr>
<td>logical</td>
<td>218</td>
</tr>
<tr>
<td>multi-pass</td>
<td>217</td>
</tr>
<tr>
<td>naming and describing</td>
<td>232</td>
</tr>
<tr>
<td>numeric</td>
<td>217</td>
</tr>
<tr>
<td>order of precedence</td>
<td>223</td>
</tr>
</tbody>
</table>
percent of total ..................................... 236
pointing to a specific value.................... 239, 241
predefined ............................. 217, 224, 225, 227
predefined in tables ................................ 225
replacing numeric values
    with text strings............................ 238
string ............................................. 218
syntax ............................................. 222
use of arrow ..................................... 222
use of brackets, braces ......................... 222
use of colon and comma ....................... 222
use of parantheses ............................ 222
use of single quote ............................ 222
use-defined ...................................... 217, 224, 228
user-defined ..................................... 217, 224, 228

Calculations dialog box
    Editor page ................................... 229, 238
cells
    autosizing in crosstabs ..................... 176
    resizing ......................................... 176
changing
    axes in charts ................................ 152
    axes in crosstabs ............................. 153
    chart type ...................................... 166
color .............................................. 194
data by using prompts ......................... 193
data sources .................................... 62, 65
filtered data ................................... 159
grid settings ................................... 203
nested dimensions ............................. 154
text labels in charts ......................... 168
titles in charts ................................ 168
chart types
    area ............................................. 32
dual axis ........................................ 30
line ............................................... 31
pie ................................................. 33
three-dimensional ................................ 34
charts .............................................. 6, 141
overview ....................................... 6, 27
adding a legend ............................... 167
adding members ............................... 160
adding to bands .............................. 106
adding to existing reports ................. 55
adding to reports ............................ 48
adding to tables ................................ 106
arranging data .................................. 146, 151, 154
changing text labels ........................ 168
changing titles .................................. 168
changing type ................................... 166
choosing types .................................. 50
data gathering .................................. 40
dimensions ....................................... 151
editing .......................................... 170
dimensions ................................. 151
examples ......................................... 27–34
filtering data .................................... 157, 159
formatting, overview .......................... 164
grouping items ................................. 154
hiding columns ............................... 170
if data values not shown ....................... 94
pivoting dimensions ......................... 152
properties ....................................... 165
refresh ............................................ 68
removing and hiding members ............... 162
removing columns ............................. 170
reordering members ........................... 161
types ............................................. 144
Charts Editor ..................................... 170
Choose a Member dialog box .................. 115, 237, 240
Choose Range dialog box ...................... 84, 93
colormap ........................................ 195
selecting ......................................... 201
colors in calculations .......................... 222
colored ............................................ 201
colons in calculations ......................... 222
colored ............................................ 201
chart types
    adding .......................................... 197
    adding to drawing objects ................. 197
    adding to text .................................. 194
    palette ......................................... 194, 197
Column Control bar ......................... 98, 111, 115, 119
columns..........................................................98
adding new.............................................112
anchoring items ....................................117
autosizing..............................................119
changing grouped data .........................128
changing the order.................................127
combining using calculations...............234
defined..................................................99
deleting .................................................114
fitting on a page .....................................116
formatting.............................................112
formatting headings..............................134
grouped..................................................127
hiding in charts .....................................170
items......................................................121
managing ..............................................113
merging .................................................115
new query data......................................125
over multiple pages...............................113
properties..............................................112
removing in charts..................................170
reordering .............................................119
resizing..................................................118
selecting ................................................111
title formatting......................................134
combining columns .....................................234
comma separated value........................... 75, 77
commas in calculations........................222
comparison operators............................221
context-sensitive titles............................190
controlling page breaks.........................175
converting two-digit years ....................210, 212
about...................................................210
example................................................210
copying
items......................................................121
objects..................................................201
presentations.........................................61
presentations to other application ..........78
tables and crosstabs .........................78
text........................................................189
copying and pasting table items.............121
creating
calculations.............................................228
calculations in crosstabs........................230
calculations in groups...........................227
calculations in tables............................228
calculations, ALL function.....................233
exceptions.............................................242
grand totals............................................226
headers and footers...............................204
hotspots................................................85
interactive reports..............................84, 85
report backgrounds...............................213
summary reports....................................253
text labels..............................................184
titles .....................................................184
totals....................................................228
user-defined calculations....................228, 230
crosstabs...............................................141, 153
overview .............................................7, 34, 141, 145
accessing.............................................172
activating.............................................172
adding members.................................160
adding percent of total.........................236
adding titles.........................................184
adding to existing reports ....................57
adding to reports.................................51
arranging data ..........................146, 149, 154
autosizing cells ..................................176
calculations..........................................230
changing filtered data.........................159
copying and pasting.............................78
data filtering..........................................157
data gathering........................................40
default formatting...............................174
defined...............................................145
dense, defined .....................................36
dimensions.........................................151
examples.............................................151
filtering data.........................................159
formatting...........................................172, 177
if data values not shown .....................94
options...............................................174
page breaks.........................................175
pivoting ................................................ 153
predefined calculations ........................ 227
redefining a metrics member ............... 150
refreshing .............................................. 68
removing, keeping members .................. 163
reordering members .............................. 161
resizing ................................................ 176
selecting ............................................... 172
selecting labels ...................................... 173
sparse, defined ...................................... 36
totals ................................................... 228

CSV. See comma separated value.
curly brackets in calculations ............ 222

D
data adding new columns ...................... 125
arranging ............................................ 146, 151
arranging in crosstabs ....................... 149
changing ............................................. 193
changing source .................................. 62
changing what’s filtered ...................... 159
copying table items .............................. 121
formatting .......................................... 177
gathering ............................................ 85
gathering for crosstabs ...................... 40
gathering for tables ............................ 39
grouped, ungrouped columns ............. 128
grouping results .................................. 39
guidelines for gathering ..................... 39
in charts ............................................. 146
mapping new ....................................... 65
qualifying .......................................... 85
reducing null values ............................ 36
refreshing .......................................... 92
replacing ......................................... 162
sorting in charts and crosstabs .......... 146
sorting in columns ............................. 128
stacking in tables ............................... 122
summarizing in charts, crosstabs ....... 146
suppressing duplicates ..................... 123
y-axis in bands ................................... 108

Data Cell Selector dialog box ............ 115, 240
data fields automatic sizing ................. 108
variable .......................................... 108
data formats ....................................... 207
null values ........................................ 206
data highlighting .............................. 244
overview ........................................... 242
applying exceptions ......................... 245
creating exceptions .......................... 242
data items .......................................... 98
adding ............................................. 125
combining ......................................... 115, 234
data sources overview ......................... 7
changing .......................................... 62, 65
defined ............................................. 7
for hotspots ...................................... 91
removing ......................................... 66
saving with reports ........................... 70
types ............................................... 3
Data Sources dialog box ..................... 66, 126
data values ....................................... 94
database distributing revisions ........... 80
reconnecting .................................... 72
date .................................................. 210
context-sensitive ................................ 190
formats ............................................ 209
formatting ....................................... 210
Date Entry dialog box ......................... 210
date/time calculations ....................... 218
default crosstab formatting ................. 174
crosstab options ............................... 174
table styles, defined ......................... 41
Define Date/Time Format dialog box ...... 210
Define Numeric Format dialog box ....... 208
defining formats ............................ 210
deleting
  calculations ...........................................233
columns ................................................114
current values..........................................20
exceptions .............................................247
dense crosstab ................................................36
describing exceptions...................................244
detail bands ........................................... 98, 104
  hiding....................................................103
  variable..................................................108
detailed data sources ........................................3
details, suppressing in reports......................103
Dimension List dialog box...........................230
dimensions ...................................................153
  adding a subtotal ..................................228
  filtering..................................................159
  grouping in charts.................................154
  nested, arranging ..................................154
  overview ................................................151
  pivoting in charts.................................152
  pivoting in crosstabs...............................153
  removing...............................................157
displaying
  bands.....................................................102
dates ............................................. 210, 212
grid lines................................................203
null values .............................................206
suppressed data.....................................124
distributing reports ....................................79
using the database .....................................80
drawing objects .........................................195
  adding ...................................................196
  adding color ...........................................197
  formatting, editing................................196
dual axis charts .........................................30
duplicate data .........................................123
  eliminating..........................................39
  hiding....................................................123
calculations........................................... 232
charts .................................................... 170
embedded objects.....................................200
grid settings ..........................................203
Hotspot Wizard ........................................91
hotspots .............................................89, 91
hyperlinks .............................................189
linked objects .........................................198
e-mailing reports as attachments .............79
embedded objects, editing .........................200
entering dates ...........................................210
exceptions .............................................244
  overview ...............................................217
  ALL function .........................................257
  applying................................................244
  applying to objects ................................245
  automatic resizing ..................................109
  creating...............................................242
delleting...............................................247
deliminating..............................................39
examples .............................................248–253
expressions .............................................220
highlighting data .....................................242
  naming and describing..............................244
  removing...............................................247
  triggering Scheduler event ......................268
exporting reports ......................................75
  Acrobat (PDF) .........................................76
  HTML .....................................................77
  Quicksheet, Palm and Excel ......................77
text (CSV) ..............................................77
  viewing ...................................................78
expressions, overview ................................220

F
fields, in labels .........................................191–192
file protocol .............................................187
File Transfer Protocol (FTP) .........................187
filtering data .............................................157
  charts, crosstabs .....................................157
  footers.....................................................204
  repeating object .....................................205
  repeating object .....................................205
Index

<table>
<thead>
<tr>
<th>Formatting</th>
<th>Page Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>bands</td>
<td>100</td>
</tr>
<tr>
<td>charts, overview</td>
<td>164</td>
</tr>
<tr>
<td>columns</td>
<td>112</td>
</tr>
<tr>
<td>column headings, titles</td>
<td>134</td>
</tr>
<tr>
<td>crosstabs</td>
<td>177</td>
</tr>
<tr>
<td>crosstabs page breaks</td>
<td>175</td>
</tr>
<tr>
<td>crosstabs, overview</td>
<td>172</td>
</tr>
<tr>
<td>data</td>
<td>177</td>
</tr>
<tr>
<td>date and time</td>
<td>209, 210</td>
</tr>
<tr>
<td>defaults for tables</td>
<td>130</td>
</tr>
<tr>
<td>drawing objects</td>
<td>196</td>
</tr>
<tr>
<td>enhancing reports</td>
<td>181</td>
</tr>
<tr>
<td>members</td>
<td>177</td>
</tr>
<tr>
<td>null values</td>
<td>206</td>
</tr>
<tr>
<td>numbers</td>
<td>207</td>
</tr>
<tr>
<td>presentations</td>
<td>129</td>
</tr>
<tr>
<td>table column headings, titles</td>
<td>134</td>
</tr>
<tr>
<td>tables</td>
<td>129, 130</td>
</tr>
<tr>
<td>text</td>
<td>193</td>
</tr>
<tr>
<td>using the Charts Editor</td>
<td>170</td>
</tr>
<tr>
<td>x-axis labels</td>
<td>169</td>
</tr>
<tr>
<td>formatting crosstabs</td>
<td>153</td>
</tr>
<tr>
<td>pivoting</td>
<td>153</td>
</tr>
<tr>
<td>FTP, See File Transfer Protocol</td>
<td></td>
</tr>
<tr>
<td>functions</td>
<td></td>
</tr>
<tr>
<td>overview</td>
<td>218</td>
</tr>
<tr>
<td>ALL</td>
<td>233, 257</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>G</th>
<th>Page Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>grand totals</td>
<td>224, 225, 227, 228, 236</td>
</tr>
<tr>
<td>adding</td>
<td>226</td>
</tr>
<tr>
<td>graphics</td>
<td>195</td>
</tr>
<tr>
<td>adding</td>
<td>195</td>
</tr>
<tr>
<td>adding to bands</td>
<td>105</td>
</tr>
<tr>
<td>aligning</td>
<td>201</td>
</tr>
<tr>
<td>selecting</td>
<td>201</td>
</tr>
<tr>
<td>grid</td>
<td>203</td>
</tr>
<tr>
<td>changing settings</td>
<td>203</td>
</tr>
<tr>
<td>settings</td>
<td>203</td>
</tr>
<tr>
<td>Grid Settings dialog box</td>
<td>203</td>
</tr>
<tr>
<td>Group Breaks dialog box</td>
<td>102, 128, 129</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>H</th>
<th>Page Numbers</th>
</tr>
</thead>
<tbody>
<tr>
<td>.hcr files</td>
<td>3</td>
</tr>
<tr>
<td>headers</td>
<td>204</td>
</tr>
<tr>
<td>repeating object</td>
<td>205</td>
</tr>
<tr>
<td>hiding</td>
<td></td>
</tr>
<tr>
<td>bands</td>
<td>102, 104</td>
</tr>
<tr>
<td>columns in charts</td>
<td>170</td>
</tr>
<tr>
<td>duplicate data</td>
<td>123</td>
</tr>
<tr>
<td>members in charts</td>
<td>170</td>
</tr>
<tr>
<td>repetitive data</td>
<td>123</td>
</tr>
<tr>
<td>highlighting specific data</td>
<td>244, 254</td>
</tr>
<tr>
<td>alternate rows</td>
<td>254</td>
</tr>
<tr>
<td>using exceptions</td>
<td>242</td>
</tr>
<tr>
<td>horizontal bar charts</td>
<td>144</td>
</tr>
<tr>
<td>hotspots</td>
<td>84</td>
</tr>
<tr>
<td>adding</td>
<td>85</td>
</tr>
<tr>
<td>as column headings</td>
<td>89</td>
</tr>
<tr>
<td>as labels</td>
<td>89</td>
</tr>
<tr>
<td>as titles</td>
<td>89</td>
</tr>
<tr>
<td>changing labels</td>
<td>89</td>
</tr>
<tr>
<td>choosing range of values</td>
<td>84</td>
</tr>
<tr>
<td>data source</td>
<td>91</td>
</tr>
<tr>
<td>editing</td>
<td>91</td>
</tr>
<tr>
<td>moving</td>
<td>91</td>
</tr>
<tr>
<td>qualification</td>
<td>92</td>
</tr>
<tr>
<td>qualifications</td>
<td>84</td>
</tr>
<tr>
<td>resizing</td>
<td>92</td>
</tr>
<tr>
<td>selecting</td>
<td>89</td>
</tr>
<tr>
<td>working with</td>
<td>89</td>
</tr>
</tbody>
</table>

283
Links dialog box ................................... 198, 199
local reports, opening ........................... 18
logical calculations ................................ 218
operators ........................................... 222
login ................................................... 14

M
mailto protocol ...................................... 187
Map Data dialog box ............................. 65, 137
mapping unmatched data .......................... 65
members
  overview ........................................... 156
  adding ............................................. 160
  formatting ....................................... 177
  formatting x-axis labels ...................... 169
  hiding in charts ................................. 170
  removing in charts ............................ 170
  removing, hiding in charts .................. 162
  removing, keeping in crosstabs ............ 163
  reordering in charts .......................... 161
  showing hidden members .................... 171
merging columns ................................... 115
metrics
  arrange ........................................... 146
  arranging in charts, crosstabs .............. 151
  redefining a member ......................... 150
modifying
  calculations ..................................... 232
  column size ..................................... 118
  data by using prompts ........................ 193
  date, time formats ............................. 209
  grid settings .................................... 203
  groups ........................................... 128
  hotspots ........................................ 89
  items ............................................. 118
  number formats ................................ 207
  sorted, unsorted columns .................... 128
moving hotspots .................................. 91
multi-pass calculations ......................... 217
multiple objects
  selecting ........................................ 201
  spacing evenly .................................. 202

N
naming exceptions ................................ 244
nested relationships
  in charts ........................................ 154
  in crosstabs .................................... 154
null values
  defined .......................................... 36
  reducing ........................................ 36
number formats ................................... 207
numeric calculations ............................ 217
numeric values .................................... 207
replacing with text strings ..................... 238

O
objects
  adding ............................................. 195
  adding to bands ............................... 105
  applying exceptions .......................... 245
  columns ......................................... 99
  copying ......................................... 201
  embedding ...................................... 200
  linked ........................................... 198
  linking ......................................... 199
  making same size ............................. 202
  on multiple pages ............................ 204, 205
  pasting ......................................... 201
  selecting ....................................... 201
  spacing evenly ................................ 202
OLE automation .................................... 18
OLE objects ......................................... 195
  adding ......................................... 195
  embedding ..................................... 200
  linking ......................................... 198
opening local reports ........................... 18
operators
  arithmetic ....................................... 221
  comparison ...................................... 221
  logical ......................................... 222
options
  opening reports ............................... 67
  refresh ......................................... 68
<table>
<thead>
<tr>
<th>Order of Columns</th>
<th>119</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organizing Data</td>
<td>146, 151</td>
</tr>
<tr>
<td>in Charts and Crosstabs</td>
<td></td>
</tr>
</tbody>
</table>

### P

<table>
<thead>
<tr>
<th>Page Breaks</th>
<th>105, 175</th>
</tr>
</thead>
<tbody>
<tr>
<td>Adding to Tables</td>
<td>132</td>
</tr>
<tr>
<td>Page Numbers</td>
<td></td>
</tr>
<tr>
<td>Adding</td>
<td>182, 190</td>
</tr>
<tr>
<td>Context-Sensitive</td>
<td>190</td>
</tr>
<tr>
<td>Pages</td>
<td></td>
</tr>
<tr>
<td>Adding, Removing</td>
<td>182</td>
</tr>
<tr>
<td>Fitting a Column</td>
<td>116</td>
</tr>
<tr>
<td>Footer Band</td>
<td>98, 99, 204</td>
</tr>
<tr>
<td>Header Band</td>
<td>98, 204</td>
</tr>
<tr>
<td>Orientation for Printing</td>
<td>74</td>
</tr>
<tr>
<td>Pasting</td>
<td></td>
</tr>
<tr>
<td>Objects</td>
<td>201</td>
</tr>
<tr>
<td>Presentations</td>
<td>61</td>
</tr>
<tr>
<td>PDF</td>
<td>76</td>
</tr>
<tr>
<td>Percent of Total, Example</td>
<td>236</td>
</tr>
<tr>
<td>Pictures</td>
<td></td>
</tr>
<tr>
<td>Selecting</td>
<td>201</td>
</tr>
<tr>
<td>Pie Charts</td>
<td>33, 144</td>
</tr>
<tr>
<td>Labels Versus Legends</td>
<td>169</td>
</tr>
<tr>
<td>Pivoting Dimensions</td>
<td>153</td>
</tr>
<tr>
<td>Charts</td>
<td>152</td>
</tr>
<tr>
<td>Crosstabs</td>
<td>153</td>
</tr>
<tr>
<td>Planning Reports</td>
<td></td>
</tr>
<tr>
<td>Gathering Data</td>
<td>39–41</td>
</tr>
<tr>
<td>Identifying Users</td>
<td>23</td>
</tr>
<tr>
<td>Presenting Data</td>
<td>24–38</td>
</tr>
<tr>
<td>Table Styles</td>
<td>41</td>
</tr>
<tr>
<td>Pointing to a Specific Value, Example</td>
<td>241</td>
</tr>
<tr>
<td>Predefined Calculations</td>
<td>224, 225, 227</td>
</tr>
<tr>
<td>Overview</td>
<td>217</td>
</tr>
<tr>
<td>Creating</td>
<td>225</td>
</tr>
<tr>
<td>Preferences</td>
<td>66</td>
</tr>
<tr>
<td>Crosstabs</td>
<td>174</td>
</tr>
<tr>
<td>Default Formatting for Tables</td>
<td>130</td>
</tr>
<tr>
<td>Query Prompts</td>
<td>69</td>
</tr>
<tr>
<td>Refresh</td>
<td>68</td>
</tr>
<tr>
<td>Report Opening Options</td>
<td>67</td>
</tr>
<tr>
<td>Resizing Bands</td>
<td>69</td>
</tr>
<tr>
<td>Preferences Dialog Box</td>
<td>66, 67, 94</td>
</tr>
<tr>
<td>Crosstab Page</td>
<td>174</td>
</tr>
<tr>
<td>Table Page</td>
<td>131</td>
</tr>
<tr>
<td>Presentation Designer Dialog Box</td>
<td>9, 46</td>
</tr>
<tr>
<td>Arrange Data Page</td>
<td>127, 146, 149</td>
</tr>
<tr>
<td>Data Source Page</td>
<td>54, 57, 107</td>
</tr>
<tr>
<td>Presentation Page</td>
<td>49, 116</td>
</tr>
<tr>
<td>Table Page</td>
<td>130</td>
</tr>
<tr>
<td>Presentations</td>
<td></td>
</tr>
<tr>
<td>Overview of Types</td>
<td>4</td>
</tr>
<tr>
<td>Adding to Reports</td>
<td>59</td>
</tr>
<tr>
<td>Changing Type</td>
<td>61</td>
</tr>
<tr>
<td>Checking View Name</td>
<td>60</td>
</tr>
<tr>
<td>Choosing</td>
<td>24–38</td>
</tr>
<tr>
<td>Copying and Pasting</td>
<td>61</td>
</tr>
<tr>
<td>Copying to Other Applications</td>
<td>78</td>
</tr>
<tr>
<td>Fine-Tuning Data</td>
<td>62</td>
</tr>
<tr>
<td>Formatting</td>
<td>129</td>
</tr>
<tr>
<td>Refreshing Charts, Crosstabs</td>
<td>68</td>
</tr>
<tr>
<td>Using Views to Link</td>
<td>61</td>
</tr>
<tr>
<td>Views</td>
<td>59</td>
</tr>
<tr>
<td>Presenting Data</td>
<td></td>
</tr>
<tr>
<td>Charts</td>
<td>27</td>
</tr>
<tr>
<td>Crosstabs</td>
<td>34</td>
</tr>
<tr>
<td>Tables</td>
<td>24</td>
</tr>
<tr>
<td>Previewing Before Printing</td>
<td>74</td>
</tr>
<tr>
<td>Printer Driver</td>
<td>79</td>
</tr>
<tr>
<td>Printing</td>
<td>72</td>
</tr>
<tr>
<td>Page Orientation</td>
<td>74</td>
</tr>
<tr>
<td>Previewing</td>
<td>74</td>
</tr>
<tr>
<td>Print Order</td>
<td>73</td>
</tr>
<tr>
<td>Reports</td>
<td>72, 79</td>
</tr>
<tr>
<td>To a Text File</td>
<td>74</td>
</tr>
<tr>
<td>Prompts</td>
<td></td>
</tr>
<tr>
<td>Adding</td>
<td>190</td>
</tr>
<tr>
<td>Modifying Data</td>
<td>193</td>
</tr>
<tr>
<td>Preferences</td>
<td>69</td>
</tr>
<tr>
<td>Refreshing Reports</td>
<td>69</td>
</tr>
</tbody>
</table>
Index

properties
- bands .................................................... 100
- charts .................................................... 165
- columns................................................ 112
- tables..................................................... 130

Properties dialog box........ 113, 130, 177, 208
- Format page ........................................ 207
- General page.................................165, 246
- General tab ........................................... 245
- Options page ......................108, 167, 169
- Style page.............................................. 166
- Titles page............................................. 168

protocols
- file………………………………………. 187
- FTP ....................................................... 187
- HTTP ................................................... 186
- HTTPS.................................................. 186
- mailto ................................................... 187
- SSL........................................................ 186

publishing
- automatically to PDF .............. 76
- reports .............................................. 261

Q
qualifying
- data .................................................... 85
- data values ........................................... 94

queries, editing .......................... 62

query results
- overview ............................................ 9
- turning into reports...................... 8

Quicksheet format .......................... 77

R
Rearrange Data dialog box ....... 107, 152, 156
rearranging
- chart metrics................................. 146
- crosstab metrics.............................. 146
- data in charts and crosstabs ........... 146
- data in charts, crosstabs ................. 151
- data in crosstabs............................. 146

Recent dialog box ........................... 16
refreshing
- charts, crosstabs .......................... 68
- data .............................................. 19, 92
- report options .............................. 19
- reports that use a prompt .......... 19
- reports, automatically ................. 20
- reports, manually ...................... 20
- reports, query prompts .................. 69

removing
- calculations ................................. 233
- columns ........................................... 114
- columns in charts ......................... 170
- dimensions ....................................... 157
- exceptions ...................................... 247
- hyperlinks ...................................... 189
- members in charts ..................... 162, 170
- members in crosstabs .................. 163
- page breaks ................................... 132
- pages ............................................... 182
- table frames....................................... 133

reordering
- columns ........................................... 119
- members in a dimension ................ 161
- members in charts, crosstabs ........ 161
- repeating objects .......................... 205
- repetitive data ............................... 123
- replacing a numeric value, example . 239
- report backgrounds ....................... 213

report exceptions
- using to schedule jobs................. 268
- using to trigger jobs................... 268

Report Size dialog box .............. 182

reports .................................................... 83
- overview ............................................ 3
- adding charts .............................. 48, 55
- adding crosstabs ......................... 51, 57
- adding presentations ................... 59
- adding tables ................................. 46, 53
- backgrounds .................................. 212, 214
- creation process overview ........... 45
- distributing ..................................... 79
- e-mailing .......................................... 79
- exceptions as triggers .................. 268
- export formats .............................. 75

287
footer band .............................................99
header band ............................................98
hotspots...................................................85
interactive 83, 84, 85
new ......................................................13
opening ...................................................18
preferences for opening ..................................67
print options ...........................................72
printing ..................................................72, 79
printing to text file ..................................74
publishing ...........................................261
refresh options ........................................19
refreshing ................................................18
refreshing data ........................................72
retrieving ..............................................263
saving .....................................................70
saving with data sources ............................70
scheduling .............................................267
security ..................................................264
setting security ......................................266
summary ...............................................103
triggering scheduled job ............................268
repository
defined ..................................................261
ID ..........................................................188
opening reports 17, 18
publishing reports ....................................261
retrieving reports .....................................263
starting BI Query Reports .......................13
working offline ........................................14
resizing
column items ........................................119
columns ..................................................118
crosstabs, cells .....................................176
hotspots ..................................................92
items in a column ....................................118
objects .....................................................202
Retrieve Data dialog box 18
Retrieve Report dialog box 17, 263
retrieving data for crosstabs 40
retrieving reports .....................................263
revising hotspots ......................................89
rich text ..................................................193
adding ..................................................185
Rich Text Editor dialog box 185, 194
round brackets in calculations ....................222
rows, suppressing duplicates .....................123
running BI Query Reports 14
from BI Query .........................................13
standalone ..............................................14
saving
locally, reports and results .....................71
reports, overview ....................................70
scheduling jobs
using report exceptions .........................268
scheduling reports ....................................267
Secure Hypertext Transfer Protocol (HTTPS) ..................186
Secure Sockets Layer protocol (SSL) ...............186
security
granting and denying access to reports ..........265
inheritance rules .....................................265
published reports .....................................264
setting for reports ....................................266
users and groups .....................................264
selecting
all crosstab cells ....................................173
bands .....................................................100
crosstab label .........................................173
data formats for nulls .............................206
data formats for numbers .......................207
data formats for numbers .......................207
date, time formats ....................................209
hotspots .................................................89
items .....................................................172
random cells ..........................................172
range of cells ..........................................173
row of cells ..........................................173
single cell .............................................173
setting
crosstab options .....................................174
default formatting ...................................174
preferences .............................................66
report backgrounds .................................214
Show/Hide Bands dialog box .............. 103, 104
showing
  bands .............................................. 102, 104
  hidden members ............................... 171
  selection tabs .................................. 172
single quotes in calculations ................. 222
size ..................................................... 184
  objects .......................................... 202
  text ................................................ 184
snap to grid ........................................ 203
sparse crosstab .................................. 36
special fields ..................................... 190
specific value calculations ...................... 239
specifying
  crosstab options .............................. 174
  data formats for nulls ....................... 206
  data formats for numbers ................... 207
date, time
  formats ........................................... 209
date, time formats ............................... 209
page breaks ....................................... 175
table size ........................................... 133
square brackets in calculations ............... 222
SSL. See Secure Sockets Layer protocol
stacking data ...................................... 122
starting B Query Reports
  automation controller ....................... 18
starting BI Query Reports
  overview ......................................... 13
  from BI Query .................................. 13
  standalone ...................................... 14
stock charts ...................................... 144
String
  functions ....................................... 234
  type converter .................................. 234
string calculations ............................. 218
styles .............................................. 181
  applying for tables ......................... 136
  changing for presentations ................. 61
  creating for tables ......................... 135
  default for crosstabs ....................... 174
  for reports .................................... 212
  modifying for tables ....................... 137
reports ............................................ 181
tables ............................................. 41, 135
tables, user defined ......................... 135
user-defined ..................................... 42
subtotals
  adding to nested dimensions ............... 228
  adding to tables ............................. 225
summary data sources ......................... 4
summary reports .............................. 242, 253
  suppressing details ......................... 103
  suppressed data, displaying ............... 124
  suppressing duplicate data ............... 123

T
Table Size dialog box ........................... 134
tables ............................................. 106
  overview ....................................... 5, 24, 97
  adding charts ................................. 106
  adding grand totals ......................... 226
  adding to existing reports ................. 53
  adding to reports ........................... 46
  adding, removing frames ................... 133
  choosing styles .............................. 47
column headings, titles ....................... 134
columns ........................................... 99
copying and pasting ........................... 78
copying items ................................... 121
creating styles .................................. 135
data gathering ................................... 39
default formatting ............................. 130
default styles ................................... 41
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
detail bands, automatic sizing ............. 108
examples ......................................... 25–26
formatting ........................................ 129, 130
formatting bands ............................... 100
modifying styles ................................ 137
moving ............................................. 121
page breaks ..................................... 132
predefined calculations ...................... 225
predefined styles ................................ 41
properties ........................................ 130